Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[resolu] Je desespere avec l'installation gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
nenoro
n00b
n00b


Joined: 07 Jan 2018
Posts: 8

PostPosted: Thu Feb 08, 2018 1:33 pm    Post subject: [resolu] Je desespere avec l'installation gentoo Reply with quote

Bonjour les gentooniens/funtooniens (clavier en qwerty donc pas d'accents desole)


Petite story time > 6 ans (- 2) de connaisances sous linux meme si je continue d'apprendre. Je suis passe par Debian / ubuntu / mint / EOS avant de finalement trouver mon bonheur sous arch, en gros j'ai pratiquement rien appris apart "apt-get install". Donc pendant 4 ans j'ai fait Arch / void, j'ai meme installe freeBSD. Et la depuis pres d'un mois j'ai decouvert que y'avait plus deep en installation que Arch. (story EndSection)

Je me dis je vais installer gentoo et prendre du plaisir, pendant 5 jours j'installe le systeme mais pas d'internet le 6eme jour en me reveillant j'elucide le mystere en me disant "make menuconfig est la cle..." Donc internet fonctionne "youpi" mais voila je fais face a un autre problem plus machiavelique, en voulant installer openbox / layman voir autre je me retrouve face a un probleme meme deux problemes > "openldap et openssl"

Mardi et Hier j'ai passe les journees a try hard a nouveau parce que les "6 jours" c'etaient en janvier, donc je try hard en essayant d'avoir le 100% sans failed en faisant lors de l'installation system "emerge -auDN @world voir + --with-bdeps=y" mais rien n'y fait je tombe sur le meme probleme suivant openldap (pour funtoo) et openssl (pour gentoo). j'ai meme essaye de passer via le mirroir "osuosl.org" en nettoyant /var/tmp/portage mais rien n'y fait le paquet continue de me nuire.

Pour gentoo je suis passe par plusieurs guide notamment celui de Adrien Linuxtricks (qui est plus simple mais qui n'explique pas que si vous avez un soucis voici comment vous pouvez le regler)

- installation du portage via emerge-webrsync
- telechargement du portage

Pour funtoo j'ai utilise le sysrescue iso qui est propose sur le site

- suivi le funtoo book (qui penche a vous faire balader a droite et a gauche parce que oui faut chercher ailleurs que sur la meme page...)

Je vais pas vous mentir mais j'ai des veines apparentes quand sa fail. Autre remarque j'ai beau checke le forum gentoo il n'y a aucune reponse qui repondent a mon soucis.


Maintenant je veux savoir une chose ou plusieurs choses:

- Pourquoi l'emerge -auDN @world a tendance a foire? (je peux pas screen quand j'utilise le terminal en iso mininal)
- Pourquoi le guide funtoo ou gentoo sont evasifs ?
- Pourquoi abuser du emerge-sync conduit au ban temporaire ? (je croyais que gentoo etait freedom comme arch)
- Est-ce que Gentoo/Funtoo me hait parce que j'ai installe arch avant lui ? (le petit second degre)
- Pourquoi gentoo a peu de mirroirs pour la france ? (j'ai consulte le status des mirroirs)

Ma config si ca peut aider:

Mobo > GA 970-gaming (am3+)
CPU > FX 8350 > (-march=bdver2 en tapant la ligne afficher sur le book de funtoo "gcc -march=native -Q --help=target | grep march")
GPU > Asus Strix RX 480
RAM > 16 GB (je ne sais pas si ca peut aider)

Pour le make.conf sous gentoo lors de l'installation system je mets:
USE="bindist python" (ce que conseille Adrien)
MAKEOPTS="-j8" (deja fait avec -j9)
LINGUAS="en_US" (je ne sais pas si je dois laisser L10N seulement)
L10N="en_US"
VIDEO_CARDS="amdgpu radeonsi" (parce que j'ai consulte gentoo)
INPUT_DEVICES="evdev keyboard mouse"
EMERGE_DEFAULTS_OPTS="${EMERGE_DEFAULTS_OPTS} --quiet-build=y" (pour skip les lignes de compilation)

J'ai vraiment envie d'installer gentoo parce que moins galere et d'y rester mais quand je vois que ca fail je desespere, j'espere trouver une solution en vous demandant de l'aide.

Merci par avance


Last edited by nenoro on Fri Feb 09, 2018 10:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7583
Location: ~Brussels - Belgique

PostPosted: Thu Feb 08, 2018 1:55 pm    Post subject: Reply with quote

Bonjour,

Pourrais-tu nous dire un peu plus clairement ce qui fonctionne et ce qui ne fonctionne pas ?

Utilise wgetpaste par exemple pour récupérer les messages et nous les publier.

Je vois que tu as suivi plusieurs tutos, mais as-tu regardé le manuel officiel Gentoo ? Pourrais-tu nous dire où tu coinces par rapport à cette référence ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
nenoro
n00b
n00b


Joined: 07 Jan 2018
Posts: 8

PostPosted: Thu Feb 08, 2018 2:55 pm    Post subject: Reply with quote

Quote:
Pourrais-tu nous dire un peu plus clairement ce qui fonctionne et ce qui ne fonctionne pas ?

Utilise wgetpaste par exemple pour récupérer les messages et nous les publier.


> J'ai reflechi par la suite que ca n'allait pas etre clair et je m'en excuse. Je vais tacher de retenter l'installation et essayer d'apporter les problemes par la suite.

Quote:
Je vois que tu as suivi plusieurs tutos, mais as-tu regardé le manuel officiel Gentoo ? Pourrais-tu nous dire où tu coinces par rapport à cette référence ?


Alors mise a part le guide de A.L j'ai consulte le Handbook surtout pour mon cpu et gpu. J'ai mis en favoris le site zugaina vu que je ne peux pas consulter la liste des paquets sur le site officiel.

La ou ca coince c'est:
Quote:
> la phase "eselect profile set X" (pas de soucis),

Quote:
> Mettre a jour le "world" via "emerge -avuDN @world", je fais etc-update (parce qu'il me dit que /etc/... doit etre a jour) et relance la commande world, seulement un paquet "openssl ou openldap" se compile mais failed et si je relance world ce paquet passe en seconde position et failed.

Quote:
> Je peux passer outre et passer a la suite mais apres le reboot je sais que je vais rencontrer ce probleme soit avec openssl/openldap, meme wget peut refuser de s'installer. J'ai essaye d'installe wget seul 1 fois sur 2 il s'installe sans broncher.


> Je vais retenter l'installation mais arrive au moment ou je devrais mettre a jour le world, j'actualiserais le /etc avec etc-update mais je ne relancerais pas le world pour eviter les heures de compilations et le risque de failure d'un paquet comme openssl.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7583
Location: ~Brussels - Belgique

PostPosted: Thu Feb 08, 2018 8:29 pm    Post subject: Reply with quote

Si tu fais
Code:
emerge -DuNav @world
, seul ce qui change va être compilé. Tu ne dois pas éviter de faire cette commande, sinon ton système ne va pas être à jour.
Essaie d'être précis dans tes termes, car "relancer le world" ne veut rien dire...
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
nenoro
n00b
n00b


Joined: 07 Jan 2018
Posts: 8

PostPosted: Fri Feb 09, 2018 10:19 am    Post subject: Reply with quote

Je viens aux nouvelles

Donc j'ai fait une nouvelle installation en ne suivant que le handbook et miracle en tout a bien fonctionné même la mise a jour du world avant de compiler le kernel. J'ai fait émerge --ask --update --deep --newuse @world

Mais après reboot j'ai fait face a un soucis lightdm ne pouvait pas afficher son login screen, j'ai pourtant suivi le guide pour xorg, openbox, lightdm mais rien n'y fait je ne pouvais pas avoir accès au login screen. J'ai même essayé avec sddm, slim, qingy.

En lisant le log /var/log/Xorg.0.conf, j'ai pu lire deux lignes fbdev n'existe pas et le système a du mal a trouver un screen.

Je me suis dit j'ai du louper quelque chose quand je faisais make menuconfig. J'ai pourtant bien choisi desktop dans le select profile list j'ai choisi le 16 pour le desktop 17.0 stable.

Donc je vais retenter une installation et prendre mon temps dans le kernel histoire de pas passer a cote d'un module.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7583
Location: ~Brussels - Belgique

PostPosted: Fri Feb 09, 2018 10:25 am    Post subject: Reply with quote

Pourquoi réinstaller ? Tu as un système qui démarre et accessible.

Pourrais-tu nous donner la sortie de "emerge --info" ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
nenoro
n00b
n00b


Joined: 07 Jan 2018
Posts: 8

PostPosted: Fri Feb 09, 2018 10:22 pm    Post subject: Reply with quote

Alors je reviens aux nouvelles.

Moi qui pensais pouvoir t'enquiquiner un peu plus helas tout est regle, lightdm fonctionne je ne sais pas par quel miracle j'ai sans doute laisser un module dans le kernel actif.

Je voulais te demander deux choses:

1 > comment on upgrade un paquet, mais la grace a un mot cle (masked) apres 20 mins j'ai enfin compris comment il fallait faire.

2 > comment fixer le probleme no menu://applications dans pcmanfm ca aussi c'est regle (en checkant les dependances sur arch)

Bon par contre j'ignorais que la compilation pour chromium pouvait durer plus longtemps que prevu (a ce qu'il parait j'ai besoin de chromium pour installer opera-ffmpeg-codecs ce qui semble etre ridicule... je sens que je vais installer vivaldi)

En tout cas desole de t'avoir importune, au final j'ai pu me debrouiller en lisant le handbook, le wiki.

Merci pour faire de gentoo un OS demoniaque j'avais besoin d'apprendre =)

Je passe le post en resolu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum