Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Issue with laptop-mode-tools
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
The_Document
Apprentice
Apprentice


Joined: 03 Feb 2018
Posts: 273

PostPosted: Thu Feb 08, 2018 1:46 am    Post subject: Issue with laptop-mode-tools Reply with quote

Im doing power managment on my laptop and using laptop-mode-tools per wiki guidelines I get the following error:

Code:
# rc-config restart laptop_mode           
Restarting init script
laptop_mode       | * Stopping laptop_mode ...
laptop_mode       |Cannot find device "eth0"
laptop_mode       |command failed: Operation not supported (-95)
laptop_mode       |Failed to set power saving mode for wireless card                                            [ ok ]
laptop_mode       | * Starting laptop_mode ...
laptop_mode       |Cannot find device "eth0"
laptop_mode       |command failed: Operation not supported (-95)
laptop_mode       |Failed to set power saving mode for wireless card                                            [ ok ]


apparently network adapter names aren't found and I tried to locate them in laptop-mode-tools configuration files in /etc/laptop-mode/conf.d/ but found nothing, I hope this can be fixed.
Back to top
View user's profile Send private message
kite14
Apprentice
Apprentice


Joined: 07 Nov 2006
Posts: 199
Location: Pordenone/Italy

PostPosted: Fri Feb 09, 2018 8:03 am    Post subject: Reply with quote

Hello,
the error about the network adapter not found is a known issue, the reason is that the device name is hard-coded in the default configuration file.
Just edit /etc/laptop-mode/conf.d/ethernet.conf file and set ETHERNET_DEVICES with the appropriate device name. It even accepts a list of devices, if needed.
For example
Code:
ETHERNET_DEVICES="enp5s0"


You may want to take a look at the Arch Wiki page which is pretty good.
Back to top
View user's profile Send private message
kite14
Apprentice
Apprentice


Joined: 07 Nov 2006
Posts: 199
Location: Pordenone/Italy

PostPosted: Fri Feb 09, 2018 10:54 am    Post subject: Reply with quote

To get rid of the error about failing to set power saving mode for wireless card (since your card, like mine, doesn't support this operation), you can just disable this module.
Edit /etc/laptop-mode/conf.d/wireless-power.conf and set
Code:
CONTROL_WIRELESS_POWER_SAVING="0"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum