Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Driver and firmware good, but no wireless?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1343
Location: Fayetteville, NC, USA

PostPosted: Mon Feb 05, 2018 2:53 am    Post subject: Driver and firmware good, but no wireless? Reply with quote

OK, I have an Intel 3165 wireless NIC in this laptop. The kernel module is built in, as is the firmware. The firmware is loaded and the device is seen by both ifocnfig and iwconfig, but iwconfig claims it has no wireless extensions and cannot connect to networks. How can I troubleshoot this? No warnings or errors in dmesg or system log. The card works fine when booting System Rescue CD, so something is missing here. I did choose MVM for this, as System Rescue did.
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
snkmoorthy
Guru
Guru


Joined: 19 Nov 2002
Posts: 376

PostPosted: Mon Feb 05, 2018 5:38 am    Post subject: Reply with quote

Check if
Code:
CONFIG_CFG80211_WEXT
is enabled in kernel.

use wpa_supplicant for testing
Code:
wpa_supplicant -Dwext -i wlan0 -c/etc/wpa_supplicant.conf
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2546

PostPosted: Mon Feb 05, 2018 5:46 am    Post subject: Re: Driver and firmware good, but no wireless? Reply with quote

The_Great_Sephiroth wrote:
The kernel module is built in, as is the firmware.
This is often problematic, even if technically adequate. I recommend using the modular approach for all things wireless.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1343
Location: Fayetteville, NC, USA

PostPosted: Mon Feb 05, 2018 1:35 pm    Post subject: Reply with quote

I do have CFG80211 set, I just checked to make sure. Also, I have a few hundred Gentoo systems out there with all built-in devices with their drivers built into the kernel. Never had any issue with it. Before I start spending hours recompiling kernels and modules, is there a quick way to test this?
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 6972
Location: Saint Amant, Acadiana

PostPosted: Mon Feb 05, 2018 2:12 pm    Post subject: Reply with quote

Everything is done as in Wiki? https://wiki.gentoo.org/wiki/Iwlwifi
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1343
Location: Fayetteville, NC, USA

PostPosted: Mon Feb 05, 2018 2:24 pm    Post subject: Reply with quote

Jag, yes. I am now seeing an issue. I rebooted and all seems well, but the system keeps failing the four-way handshake. It keeps timing out. What would cause this?

*UPDATE*

Fixed. Every distro I have used requires me to escape "!" in my passphrase. Gentoo does not. That was my issue. So the following was incorrect.
Code:

wpa_passphrase "My Wireless" "My Password\!" > /etc/wpa_supplicant/whatever.conf

Removing the escape character fixed it. No idea why I have to escape it on Sys Rescue and others, but not here.
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum