Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde-apps/konsole root login needs > 20 sec.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Sat Feb 03, 2018 3:10 pm    Post subject: kde-apps/konsole root login needs > 20 sec. Reply with quote

Hi Folks,

since I'm giving the latest ~Plasma-meta packages a shot, for about 3 month now, konsole has the same sluggish behavior her on my box.

Every time when I want to get to root under konsole with help of su - , after entering my passphrase, it takes about 23 seconds before I was prompted as root!
Absolutely reproducible here with every new tab under konsole.
An xfce4-terminal e.g. under the same plasma environment reacts immediately instead.

Searching since days for already existing bug-reports or known solutions, but couldn't find one.

I've already retried after deleting the konsolerc and all existing user-profiles, but still the same.

Any Idea what could be the root cause for this lag?

Many thanks, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1129
Location: Romania

PostPosted: Sun Feb 04, 2018 8:39 am    Post subject: Reply with quote

There was a similar bug in kde-frameworks/knotifications, which version do you have installed?
https://bugs.kde.org/show_bug.cgi?id=382444
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b868d154f825023aa7cab38852336e2c30d6d18e
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Sun Feb 04, 2018 11:19 am    Post subject: Reply with quote

Thanks sebaro,

for pointing me to this, but it must be a different fault, as you can see from my installation history of knotifications on my box:

Code:

Mon Jul 10 18:57:59 2017 >>> kde-frameworks/knotifications-5.36.0
     Tue Aug 15 16:31:46 2017 >>> kde-frameworks/knotifications-5.37.0
     Wed Aug 30 16:26:39 2017 >>> kde-frameworks/knotifications-5.37.0-r1                                           
     Sun Sep 10 11:09:09 2017 >>> kde-frameworks/knotifications-5.38.0                                             
     Tue Oct 17 16:56:06 2017 >>> kde-frameworks/knotifications-5.39.0                                             
     Thu Nov 16 18:14:54 2017 >>> kde-frameworks/knotifications-5.40.0                                             
     Sun Nov 26 18:03:05 2017 >>> kde-frameworks/knotifications-5.40.0                                             
     Tue Dec 12 21:44:00 2017 >>> kde-frameworks/knotifications-5.41.0                                             
     Fri Jan 19 20:35:59 2018 >>> kde-frameworks/knotifications-5.42.0


Any further ideas?
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1129
Location: Romania

PostPosted: Mon Feb 05, 2018 10:00 am    Post subject: Reply with quote

Did you start konsole from another terminal? Maybe there are some warnings.
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Mon Feb 05, 2018 5:02 pm    Post subject: Reply with quote

Thx sebaro,
already tried out, but sadly without any messages or hints.

Additionally I tried to replace my .bashrc with a very easy and generic one, but this also makes no difference.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1129
Location: Romania

PostPosted: Tue Feb 06, 2018 11:35 am    Post subject: Reply with quote

Maybe you'll find something in the logs, try KSystemLog.

Also you can remove/backup konsole config files/directories:
~/.config/konsole*
~/.local/share/konsole
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6825
Location: Austria

PostPosted: Tue Feb 06, 2018 11:50 am    Post subject: Reply with quote

If su is your only problem then the issue is almost certainly not konsole itself but somewhere in the permissions of your user session.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Wed Feb 07, 2018 12:18 pm    Post subject: Reply with quote

I had similar problem, it turned out elogind was the culprit. updated elogind
and it solved that for me.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Wed Feb 07, 2018 6:51 pm    Post subject: Reply with quote

Thank you for the hints guys.

@sebareo
I already tried out to delete these files, but it doesn't improve the situation.

@tranquilcool
I'm not using systemd, so I havn't elogind. My system i up to date and today I compiled plasma 5.12, but the delay is still the same.

@asturm
possible, but actually I have no clue where to look for wrong permissions regarding this.
Anyway, I couldn't see any problems in my /var/log/messages regarding su when getting to root, except lots of nouveau faults.

root login entries looks like this instead:
Code:

Feb  7 17:41:26 big-server su[5081]: Successful su for root by andy
Feb  7 17:41:26 big-server su[5081]: + /dev/pts/0 andy:root
Feb  7 17:41:26 big-server su[5081]: pam_unix(su:session): session opened for user root by andy(uid=1000)
Feb  7 17:41:35 big-server su[5089]: Successful su for root by andy
Feb  7 17:41:35 big-server su[5089]: + /dev/pts/1 andy:root
Feb  7 17:41:35 big-server su[5089]: pam_unix(su:session): session opened for user root by andy(uid=1000)

_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Wed Feb 07, 2018 6:59 pm    Post subject: Reply with quote

Randy Andy wrote:
Thank you for the hints guys.

@sebareo
I already tried out to delete these files, but it doesn't improve the situation.

@tranquilcool
I'm not using systemd, so I havn't elogind. My system i up to date and today I compiled plasma 5.12, but the delay is still the same.

@asturm
possible, but actually I have no clue where to look for wrong permissions regarding this.
Anyway, I couldn't see any problems in my /var/log/messages regarding su when getting to root, except lots of nouveau faults.

root login entries looks like this instead:
Code:

Feb  7 17:41:26 big-server su[5081]: Successful su for root by andy
Feb  7 17:41:26 big-server su[5081]: + /dev/pts/0 andy:root
Feb  7 17:41:26 big-server su[5081]: pam_unix(su:session): session opened for user root by andy(uid=1000)
Feb  7 17:41:35 big-server su[5089]: Successful su for root by andy
Feb  7 17:41:35 big-server su[5089]: + /dev/pts/1 andy:root
Feb  7 17:41:35 big-server su[5089]: pam_unix(su:session): session opened for user root by andy(uid=1000)


elogind doesn't depend on systemd. Maybe it's time for you to go the elogind way.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Fri Feb 09, 2018 4:46 pm    Post subject: Reply with quote

Thanks tranquilcool,

you're right as I see now, but I'm not sure if I'm willing to change this only cause the konsole delay, especially if it's not clear if I can solve the Problem with that...
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Randy Andy
Veteran
Veteran


Joined: 19 Jun 2007
Posts: 1136
Location: /dev/koelsch

PostPosted: Thu Sep 20, 2018 4:10 pm    Post subject: Reply with quote

Hi Folks,

some time ago I migrated my system to elogind in according to: https://wiki.gentoo.org/wiki/Elogind
but konsole takes furthermore 20 sec. to login as root, as you can see here from my log:

Code:

Sep 20 17:40:26 big-server su[4613]: pam_unix(su:session): session closed for user root
Sep 20 17:40:46 big-server su[5293]: Successful su for root by andy
Sep 20 17:40:46 big-server su[5293]: + /dev/pts/1 andy:root
Sep 20 17:40:46 big-server su[5293]: pam_unix(su:session): session opened for user root by andy(uid=1000)
Sep 20 17:40:46 big-server su[5293]: pam_elogind(su:session): Cannot create session: Already occupied by a session


Could it had to do somthing with pam, a misconfiguration, do I need pam together with logind?

I also noticed some regular baloo_file_extr[4545]: segfault errors in my log, but Baloo seems to work for me.
Code:

Sep 20 17:09:43 big-server kernel: baloo_file_extr[4545]: segfault at 0 ip 00007fe39822bf30 sp 00007ffc9ced38d0 error 4 in libKF5BalooEngine.so.5.50.0[7fe3981fe000+2f000]
Sep 20 17:09:43 big-server kernel: Code: 8d 44 24 18 4c 8d 7c 24 20 48 89 44 24 08 4d 8d 67 08 eb 5b 66 0f 1f 44 00 00 83 f8 ff 74 0b f0 83 2f 01 48 8b 7c 24 18 74 6b <48> 8b 03 48 8d 7b 08 4c 89 e2 48 89 ee 48 89 44 24 20 e8 e9 05 00


I also noticed a very strong delay of 150 seconds when starting the telegram-desktop application, I guess there could be a connection, or should this really caused by a missing pulse audio or lots of fonts?

Code:

telegram-desktop
Fontconfig warning: line 5: unknown element "its:rules"
Fontconfig warning: line 6: unknown element "its:translateRule"
Fontconfig error: line 6: invalid attribute 'translate'
Fontconfig error: line 6: invalid attribute 'selector'
Fontconfig error: line 7: invalid attribute 'xmlns:its'
Fontconfig error: line 7: invalid attribute 'version'
Fontconfig warning: line 9: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-full.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-full.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/10-hinting-full.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/10-hinting-full.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/10-hinting-full.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/10-hinting-full.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/10-hinting-full.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-sub-pixel-bgr.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-sub-pixel-bgr.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-bgr.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-bgr.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-bgr.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-bgr.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/10-sub-pixel-bgr.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-sub-pixel-rgb.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-sub-pixel-rgb.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-rgb.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-rgb.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-rgb.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-rgb.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/10-sub-pixel-rgb.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-sub-pixel-vbgr.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-sub-pixel-vbgr.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-vbgr.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-vbgr.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-vbgr.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-vbgr.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/10-sub-pixel-vbgr.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/10-sub-pixel-vrgb.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/10-sub-pixel-vrgb.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-vrgb.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-vrgb.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-vrgb.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/10-sub-pixel-vrgb.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/10-sub-pixel-vrgb.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/20-unhint-small-vera.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/30-metric-aliases.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/30-metric-aliases.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/30-metric-aliases.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/30-metric-aliases.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/30-metric-aliases.conf", line 8: unknown element "description"
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/40-nonlatin.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/40-nonlatin.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/40-nonlatin.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/40-nonlatin.conf", line 6: invalid attribute 'version'
Fontconfig warning: "/etc/fonts/conf.d/40-nonlatin.conf", line 8: unknown element "description"
.....

Fontconfig warning: "/etc/fonts/conf.d/90-synthetic.conf", line 4: unknown element "its:rules"
Fontconfig warning: "/etc/fonts/conf.d/90-synthetic.conf", line 5: unknown element "its:translateRule"
Fontconfig error: "/etc/fonts/conf.d/90-synthetic.conf", line 5: invalid attribute 'translate'
Fontconfig error: "/etc/fonts/conf.d/90-synthetic.conf", line 5: invalid attribute 'selector'
Fontconfig error: "/etc/fonts/conf.d/90-synthetic.conf", line 6: invalid attribute 'xmlns:its'
Fontconfig error: "/etc/fonts/conf.d/90-synthetic.conf", line 6: invalid attribute 'version'
Fontconfig error: Cannot load default config file
AL lib: (WW) pulse_load: Failed to load libpulse.so.0
AL lib: (WW) alc_initconfig: Failed to initialize backend "pulse"

drastically shortened now ;-)



And last but not least my strace output of the getting to root event, sorry for the german comments cause my lang= de adjustment settings into:
https://paste.pound-python.org/show/VnvKwXpmVfuc3Od7qiJ3/

Thanks for your help, Andy.
_________________
If you want to see a Distro done right, compile it yourself!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum