Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Cinnamon 3.6.6-r2 Language Option
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 267
Location: Cleebronn, Germany

PostPosted: Fri Feb 02, 2018 8:35 pm    Post subject: [solved] Cinnamon 3.6.6-r2 Language Option Reply with quote

Hi there, i have a little Problem with my Cinnamon, specially i mean the Language Support. I have configurated KDE for my language (german), i start it, its in german and all the apps / programs start in german. But in cinnamon i cant find anything to change the language. I have also read the Gentoo localizion Guide. But i found nothing for a localation of the Desktop. Here is my "emerge --info":
Code:
Portage 2.3.19 (python 3.5.4-final-0, default/linux/amd64/17.0, gcc-6.4.0, glibc-2.25-r9, 4.14.8-gentoo-r1-gladdle x86_64)
=================================================================
System uname: Linux-4.14.8-gentoo-r1-gladdle-x86_64-Intel-R-_Core-TM-_i7-2670QM_CPU_@_2.20GHz-with-gentoo-2.4.1
KiB Mem:    16391388 total,  14576312 free
KiB Swap:   16777212 total,  16777212 free
Timestamp of repository gentoo: Wed, 31 Jan 2018 17:00:01 +0000
Head commit of repository gentoo: a7047847b3414613303039bd7a13e2fce3db4ce0
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.4-r1::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.12::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.15.1-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0-r1::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:

torbrowser
    location: /var/lib/layman/torbrowser
    masters: gentoo
    priority: 50

zugaina
    location: /var/lib/layman/zugaina
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.1/ext-active/ /etc/php/cgi-php7.1/ext-active/ /etc/php/cli-php7.1/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --quiet-build=y --with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE@euro"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en ja"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aacs acl alsa amd64 apache2 apng bdplus berkdb bluetooth bluray bzip2 cdda cddb cli crypt cryptsetup cxx d3d9 dbus directx dri dvd dvdr elogind encode exif f2fs fat ffmpeg flac fontconfig fonts fortran gd gdbm gnome gnome-keyring gpm grub gtk gtk3 iconv icu ipv6 jpeg jpeg2k jpg kde legacy-systray libnotify linguas_de* linguas_en_GB linguas_ja* lm_sensors lua lvm matroska mesa modules mp3 mpeg mtp multilib multimedia musepack mysql mysqli ncurses networkmanager nls nptl ntfs ogg openal opengl openh264 openmp openssl pam pcre pdf php plasma plymouth pm-utils png policykit pulseaudio python qt5 raw readline samba schroedinger sddm sdk seccomp skins speex spell ssl svg taglib tcpd text themes theora tiff tools truetype twolame udev udf udisks unicode usb utils v4l vaapi vcdx vnc vorbis wallpaper wayland wifi x264 x265 xattr xfs xml xv zip zlib" ABI_X86="64" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_core authn_dbm authn_file authz_core authz_dbm authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir env expires ext_filter file_cache filter headers http2 include info log_config logio mime mime_magic negotiation proxy proxy_html proxy_http rewrite setenvif socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias xml2enc" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-32 efi-64 pc multiboot qemu" INPUT_DEVICES="evdev synaptics mouse roccat_kone roccat_konextd keyboard" KERNEL="linux" L10N="de en ja" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport java javafx mobility php profiler webcommon websvccommon" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby22 ruby23" USERLAND="GNU" VIDEO_CARDS="intel nouveau vmware qemu" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Can anyone tell me, what i did wrong?
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)


Last edited by Gladdle on Sat Feb 03, 2018 9:42 am; edited 1 time in total
Back to top
View user's profile Send private message
sebaro
Veteran
Veteran


Joined: 03 Jul 2006
Posts: 1129
Location: Romania

PostPosted: Sat Feb 03, 2018 7:46 am    Post subject: Reply with quote

Did you merge cinnamon with the "nls" flag enabled, this should pull gnome-extra/cinnamon-translations.
Back to top
View user's profile Send private message
Gladdle
Apprentice
Apprentice


Joined: 27 Jul 2008
Posts: 267
Location: Cleebronn, Germany

PostPosted: Sat Feb 03, 2018 9:42 am    Post subject: Reply with quote

I have installed Cinnamon with unmask the 3.6.6 Version (See in this topic). The problem was to unmask the new version for "gnome-extra/cinnamon-translations", too.
Code:
echo "=gnome-extra/cinnamon-translations-3.6.3 ~amd64" >> /etc/portage/package.accept_keywords

That solved te problem, thank you very much!
_________________
Meine Gentoo Linux Konfiguration: Notebook (ACER Aspire 9920G)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum