Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] KDE/file association: Firefox listed first for text
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
equaeghe
Guru
Guru


Joined: 22 Feb 2005
Posts: 464

PostPosted: Wed Jan 31, 2018 1:55 pm    Post subject: [solved] KDE/file association: Firefox listed first for text Reply with quote

Recently, whenever I open a text file such as, e.g., source code, Firefox opens it. Looking in the file associations of KDE, I see that Firefox is listed as the first option for many text-based file types. This was not that way before. I think the problems started after updating to plasma 5.11.5. Can others confirm they also have this issue (or whether it is a problem just I have)? What is the best way to fix this locally?

Last edited by equaeghe on Wed Jan 31, 2018 2:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
toralf
Developer
Developer


Joined: 01 Feb 2004
Posts: 3647
Location: Hamburg

PostPosted: Wed Jan 31, 2018 2:03 pm    Post subject: Re: KDE/file association: Firefox listed first for text file Reply with quote

equaeghe wrote:
Recently, whenever I open a text file such as, e.g., source code, Firefox opens it. Looking in the file associations of KDE, I see that Firefox is listed as the first option for many text-based file types. This was not that way before. I think the problems started after updating to plasma 5.11.5. Can others confirm they also have this issue (or whether it is a problem just I have)? What is the best way to fix this locally?
YOu might look for a local desktop file, eg.:
Code:
find ~ -name '*.desktop'
and maybe move it to /tmp for a test.
Back to top
View user's profile Send private message
equaeghe
Guru
Guru


Joined: 22 Feb 2005
Posts: 464

PostPosted: Wed Jan 31, 2018 3:00 pm    Post subject: Re: KDE/file association: Firefox listed first for text file Reply with quote

toralf wrote:
YOu might look for a local desktop file, eg.:
Code:
find ~ -name '*.desktop'
and maybe move it to /tmp for a test.

That did the trick: I removed some stuff that didn't seem right, also some mimeapps.list files laying around not containing anything I still wanted.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum