Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201801-20 ] Fossil
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message

Joined: 12 May 2004
Posts: 2037

PostPosted: Sat Jan 27, 2018 5:26 pm    Post subject: [ GLSA 201801-20 ] Fossil Reply with quote

Gentoo Linux Security Advisory

Title: Fossil: User-assisted execution of arbitrary code (GLSA 201801-20)
Severity: normal
Exploitable: remote
Date: 2018-01-27
Bug(s): #640208
ID: 201801-20


A vulnerability has been discovered in Fossil allowing for
user-assisted remote execution of arbitrary code.


Fossil is a simple, high-reliability, distributed software configuration
management system.

Affected Packages

Package: dev-vcs/fossil
Vulnerable: < 2.4
Unaffected: >= 2.4
Architectures: All supported architectures


Fossil does not properly validate SSH sync protocol URLs.


A remote attacker, by enticing a user to open a specially crafted URL,
could possibly execute arbitrary commands with the privileges of the user
running the application.


There is no known workaround at this time.


All Fossil users should upgrade to the latest version:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-vcs/fossil-2.4"


Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum