Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE: bold not working syntax highlighting for monospace
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
equaeghe
Guru
Guru


Joined: 22 Feb 2005
Posts: 463

PostPosted: Fri Jan 26, 2018 8:48 am    Post subject: KDE: bold not working syntax highlighting for monospace Reply with quote

Since recently, perhaps due to the kde frameworks update from 5.10 to 5.11, syntax highlighting in KDE applications such as Kate, Kile, Krusader (viewer) do not show for monospace fonts such as Liberation Mono. If I use a proportional font such as Liberation Sans, the bold does show. Both have bold listed in the font config window. Does anyone have an idea what could be the issue?
Back to top
View user's profile Send private message
Apheus
Guru
Guru


Joined: 12 Jul 2008
Posts: 418

PostPosted: Fri Jan 26, 2018 9:30 am    Post subject: Reply with quote

Konsole looks different too after the Frameworks 5.11 update. I don't mind that much in konsole, but with the syntax highlighting this is really ugly. Seems to be this bug:

KFontRequester: Fonts are saved with face name preventing bold/italic to work

Edit: Gentoo Bug
_________________
My phrenologist says I'm stupid.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum