Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ebuild] masquer pour moins avoir à mettre à jour (biais)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
pti-rem
Apprentice
Apprentice


Joined: 14 Oct 2011
Posts: 265

PostPosted: Fri Jan 19, 2018 5:43 pm    Post subject: [ebuild] masquer pour moins avoir à mettre à jour (biais) Reply with quote

Bonsoir,

Dans le contexte de début d'année plutôt anxiogène de part les médias principalement, il m'a semblé important de mettre à jour mon système plusieurs fois ces quelques dernières semaines.

D'une manière générale, mes mises à jour globales sont vraiment trop importantes en temps de compilation et en chaleur interne pour mon portable i7-2670QM@2.2 de 2012.

Code:
CFLAGS="-march=corei7-avx -O2 -pipe"
CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
USE="aes avx mmx mmxext sse sse2 ssse3 sse4_1 sse4_2 ssse3 nls unicode ssl examples handbook bluetooth pulseaudio -ipv6 aac fdk qt3support x265 nautilus -systemd -airplay"

J'ai adopté le C++14 PIE comme l'indique la news ; Donc désormais avec gcc version 6.4.0 (Gentoo 6.4.0-r1 p1.3)

Je souhaite idéalement masquer des versions d'ebuilds > à des versions stables - mais dont des mises à jour sont proposées... Encore et encore.

Je ne sais pas trop bien m'y prendre, je fais ça au semi-pifomètre et c'est pas méthodique.
Pour les applications utilisateur, ça reste plutôt facile ; je pense davantage au système.

C'est surtout "les gros morceaux" que je voudrais fixer, des ebuilds particulièrement longs à compiler.
Je me demande si il y aurait des "sortes" de listes d'ensembles stables dont la version > est masquée ?

Mon installation remonte à plusieurs années ; peut-être 2012...
Maintenant, je patauge tranquillement dedans sans y faire de changement majeur.

J'utilise le simple xfce4 et ses extras
Je reste avec openrc et le nommage d'interfaces style eth0

Je ne pense pas prendre le noyau 4.14 ; même quand il sera stable.
Je ne crois pas qu'il présente vraiment de l'utilité dans mon cas. Malgré Meltdown...

Suit mes bidouillages de masquage ; je n'ai pas mis mon système à jour après.

Code:
n73sm /etc/portage/package.mask # ls -gt
total 96
-rw-r--r-- 1 root  30 19 janv. 16:26 dev-python-pygobject
-rw-r--r-- 1 root  79 19 janv. 16:21 gnome-base-gnome-desktop
-rw-r--r-- 1 root  52 19 janv. 16:09 vala
-rw-r--r-- 1 root  60 19 janv. 15:56 x11-libs-gtk+
-rw-r--r-- 1 root  22 19 janv. 15:47 dev-libs-glib
-rw-r--r-- 1 root  41 19 janv. 15:46 xfce4-terminal
-rw-r--r-- 1 root  22 19 janv. 15:38 net-fs-libnfs
-rw-r--r-- 1 root  29 19 janv. 15:32 webkit-gtk
-rw-r--r-- 1 root  24 19 janv. 15:25 kodi
-rw-r--r-- 1 root  25 19 janv. 15:24 libxml2
-rw-r--r-- 1 root  38 19 janv. 15:21 sources
-rw-r--r-- 1 root  77 19 janv. 15:20 llvm
-rw-r--r-- 1 root  26  2 déc.  23:40 hplip-3.17
-rw-r--r-- 1 root  75 13 nov.  06:33 nvidia
-rw-r--r-- 1 root 257 11 nov.  19:44 qtwebkit
-rw-r--r-- 1 root  33 29 sept. 08:04 opera
-rw-r--r-- 1 root  93 29 juin   2017 plex
-rw-r--r-- 1 root  30 15 déc.   2016 paramiko
-rw-r--r-- 1 root  30 17 oct.   2016 systemd
-rw-r--r-- 1 root  21 25 févr.  2016 vo-aacenc
-rw-r--r-- 1 root  50 21 déc.   2015 emul
-rw-r--r-- 1 root  28 22 févr.  2015 libtool
-rw-r--r-- 1 root  53 22 févr.  2015 openrc
-rw-r--r-- 1 root  22 22 févr.  2015 perl


édité le 21 janvier:
n73sm /etc/portage/package.mask # echo "" && for f in $(ls -t1); do echo "Pour "$f" :" && cat $f | sed '/^$/d' && echo ""; done

Pour x11-libs-gtk+ :
#>x11-libs/gtk+-3.22.19:3::gentoo
=x11-libs/gtk+-3.22.19::mv

Pour sources :
#>sys-kernel/gentoo-sources-4.9.76-r1

Pour llvm :
#>sys-devel/clang-4.0.1
#>sys-devel/llvm-4.0.1-r1
#>sys-devel/llvm-common-4.0.1

Pour libxml2 :
#>dev-libs/libxml2-2.9.6

Pour webkit-gtk :
#>net-libs/webkit-gtk-2.18.5

Pour net-fs-libnfs :
#>net-fs/libnfs-1.9.7

Pour xfce4-terminal :
#>x11-terms/xfce4-terminal-0.8.6::gentoo

Pour dev-libs-glib :
#>dev-libs/glib-2.52.3

Pour vala :
#>dev-lang/vala-0.34.9
#>dev-libs/vala-common-0.34.9

Pour gnome-base-gnome-desktop :
#>gnome-base/gnome-desktop-3.22.2
#>gnome-base/gsettings-desktop-schemas-3.22.0

Pour dev-python-pygobject :
#>dev-python/pygobject-3.22.0

Pour kodi :
>media-tv/kodi-17.3-r1

Pour hplip-3.17 :
>=net-print/hplip-3.17.10

Pour nvidia :
#>x11-drivers/nvidia-drivers-340.93-r1
#>x11-drivers/nvidia-drivers-361.28

Pour qtwebkit :
# required by dev-qt/qtwebkit:4 (argument)
# /usr/portage/profiles/package.mask:
# Andreas Sturmlechner <asturm@gentoo.org> (16 Oct 2017)
# Qt4WebKit is ancient and is likely to have more holes
# in it than swiss cheese. Bug #620684
=dev-qt/qtwebkit-4.8.7

Pour opera :
=www-client/opera-12.16_p1860-r1

Pour plex :
<=media-tv/plex-media-server-1.5.7.4016::fkmclane
<=media-tv/plex-media-server-1.5.5::gentoo

Pour paramiko :
#>=dev-python/paramiko-2.0.2

Pour systemd :
sys-apps/systemd
sys-fs/udev

Pour vo-aacenc :
media-libs/vo-aacenc

Pour emul :
# mask emul-linux
app-emulation/emul-linux-x86-*

Pour libtool :
<sys-devel/libtool-2.4.3-r2

Pour openrc :
<sys-apps/openrc-0.13.0
<sys-process/procps-3.3.9-r2

Pour perl :
<dev-lang/perl-5.18.0

_________________
Il faut être léger pour voler sur les cailloux


Last edited by pti-rem on Sun Jan 21, 2018 3:42 pm; edited 2 times in total
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3059
Location: Paris

PostPosted: Fri Jan 19, 2018 8:22 pm    Post subject: Re: [ebuild] masquer pour moins avoir à mettre à jour Reply with quote

pti-rem wrote:
Je ne pense pas prendre le noyau 4.14 ; même quand il sera stable.
Je ne crois pas qu'il présente vraiment de l'utilité dans mon cas. Malgré Meltdown...

Oh que si.
Tu as une machine avec un CPU Intel et un navigateur internet contenant un moteur Javascript. Tu exécutes donc du code tiers tous les jours.
Bienvenue en 2018 ;)
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 721
Location: S.O. France

PostPosted: Sun Jan 21, 2018 8:49 am    Post subject: Reply with quote

Le problème est que tu vas te retrouver bloqué à un moment ou un autre (par le jeu des dépendances).
Ca ne sera pas forcément de suite, mais peut-être dans 6 mois, 1 an, et là, la maj va être folklorique.

Si je suis ta logique, tu souhaite presque figer ton système?

Par contre, il est pas beau du tout ton package.mask.

Quote:
D'une manière générale, mes mises à jour globales sont vraiment trop importantes en temps de compilation et en chaleur interne pour mon portable i7-2670QM@2.2 de 2012.

Ca te prends combien de temps pour compiler gtk+?
Back to top
View user's profile Send private message
pti-rem
Apprentice
Apprentice


Joined: 14 Oct 2011
Posts: 265

PostPosted: Sun Jan 21, 2018 11:17 am    Post subject: Reply with quote

Salut sebB et merci.

Pour réinstaller x11-libs/gtk+-3.22.19::gentoo seul j'ai ce time :

real 5m2,772s
user 19m38,694s
sys 2m6,242s

Ça fait pas gros.

Je me disais que je pouvais me satisfaire d'une certaine version stable pour certains paquets ; je n'ai pas envie de me retrouver dans le folklore non plus.
C'est théoriquement possible de figer un peu son système et même d'en revenir j'imagine.

Ma machine tourne h24 et il y a un aspect un peu déplaisant que je ne m'explique pas bien à faire une mise à jour globale @world
genre « on sait ce qu'on a mais pas ce qu'on va trouver » & « Pourquoi tout ça encore ? »
Elle fait un petit peu serveur, j'aimerai pas l'avoir en rade en rapport à une mise à jour.

Pour mon package.mask, c'est la forme ou le fond qui ne va pas ? les deux ? J'y ai commenté tous mes ajouts du 19 janvier.
Mes USE doivent aussi manquer d'élégance, si ce n'est de logique. Avec des excédents aussi.

Il y a plein de principes fondamentaux qui m'échappent encore. Mon système est probablement surchargé par rapport à mes besoins. C'est pas certain.
J'ai plus de mal à me former davantage maintenant ; bon... j'ai un système qui tourne et c'est déjà bien.

Pour mon time emerge -pvuDN @world : https://pastebin.com/YXFKvxUG
Par exemple : llvm clang passent de la version 4 à la 5 en nouveau slot et j'ai pas mal de paquets en 3.22 qui passent en 3.24
Je donnerai le time de cette emerge.

J'aimerai bien - ça c'est sûr - avoir une trace du temps mis par chaque paquet pour émerger et utiliser juste ce facteur en premier.
Si il y a une astuce à utiliser ? Je dois bien pouvoir faire quelque chose avec /var/log/emerge.log

Je crois également qu'il vaut mieux que j'accepte de faire comme d'habitude tant que je ne connais pas davantage le rôle des paquets.
C'est aussi que j'étais avec gcc en version 4.x et j'ai eu du boulot pour le mettre à jour en version 5.y juste avant de devoir suivre la news pour le mettre à jour à nouveau (Gentoo 6.4.0-r1 p1.3)

Je vais passer mon MAKEOPTS de j9 à j5 ; pour utiliser en même temps et voir si ça chauffe moins. Le temps n'a guère d'importance en fait.

Au passage, y a t'il une version unstable conseillée des gentoo-sources du noyau 4.14 ?

édition : Je suis un peu ambivalent pour ce qui est du temps, peut-être que maintenant en j5 je me sentirai moins contrarié en pouvant utiliser ma machine tout en surveillant l'emerge.
_________________
Il faut être léger pour voler sur les cailloux


Last edited by pti-rem on Sun Jan 21, 2018 3:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
pti-rem
Apprentice
Apprentice


Joined: 14 Oct 2011
Posts: 265

PostPosted: Sun Jan 21, 2018 3:07 pm    Post subject: Reply with quote

MAKEOPTS="j5" résout mes soucis :-)

La température des cœurs reste raisonnable.
J'ai de la disponibilité pour travailler ou servir un peu.
Je peux suivre la mise à jour ; jeter un coup d'œil.
Le temps de compilation ne rentre plus en ligne de compte.

Je me sens bête alors ! d'être resté si longtemps avec cette problématique qui trouve une si simple solution.
Du coup, évidemment, je m'intéresse bien moins à masquer des paquets comme j'ai pu l'envisager.

El_Goretto wrote:
Tu as une machine avec un CPU Intel et un navigateur internet contenant un moteur Javascript. Tu exécutes donc du code tiers tous les jours.
Bienvenue en 2018 ;)


Cette affaire est tellement énorme et incroyable. C'est dingue.
Qui pourra dire que telle url donne à exécuter un code malveillant ?
Toutes les machines sont bonnes pour le rouleau à terme, si je me réfère à un article du point.

Autrement, Merci El_Goretto.
C'est pas ici que l'on va épiloguer.
_________________
Il faut être léger pour voler sur les cailloux
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 721
Location: S.O. France

PostPosted: Sun Jan 21, 2018 6:18 pm    Post subject: Reply with quote

Déjà tu peux virer tout les < dans tes mask.

Avec sensiblement le même CPU que toi voilà ce que j'utilise (le temps de compil je m'en fou et mon ordi n'est jamais surchargé)
Code:
MAKEOPTS="-j4 -l8"
EMERGE_DEFAULT_OPTS="--jobs=4 --load-average=4.0 --keep-going --with-bdeps=y"


Ca avec une compil en tmpfs et ton ordi devrait respirer.

Sinon pour les grosses compil, tu peux les virer à coup de exclude.
Quote:

J'aimerai bien - ça c'est sûr - avoir une trace du temps mis par chaque paquet pour émerger et utiliser juste ce facteur en premier.

genlop -t paquet
Back to top
View user's profile Send private message
pti-rem
Apprentice
Apprentice


Joined: 14 Oct 2011
Posts: 265

PostPosted: Mon Jan 22, 2018 9:05 am    Post subject: Reply with quote

J'ai fait comme tu m'as recommandé sebB

Je suis vraiment satisfait ! Merci beaucoup.
Ça change la donne.

Mes mask sont nettoyés
https://pastebin.com/4FdGZchG

Bonne journée
_________________
Il faut être léger pour voler sur les cailloux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum