Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
wifi needs LAN cable connection to startup, [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
skorefish
Apprentice
Apprentice


Joined: 21 Jun 2015
Posts: 273

PostPosted: Fri Jan 12, 2018 1:52 pm    Post subject: wifi needs LAN cable connection to startup, [solved] Reply with quote

hello,

Yesterday i had a problem with /etc/init.d/net.wlp2s0 restart (see https://forums.gentoo.org/viewtopic-t-1075300-highlight-.html).
I thought this was solved by installing the firmware.

Today i checked this again but i have the same issue...

After a little experimenting i discovered that wlp2s0 only restart,when i boot up with the lan cable connected to my computer.
The wlp2s0 keeps working normaly, so i can disconnect my network cable.

Without cable my system waits a long time before booting, and my wifi
doesn't get an ip address. The lan connection does...

What do i need to check to make the system boot properly without lan cable connected?


Last edited by skorefish on Fri Jan 12, 2018 4:21 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42558
Location: 56N 3W

PostPosted: Fri Jan 12, 2018 2:08 pm    Post subject: Reply with quote

skorefish,

Read the comments in /etc/rc.conf and edit the file.

The default is to require all network interfaces to be started before the network service is considered to be up.
You need to change that to any.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
skorefish
Apprentice
Apprentice


Joined: 21 Jun 2015
Posts: 273

PostPosted: Fri Jan 12, 2018 4:18 pm    Post subject: Reply with quote

hello Neddy,

thx to make me remember that file. Now it works again! :)
I added
Code:
 rc_hotplug="!net.*"


parallel works well to, no need for systemd 8) but i 'll test it anyway
gentoo = freedom of choice !!! :wink:

/etc/rc.conf
https://paste.pound-python.org/show/iIcpdevJPR0nuUQCtyb1/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum