Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to use certain installed fonts
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
cmrd
n00b
n00b


Joined: 13 Jul 2014
Posts: 10

PostPosted: Sun Jan 07, 2018 11:37 pm    Post subject: Unable to use certain installed fonts Reply with quote

I recently installed gentoo on a new machine as I have done many times before.

I then emerged media-fonts/proggy-fonts along with some others. All the media-fonts packages currently on my system are:
Code:
media-fonts/corefonts-1-r7::gentoo
media-fonts/dejavu-2.35::gentoo
media-fonts/encodings-1.0.4-r1::gentoo
media-fonts/font-util-1.3.1::gentoo
media-fonts/inconsolata-20140821::gentoo
media-fonts/liberation-fonts-2.00.1-r1::gentoo
media-fonts/libertine-5.3.0.20120702-r2::gentoo
media-fonts/proggy-fonts-1::gentoo
media-fonts/urw-fonts-2.4.9::gentoo

When I open libreoffice-writer, and open the font selection dropdown, some fonts I've installed, e.g. "Times New Roman" from corefonts and "Inconsolata" are shown in the dropdown, while others, e.g. any of the proggy-fonts are absent.

This issue is present not just in libreoffice-writer but in any program that uses fonts.

When I attempt to run xfontsel, I get:
Code:
Warning: Unable to load any usable ISO8859 font
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Error: Aborting: no font found

When I asked about my issue in #gentoo one of the suggestions was to run fc-cache. I noticed there's an fc-cat command, the output of which is below, in case it's useful. It includes the fonts that are meant to be showing:
https://paste.pound-python.org/show/NHMqsYbgspOQ8KvgNe2r/

Please could I get some help troubleshooting this?
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1574
Location: Frankfurt, Germany

PostPosted: Mon Jan 08, 2018 12:22 am    Post subject: Reply with quote

1) LibreOffice: proggy-fonts are bitmap fonts. As far as I know, newer versions of LibreOffice can't use them.

2) Other programs not showing proggy-fonts: look at the output of
Code:
eselect fontconfig list
Are bitmap fonts disabled? If they are disabled, enable them and restart X.

3) xfontsel: what is the output of
Code:
export | egrep "(LANG|LC_)"
Back to top
View user's profile Send private message
cmrd
n00b
n00b


Joined: 13 Jul 2014
Posts: 10

PostPosted: Sat Jan 13, 2018 12:08 am    Post subject: Reply with quote

Thanks for replying.

1) Fair enough, last time i checked it worked. I tried GIMP and GIMP can use them fine. I think it's just an issue with i3 where i'm actually trying to use them for window borders so I need to investigate that.

2) I'm not sure what to toggle to enable bitmap fonts:
Code:
$> eselect fontconfig list
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-hinting-full.conf
  [3]   10-hinting-medium.conf
  [4]   10-hinting-none.conf
  [5]   10-hinting-slight.conf *
  [6]   10-no-sub-pixel.conf
  [7]   10-scale-bitmap-fonts.conf *
  [8]   10-sub-pixel-bgr.conf
  [9]   10-sub-pixel-rgb.conf
  [10]  10-sub-pixel-vbgr.conf
  [11]  10-sub-pixel-vrgb.conf
  [12]  10-unhinted.conf
  [13]  11-lcdfilter-default.conf
  [14]  11-lcdfilter-legacy.conf
  [15]  11-lcdfilter-light.conf
  [16]  20-unhint-small-dejavu-sans.conf
  [17]  20-unhint-small-dejavu-sans-mono.conf
  [18]  20-unhint-small-dejavu-serif.conf
  [19]  20-unhint-small-vera.conf *
  [20]  25-unhint-nonlatin.conf
  [21]  30-metric-aliases.conf *
  [22]  30-urw-aliases.conf *
  [23]  40-nonlatin.conf *
  [24]  45-latin.conf *
  [25]  49-sansserif.conf *
  [26]  50-user.conf *
  [27]  51-local.conf *
  [28]  57-dejavu-sans.conf
  [29]  57-dejavu-sans-mono.conf
  [30]  57-dejavu-serif.conf
  [31]  60-latin.conf *
  [32]  60-liberation.conf
  [33]  65-fonts-persian.conf *
  [34]  65-khmer.conf
  [35]  65-nonlatin.conf *
  [36]  69-unifont.conf *
  [37]  70-no-bitmaps.conf
  [38]  70-yes-bitmaps.conf *
  [39]  80-delicious.conf *
  [40]  90-synthetic.conf *
  [41]  99pdftoopvp.conf


3) I just nave a normal UTF8 locale as far as i know:
Code:
$> export | egrep "(LANG|LC_)"
declare -x LANG="en_GB.utf8"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum