Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Problem with AMDGPU: blank screen at boot
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13490

PostPosted: Sat Jan 13, 2018 6:02 pm    Post subject: Reply with quote

If you want to cheat a bit, but not use a separate editor as Neddy did, one option would be:
  • cd /lib/firmware (or whatever directory you set for CONFIG_EXTRA_FIRMWARE_DIR). Important: you must cd to this directory, not a subdirectory, even if all the files you want to use are in the same subdirectory. This is required since you need the paths generated in the next step to be as seen from CONFIG_EXTRA_FIRMWARE_DIR.
  • echo glob-to-select-required-files (in this case, perhaps amdgpu/polaris10*). You may use multiple globs or run multiple echos if there is no convenient glob that matches all files you want to include and no files you want to exclude.
  • Inspect the result. If satisfactory, copy it to the X clipboard. Switch to the terminal running menuconfig, enter text input mode to name the files, then paste from the X clipboard instead of typing the filenames.
This lets you use only the supported tool to edit the configuration file, but spares you retyping the filenames.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 42559
Location: 56N 3W

PostPosted: Sat Jan 13, 2018 6:34 pm    Post subject: Reply with quote

Hu,

Live and learn, thank you.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Atha
Apprentice
Apprentice


Joined: 22 Sep 2004
Posts: 164

PostPosted: Thu Feb 08, 2018 5:31 pm    Post subject: Reply with quote

Chrishas wrote:
I had a similar error with my Vega 64 and the latest 4.15-rc kernel which went away when I disabled AMD Secure Memory Encryption (SME) support under Processor Type and Features, although could be completely unrelated to your issue.

Thank you so much! I had this issue with gentoo-sources-4.15 and couldn't figure out why the video output got frozen at the early printk just after the switch to amdgpu. I could save the dmesg output in the blind:
Code:
fb: switching to amdgpudrmfb from simple
Console: switching to colour dummy device 80x25
[drm] initializing kernel modesetting (VEGA10 0x1002:0x687F 0x1043:0x04C4 0xC1).
[drm] register mmio base: 0xFE600000
[drm] register mmio size: 524288
[drm] probing gen 2 caps for device 1022:1471 = 700d03/e
[drm] probing mlw for device 1022:1471 = 700d03
[drm] UVD is enabled in VM mode
[drm] UVD ENC is enabled in VM mode
[drm] VCE enabled in VM mode
amdgpu 0000:0c:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff
ATOM BIOS: 115-D050PIL-100
[drm] GPU post is not needed
[drm] vm size is 262144 GB, block size is 9-bit,fragment size is 9-bit
amdgpu 0000:0c:00.0: SME is active, device will require DMA bounce buffers
amdgpu 0000:0c:00.0: SME is active, device will require DMA bounce buffers
amdgpu 0000:0c:00.0: VRAM: 8176M 0x000000F400000000 - 0x000000F5FEFFFFFF (8176M used)
amdgpu 0000:0c:00.0: GTT: 256M 0x000000F5FF000000 - 0x000000F60EFFFFFF
[drm] Detected VRAM RAM=8176M, BAR=256M
[drm] RAM width 2048bits HBM
[TTM] Zone  kernel: Available graphics memory: 16408168 kiB
[TTM] Zone   dma32: Available graphics memory: 2097152 kiB
[TTM] Initializing pool allocator
[TTM] Initializing DMA pool allocator
[drm] amdgpu: 8176M of VRAM memory ready
[drm] amdgpu: 8176M of GTT memory ready.
SME is active and system is using DMA bounce buffers
[drm] GART: num cpu pages 65536, num gpu pages 65536
[drm] PCIE GART of 256M enabled (table at 0x000000F400800000).
amdgpu 0000:0c:00.0: swiotlb buffer is full (sz: 262152 bytes)
swiotlb: coherent allocation failed for device 0000:0c:00.0 size=262152
CPU: 9 PID: 2575 Comm: modprobe Not tainted 4.15.0-gentoo #8
Hardware name: System manufacturer System Product Name/PRIME X370-PRO, BIOS 3803 01/22/2018
Call Trace:
 dump_stack+0x5c/0x81
 swiotlb_alloc_coherent+0xf6/0x180
 amdgpu_ih_ring_init+0x214/0x290 [amdgpu]
 vega10_ih_sw_init+0x13/0xf0 [amdgpu]
 amdgpu_device_init+0xc3a/0x1520 [amdgpu]
 amdgpu_driver_load_kms+0x75/0x1f0 [amdgpu]
 drm_dev_register+0x161/0x1f0
 amdgpu_pci_probe+0x11d/0x150 [amdgpu]
 pci_device_probe+0xf0/0x170
 driver_probe_device+0x281/0x370
 __driver_attach+0xa4/0xb0
 ? driver_probe_device+0x370/0x370
 bus_for_each_dev+0x77/0xc0
 bus_add_driver+0x1b7/0x240
 ? 0xffffffffc0a3d000
 driver_register+0x52/0xc0
 ? 0xffffffffc0a3d000
 do_one_initcall+0x57/0x1b0
 ? __vunmap+0x7d/0xd0
 ? _cond_resched+0x10/0x40
 do_init_module+0x59/0x1e3
 load_module+0x2075/0x2630
 ? m_start+0x20/0x20
 SyS_finit_module+0xfb/0x120
 entry_SYSCALL_64_fastpath+0x24/0x87
RIP: 0033:0x7fb8e6d03709
RSP: 002b:00007ffcea6ed118 EFLAGS: 00000246
[drm:amdgpu_device_init [amdgpu]] *ERROR* sw_init of IP block <vega10_ih> failed -12
amdgpu 0000:0c:00.0: amdgpu_init failed
[TTM] Finalizing pool allocator
[TTM] Finalizing DMA pool allocator
[TTM] Zone  kernel: Used memory at exit: 0 kiB
[TTM] Zone   dma32: Used memory at exit: 0 kiB
[drm] amdgpu: ttm finalized
amdgpu 0000:0c:00.0: Fatal error during GPU init
[drm] amdgpu: finishing device.
[TTM] Memory type 2 has not been initialized
amdgpu: probe of 0000:0c:00.0 failed with error -12

Note: the last line visible on the early printk was "fb: switching to amdgpudrmfb from simple".

After disabling SME (CONFIG_AMD_MEM_ENCRYPT=y but CONFIG_AMD_MEM_ENCRYPT_ACTIVE_BY_DEFAULT not set or mem_encrypt=off as kernel commandline option) everything works now. I'm very pleased, although I hope that AMDGPU+DC will work with SME in the future...

For completeness, here the working dmesg (relevant part, with lots of debug output and anonymized monitor information "***"):
Code:
[drm] amdgpu kernel modesetting enabled.
checking generic (e0000000 300000) vs hw (e0000000 10000000)
fb: switching to amdgpudrmfb from simple
Console: switching to colour dummy device 80x25
[drm] initializing kernel modesetting (VEGA10 0x1002:0x687F 0x1043:0x04C4 0xC1).
[drm] register mmio base: 0xFE600000
[drm] register mmio size: 524288
[drm] probing gen 2 caps for device 1022:1471 = 700d03/e
[drm] probing mlw for device 1022:1471 = 700d03
[drm] UVD is enabled in VM mode
[drm] UVD ENC is enabled in VM mode
[drm] VCE enabled in VM mode
amdgpu 0000:0c:00.0: Invalid PCI ROM header signature: expecting 0xaa55, got 0xffff
ATOM BIOS: 115-D050PIL-100
[drm] GPU post is not needed
[drm] vm size is 262144 GB, block size is 9-bit,fragment size is 9-bit
amdgpu 0000:0c:00.0: VRAM: 8176M 0x000000F400000000 - 0x000000F5FEFFFFFF (8176M used)
amdgpu 0000:0c:00.0: GTT: 256M 0x000000F5FF000000 - 0x000000F60EFFFFFF
[drm] Detected VRAM RAM=8176M, BAR=256M
[drm] RAM width 2048bits HBM
[TTM] Zone  kernel: Available graphics memory: 16403994 kiB
[TTM] Zone   dma32: Available graphics memory: 2097152 kiB
[TTM] Initializing pool allocator
[TTM] Initializing DMA pool allocator
[drm] amdgpu: 8176M of VRAM memory ready
[drm] amdgpu: 8176M of GTT memory ready.
[drm] GART: num cpu pages 65536, num gpu pages 65536
[drm] PCIE GART of 256M enabled (table at 0x000000F400800000).
amdgpu 0000:0c:00.0: amdgpu: using MSI.
[drm] amdgpu: irq initialized.
amdgpu: [powerplay] amdgpu: powerplay sw initialized
amdgpu 0000:0c:00.0: fence driver on ring 0 use gpu addr 0x000000f5ff400040, cpu addr 0x00000000a1f28035
amdgpu 0000:0c:00.0: fence driver on ring 1 use gpu addr 0x000000f5ff4000c0, cpu addr 0x00000000e0ae1441
amdgpu 0000:0c:00.0: fence driver on ring 2 use gpu addr 0x000000f5ff400140, cpu addr 0x00000000a46b2833
amdgpu 0000:0c:00.0: fence driver on ring 3 use gpu addr 0x000000f5ff4001c0, cpu addr 0x00000000211ede71
amdgpu 0000:0c:00.0: fence driver on ring 4 use gpu addr 0x000000f5ff400240, cpu addr 0x00000000f3fb64fb
amdgpu 0000:0c:00.0: fence driver on ring 5 use gpu addr 0x000000f5ff4002c0, cpu addr 0x000000000ef76f17
amdgpu 0000:0c:00.0: fence driver on ring 6 use gpu addr 0x000000f5ff400340, cpu addr 0x000000001d3ea63a
amdgpu 0000:0c:00.0: fence driver on ring 7 use gpu addr 0x000000f5ff4003c0, cpu addr 0x000000003884c925
amdgpu 0000:0c:00.0: fence driver on ring 8 use gpu addr 0x000000f5ff400440, cpu addr 0x000000008c869fa1
amdgpu 0000:0c:00.0: fence driver on ring 9 use gpu addr 0x000000f5ff4004e0, cpu addr 0x00000000fb587289
[drm] use_doorbell being set to: [true]
amdgpu 0000:0c:00.0: fence driver on ring 10 use gpu addr 0x000000f5ff400560, cpu addr 0x00000000f06fe7bd
[drm] use_doorbell being set to: [true]
amdgpu 0000:0c:00.0: fence driver on ring 11 use gpu addr 0x000000f5ff4005e0, cpu addr 0x0000000058992921
[drm] Found UVD firmware Version: 1.68 Family ID: 17
[drm] PSP loading UVD firmware
amdgpu 0000:0c:00.0: fence driver on ring 12 use gpu addr 0x000000f4008faa60, cpu addr 0x00000000a7fdd691
amdgpu 0000:0c:00.0: fence driver on ring 13 use gpu addr 0x000000f5ff4006e0, cpu addr 0x0000000095853c26
amdgpu 0000:0c:00.0: fence driver on ring 14 use gpu addr 0x000000f5ff400760, cpu addr 0x000000003cef75c5
[drm] Found VCE firmware Version: 53.40 Binary ID: 4
[drm] PSP loading VCE firmware
amdgpu 0000:0c:00.0: fence driver on ring 15 use gpu addr 0x000000f5ff4007e0, cpu addr 0x000000004c6c771e
amdgpu 0000:0c:00.0: fence driver on ring 16 use gpu addr 0x000000f5ff400860, cpu addr 0x00000000d3350e70
amdgpu 0000:0c:00.0: fence driver on ring 17 use gpu addr 0x000000f5ff4008e0, cpu addr 0x000000002a289f2c
[drm] DC: create_links: connectors_num: physical:5, virtual:0
[drm] Display Core initialized!
i2c i2c-0: adapter [AMDGPU DM i2c hw bus 0] registered
i2c i2c-1: adapter [dmdc] registered
i2c i2c-2: adapter [AMDGPU DM i2c hw bus 1] registered
i2c i2c-3: adapter [dmdc] registered
i2c i2c-4: adapter [AMDGPU DM i2c hw bus 2] registered
i2c i2c-5: adapter [AMDGPU DM i2c hw bus 3] registered
i2c i2c-6: adapter [AMDGPU DM i2c hw bus 4] registered
i2c i2c-6: master_xfer[0] W, addr=0x50, len=1
i2c i2c-6: master_xfer[1] R, addr=0x50, len=1
i2c i2c-6: master_xfer[0] W, addr=0x50, len=1
i2c i2c-6: master_xfer[1] R, addr=0x50, len=128
i2c i2c-6: master_xfer[0] W, addr=0x50, len=1
i2c i2c-6: master_xfer[1] R, addr=0x50, len=128
[drm] SADs count is: 0, don't need to read it
[drm] ***: [Block 0]
[drm] ***: [Block 1]
[drm] dc_link_detect: manufacturer_id = ***, product_id = ***, serial_number = ***, manufacture_week = ***, manufacture_year = ***, display_name = ***, speaker_flag = 0, audio_mode_count = 0
[drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[drm] Driver supports precise vblank timestamp query.
[drm] ring test on 0 succeeded in 1 usecs
[drm] ring test on 9 succeeded in 5 usecs
[drm] ring test on 1 succeeded in 2 usecs
[drm] ring test on 2 succeeded in 1 usecs
[drm] ring test on 3 succeeded in 1 usecs
[drm] ring test on 4 succeeded in 1 usecs
[drm] ring test on 5 succeeded in 1 usecs
[drm] ring test on 6 succeeded in 1 usecs
[drm] ring test on 7 succeeded in 1 usecs
[drm] ring test on 8 succeeded in 1 usecs
[drm] ring test on 10 succeeded in 10 usecs
[drm] ring test on 11 succeeded in 9 usecs
[drm] ring test on 12 succeeded in 1 usecs
[drm] ring test on 13 succeeded in 25 usecs
[drm] ring test on 14 succeeded in 4 usecs
[drm] UVD and UVD ENC initialized successfully.
[drm] ring test on 15 succeeded in 29 usecs
[drm] ring test on 16 succeeded in 22 usecs
[drm] ring test on 17 succeeded in 22 usecs
[drm] VCE initialized successfully.
[drm] ib test on ring 0 succeeded
[drm] ib test on ring 1 succeeded
[drm] ib test on ring 2 succeeded
[drm] ib test on ring 3 succeeded
[drm] ib test on ring 4 succeeded
[drm] ib test on ring 5 succeeded
[drm] ib test on ring 6 succeeded
[drm] ib test on ring 7 succeeded
[drm] ib test on ring 8 succeeded
[drm] ib test on ring 9 succeeded
[drm] ib test on ring 10 succeeded
[drm] ib test on ring 11 succeeded
[drm] ib test on ring 12 succeeded
[drm] ib test on ring 13 succeeded
[drm] ib test on ring 14 succeeded
[drm] ib test on ring 15 succeeded
[drm] fb mappable at 0xE0E00000
[drm] vram apper at 0xE0000000
[drm] size 21786624
[drm] fb depth is 24
[drm]    pitch is 6912
fbcon: amdgpudrmfb (fb0) is primary device
[drm] {***x***, ***x***@***Khz}
Console: switching to colour frame buffer device 210x65
tsc: Refined TSC clocksource calibration: 3842.780 MHz
clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x6ec86b06a41, max_idle_ns: 881591082858 ns
amdgpu 0000:0c:00.0: fb0: amdgpudrmfb frame buffer device
amdgpu 0000:0c:00.0: ring 0(gfx) uses VM inv eng 4 on hub 0
amdgpu 0000:0c:00.0: ring 1(comp_1.0.0) uses VM inv eng 5 on hub 0
amdgpu 0000:0c:00.0: ring 2(comp_1.1.0) uses VM inv eng 6 on hub 0
amdgpu 0000:0c:00.0: ring 3(comp_1.2.0) uses VM inv eng 7 on hub 0
amdgpu 0000:0c:00.0: ring 4(comp_1.3.0) uses VM inv eng 8 on hub 0
amdgpu 0000:0c:00.0: ring 5(comp_1.0.1) uses VM inv eng 9 on hub 0
amdgpu 0000:0c:00.0: ring 6(comp_1.1.1) uses VM inv eng 10 on hub 0
amdgpu 0000:0c:00.0: ring 7(comp_1.2.1) uses VM inv eng 11 on hub 0
amdgpu 0000:0c:00.0: ring 8(comp_1.3.1) uses VM inv eng 12 on hub 0
amdgpu 0000:0c:00.0: ring 9(kiq_2.1.7) uses VM inv eng 13 on hub 0
amdgpu 0000:0c:00.0: ring 10(sdma0) uses VM inv eng 4 on hub 1
amdgpu 0000:0c:00.0: ring 11(sdma1) uses VM inv eng 5 on hub 1
amdgpu 0000:0c:00.0: ring 12(uvd) uses VM inv eng 6 on hub 1
amdgpu 0000:0c:00.0: ring 13(uvd_enc0) uses VM inv eng 7 on hub 1
amdgpu 0000:0c:00.0: ring 14(uvd_enc1) uses VM inv eng 8 on hub 1
amdgpu 0000:0c:00.0: ring 15(vce0) uses VM inv eng 9 on hub 1
amdgpu 0000:0c:00.0: ring 16(vce1) uses VM inv eng 10 on hub 1
amdgpu 0000:0c:00.0: ring 17(vce2) uses VM inv eng 11 on hub 1
amdgpu 0000:0c:00.0: kfd not supported on this ASIC
[drm] Initialized amdgpu 3.23.0 20150101 for 0000:0c:00.0 on minor 0
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum