Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] sys-libs/readline slot slot conflict
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
gangstervano
n00b
n00b


Joined: 15 Aug 2016
Posts: 35

PostPosted: Thu Jan 04, 2018 2:25 pm    Post subject: [SOLVED] sys-libs/readline slot slot conflict Reply with quote

Hi!

I have a problem:

Code:
emerge -a --update --deep --with-bdeps=y --newuse --depclean-lib-check=y --verbose-conflicts @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-libs/ncurses-6.0-r1  ABI_X86="32*"
[ebuild     U  ] sys-apps/debianutils-4.8.3 [4.7]
[ebuild     U  ] app-text/sgml-common-0.6.3-r6 [0.6.3-r5]
[ebuild     U  ] sys-power/pm-quirks-20100619-r1 [20100619]
[ebuild     U  ] sys-devel/binutils-config-5-r4 [5-r3]
[ebuild     U  ] app-text/docbook-dsssl-stylesheets-1.79-r2 [1.79]
[ebuild     U  ] sys-apps/less-529 [487]
[ebuild     U  ] app-text/libstaroffice-0.0.5 [0.0.4]
[ebuild     U  ] app-arch/unzip-6.0_p21-r2 [6.0_p20]
[ebuild     U  ] dev-python/setuptools-36.7.2 [34.0.2-r1]
[ebuild     U  ] dev-python/pygments-2.2.0 [2.1.1]
[ebuild     U  ] sys-kernel/linux-headers-4.13 [4.4]
[ebuild  NS    ] sys-kernel/gentoo-sources-4.9.72 [4.12.12, 4.14.8-r1] USE="-build -experimental -symlink"
[ebuild     U  ] dev-libs/expat-2.2.5 [2.2.1]
[ebuild     U  ] dev-util/mdds-1.3.1 [1.2.3]
[ebuild   R    ] dev-lang/ghc-8.0.2  USE="-binary*"
[ebuild     U  ] sys-apps/iproute2-4.14.1-r2 [4.14.1-r1]
[ebuild     U  ] sys-libs/readline-7.0_p3 [6.3_p8-r3]
[ebuild   R    ] sys-libs/gpm-1.20.7-r2  ABI_X86="-32*"
[ebuild     U  ] app-text/libmwaw-0.3.13 [0.3.12]
[ebuild     U  ] media-libs/libvisio-0.1.6 [0.1.5-r1]
[ebuild     U  ] app-text/libetonyek-0.1.7 [0.1.6]
[ebuild     U  ] app-text/libwps-0.4.8 [0.4.7]
[ebuild   R    ] dev-lang/python-3.4.5-r1  USE="-sqlite*"
[ebuild     U  ] app-shells/bash-4.4_p12 [4.3_p48-r1]
[ebuild     U  ] dev-util/cmake-3.9.6 [3.8.2]
[ebuild     U  ] x11-misc/shared-mime-info-1.9 [1.8]
[ebuild   R    ] x11-libs/cairo-1.14.8  USE="(-directfb%)"
[ebuild     U  ] app-text/enchant-1.6.1 [1.6.0] USE="{-test%}"
[ebuild     U  ] kde-frameworks/kpty-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kplotting-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kitemmodels-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/oxygen-icons-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/threadweaver-5.40.0 [5.37.0]
[ebuild     U  ] dev-lang/vala-0.34.9 [0.34.8]
[ebuild     U  ] kde-frameworks/prison-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kimageformats-5.40.0 [5.37.0]
[ebuild     U  ] x11-libs/gdk-pixbuf-2.36.10-r2 [2.36.9]
[ebuild     U  ] media-libs/harfbuzz-1.7.2 [1.4.6-r2]
[ebuild     U  ] x11-libs/pango-1.40.12 [1.40.6]
[ebuild     U  ] dev-util/gtk-update-icon-cache-3.22.19 [3.22.2]
[ebuild     U  ] kde-frameworks/kdesu-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kemoticons-5.40.0 [5.37.0]
[ebuild     U  ] dev-libs/libusb-1.0.21 [1.0.19-r1]
[ebuild     U  ] dev-libs/libgudev-232 [231]
[ebuild     U  ] sys-fs/cryptsetup-1.7.5 [1.7.4] PYTHON_TARGETS="-python3_6%"
[ebuild     U  ] app-editors/vim-8.0.1298 [8.0.0386] USE="-terminal%" PYTHON_SINGLE_TARGET="python3_5%* -python2_7% -python3_4% -python3_6%"
[ebuild     U  ] media-gfx/imagemagick-7.0.7.14 [6.9.9.20]
[ebuild     U  ] gnome-base/dconf-0.26.1 [0.26.0-r1]
[ebuild     U  ] kde-frameworks/kjs-5.40.0 [5.37.0]
[ebuild     U  ] dev-libs/libpwquality-1.4.0 [1.3.0]
[ebuild     U  ] net-misc/iputils-20171016_pre [20151218] USE="openssl%* -nettle%"
[ebuild     U  ] media-libs/gstreamer-1.12.3 [1.10.5]
[ebuild     U  ] x11-libs/gtk+-3.22.19 [3.22.16] USE="-xinerama*"
[ebuild     U  ] app-text/gtkspell-3.0.9 [3.0.7]
[ebuild     U  ] sys-boot/plymouth-0.9.3-r1 [0.9.2-r1]
[ebuild   R    ] dev-qt/qtgui-4.8.7  USE="-xinerama*"
[ebuild     U  ] sys-libs/pam-1.2.1-r2 [1.2.1] USE="filecaps%*"
[ebuild   R    ] x11-libs/gtk+-2.24.31-r1  USE="-xinerama*"
[ebuild     U  ] sys-libs/libblockdev-2.14-r1 [2.14] USE="cryptsetup%*"
[ebuild     U  ] sys-auth/pambase-20150213-r1 [20150213] USE="(-elogind)"
[ebuild     U  ] sys-apps/accountsservice-0.6.45 [0.6.43-r1]
[ebuild     U  ] kde-frameworks/kunitconversion-5.40.0 [5.37.0]
[ebuild     U  ] net-libs/signond-8.59 [8.58]
[ebuild     U  ] kde-frameworks/networkmanager-qt-5.40.0 [5.37.0]
[ebuild     U  ] net-libs/libsignon-glib-1.14 [1.13-r1]
[ebuild     U  ] kde-frameworks/kpeople-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/bluez-qt-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/syntax-highlighting-5.40.0 [5.37.0-r1]
[ebuild     U  ] kde-frameworks/kdesignerplugin-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kdnssd-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kjsembed-5.40.0 [5.37.0]
[ebuild     U  ] media-sound/pulseaudio-11.1 [10.0]
[ebuild   R    ] media-libs/libsdl-1.2.15-r9  USE="-xinerama*"
[ebuild   R    ] media-libs/libsdl2-2.0.4  USE="-xinerama*"
[ebuild  N     ] media-sound/mpg123-1.25.6  USE="alsa ipv6 pulseaudio sdl (-altivec) (-coreaudio) -int-quality -jack -nas -oss -portaudio" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse (-3dnow) (-3dnowext) (-mmx)"
[ebuild     U  ] media-video/vlc-2.2.8 [2.2.6]
[ebuild     U  ] kde-frameworks/kfilemetadata-5.40.0 [5.37.0]
[ebuild     U  ] www-client/firefox-bin-52.5.2 [52.5.0-r1]
[ebuild   R    ] net-misc/freerdp-2.0.0_rc0  USE="-xinerama*" CPU_FLAGS_X86="-ssse3% (-sse2%*)"
[ebuild     U  ] kde-frameworks/kparts-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/knotifyconfig-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/baloo-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kxmlrpcclient-5.40.0 [5.37.0]
[ebuild     U  ] media-plugins/kipi-plugins-5.7.0 [5.5.0]
[ebuild     U  ] kde-frameworks/khtml-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/ktexteditor-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kross-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kdewebkit-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kdelibs4support-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kactivities-stats-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/krunner-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/frameworkintegration-5.40.0 [5.37.0]
[ebuild     U  ] media-libs/gst-plugins-base-1.12.3 [1.10.5]
[ebuild     U  ] media-libs/gst-plugins-ugly-1.12.3 [1.10.5]
[ebuild     U  ] media-libs/gst-plugins-good-1.12.3 [1.10.5]
[ebuild     U  ] media-libs/gst-plugins-bad-1.12.3 [1.10.5] USE="egl*"
[blocks b      ] <media-libs/gst-plugins-bad-1.11.90:1.0 ("<media-libs/gst-plugins-bad-1.11.90:1.0" is blocking media-libs/gst-plugins-base-1.12.3)                                               
[ebuild     U  ] media-plugins/gst-plugins-libav-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-cdparanoia-1.12.3 [1.10.5]
[ebuild     U  ] app-office/libreoffice-bin-5.4.2.2-r1 [5.4.2.2]
[ebuild     U  ] media-plugins/gst-plugins-faad-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-pulse-1.12.3 [1.10.5]
[ebuild  N     ] media-plugins/gst-plugins-mpg123-1.12.3  ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] media-plugins/gst-plugins-mpeg2dec-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-x264-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-dvdread-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-dts-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-a52dec-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-flac-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-resindvd-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-meta-1.12.3 [1.10.5]
[ebuild  N     ] kde-apps/kdeedu-meta-17.08.3
[ebuild     U  ] app-cdr/brasero-3.12.2 [3.12.1-r1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/readline:0

  (sys-libs/readline-7.0_p3:0/7::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/readline-7.0:0= required by (app-shells/bash-4.4_p12:0/0::gentoo, ebuild scheduled for merge)
    ^^                  ^^^^^^                                                                                                                                                       

  (sys-libs/readline-6.3_p8-r3:0/0::gentoo, installed) pulled in by
    sys-libs/readline:0/0= required by (sys-apps/util-linux-2.30.2:0/0::gentoo, installed)
                     ^^^^^                                                                                                   
    sys-libs/readline:0/0= required by (dev-lang/spidermonkey-1.8.5-r6:0/mozjs185::gentoo, installed)
                     ^^^^^                                                                                                               
    >=sys-libs/readline-6.2_p5-r1:0/0=[abi_x86_64(-)] required by (sys-libs/slang-2.3.0:0/0::gentoo, installed)
                                 ^^^^^                                                                                                             
    >=sys-libs/readline-4.1:0/0= required by (net-misc/ntp-4.2.8_p10-r1:0/0::gentoo, installed)
                           ^^^^^                                                                                                   
    >=sys-libs/readline-4.1:0/0= required by (dev-lang/python-2.7.14-r1:2.7/2.7::gentoo, installed)
                           ^^^^^                                                                                                       
    sys-libs/readline:0/0= required by (sci-libs/libqalculate-0.9.9:0/6::gentoo, installed)
                     ^^^^^                                                                                                     
    >=sys-libs/readline-4.1:0/0= required by (dev-lang/python-3.6.3-r1:3.6/3.6m::gentoo, installed)
                           ^^^^^                                                                                                       
    sys-libs/readline:0/0= required by (dev-libs/libpcre-8.41-r1:3/3::gentoo, installed)
                     ^^^^^                                                                                                 
    sys-libs/readline:0/0= required by (sys-apps/gawk-4.1.4:0/0::gentoo, installed)
                     ^^^^^                                                                                             
    >=sys-libs/readline-6.2_p5-r1:0/0=[abi_x86_64(-)] required by (dev-db/unixODBC-2.3.4-r1:0/0::gentoo, installed)
                                 ^^^^^                                                                                                                 
    sys-libs/readline:0/0=[abi_x86_64(-)] required by (dev-db/sqlite-3.20.1-r1:3/3::gentoo, installed)
                     ^^^^^                                                                                                               
    sys-libs/readline:0/0= required by (net-wireless/bluez-5.47-r1:0/3::gentoo, installed)
                     ^^^^^                                                                                                   
    >=sys-libs/readline-4.1:0/0= required by (dev-db/mariadb-10.1.29:0/18::gentoo, installed)
                           ^^^^^                                                                                                 
    sys-libs/readline:0/0= required by (sys-fs/lvm2-2.02.145-r2:0/0::gentoo, installed)
                     ^^^^^                                                                                                 
    sys-libs/readline:0/0= required by (net-wireless/wpa_supplicant-2.6-r3:0/0::gentoo, installed)
                     ^^^^^                                                                                                           
    >=sys-libs/readline-4.1:0/0= required by (dev-lang/python-3.5.4-r1:3.5/3.5m::gentoo, installed)
                           ^^^^^                                                                                                       
    sys-libs/readline:0/0= required by (kde-apps/kalgebra-17.08.3:5/5::gentoo, installed)
                     ^^^^^                                                                                                   
    >=sys-libs/readline-5.2:0/0= required by (sys-block/parted-3.2-r1:0/0::gentoo, installed)
                           ^^^^^                                                                                                 
    sys-libs/readline:0/0= required by (app-text/hunspell-1.6.1-r1:0/1.6::gentoo, installed)
                     ^^^^^                                                                                                     
    sys-libs/readline:0/0= required by (dev-lang/ruby-2.2.9:2.2/2.2::gentoo, installed)
                     ^^^^^                                                                                                 
    sys-libs/readline:0/0= required by (app-crypt/gnupg-2.2.0:0/0::gentoo, installed)
                     ^^^^^                                                                                               
    sys-libs/readline:0/0= required by (net-misc/networkmanager-1.8.4:0/0::gentoo, installed)
                     ^^^^^                                                                                                       
    sys-libs/readline:0/0= required by (net-misc/socat-1.7.3.2:0/0::gentoo, installed)
                     ^^^^^                                                                                               
    sys-libs/readline:0/0= required by (sys-fs/xfsprogs-4.9.0:0/0::gentoo, installed)
                     ^^^^^                                                                                               
    >=sys-libs/readline-6.2_p5-r1:0/0=[abi_x86_64(-)] required by (media-sound/fluidsynth-1.1.6-r1:0/0::gentoo, installed)
                                 ^^^^^                                                                                                                       
    sys-libs/readline:0/0= required by (dev-libs/libxml2-2.9.6:2/2::gentoo, installed)
                     ^^^^^                                                                                               


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-libs/wayland-1.13.0::gentoo
# required by media-libs/mesa-17.2.7::gentoo[wayland]
# required by media-libs/gst-plugins-bad-1.12.3::gentoo[egl]
# required by media-plugins/gst-plugins-dts-1.12.3::gentoo
# required by media-plugins/gst-plugins-meta-1.12.3::gentoo[dts]
# required by app-cdr/brasero-3.12.2::gentoo
# required by @selected
# required by @world (argument)
>=dev-libs/expat-2.2.5 abi_x86_32
# required by sys-devel/llvm-4.0.1-r1::gentoo
# required by media-libs/mesa-17.2.7::gentoo[llvm,-opencl,-video_cards_r600,-video_cards_radeon,video_cards_radeonsi]
# required by media-libs/gst-plugins-bad-1.12.3::gentoo[egl]
# required by media-plugins/gst-plugins-dts-1.12.3::gentoo
# required by media-plugins/gst-plugins-meta-1.12.3::gentoo[dts]
# required by app-cdr/brasero-3.12.2::gentoo
# required by @selected
# required by @world (argument)
>=sys-libs/ncurses-6.0-r1 abi_x86_32

Would you like to add these changes to your config files? [Yes/No]


make.conf:

Code:
gangstervano ~ # cat make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=core-avx-i -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE and USE_EXPAND flags that were used for
# buidling in addition to what is provided by the profile.
USE="X kde mmx mmxext sse sse2 sse3 libkms plymouth qt5 alsa dvd \
     cdr gtk networkmanager pam pulseaudio display-manager grub \
     mediacenter sddm sdk wallpapers dbus policykit udev udisks \
     video consolekit ffmpeg infinality"
CPU_FLAGS_X86="mmx mmxext sse sse2 sse3"
PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
MAKEOPTS="-j5"
INPUT_DEVICES="evdev synaptics"
VIDEO_CARDS="amdgpu radeonsi"
#VIDEO_CARDS="radeon"
#VIDEO_CARDS="fglrx"
FEATURES="ccache"
CCACHE_SIZE="2G"
CCACHE_DIR="/var/tmp/ccache"
L10N="en"
LINGUAS="en"
ABI_X86="64"
ACCEPT_LICENSE="*"
SANE_BACKENDS="hp"
source /var/lib/layman/make.conf
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/ \
                http://gentoo.bloodhost.ru/ \
                ftp://gentoo.bloodhost.ru/ \
                rsync://gentoo.bloodhost.ru/gentoo-distfiles \
                ftp://xeon.gentoo.ru/mirrors/gentoo/distfiles/"
source /var/lib/layman/make.conf


Last edited by gangstervano on Fri Jan 05, 2018 12:53 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18586
Location: here

PostPosted: Thu Jan 04, 2018 3:17 pm    Post subject: Reply with quote

Try with
Code:
# emerge -uUD --with-bdeps=y @world --backtrack=30

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
gangstervano
n00b
n00b


Joined: 15 Aug 2016
Posts: 35

PostPosted: Thu Jan 04, 2018 6:17 pm    Post subject: Reply with quote

Unfortunately did not help. :(
Code:
gangstervano ~ # emerge -uUD --with-bdeps=y @world --backtrack=30
Calculating dependencies... done!
[ebuild   R    ] sys-libs/ncurses-6.0-r1  ABI_X86="32*"
[ebuild     U  ] sys-apps/debianutils-4.8.3 [4.7]
[ebuild     U  ] app-text/sgml-common-0.6.3-r6 [0.6.3-r5]
[ebuild     U  ] sys-power/pm-quirks-20100619-r1 [20100619]
[ebuild     U  ] sys-devel/binutils-config-5-r4 [5-r3]
[ebuild     U  ] app-text/docbook-dsssl-stylesheets-1.79-r2 [1.79]
[ebuild     U  ] sys-apps/less-529 [487]
[ebuild     U  ] app-text/libstaroffice-0.0.5 [0.0.4]
[ebuild     U  ] app-arch/unzip-6.0_p21-r2 [6.0_p20]
[ebuild     U  ] dev-python/setuptools-36.7.2 [34.0.2-r1]
[ebuild     U  ] dev-python/pygments-2.2.0 [2.1.1]
[ebuild     U  ] sys-kernel/linux-headers-4.13 [4.4]
[ebuild  NS    ] sys-kernel/gentoo-sources-4.9.72 [4.12.12, 4.14.8-r1] USE="-build -experimental -symlink"
[ebuild     U  ] dev-libs/expat-2.2.5 [2.2.1]
[ebuild     U  ] dev-util/mdds-1.3.1 [1.2.3]
[ebuild   R    ] dev-lang/ghc-8.0.2  USE="-binary*"
[ebuild     U  ] sys-apps/iproute2-4.14.1-r2 [4.14.1-r1]
[ebuild     U  ] sys-libs/readline-7.0_p3 [6.3_p8-r3]
[ebuild   R    ] sys-libs/gpm-1.20.7-r2  ABI_X86="-32*"
[ebuild     U  ] app-text/libmwaw-0.3.13 [0.3.12]
[ebuild     U  ] media-libs/libvisio-0.1.6 [0.1.5-r1]
[ebuild     U  ] app-text/libetonyek-0.1.7 [0.1.6]
[ebuild     U  ] app-text/libwps-0.4.8 [0.4.7]
[ebuild   R    ] dev-lang/python-3.4.5-r1  USE="-sqlite*"
[ebuild     U  ] app-shells/bash-4.4_p12 [4.3_p48-r1]
[ebuild     U  ] dev-util/cmake-3.9.6 [3.8.2]
[ebuild     U  ] x11-misc/shared-mime-info-1.9 [1.8]
[ebuild     U  ] app-text/enchant-1.6.1 [1.6.0] USE="{-test%}"
[ebuild     U  ] kde-frameworks/kpty-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kplotting-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kitemmodels-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/oxygen-icons-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/threadweaver-5.40.0 [5.37.0]
[ebuild     U  ] dev-lang/vala-0.34.9 [0.34.8]
[ebuild     U  ] kde-frameworks/prison-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kimageformats-5.40.0 [5.37.0]
[ebuild     U  ] x11-libs/gdk-pixbuf-2.36.10-r2 [2.36.9]
[ebuild     U  ] media-libs/harfbuzz-1.7.2 [1.4.6-r2]
[ebuild     U  ] x11-libs/pango-1.40.12 [1.40.6]
[ebuild     U  ] dev-util/gtk-update-icon-cache-3.22.19 [3.22.2]
[ebuild     U  ] kde-frameworks/kdesu-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kemoticons-5.40.0 [5.37.0]
[ebuild     U  ] dev-libs/libusb-1.0.21 [1.0.19-r1]
[ebuild     U  ] dev-libs/libgudev-232 [231]
[ebuild     U  ] sys-fs/cryptsetup-1.7.5 [1.7.4] PYTHON_TARGETS="-python3_6%"
[ebuild     U  ] app-editors/vim-8.0.1298 [8.0.0386] USE="-terminal%" PYTHON_SINGLE_TARGET="python3_5%* -python2_7% -python3_4% -python3_6%"
[ebuild     U  ] media-gfx/imagemagick-7.0.7.14 [6.9.9.20]
[ebuild     U  ] gnome-base/dconf-0.26.1 [0.26.0-r1]
[ebuild     U  ] kde-frameworks/kjs-5.40.0 [5.37.0]
[ebuild     U  ] dev-libs/libpwquality-1.4.0 [1.3.0]
[ebuild     U  ] net-misc/iputils-20171016_pre [20151218] USE="openssl%* -nettle%"
[ebuild     U  ] media-libs/gstreamer-1.12.3 [1.10.5]
[ebuild     U  ] x11-libs/gtk+-3.22.19 [3.22.16] USE="-xinerama*"
[ebuild     U  ] app-text/gtkspell-3.0.9 [3.0.7]
[ebuild     U  ] sys-boot/plymouth-0.9.3-r1 [0.9.2-r1]
[ebuild   R    ] dev-qt/qtgui-4.8.7  USE="-xinerama*"
[ebuild     U  ] sys-libs/pam-1.2.1-r2 [1.2.1] USE="filecaps%*"
[ebuild   R    ] x11-libs/gtk+-2.24.31-r1  USE="-xinerama*"
[ebuild     U  ] sys-libs/libblockdev-2.14-r1 [2.14] USE="cryptsetup%*"
[ebuild     U  ] sys-auth/pambase-20150213-r1 [20150213] USE="(-elogind)"
[ebuild     U  ] sys-apps/accountsservice-0.6.45 [0.6.43-r1]
[ebuild     U  ] kde-frameworks/kunitconversion-5.40.0 [5.37.0]
[ebuild     U  ] net-libs/signond-8.59 [8.58]
[ebuild     U  ] kde-frameworks/networkmanager-qt-5.40.0 [5.37.0]
[ebuild     U  ] net-libs/libsignon-glib-1.14 [1.13-r1]
[ebuild     U  ] kde-frameworks/kpeople-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/bluez-qt-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/syntax-highlighting-5.40.0 [5.37.0-r1]
[ebuild     U  ] kde-frameworks/kdesignerplugin-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kdnssd-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kjsembed-5.40.0 [5.37.0]
[ebuild     U  ] media-sound/pulseaudio-11.1 [10.0]
[ebuild   R    ] media-libs/libsdl-1.2.15-r9  USE="-xinerama*"
[ebuild   R    ] media-libs/libsdl2-2.0.4  USE="-xinerama*"
[ebuild  N     ] media-sound/mpg123-1.25.6  USE="alsa ipv6 pulseaudio sdl (-altivec) (-coreaudio) -int-quality -jack -nas -oss -portaudio" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse (-3dnow) (-3dnowext) (-mmx)"
[ebuild     U  ] media-video/vlc-2.2.8 [2.2.6]
[ebuild     U  ] kde-frameworks/kfilemetadata-5.40.0 [5.37.0]
[ebuild     U  ] www-client/firefox-bin-52.5.2 [52.5.0-r1]
[ebuild   R    ] net-misc/freerdp-2.0.0_rc0  USE="-xinerama*" CPU_FLAGS_X86="-ssse3% (-sse2%*)"
[ebuild     U  ] kde-frameworks/kparts-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/knotifyconfig-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/baloo-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kxmlrpcclient-5.40.0 [5.37.0]
[ebuild     U  ] media-plugins/kipi-plugins-5.7.0 [5.5.0]
[ebuild     U  ] kde-frameworks/khtml-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/ktexteditor-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kross-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kdewebkit-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kdelibs4support-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/kactivities-stats-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/krunner-5.40.0 [5.37.0]
[ebuild     U  ] kde-frameworks/frameworkintegration-5.40.0 [5.37.0]
[ebuild     U  ] media-libs/gst-plugins-base-1.12.3 [1.10.5]
[ebuild     U  ] media-libs/gst-plugins-ugly-1.12.3 [1.10.5]
[ebuild     U  ] media-libs/gst-plugins-good-1.12.3 [1.10.5]
[ebuild     U  ] media-libs/gst-plugins-bad-1.12.3 [1.10.5] USE="egl*"
[blocks b      ] <media-libs/gst-plugins-bad-1.11.90:1.0 ("<media-libs/gst-plugins-bad-1.11.90:1.0" is blocking media-libs/gst-plugins-base-1.12.3)                                               
[ebuild     U  ] media-plugins/gst-plugins-libav-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-cdparanoia-1.12.3 [1.10.5]
[ebuild     U  ] app-office/libreoffice-bin-5.4.2.2-r1 [5.4.2.2]
[ebuild     U  ] media-plugins/gst-plugins-faad-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-pulse-1.12.3 [1.10.5]
[ebuild  N     ] media-plugins/gst-plugins-mpg123-1.12.3  ABI_X86="(64) -32 (-x32)"
[ebuild     U  ] media-plugins/gst-plugins-mpeg2dec-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-x264-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-dvdread-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-dts-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-a52dec-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-flac-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-resindvd-1.12.3 [1.10.5]
[ebuild     U  ] media-plugins/gst-plugins-meta-1.12.3 [1.10.5]
[ebuild  N     ] kde-apps/kdeedu-meta-17.08.3
[ebuild     U  ] app-cdr/brasero-3.12.2 [3.12.1-r1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/readline:0

  (sys-libs/readline-7.0_p3:0/7::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/readline-7.0:0= required by (app-shells/bash-4.4_p12:0/0::gentoo, ebuild scheduled for merge)
    ^^                  ^^^^^^                                                                                                                                                       

  (sys-libs/readline-6.3_p8-r3:0/0::gentoo, installed) pulled in by
    sys-libs/readline:0/0= required by (sys-apps/util-linux-2.30.2:0/0::gentoo, installed)
                     ^^^^^                                                                                                   
    (and 25 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above


Also does not help:
Code:
emerge --ask --oneshot  =sys-libs/readline-7.0_p3 dev-lang/spidermonkey net-misc/ntp dev-lang/python sci-libs/libqalculate dev-lang/python dev-libs/libpcre sys-apps/gawk net-wireless/bluez dev-db/mariadb sys-fs/lvm2 net-wireless/wpa_supplicant dev-lang/python kde-apps/kalgebra sys-block/parted app-text/hunspell dev-lang/ruby app-crypt/gnupg net-misc/networkmanager net-misc/socat sys-fs/xfsprogs dev-libs/libxml2




Code:
Calculating dependencies... done!
[ebuild  r  U  ] sys-libs/readline-7.0_p3 [6.3_p8-r3]
[ebuild   R    ] dev-libs/libpcre-8.41-r1
[ebuild  rR    ] dev-db/sqlite-3.20.1-r1
[ebuild  r  U  ] app-shells/bash-4.4_p12 [4.3_p48-r1]
[ebuild   R    ] dev-lang/python-3.6.3-r1
[ebuild   R    ] net-misc/ntp-4.2.8_p10-r1
[ebuild   R    ] net-misc/socat-1.7.3.2
[ebuild  rR    ] dev-db/unixODBC-2.3.4-r1
[ebuild  rR    ] dev-lang/python-3.4.5-r1  USE="-sqlite*"
[ebuild  rR    ] sys-libs/slang-2.3.0
[ebuild   R    ] dev-libs/libxml2-2.9.6
[ebuild  rR    ] dev-lang/spidermonkey-1.8.5-r6
[ebuild   R    ] dev-lang/spidermonkey-24.2.0-r4
[ebuild   R    ] sys-apps/gawk-4.1.4
[ebuild   R    ] app-text/hunspell-1.6.1-r1
[ebuild   R    ] dev-lang/ruby-2.2.9
[ebuild   R    ] dev-db/mariadb-10.1.29
[ebuild   R    ] sci-libs/libqalculate-0.9.9
[ebuild   R    ] net-wireless/wpa_supplicant-2.6-r3
[ebuild  rR    ] sys-apps/util-linux-2.30.2
[ebuild   R    ] sys-fs/lvm2-2.02.145-r2
[ebuild   R    ] sys-fs/xfsprogs-4.9.0
[ebuild   R    ] sys-block/parted-3.2-r1
[ebuild   R    ] net-wireless/bluez-5.47-r1
[ebuild   R    ] app-crypt/gnupg-2.2.0
[ebuild   R    ] net-misc/networkmanager-1.8.4
[ebuild  rR    ] media-sound/fluidsynth-1.1.6-r1
[ebuild   R    ] kde-apps/kalgebra-17.08.3

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/readline:0

  (sys-libs/readline-7.0_p3:0/7::gentoo, ebuild scheduled for merge) pulled in by
    =sys-libs/readline-7.0_p3 (Argument)
    >=sys-libs/readline-7.0:0= required by (app-shells/bash-4.4_p12:0/0::gentoo, ebuild scheduled for merge)
    ^^                  ^^^^^^                                                                                                                                                       

  (sys-libs/readline-6.3_p8-r3:0/0::gentoo, installed) pulled in by
    >=sys-libs/readline-4.1:0/0= required by (dev-lang/python-3.5.4-r1:3.5/3.5m::gentoo, installed)
                           ^^^^^                                                                                                       
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above


May be it is possible to try to add the flag sqlite for python?
Code:

emerge --verbose-conflicts  =dev-lang/python-3.5.4-r1:3.5
Calculating dependencies... done!
[ebuild   R    ] dev-lang/python-3.5.4-r1  USE="-sqlite*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/python:3.5

  (dev-lang/python-3.5.4-r1:3.5/3.5m::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/python-3.5.4-r1:3.5 (Argument)

  (dev-lang/python-3.5.4-r1:3.5/3.5m::gentoo, installed) pulled in by
    dev-lang/python:3.5[sqlite] required by (dev-python/translate-toolkit-2.0.0:0/0::gentoo, installed)
                        ^^^^^^                                                                                                             


It might be possible to solve this slot collision
by applying all of the following changes:
   - dev-lang/python-3.5.4-r1 (Change USE: +sqlite)


Last edited by gangstervano on Thu Jan 04, 2018 6:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2493
Location: Near Toronto

PostPosted: Thu Jan 04, 2018 6:18 pm    Post subject: Reply with quote

FWIW, when I hit this I just unmerged readline, emerged the
new readline and then had to rebuild a bunch of packages
with @preserved-rebuild
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
gangstervano
n00b
n00b


Joined: 15 Aug 2016
Posts: 35

PostPosted: Thu Jan 04, 2018 6:27 pm    Post subject: Reply with quote

Hello!

And it is possible more in detail?

What commands do you perform?

Code:
unmerge -C readline

so what is next?
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2493
Location: Near Toronto

PostPosted: Thu Jan 04, 2018 11:06 pm    Post subject: Reply with quote

something like this I think: I ran

Code:
emerge -uDav world --exclude readline


(I needed a bunch of USE flags but every system will be different
for them)

Once the only blocker was readline I ran

Code:
emerge -Ca readline


and then

Code:
emerge -av readline


this put in the new readline version

the system complained at the end of the readline install
of a number of packages that needed to be rebuilt,
so

Code:
emerge -av @preserved-rebuild


(Again, a bunch of USE flags were involved to get this
to run properly ...)

I'm not altogether sure I recommend this; my system is an unholy
mixture of stable and ~amd64 but it worked for me

Good luck :wink:
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
gangstervano
n00b
n00b


Joined: 15 Aug 2016
Posts: 35

PostPosted: Fri Jan 05, 2018 12:51 am    Post subject: Reply with quote

I solved the problem by adding USE flags to package.use.

Code:
dev-lang/python sqlite


then

Code:
emerge dev-lang/python


OK

then

Code:
emerge --update --newuse --deep --with-bdeps=y --ask @world


OK

then
Code:

x11-libs/libxcb abi_x86_32
x11-proto/inputproto abi_x86_32
x11-proto/xf86vidmodeproto abi_x86_32
dev-libs/expat abi_x86_32
sys-libs/ncurses abi_x86_32
x11-proto/damageproto abi_x86_32
x11-libs/libX11 abi_x86_32
x11-libs/libXxf86vm abi_x86_32
x11-proto/presentproto abi_x86_32
virtual/libffi abi_x86_32
dev-python/dbus abi_x86_32
dev-libs/wayland abi_x86_32
x11-libs/libxshmfence abi_x86_32
x11-libs/libXfixes abi_x86_32
x11-proto/dri2proto abi_x86_32
x11-proto/xproto abi_x86_32
virtual/libelf abi_x86_32
dev-libs/elfutils abi_x86_32
x11-proto/xcb abi_x86_32
x11-proto/fixesproto abi_x86_32
x11-proto/kbproto abi_x86_32
x11-libs/libdrm abi_x86_32
x11-libs/libXext abi_x86_32
dev-libs/libffi abi_x86_32
app-arch/bzip2 abi_x86_32
sys-libs/zlib abi_x86_32
x11-proto/glproto abi_x86_32
x11-proto/xextproto abi_x86_32
x11-proto/xf86driproto abi_x86_32
x11-libs/libXdamage abi_x86_32
x11-proto/xcb-proto abi_x86_32
dev-python/dbus-python python_targets_python3_4
sys-libs/ncurses -gpm


and


Code:
emerge --update --newuse --deep --with-bdeps=y --ask @world


And the emerge works and stops issuing warnings.

I also, did many installs / deletions of packages. Many things I already do not remember ...

Thank you all for your support! :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum