Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to get a working desktop (KDE)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
DKMR
n00b
n00b


Joined: 03 Jan 2018
Posts: 3

PostPosted: Wed Jan 03, 2018 9:09 pm    Post subject: Unable to get a working desktop (KDE) Reply with quote

This is my first experience with Gentoo so I apologize if I forgot to mention something important. I followed the handbook installation and everything went smooth, I chose the KDE Desktop profile during the installation. With a bit of digging I kinda set up everything except the damn desktop.

It was a painful fight to get this far, first I was having issues with base packages missing but I had plasma-meta installed. Fixed it magically today by updating the system (haven't touched the laptop since I installed everything 2 months ago). Then I had a black screen with the cursor (the themed one mind you, not the standard X11 cursor) and the CPU fan was going nuts. XSM was missing for some reason so I got that (x11-apps/xsm).

Now the wallpaper is shown, the hamburger menu in the top left corner, and the cursor is there as well, however the bottom taskbar is not showing and clicking the mouse anywhere doesn't do anything. The fan is still going crazy, looking at "top" I see dbus-daemon on top with 25-26% CPU usage, below is the kded5 and klauncher with some minor usage (5-7%) and below that is nothing siginificant in terms of resource drain.

Pressing the power button shows the shutdown menu which kinda works - except "Shut down" brings me back to the greeter and the fan calms down as dbus-daemon is no longer molesting the poor CPU.
Also, I modified the plasma.desktop file in /usr/share/xsession so the Exec parameter has --failsafe at the end, and kwinrc has OpenGLIsUnsafe set to true - these two things were responsible for going from a black background to displaying a wallpaper and the hamburger menu.

I have the Nouveau driver loaded for now, the GPU is GeForce Go 7200, CPU is Core2Duo T7700, the system has 4GB of RAM.

I'd really like to start using this system daily and having a GUI is a must since I'll use LibreOffice and Firefox most of the time.

Thanks for any suggestions, and once again I apologize if I forgot to mention something important!
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Wed Jan 03, 2018 10:26 pm    Post subject: Re: Unable to get a working desktop (KDE) Reply with quote

DKMR wrote:
XSM was missing for some reason so I got that (x11-apps/xsm).

That is hard to believe, since xsm is a dependency of xinit unless you have manually set the USE=minimal flag.

Please add your emerge --info.

Did you follow https://wiki.gentoo.org/wiki/KDE ?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
DKMR
n00b
n00b


Joined: 03 Jan 2018
Posts: 3

PostPosted: Sat Jan 06, 2018 1:08 pm    Post subject: Re: Unable to get a working desktop (KDE) Reply with quote

asturm wrote:
DKMR wrote:
XSM was missing for some reason so I got that (x11-apps/xsm).

That is hard to believe, since xsm is a dependency of xinit unless you have manually set the USE=minimal flag.

Please add your emerge --info.

Did you follow https://wiki.gentoo.org/wiki/KDE ?

Fixed by installing a Debian-based system.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Sat Jan 06, 2018 1:33 pm    Post subject: Reply with quote

Why bother opening a support thread, then? It's not like you had to wait too long for a response here. Would have been interesting to find out your problem, anyway.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
DKMR
n00b
n00b


Joined: 03 Jan 2018
Posts: 3

PostPosted: Sat Jan 06, 2018 1:50 pm    Post subject: Reply with quote

asturm wrote:
Why bother opening a support thread, then? It's not like you had to wait too long for a response here. Would have been interesting to find out your problem, anyway.

Sorry for bothering you, decided to do a re-install yesterday and spent the whole night carefully following the Handbook. After hours of compiling (on a low-end machine) I gave up, another set of issues popped up. Thanks for trying to help, this thread can be closed. Maybe one day I'll try again.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6828
Location: Austria

PostPosted: Sat Jan 06, 2018 1:54 pm    Post subject: Reply with quote

That's fine; I'm sure many people here do not run with their first, or even second try of a Gentoo install. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum