Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
4.12 to 4.14, kernel panic. Solved.
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5934
Location: Austria

PostPosted: Fri Jan 19, 2018 2:16 pm    Post subject: Reply with quote

Don't use .8, use the latest available version 4.14.14.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
1clue
Advocate
Advocate


Joined: 05 Feb 2006
Posts: 2142

PostPosted: Fri Jan 19, 2018 4:31 pm    Post subject: Reply with quote

mimosinnet wrote:
Have you been able to solve it?

I am having a similar issue when moving to 4.14.8 kernel in a hardened box. This is the screenshot of the error. I can boot with SystemRescueCd and this is the kernel created with oldconfig and this is a new kernel config from scratch.

Cheers!


Still not solved. My next step is to start over with my 4.12.12 kernel config, do 'make oldconfig' and then be very careful about all the new options.

I haven't had time to mess with this for awhile, so it's been running on 4.12.12.
Back to top
View user's profile Send private message
mimosinnet
l33t
l33t


Joined: 10 Aug 2006
Posts: 636
Location: Barcelona, Spain

PostPosted: Tue Jan 23, 2018 11:02 am    Post subject: Reply with quote

1clue wrote:
Still not solved. My next step is to start over with my 4.12.12 kernel config, do 'make oldconfig' and then be very careful about all the new options.


I have done the other way around. I have 'make oldconfig' with the .config from linux-4.14.8-gentoo-r1 (that does not boot) in linux-4.12.12-gentoo, and it boots. These are the differences between both .config files. As suggested by astrum:

asturm wrote:
Don't use .8, use the latest available version 4.14.14.


There seems to be an issue with linux-4.14.8-gentoo-r1.

Cheers!

Edit: Ups! I just have noticed that kernels 4.12.12 and 4.14.8-r1 are masked!
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved.
Take care of the community answering unanswered posts.
Back to top
View user's profile Send private message
1clue
Advocate
Advocate


Joined: 05 Feb 2006
Posts: 2142

PostPosted: Fri Feb 09, 2018 6:26 pm    Post subject: Reply with quote

asturm wrote:
Don't use .8, use the latest available version 4.14.14.


FWIW I finally got it.

I abandoned 4.14.8 and did 4.14.14, worked the first time. I did 'make oldconfig' and was sure to read all the documentation before choosing an option. Did that on 4.14.8 as well, but nothing I did made a running kernel.

Thanks.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5934
Location: Austria

PostPosted: Fri Feb 09, 2018 6:29 pm    Post subject: Reply with quote

Because .8 was broken on hardened. That's why it was masked.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum