Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]nmcli: link is not ready
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message

Joined: 25 Jun 2014
Posts: 189
Location: Lent

PostPosted: Fri Feb 02, 2018 8:11 am    Post subject: [SOLVED]nmcli: link is not ready Reply with quote

So yesterday I upgraded sone packages, among them the plasma workspace which now fails to start. Now I was gonna file a bugreport for that, but then I realized the wifi was not working, so i tried

nmcli dev wifi connect 'ssid' password 'password'

But that gives me 'dhcp client failed to start'
dmesg shows that: 'IPv6: wlp8s0: link is not ready'. Now nornally I dont use ipv6, and that used to work. Is thrre a way to force ipv4 with nmcli? And why does it mean that the link is not ready?

I managed to get it up and running with:

nmcli connection up --ask 'ssid'

So now that I have an active internet connection I can finally try and fix plasmashell, I would still like to know what is up with this 'link not ready' stuff though :? .

Forgot to mention that I tried downgrading/upgrading networkmanger dhcpcd and plasma. Also I remember networkmanager gave me the same error before, which was probably why I was using only ipv4 in the first place.
OS: Gentoo KDE x86_64 (~amd64, 5.9.12-gentoo)
CPU: Intel Core i7-8700K
GPU: AMD RX 590 8GB & Intel UHD Graphics 630
SSD: Samsung 970 Pro 512GB
RAM: Crucial Ballistix 32GB DDR4-2400
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum