Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] smart-live-rebuild: Error enumerating
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 707

PostPosted: Thu Dec 21, 2017 7:30 am    Post subject: [Solved] smart-live-rebuild: Error enumerating Reply with quote

I've installed app-office/libreoffice-6.0.9999.
smart-live-rebuild shows that error
Code:
!!! Error enumerating =app-office/libreoffice-6.0.9999: [KeyError] "Environment does not declare: ['EGIT_REPO_URI']"

Code:
$ smart-live-rebuild --version
smart-live-rebuild 1.3.5


Last edited by Perfect Gentleman on Sun Dec 24, 2017 8:48 am; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5006

PostPosted: Thu Dec 21, 2017 7:23 pm    Post subject: Reply with quote

The error is correct... that's something that should have been caught by QA. The ebuild doesn't set EGIT_REPO_URI and instead does everything in src_unpack() manually, just because the help files are in a different repo. Best to file a bug about it.
_________________
*.ebuild // /etc/service/*
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 707

PostPosted: Fri Dec 22, 2017 5:08 am    Post subject: Reply with quote

what package should bug concern: smart-live-rebuild or libreoffice?
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5006

PostPosted: Fri Dec 22, 2017 6:44 am    Post subject: Reply with quote

libreoffice. smart-live-rebuild is in the right to complain about it.
_________________
*.ebuild // /etc/service/*
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 707

PostPosted: Sun Dec 24, 2017 8:48 am    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=642082
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum