Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plymouth no trabaja [CLOSED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 507

PostPosted: Fri Dec 15, 2017 11:58 pm    Post subject: Plymouth no trabaja [CLOSED] Reply with quote

Hola genturiones!!

Acá estoy volviendo al foro después de un tiempo.

Escribo este hilo por un problema que vengo arrastrando desde hace tiempo.

Desde la aparición de “sys-boot/plymouth-0.9.2-r1” no tengo más Plymouth en el arranque, solo aparece unos segundos antes del login. Por mucho tiempo mantuve “plymouth-0.9.0” hasta que salió de portage.

Lo raro es que cuando corro “plymouth --show-splash” no pasa nada, ni siquiera un mensaje de error. El problema sigue con "plymouth-0.9.3-r1"

Alguna idea de que puede ser? O por donde pasar a buscar?

Muchas gracias!!

PS: Por las dudas les dejo el grub:
Code:
GRUB_DISTRIBUTOR="Gentoo"
GRUB_TIMEOUT=5
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DEFAULT=0
GRUB_GFXMODE=1024x768
GRUB_CMDLINE_LINUX_DEFAULT='quiet splash'
GRUB_CMDLINE_LINUX="dolvm root=/dev/sda6 rootfstype=ext4 init=/usr/lib/systemd/systemd quiet udev.log-priority=3"
GRUB_THEME=/boot/grub/themes/breeze/theme.txt
GRUB_HIDDEN_TIMEOUT=0
GRUB_DISABLE_RECOVERY=true
GRUB_DISABLE_SUBMENU=y
#GRUB_GFXMODE=1366x768x24
GRUB_GFXPAYLOAD_LINUX=keep
#GRUB_CMDLINE_LINUX="dolvm rootfstype=ext4 init=/usr/lib/systemd/systemd quiet loglevel=0 show_status=0 udev.log-priority=3"


Last edited by natrix on Fri Dec 22, 2017 1:00 am; edited 1 time in total
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1124

PostPosted: Sat Dec 16, 2017 4:39 pm    Post subject: Reply with quote

Puedes instalar el 0.9.0, tan sólo tienes que crear un repositorio personalizado.
Si te funciona con ello podrías descartar que el problema venga de otra parte.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 507

PostPosted: Sat Dec 16, 2017 5:06 pm    Post subject: Reply with quote

Gracias Cameta!

La versión 0.9.0 del overlay de sabayon trabaja correctamente.

No encuentro que cambió de "0.9" al "0.9.2". Por ejemplo, en la wiki no encuentro ninguna implementación adicional con systemd.

Hoy en portage apareció como estable la versión "sys-boot/plymouth-0.9.3-r1", pero nada cambio.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1124

PostPosted: Sat Dec 16, 2017 9:28 pm    Post subject: Reply with quote

Mira si hay alguna diferencia con las USES.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1124

PostPosted: Sat Dec 16, 2017 9:36 pm    Post subject: Reply with quote

La otra opción es que se trate de un bug que afecte sólo a una configuración muy concreta.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1124

PostPosted: Sat Dec 16, 2017 9:49 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-1067912-highlight-plymouth.html
Mira esto, me parece que describe tu problema.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 507

PostPosted: Sun Dec 17, 2017 1:48 am    Post subject: Reply with quote

Interesante el hilo, pero parece que no es mi caso:

El patche corre pero no funciona. Las USEs las fui probando de a una (agregando y sacando) y nada, la falla que menciona con static-libs es cierta. Tampoco tengo ningún error al generar el initramsfs, incluso menciona que el theme si instaló bien.

También hurgue un poco en las USE de las dependencias pero no encontré nada sospechoso.

Rarísimo!!
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1124

PostPosted: Sun Dec 17, 2017 11:58 am    Post subject: Reply with quote

Quote:
There was a file iputils.save

Según el hilo al borrar este fichero y recompilar la cosa funciona.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 507

PostPosted: Sun Dec 17, 2017 4:34 pm    Post subject: Reply with quote

Hola cameta:

Si compilo plymouth con la USE "statics-libs", la instalación del initramfs me arroja el error de que no encuentra archivos como dice el hilo. Pero cuando compilo con "-statics-libs" no hay ningún problema y me aparece que el 'theme' se instaló correctamente.

Por otro lado, no tengo ningún archivo "iputils.save" en ninguna parte (busqueda global) ni ningún archivo que no reconozca en el '/etc/portage'.

Saludos!
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 507

PostPosted: Sun Dec 17, 2017 5:03 pm    Post subject: Reply with quote

Hola:
Agrego información, esto aparece en el journal del arranque:

Code:
 # journalctl -b | grep plymouth
dic 17 13:58:25 natrix systemd[1]: Received SIGRTMIN+20 from PID 617 (plymouthd).
dic 17 13:58:26 natrix systemd[1]: Received SIGRTMIN+21 from PID 617 (plymouthd).


Todavía no encontré que significa...
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1124

PostPosted: Sun Dec 17, 2017 10:54 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-1065502-highlight-plymouth.html
En este otro hilo se quejan de que según que kernel no funciona.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 507

PostPosted: Tue Dec 19, 2017 1:27 am    Post subject: Reply with quote

Gracias Cameta!! No había visto ese hilo

El hilo se veía prometedor, lástima que se cortó ahí.

Siempre usó el kernel más reciente estable, ahora tengo la versión 4.12. Revisé la wiki y mi ‘.config’ por si el kernel había cambiado algo de nouveau pero sigue todo igual.

Qué problema si la causa viene del kernel mismo!! No? Plymouth no justifica tanto escarbe!
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7579
Location: ~Brussels - Belgique

PostPosted: Tue Dec 19, 2017 8:18 am    Post subject: Reply with quote

Moved to Spanish.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1124

PostPosted: Tue Dec 19, 2017 11:38 am    Post subject: Reply with quote

Podrías probar con un kernel más antiguo a ver si es eso.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 507

PostPosted: Fri Dec 22, 2017 12:58 am    Post subject: Reply with quote

Sería interesante!! pero no me gusta jugar con el kernel, necesito la PC funcionando, jeje

Por ahora me quedo con el plymouth-0.8.8-r4 en un repositorio local.

Una diferencia que encontré es que una dependencia del plymouth-0.8* es '>=x11-libs/gtk+:2', mientras que plymouth-0.9* es '>=x11-libs/gtk+:3'. Pero no me doy cuenta si tiene algo que ver con lo que pasa. :? :?
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1124

PostPosted: Fri Dec 22, 2017 9:02 pm    Post subject: Reply with quote

Quote:
necesito la PC funcionando, jeje

La verdad es que si algo funciona, ¿para que actualizarlo?
Normalmente cuando actualizas suele estropearse alguna cosa :oops: :oops: :oops: :oops:
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 507

PostPosted: Sat Dec 23, 2017 7:32 pm    Post subject: Reply with quote

Hasta ahora, todas las mejoras de gentoo valieron la pena alguna que otra rotura.

Además, las roturas me obligan a aprende. E.g. con este hilo aprendí a crear un repositorio local para la versión vieja de plymouth.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1124

PostPosted: Sun Dec 24, 2017 12:03 pm    Post subject: Reply with quote

En mi caso la última versión de HPLIP tiene problemas con la identificación, pero bueno uso la anterior y no pasa nada.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 507

PostPosted: Thu Dec 28, 2017 12:46 am    Post subject: Reply with quote

El tema de los drivers para periférico, tristemente, más que un problema es una lucha linuxera. Muchas veces hay que conformarse con lo que hay!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum