Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
clisp does not emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Konrarad81
n00b
n00b


Joined: 10 Dec 2017
Posts: 8

PostPosted: Sun Dec 10, 2017 12:49 pm    Post subject: clisp does not emerge Reply with quote

Hey folks,
on reinstalling my gentoo I am having troubles with clisp. I have been searching google for a while but I could not find anything helpful. Also the error message "cannot run C compiled programs" seems strange to me.
The emerge output asks me to provide some information that I pass underneath:
Code:

# emerge --info '=dev-lisp/clisp-2.49-r9::gentoo'
Portage 2.3.13 (python 3.5.4-final-0, default/linux/amd64/17.0/desktop, gcc-6.4.0, glibc-2.25-r9, 4.12.12-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.12.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-3520M_CPU_@_2.90GHz-with-gentoo-2.4.1
KiB Mem:     3740068 total,    615780 free
KiB Swap:    1951740 total,   1951740 free
Timestamp of repository gentoo: Sun, 10 Dec 2017 12:00:01 +0000
Head commit of repository gentoo: 3376380976d9f057a8d333e5a9a7856b9498c564
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.4-r1::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r2::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            6.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/"
LANG="en_US.iso88591"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg lcms ldap libnotify lock mad mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl nvidia ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support qt5 readline sdl seccomp session spell sse sse2 ssl startup-notification svg tcpd tiff tk truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="nvidia" XFCE_PLUGINS="brightness clock trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Code:

# emerge -pqv '=dev-lisp/clisp-2.49-r9::gentoo'
[ebuild  N    ] dev-lisp/clisp-2.49-r9  USE="X berkdb dbus gdbm gtk pcre readline unicode zlib -fastcgi -hyperspec -pari -postgres (-svm) -threads"

 * IMPORTANT: 12 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


The build log is
Code:

# cat /var/tmp/portage/dev-lisp/clisp-2.49-r9/temp/build.log
 * Package:    dev-lisp/clisp-2.49-r9
 * Repository: gentoo
 * Maintainer: common-lisp@gentoo.org
 * USE:        X abi_x86_64 amd64 berkdb dbus elibc_glibc gdbm gtk kernel_linux pcre readline unicode userland_GNU zlib
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking clisp-2.49.tar.bz2 to /var/tmp/portage/dev-lisp/clisp-2.49-r9/work
>>> Source unpacked in /var/tmp/portage/dev-lisp/clisp-2.49-r9/work
>>> Preparing source in /var/tmp/portage/dev-lisp/clisp-2.49-r9/work/clisp-2.49 ...
 * Applying clisp-2.49-bits_ipctypes_to_sys_ipc.patch ...                [ ok ]
 * Applying clisp-2.49-get_hostname.patch ...                            [ ok ]
 * Applying clisp-2.49-tinfo.patch ...                                   [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-lisp/clisp-2.49-r9/work/clisp-2.49 ...
 * enabling module wildcard
 * enabling module rawsock
 * enabling module bindings/glibc
 * enabling module clx/new-clx
 * enabling module berkeley-db
 * enabling module dbus
 * enabling module gdbm
 * enabling module gtk2
 * enabling module pcre
 * enabling module zlib
 * ./configure --prefix=/usr --libdir=/usr/lib64       --with-readline --with-unicode       --with-ffcall --without-dynamic-modules --with-module=wildcard --with-module=rawsock --with-module=bindings/glibc --with-module=clx/new-clx --with-module=berkeley-db --with-module=dbus --with-module=gdbm --with-module=gtk2 --with-module=pcre --with-module=zlib --hyperspec=http://www.lispworks.com/reference/HyperSpec/ builddir
executing /var/tmp/portage/dev-lisp/clisp-2.49-r9/work/clisp-2.49/builddir/configure --prefix=/usr --libdir=/usr/lib64 --with-readline --with-unicode --with-ffcall --without-dynamic-modules --with-module=wildcard --with-module=rawsock --with-module=bindings/glibc --with-module=clx/new-clx --with-module=berkeley-db --with-module=dbus --with-module=gdbm --with-module=gtk2 --with-module=pcre --with-module=zlib --hyperspec=http://www.lispworks.com/reference/HyperSpec/ builddir
configure: creating cache config.cache
checking for a BSD-compatible install... /usr/lib/portage/python3.5/ebuild-helpers/xattr/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
configure: ** check for host type
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... configure: error: in `/var/tmp/portage/dev-lisp/clisp-2.49-r9/work/clisp-2.49/builddir':
configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.
 * ERROR: dev-lisp/clisp-2.49-r9::gentoo failed (configure phase):
 *   ./configure failed
 *
 * Call stack:
 *     ebuild.sh, line 124:  Called src_configure
 *   environment, line 2307:  Called die
 * The specific snippet of code:
 *       ${configure} || die "./configure failed";
 *
 * If you need support, post the output of `emerge --info '=dev-lisp/clisp-2.49-r9::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-lisp/clisp-2.49-r9::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-lisp/clisp-2.49-r9/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-lisp/clisp-2.49-r9/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-lisp/clisp-2.49-r9/work/clisp-2.49'
 * S: '/var/tmp/portage/dev-lisp/clisp-2.49-r9/work/clisp-2.49'


I never had a similar problem with clisp in the past. I use it for maxima (computer algebra software), I am not a lisp programmer.
I would be grateful if anyone could give me a hint on how to fix it. My request is NOT urgent. Please note that I am very busy during weekdays and maybe cannot respond because I cannot test some advice immediately. So please be not disappointed/angry should my response may take some days.
Thanks in advance!

[Moderator edit: changed [quote] tags to [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21536
Location: here

PostPosted: Sun Dec 10, 2017 1:01 pm    Post subject: Reply with quote

It's a bug.
Unmask version 2.49-r101 and remove pie cflag for this package.
Code:
# echo -e "CFLAGS=\"\${CFLAGS} -no-pie\"\nCXXFLAGS=\"\${CXXFLAGS} -no-pie\"" > /etc/portage/env/nopie.conf
# echo "dev-lisp/clisp nopie.conf" >> /etc/portage/package.env
# emerge -1 clisp


EDIT: Welcome to forum!!
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Konrarad81
n00b
n00b


Joined: 10 Dec 2017
Posts: 8

PostPosted: Sun Dec 10, 2017 1:47 pm    Post subject: [solved] Reply with quote

Hey, thanks a lot. That solved my issue.
So I guess the bug is known and I am not supposed to report it somewhere, right?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21536
Location: here

PostPosted: Sun Dec 10, 2017 1:51 pm    Post subject: Reply with quote

You can report this workaround on related bug
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum