Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst]Problem bei dem Profil Umstellung 13 -> 17
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 109

PostPosted: Sat Dec 09, 2017 2:06 pm    Post subject: [gelöst]Problem bei dem Profil Umstellung 13 -> 17 Reply with quote

Hallöchen

Hab da ein kleines Problem und hoffe das hier eventuell mehr Leute reingucken hab das ganze auch hier schon gepostet und nachgefragt..

http://www.gentooforum.de/artikel/22537/problem-bei-dem-profil-umstellung-13-17.html#post156513

Wie in anderen Forum habe ich mich nach dieser kleinen Anleitung gehalten
Code:
2017-11-30  New 17.0 profiles in the Gentoo repository

If you are not already running a hardened setup with PIE enabled, then
switching the profile involves the following steps:
If not already done,
* Use gcc-config to select gcc-6.4.0 or later as system compiler
* Re-source /etc/profile:
    . /etc/profile
* Re-emerge libtool
    emerge -1 sys-devel/libtool
Then,
* Select the new profile with eselect
* Re-emerge, in this sequence, gcc, binutils, and glibc
    emerge -1 sys-devel/gcc:6.4.0
    emerge -1 sys-devel/binutils
    emerge -1 sys-libs/glibc
* Rebuild your entire system
    emerge -e @world


der erste Versuch verlief mit dieser Fehlermeldung

Code:
 UPD     include/generated/utsrelease.h
  HOSTCC  arch/x86/tools/relocs_32.o
  HOSTCC  arch/x86/tools/relocs_64.o
  HOSTCC  arch/x86/tools/relocs_common.o
In file included from arch/x86/tools/relocs_64.c:17:0:
arch/x86/tools/relocs.c: In function ‘process_64’:
arch/x86/tools/relocs.c:953:2: warning: argument 1 null where non-null expected [-Wnonnull]
  qsort(r->offset, r->count, sizeof(r->offset[0]), cmp_relocs);
  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In file included from arch/x86/tools/relocs.h:6:0,
                 from arch/x86/tools/relocs_64.c:1:
/usr/include/stdlib.h:741:13: note: in a call to function ‘qsort’ declared here
 extern void qsort (void *__base, size_t __nmemb, size_t __size,
             ^~~~~
  HOSTLD  arch/x86/tools/relocs
  CHK     include/generated/timeconst.h
  CC      kernel/bounds.s
  UPD     include/generated/timeconst.h
cc1: error: code model kernel does not support PIC mode
make[1]: *** [Kbuild:45: kernel/bounds.s] Error 1
make[1]: *** Waiting for unfinished jobs....
make: *** [Makefile:986: prepare0] Error 2
 * ERROR: dev-libs/klibc-2.0.4-r2::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=dev-libs/klibc-2.0.4-r2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-libs/klibc-2.0.4-r2::gentoo'`.
 * The complete build log is located at '/tmp/portage/dev-libs/klibc-2.0.4-r2/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/dev-libs/klibc-2.0.4-r2/temp/environment'.
 * Working directory: '/tmp/portage/dev-libs/klibc-2.0.4-r2/work/linux-4.4'
 * S: '/tmp/portage/dev-libs/klibc-2.0.4-r2/work/klibc-2.0.4'


Habe dann den Link zu https://bugs.gentoo.org/621848 von sdoubleyou bekommen

Nun hab ich wie dort geschrieben diesen Tipp versucht

Code:
edit /usr/portage/dev-libs/klibc/klibc-2.0.4-r2.ebuild changing the 25 line from
KV_MAJOR="4" KV_MINOR="x" KV_SUB="4"
to
KV_MAJOR="4" KV_MINOR="x" KV_SUB="14"

run
ebuild /usr/portage/dev-libs/klibc/klibc-2.0.4-r2.ebuild digest
to validate the change and then emerge with
emerge -av dev-libs/klibc


hier bekomme ich folgendes gemeldet

Code:
--- replaced obj /lib64/klibc-irxxSRIG_eIV0cUL3_D3at_S6K4.so
--- replaced dir /lib64
--- replaced obj /etc/env.d/70klibc
--- replaced dir /etc/env.d
--- replaced dir /etc
>>> Regenerating /etc/ld.so.cache...
>>> Original instance of package unmerged safely.
>>> dev-libs/klibc-2.0.4-r2 merged.
>>> Regenerating /etc/ld.so.cache...

 * Messages for package dev-libs/klibc-2.0.4-r2:

 *
 * Installation of a symlink is blocked by a directory:
 *   '/usr/lib64/klibc/include/linux'
 * This symlink will be merged with a different name:
 *   '/usr/lib64/klibc/include/linux.backup.0000'
 *
 *
 * Installation of a symlink is blocked by a directory:
 *   '/usr/lib64/klibc/include/asm'
 * This symlink will be merged with a different name:
 *   '/usr/lib64/klibc/include/asm.backup.0000'
 *
 *
 * Installation of a symlink is blocked by a directory:
 *   '/usr/lib64/klibc/include/asm-generic'
 * This symlink will be merged with a different name:
 *   '/usr/lib64/klibc/include/asm-generic.backup.0000'


Compilieren und Installieren läuft ja soweit durch nur was oder besser warum wird dann diese blocks ausgegeben !?

Hoffe es kann mir helfen das zu lösen ... danke schon mal

lg
schatti


Last edited by Schattenschlag on Fri Dec 15, 2017 4:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6070

PostPosted: Sun Dec 10, 2017 9:37 pm    Post subject: Reply with quote

Das sind keine Blocks, und klibc solte auch installiert worden sein.
Was passiert ist:

In einer früheren Version von klibc waren /usr/lib/klibc/include/linux und /usr/lib64/klibc/include/asm Directories.
In der aktuellen Version sind es Symlinks.

Portage müsste also zwei Directories durch Symlinks ersetzen.
Aber das ist riskant: Schließlich könnten die Directories ja noch mehr enthalten, als nur die alten Daten aus klbic.

Deshalb hat portage die alten Directories kurzerhand umbenannt.

Du kannst das Problem nun "lösen", indem Du einfach die umbenannten Directories löschst (oder vorher sicherst für den Fall, dass Du sie doch noch brauchen solltest, obwohl ich das für sehr unwahrscheinlich halt).
Back to top
View user's profile Send private message
Schattenschlag
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2011
Posts: 109

PostPosted: Fri Dec 15, 2017 4:38 pm    Post subject: Reply with quote

Alles klar danke "mv" für den Hinweis ...

wünsche noch ein schönes Wochenende

lg
schatti
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum