Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] No more line editing keys
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Waterdevil
Tux's lil' helper
Tux's lil' helper


Joined: 15 Aug 2017
Posts: 126
Location: LaniakeaHypercluster VirgoSupercluster MilkomedaGroup OrionArm Sector001 GouldBelt SolSystem Austria

PostPosted: Fri Dec 08, 2017 11:15 am    Post subject: [Solved] No more line editing keys Reply with quote

Hello World,

what I did:
  • gcc-5 -> gcc-6
  • openrc -> systemd
  • gnome-3.26::dantrell ->gnome-3.22
  • mate 1.18 -> 1.12
  • profile 13 -> 17


then
Code:
emaint sync --auto
eix-sync
eix-update
layman -S
emerge --verbose --ask --update --newuse --deep --with-bdeps=y --complete-graph=y @world
perl-cleaner --reallyall -- -av
emerge -av --depclean
revdep-rebuild -v -- --ask
eclean-dist -d
dispatch-conf
glsa-check -t all
glsa-check -f all
glsa-check -vp affected
eix-test-obsolete
emaint --check all
eix-update



I'm using lightdm with gnome (for emergency mate and xfce) and a few kde apps (k3b, kino).

Now in gnome the line editing keys are missing. This is annoying in terminal and editor! I believe I'm in the seventies with a console terminal at an ibm mainframe.

My /etc/X11/xorg.conf https://gist.github.com/anonymous/f5cb7b937f387b1b7151b2f81ebe13fe

No or wrong function: arrow keys, delete, alt gr, home, end, pipe backslash, tilde.

If one has the same problem:
    arrow left = Ctrl+B
    arrow right = Ctrl+F
    arrow up = Ctrl+P
    arrow down = Ctrl+N
    Home = Ctrl+A
    End = Ctrl+E
    Page up = Ctrl+Y
    Page down = Ctrl+V
    Backspace = Ctrl+D
    Tab = Ctrl+I

Anyone has an idea?
Many thanks
_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,X11DPG-QT,MEM:64G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChannel,Tandberg LTO-6


Last edited by Waterdevil on Sat Dec 09, 2017 11:43 am; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7048
Location: almost Mile High in the USA

PostPosted: Fri Dec 08, 2017 7:18 pm    Post subject: Reply with quote

Having \| and `~ not work is indeed annoying...

Is it only within a gnome-terminal? If so I'd make sure your gnome-terminal profiles (if that's what you're using) are up to date, perhaps clearing them if needed.

Questions for debug:
- Do the keys still work at all - do they print out funny escape sequences or not?
- Which programs work and which do not?
- Do you have any manual key remap files? Looks like you have .de keyboard commented out?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Waterdevil
Tux's lil' helper
Tux's lil' helper


Joined: 15 Aug 2017
Posts: 126
Location: LaniakeaHypercluster VirgoSupercluster MilkomedaGroup OrionArm Sector001 GouldBelt SolSystem Austria

PostPosted: Sat Dec 09, 2017 12:26 am    Post subject: Reply with quote

Hi,

no the same malfunction in terminal, kate, browser.

The keys deliver wrong sequences

Arrow up = screen shot
End = Meta
Page Up = /
Page down = right mouse click = context menu
No Ctrl+Alt+F1

I don't know if remappings resides. I did none.
_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,X11DPG-QT,MEM:64G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChannel,Tandberg LTO-6
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7048
Location: almost Mile High in the USA

PostPosted: Sat Dec 09, 2017 12:30 am    Post subject: Reply with quote

All others generally correct?

Same problem in console?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Waterdevil
Tux's lil' helper
Tux's lil' helper


Joined: 15 Aug 2017
Posts: 126
Location: LaniakeaHypercluster VirgoSupercluster MilkomedaGroup OrionArm Sector001 GouldBelt SolSystem Austria

PostPosted: Sat Dec 09, 2017 12:58 am    Post subject: Reply with quote

Normal keys are correct - all without combi keys.
all keys with alt-gr are not possible because alt-gr is arrow down

I have a german keyboard and setting.

I can't get console. without ctrl+alt+f1

Not working too:
number block /
ctrl+arrows
Meta
right meta
_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,X11DPG-QT,MEM:64G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChannel,Tandberg LTO-6
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5588

PostPosted: Sat Dec 09, 2017 1:09 am    Post subject: Reply with quote

This sounds familiar. Are you trying to use the obsolete kbd driver with an evdev layout?
Back to top
View user's profile Send private message
Waterdevil
Tux's lil' helper
Tux's lil' helper


Joined: 15 Aug 2017
Posts: 126
Location: LaniakeaHypercluster VirgoSupercluster MilkomedaGroup OrionArm Sector001 GouldBelt SolSystem Austria

PostPosted: Sat Dec 09, 2017 11:42 am    Post subject: Reply with quote

Yes, that was it.

There were suddenly an /etc/X11/xorg.conf.d/10-keyboard.conf with these evdev definitions.

Many thanks.
_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,X11DPG-QT,MEM:64G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChannel,Tandberg LTO-6
Back to top
View user's profile Send private message
ArneBab
Guru
Guru


Joined: 24 Jan 2006
Posts: 427
Location: Graben-Neudorf, Germany

PostPosted: Tue Jun 26, 2018 8:32 pm    Post subject: Reply with quote

Waterdevil wrote:
Yes, that was it.

There were suddenly an /etc/X11/xorg.conf.d/10-keyboard.conf with these evdev definitions.

Many thanks.


Can you share how you fixed it? I also experience broken arrow keys right now.
_________________
Being unpolitical means being political without realizing it. - Arne Babenhauserheide ( http://draketo.de )

pkgcore: So fast that it feels unreal - by doing only what is needed.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum