Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Configuring The System.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Waterdevil
n00b
n00b


Joined: 15 Aug 2017
Posts: 63

PostPosted: Fri Dec 08, 2017 12:53 am    Post subject: [Solved] Configuring The System. Reply with quote

Split from I am about to give Gentoo up as its turning into a help request. -- NeddySeagoon

installed gentoo in may. since then every time 3-8 packages couldn't emerge, new blockers I couldn't solve, dependency conflicts still prevent many things.
I want to use xen since may. I couldn't do i - not 1 time. xen fail, xen ok, xen-tools fail. xen-tools ok, qemu fail.

I never can emerge --depclean. I every time have to use emerge --unmerge.

Since 30.11. I'm working on change gcc-6.4, openrc to systemd, remove gnome-dantrell, remove mate-1.18, remove all unnecessary ~amd64 without a good solution.
My zfs-pool doesn't mount after reboot, my lightdm doesn't start, my keyboard has no more arrow key function for editing, xen doesn't work.

If I want to re-emerge some packages then thousand lines are coming:

Code:
[ebuild   R    ] app-arch/bzip2-1.0.6-r8:0/1::gentoo  USE="-static -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] dev-lang/mujs-0_p20161202::gentoo  0 KiB
[ebuild   R    ] media-libs/libpng-1.6.29:0/16::gentoo  USE="apng (-neon) -static-libs" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="sse" 0 KiB
[ebuild   R    ] media-libs/jbig2dec-0.13-r4::gentoo  USE="png -static-libs {-test}" 0 KiB
[ebuild  N     ] dev-libs/libressl-2.6.0:0/43::gentoo  USE="asm -static-libs" ABI_X86="32 (64) (-x32)" 3.221 KiB
[ebuild   R    ] virtual/jpeg-0-r2::gentoo  USE="-static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] dev-libs/openssl-1.0.2m::gentoo  USE="asm sslv3 tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779 -sctp -sslv2 -static-libs {-test} -vanilla" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="(sse2)" 0 KiB
[ebuild   R    ] virtual/pkgconfig-0-r1::gentoo  ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] media-libs/freetype-2.8:2::gentoo  USE="X adobe-cff bzip2 cleartype_hinting png -bindist -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] net-misc/curl-7.57.0::gentoo  USE="ipv6 ldap samba ssl -adns -http2 -idn -kerberos -metalink -rtmp -ssh -static-libs {-test} -threads" ABI_X86="32 (64) (-x32)" CURL_SSL="openssl -axtls -gnutls -libressl -mbedtls -nss (-winssl)" 0 KiB
[ebuild   R    ] x11-libs/libXau-1.0.8::gentoo  USE="-static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] x11-libs/libXdmcp-1.1.2-r1::gentoo  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] x11-libs/libxcb-1.12-r2:0/1.12::gentoo  USE="xkb -doc (-selinux) -static-libs {-test}" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] x11-libs/libX11-1.6.5::gentoo  USE="ipv6 -doc -static-libs {-test}" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] media-libs/openjpeg-2.3.0:2/7::gentoo  USE="-doc -static-libs {-test}" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] x11-libs/libXext-1.3.3::gentoo  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N     ] sys-devel/llvm-3.9.1-r1:0/3.9.1::gentoo  USE="libffi ncurses ocaml python sanitize static-analyzer xml -clang -debug -default-compiler-rt -default-libcxx -doc -gold -libedit (-lldb) -multitarget {-test}" ABI_X86="32 (64) (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild  N     ] media-libs/mesa-17.1.10::gentoo  USE="classic dri3 egl gallium gbm gles2 llvm nptl -bindist -d3d9 -debug -gles1 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -unwind -vaapi -valgrind -vdpau -vulkan -wayland -xa -xvmc" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="i965 intel (-freedreno) -i915 (-imx) -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) (-vivante) -vmware" 0 KiB
[ebuild  N     ] x11-libs/cairo-1.14.8::gentoo  USE="X glib opengl svg xcb (-aqua) -debug (-directfb) (-gles2) -static-libs -valgrind" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N     ] virtual/opengl-7.0-r1::gentoo  ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] media-libs/harfbuzz-1.4.6-r2:0/0.9.18::gentoo  USE="cairo fontconfig glib graphite icu introspection truetype -debug -static-libs {-test}" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R    ] media-libs/glfw-3.2.1::gentoo  USE="examples -wayland" 0 KiB
[ebuild     U ~] app-text/mupdf-1.11-r2:0/1.11::gentoo [1.11-r1:0/1.11::gentoo] USE="X curl javascript opengl openssl -libressl -static -static-libs -vanilla" 0 KiB
[blocks B      ] dev-libs/openssl:0 ("dev-libs/openssl:0" is blocking dev-libs/libressl-2.6.0)

Total: 23 packages (1 upgrade, 5 new, 17 reinstalls), Size of downloads: 3.221 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/libressl-2.6.0:0/43::gentoo, ebuild scheduled for merge) pulled in by
    =dev-libs/libressl-2.6.0

  (dev-libs/openssl-1.0.2m:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0[static-libs?] (dev-libs/openssl:0) required by (app-text/mupdf-1.11-r2:0/1.11::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0= required by (net-misc/freerdp-2.0.0_rc0:0/2::gentoo, installed)
    dev-libs/openssl:0= required by (net-print/hplip-3.17.10:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-lang/ruby-2.2.8:2.2/2.2::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2[abi_x86_32(-)?, abi_x86_64(-)?, abi_x86_x32(-)?, abi_mips_n32(-)?, abi_mips_n64(-)?, abi_mips_o32(-)?, abi_ppc_32(-)?, abi_ppc_64(-)?, abi_s390_32(-)?, abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2[abi_x86_32(-), abi_x86_64(-)]) required by (dev-libs/cyrus-sasl-2.1.26-r9:2/2::gentoo, installed)
    dev-libs/openssl:0 required by (net-wireless/crda-3.18-r1:0/0::gentoo, installed)
    dev-libs/openssl:0 required by (kde-frameworks/khtml-5.37.0:5/5.37::gentoo, installed)
    dev-libs/openssl:= required by (www-client/httrack-3.48.21-r1:0/0::gentoo, installed)
    dev-libs/openssl:0/0=[abi_x86_32(-), abi_x86_64(-)] required by (net-libs/neon-0.30.2:0/27::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-lang/python-3.5.4-r1:3.5/3.5m::gentoo, installed)
    dev-libs/openssl:0= required by (www-client/lynx-2.8.9_pre11:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-analyzer/nmap-7.40:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (dev-perl/Net-SSLeay-1.810.0:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (app-text/podofo-0.9.6_pre20170508-r1:0/0.9.6_pre20170508-r1::gentoo, installed)
    dev-libs/openssl:0 required by (app-pda/libimobiledevice-1.2.0:0/6::gentoo, installed)
    dev-libs/openssl:0= required by (net-misc/ntp-4.2.8_p10-r1:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.0:0/0=[abi_x86_32(-), abi_x86_64(-)] required by (dev-db/mariadb-10.1.26-r1:0/18::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-misc/wget-1.19.1-r2:0/0::gentoo, installed)
    dev-libs/openssl:0=[static-libs(+)?] (dev-libs/openssl:0=) required by (app-emulation/spice-0.13.3-r2:0/0::gentoo, installed)
    dev-libs/openssl:0 required by (dev-lang/php-7.0.25:7.0/7.0::gentoo, installed)
    dev-libs/openssl:0= required by (kde-frameworks/kdelibs-4.14.37:4/4.14::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-db/mysql-connector-c++-1.1.6:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.0d:0 required by (app-office/libreoffice-5.4.2.2:0/0::gentoo, installed)
    >=dev-libs/openssl-0.9.8:0/0= required by (dev-python/m2crypto-0.24.0:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (app-admin/apache-tools-2.4.27:0/0::gentoo, installed)
    dev-libs/openssl:0[-bindist] required by (net-p2p/bitcoin-qt-0.13.1-r1:0/0::gentoo, installed)
    dev-libs/openssl:0[-bindist] required by (net-p2p/bitcoind-0.13.1:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (app-emulation/spice-0.13.3-r2:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-libs/c-client-2007f-r6:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (dev-lang/python-3.4.5-r1:3.4/3.4m::gentoo, installed)
    >=dev-libs/openssl-0.9.8:0= required by (dev-python/m2crypto-0.24.0:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?, abi_x86_64(-)?, abi_x86_x32(-)?, abi_mips_n32(-)?, abi_mips_n64(-)?, abi_mips_o32(-)?, abi_ppc_32(-)?, abi_ppc_64(-)?, abi_s390_32(-)?, abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-), abi_x86_64(-)]) required by (gnome-base/gnome-vfs-2.24.4-r5:2/2::gentoo, installed)
    dev-libs/openssl:0= required by (dev-lang/python-2.7.14-r1:2.7/2.7::gentoo, installed)
    dev-libs/openssl:0 required by (net-misc/dhcp-4.3.5:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (media-sound/pulseaudio-10.0:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by (dev-python/cryptography-2.0.2-r1:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-misc/openssh-7.5_p1-r3:0/0::gentoo, installed)
    dev-libs/openssl:0 required by (net-nds/openldap-2.4.44:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-lang/python-3.4.5-r1:3.4/3.4m::gentoo, installed)
    dev-libs/openssl:0/0= required by (gnome-extra/libgda-5.2.4-r2:5/4::gentoo, installed)
    >=dev-libs/openssl-1.0.2:0/0= required by (www-servers/apache-2.4.27-r1:2/2::gentoo, installed)
    dev-libs/openssl:= required by (gnome-extra/libgda-5.2.4-r2:5/4::gentoo, installed)
    dev-libs/openssl:0= required by (dev-lang/php-5.6.32:5.6/5.6::gentoo, installed)
    dev-libs/openssl:0= required by (net-misc/openssh-7.5_p1-r3:0/0::gentoo, installed)
    >=dev-libs/openssl-0.9.6d:0 required by (net-analyzer/net-snmp-5.7.3-r5:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-perl/Net-SSLeay-1.810.0:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (kde-frameworks/kdelibs-4.14.37:4/4.14::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-misc/ntp-4.2.8_p10-r1:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (www-client/lynx-2.8.9_pre11:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (net-libs/c-client-2007f-r6:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (www-client/httrack-3.48.21-r1:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-libs/xmlsec-1.2.24-r1:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (net-misc/wget-1.19.1-r2:0/0::gentoo, installed)
    dev-libs/openssl required by (net-wireless/aircrack-ng-1.2_rc1-r1:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-print/hplip-3.17.10:0/0::gentoo, installed)
    dev-libs/openssl:=[-bindist] required by (sys-cluster/glusterfs-3.12.3:0/0::gentoo, installed)
    dev-libs/openssl:0[bindist=] (dev-libs/openssl:0[-bindist]) required by (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, installed)
    >=dev-libs/openssl-1.0.1:0=[bindist=] (>=dev-libs/openssl-1.0.1:0=[-bindist]) required by (net-misc/openssh-7.5_p1-r3:0/0::gentoo, installed)
    dev-libs/openssl:0/0=[-bindist] required by (sys-cluster/glusterfs-3.12.3:0/0::gentoo, installed)
    =dev-libs/openssl-1.0.2m
    dev-libs/openssl:0=[abi_x86_32(-)?, abi_x86_64(-)?, abi_x86_x32(-)?, abi_mips_n32(-)?, abi_mips_n64(-)?, abi_mips_o32(-)?, abi_ppc_32(-)?, abi_ppc_64(-)?, abi_s390_32(-)?, abi_s390_64(-)?] (dev-libs/openssl:0=[abi_x86_32(-), abi_x86_64(-)]) required by (net-libs/neon-0.30.2:0/27::gentoo, installed)
    dev-libs/openssl required by (sys-block/mbuffer-20150412:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-wireless/wpa_supplicant-2.6-r3:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.0:0=[abi_x86_32(-)?, abi_x86_64(-)?, abi_x86_x32(-)?, abi_mips_n32(-)?, abi_mips_n64(-)?, abi_mips_o32(-)?, abi_ppc_32(-)?, abi_ppc_64(-)?, abi_s390_32(-)?, abi_s390_64(-)?, static-libs?] (>=dev-libs/openssl-1.0.0:0=[abi_x86_32(-), abi_x86_64(-)]) required by (dev-db/mariadb-10.1.26-r1:0/18::gentoo, installed)
    dev-libs/openssl:0=[static-libs?, abi_x86_32(-)?, abi_x86_64(-)?, abi_x86_x32(-)?, abi_mips_n32(-)?, abi_mips_n64(-)?, abi_mips_o32(-)?, abi_ppc_32(-)?, abi_ppc_64(-)?, abi_s390_32(-)?, abi_s390_64(-)?] (dev-libs/openssl:0=[abi_x86_32(-), abi_x86_64(-)]) required by (net-misc/curl-7.57.0:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/openssl:0= required by (net-misc/spice-gtk-0.33-r2:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-lang/php-5.6.32:5.6/5.6::gentoo, installed)
    dev-libs/openssl:0/0=[abi_x86_32(-), abi_x86_64(-)] required by (app-arch/libarchive-3.3.1:0/13::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?, abi_x86_64(-)?, abi_x86_x32(-)?, abi_mips_n32(-)?, abi_mips_n64(-)?, abi_mips_o32(-)?, abi_ppc_32(-)?, abi_ppc_64(-)?, abi_s390_32(-)?, abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-), abi_x86_64(-)]) required by (dev-qt/qtcore-4.8.7-r3:4/4::gentoo, installed)
    >=dev-libs/openssl-1.0.2:0= required by (www-servers/apache-2.4.27-r1:2/2::gentoo, installed)
    dev-libs/openssl required by (net-ftp/ftp-0.17-r7:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (app-text/podofo-0.9.6_pre20170508-r1:0/0.9.6_pre20170508-r1::gentoo, installed)
    dev-libs/openssl:0 required by (dev-libs/libgit2-0.24.6:0/24::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-misc/freerdp-2.0.0_rc0:0/2::gentoo, installed)
    >=dev-libs/openssl-1.0.2:0/0=[-bindist(-)] required by (dev-python/cryptography-2.0.2-r1:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?, abi_x86_64(-)?, abi_x86_x32(-)?, abi_mips_n32(-)?, abi_mips_n64(-)?, abi_mips_o32(-)?, abi_ppc_32(-)?, abi_ppc_64(-)?, abi_s390_32(-)?, abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-), abi_x86_64(-)]) required by (app-crypt/mit-krb5-1.15.2-r1:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-lang/python-2.7.14-r1:2.7/2.7::gentoo, installed)
    dev-libs/openssl:0= required by (net-analyzer/nmap-7.40:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1:0/0=[-bindist] required by (net-misc/openssh-7.5_p1-r3:0/0::gentoo, installed)
    dev-libs/openssl:0=[abi_x86_32(-)?, abi_x86_64(-)?, abi_x86_x32(-)?, abi_mips_n32(-)?, abi_mips_n64(-)?, abi_mips_o32(-)?, abi_ppc_32(-)?, abi_ppc_64(-)?, abi_s390_32(-)?, abi_s390_64(-)?] (dev-libs/openssl:0=[abi_x86_32(-), abi_x86_64(-)]) required by (app-arch/libarchive-3.3.1:0/13::gentoo, installed)
    >=dev-libs/openssl-1.0.1:0= required by (app-crypt/qca-2.1.3-r1:2/2::gentoo, installed)
    dev-libs/openssl:0= required by (dev-db/mysql-connector-c++-1.1.6:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (net-wireless/wpa_supplicant-2.6-r3:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?, abi_x86_64(-)?, abi_x86_x32(-)?, abi_mips_n32(-)?, abi_mips_n64(-)?, abi_mips_o32(-)?, abi_ppc_32(-)?, abi_ppc_64(-)?, abi_s390_32(-)?, abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-), abi_x86_64(-)]) required by (net-nds/openldap-2.4.44:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_32(-)?, abi_x86_64(-)?, abi_x86_x32(-)?, abi_mips_n32(-)?, abi_mips_n64(-)?, abi_mips_o32(-)?, abi_ppc_32(-)?, abi_ppc_64(-)?, abi_s390_32(-)?, abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0=[abi_x86_32(-), abi_x86_64(-)]) required by (net-libs/libvncserver-0.9.11-r1:0/0::gentoo, installed)
    dev-libs/openssl:0 required by (net-dns/bind-tools-9.11.1_p3:0/0::gentoo, installed)
    >=dev-libs/openssl-0.9.6m:0 required by (net-analyzer/tcpdump-4.9.2:0/0::gentoo, installed)
    dev-libs/openssl:0 required by (net-misc/iputils-20151218:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (dev-lang/ruby-2.2.8:2.2/2.2::gentoo, installed)
    dev-libs/openssl:0= required by (dev-vcs/git-2.13.6:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (x11-base/xorg-server-1.19.5:0/1.19.5::gentoo, installed)
    >=dev-libs/openssl-1.0.1:0/0= required by (app-crypt/qca-2.1.3-r1:2/2::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?, abi_x86_64(-)?, abi_x86_x32(-)?, abi_mips_n32(-)?, abi_mips_n64(-)?, abi_mips_o32(-)?, abi_ppc_32(-)?, abi_ppc_64(-)?, abi_s390_32(-)?, abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-), abi_x86_64(-)]) required by (dev-libs/libevent-2.1.8:0/2.1-6::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?, abi_x86_64(-)?, abi_x86_x32(-)?, abi_mips_n32(-)?, abi_mips_n64(-)?, abi_mips_o32(-)?, abi_ppc_32(-)?, abi_ppc_64(-)?, abi_s390_32(-)?, abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-), abi_x86_64(-)]) required by (net-libs/libssh-0.7.4:0/4::gentoo, installed)
    dev-libs/openssl:0= required by (dev-lang/python-3.5.4-r1:3.5/3.5m::gentoo, installed)
    dev-libs/openssl:0 required by (www-servers/apache-2.4.27-r1:2/2::gentoo, installed)
    dev-libs/openssl:0/0= required by (x11-base/xorg-server-1.19.5:0/1.19.5::gentoo, installed)
    dev-libs/openssl:0/0= required by (dev-vcs/git-2.13.6:0/0::gentoo, installed)
    >=dev-libs/openssl-0.9.8:* required by (net-vpn/openvpn-2.4.4:0/0::gentoo, installed)
    >=dev-libs/openssl-0.9.6:0 required by (app-editors/xemacs-21.4.24:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0/0=[abi_x86_32(-), abi_x86_64(-)] required by (net-libs/libvncserver-0.9.11-r1:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (net-misc/spice-gtk-0.33-r2:0/0::gentoo, installed)
    dev-libs/openssl:0/0= required by (app-admin/apache-tools-2.4.27:0/0::gentoo, installed)
    >=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-)?, abi_x86_64(-)?, abi_x86_x32(-)?, abi_mips_n32(-)?, abi_mips_n64(-)?, abi_mips_o32(-)?, abi_ppc_32(-)?, abi_ppc_64(-)?, abi_s390_32(-)?, abi_s390_64(-)?] (>=dev-libs/openssl-1.0.1h-r2:0[abi_x86_32(-), abi_x86_64(-)]) required by (net-libs/libssh2-1.7.0:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (media-sound/pulseaudio-10.0:0/0::gentoo, installed)
    dev-libs/openssl:0= required by (dev-libs/xmlsec-1.2.24-r1:0/0::gentoo, installed)

_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,AsrockZ97,i7,MEM:32G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChan,Tandberg LTO-6


Last edited by Waterdevil on Fri Dec 08, 2017 1:24 pm; edited 5 times in total
Back to top
View user's profile Send private message
Waterdevil
n00b
n00b


Joined: 15 Aug 2017
Posts: 63

PostPosted: Fri Dec 08, 2017 1:10 am    Post subject: Reply with quote

moved to https://forums.gentoo.org/viewtopic-t-1072256-start-75-postdays-0-postorder-asc-highlight-.html
_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,AsrockZ97,i7,MEM:32G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChan,Tandberg LTO-6


Last edited by Waterdevil on Fri Dec 08, 2017 1:19 pm; edited 2 times in total
Back to top
View user's profile Send private message
helecho
Apprentice
Apprentice


Joined: 26 Dec 2016
Posts: 238

PostPosted: Fri Dec 08, 2017 8:28 am    Post subject: Reply with quote

In the absence of statistical data, the claims are fundamentally wrong. We can imagine fifty people exposing a similar opinion on the forum but that
they may represent only one tenth of the users. Your reactionary attitudes are damaging: you can not impose your opinion.

    Gentoo is these or that. GNU-MIT-.../Linux is this or that. MS Windows is this or that. OS X is this or that...

What are the prospects of the developers? What are the prospects of the users?

helecho
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39281
Location: 56N 3W

PostPosted: Fri Dec 08, 2017 9:19 am    Post subject: Reply with quote

Waterdevil,

You are doing something wrong. I can't tell what but
Code:
[blocks B      ] dev-libs/openssl:0 ("dev-libs/openssl:0" is blocking dev-libs/libressl-2.6.0)

openssl and libressl are not binary interchangeable. That means if you want to swap, you need to rebuild everything that uses them.
It gets worse too. Lots of things don't work with libressl, so you probably don't want to switch.

If you want help, you need to post your
Code:
emerge --info
and the emerge command that generated the emerge output you posted.
We will need more information too but that will tell us where to look next.

Of course, you are your system admin. If you really want to use libressl, that's your choice, as long as you understand that lots of things won't work with it.
Its your Gentoo your way.

From your reported system behaviour, I suspect you are doing several things in incompatible ways.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Waterdevil
n00b
n00b


Joined: 15 Aug 2017
Posts: 63

PostPosted: Fri Dec 08, 2017 12:16 pm    Post subject: Reply with quote

Yes, I know, and I want to learn it.

moved to https://forums.gentoo.org/viewtopic-t-1072256-start-75-postdays-0-postorder-asc-highlight-.html
_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,AsrockZ97,i7,MEM:32G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChan,Tandberg LTO-6


Last edited by Waterdevil on Fri Dec 08, 2017 1:23 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39281
Location: 56N 3W

PostPosted: Fri Dec 08, 2017 12:41 pm    Post subject: Reply with quote

Split from I am about to give Gentoo up as its turning into a help request.
Its not clear if this in the right forum yet.

Waterdevil,

You can edit the topic title by editing what is not your first post in this topic.

To actually supply help, we need the information I asked for above.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Waterdevil
n00b
n00b


Joined: 15 Aug 2017
Posts: 63

PostPosted: Fri Dec 08, 2017 1:11 pm    Post subject: Reply with quote

I unemerged xen, xemacs

emaint sync --auto
eix-sync
eix-update
layman -S
emerge --verbose --ask --update --newuse --deep --with-bdeps=y --complete-graph=y @world
perl-cleaner --reallyall -- -av
emerge -av --depclean
revdep-rebuild -v -- --ask
eclean-dist -d
dispatch-conf
glsa-check -t all
glsa-check -f all
glsa-check -vp affected
eix-test-obsolete
emaint --check all
eix-update

And now all seems clean.

So this is solved. But not xen, xen-tools, aisleriot,... and not my second computer.
_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,AsrockZ97,i7,MEM:32G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChan,Tandberg LTO-6
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 39281
Location: 56N 3W

PostPosted: Fri Dec 08, 2017 2:15 pm    Post subject: Reply with quote

Waterdevil,

Discuss each problem in a separate thread. One problem at a time to keep the problem space simple.
Good luck with the remaining problems.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Waterdevil
n00b
n00b


Joined: 15 Aug 2017
Posts: 63

PostPosted: Fri Dec 08, 2017 3:14 pm    Post subject: Reply with quote

Yes, this was my intention.

Many, many thanks for your patience. You save me for a stroke.
_________________
_____________________
Aut semper aut numquam

Main-Sys: LianLi modded Big Cube 8000,AsrockZ97,i7,MEM:32G,LSI 9305,HDD:102TB(16x3T,8x6T,4x1T,1x0,5Tm.2,4x0,5TSSD),nVidia GTX1060,NIC:2x10GbSFP+,Fans:20,PSU:1200W+500W,UPS:APC1500VA,FibreChan,Tandberg LTO-6
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum