Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
profil 17
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 411
Location: LB

PostPosted: Tue Dec 05, 2017 7:54 pm    Post subject: profil 17 Reply with quote

8O
ok also entweder warten oder gleich machen
Ich habe mich für gleich machen entschieden, allerdings auf Nummer Sicher :lol:

mit rsync meine Installation auf eine neue Partition gespiegelt.

dann chroot
Code:
mount /mnt/gentoo
mount /dev/sdc2 /mnt/gentoo/boot
mount -t proc /proc /mnt/gentoo/proc
mount --rbind /sys /mnt/gentoo/sys
mount --make-rslave /mnt/gentoo/sys
mount --rbind /dev /mnt/gentoo/dev
mount --make-rslave /mnt/gentoo/dev
test -L /dev/shm && rm /dev/shm && mkdir /dev/shm
mount -t tmpfs -o nosuid,nodev,noexec shm /dev/shm
chmod 1777 /dev/shm
chroot /mnt/gentoo /bin/bash
source /etc/profile
export PS1="(chroot) $PS1"


emerge --sync weil letzter Update kurz vor der Profil einführung von 17 (ca 2 Wochen ohne Update)
Code:

emerge --sync
eselect profile set 19
emerge -1 sys-devel/gcc:6.4.0



und ein beherztes :D
Code:
emerge -euDNav --keep-going @world


noch ein paar PHYTHON Meckerkandidaten :oops: :x :evil: :twisted: :?:
für package.use
Code:

=sys-apps/util-linux-2.30.2  -python_single_target_python2_7 -python_single_target_python3_4 python_single_target_python3_5 -python_single_target_python3_6 python_targets_python3_5
=media-gfx/cura-2.3.1  -python_single_target_python2_7 -python_single_target_python3_4 python_single_target_python3_5 -python_single_target_python3_6 python_targets_python3_5
=sys-apps/util-linux-2.30.2   -python_single_target_python2_7 -python_single_target_python3_4 python_single_target_python3_5 -python_single_target_python3_6 python_targets_python3_5
=dev-tcltk/tclpython-4.1-r6 -python_single_target_python2_7 -python_single_target_python3_4 python_single_target_python3_5 -python_single_target_python3_6 python_targets_python3_5
=dev-libs/botan-2.3.0 -python_single_target_python2_7 -python_single_target_python3_4 python_single_target_python3_5 -python_single_target_python3_6 python_targets_python3_5 boost
=net-print/hplip-3.17.10-r1  -python_single_target_python2_7 -python_single_target_python3_4 python_single_target_python3_5 -python_single_target_python3_6 python_targets_python3_5

=app-text/asciidoc-8.6.9-r2   -python_single_target_pypy  python_single_target_python2_7
=dev-python/uranium-2.3.1 -python_single_target_python3_4 python_single_target_python3_5
=dev-libs/libarcus-2.3.1 -python_single_target_python3_4 python_single_target_python3_5# required by dev-python/sqlalchemy-1.1.12::gentoo[python_targets_python3_5]


UND ab geht die Post mit
Code:
1647 Packete werden installiert


wenn es durch ist geb ich Bescheid :wink:
_________________
Samsung 245B 1920x1200 GeForce GT710
4.12.12-gentoo #1 SMP 2017 DEZ 06 x86_64 AMD FX(tm)-8350 Eight-Core Processor AuthenticAMD GNU/Linux
WM : E16
achim
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2720
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Tue Dec 05, 2017 8:31 pm    Post subject: Re: profil 17 Reply with quote

artbody wrote:
8O
ok also entweder warten oder gleich machen
Ich habe mich für gleich machen entschieden, allerdings auf Nummer Sicher :lol:

mit rsync meine Installation auf eine neue Partition gespiegelt.

dann chroot


yep, das habe ich auch so gemacht. Bei mir waren es ~ 1300 Pakete und es hat insgesamt um die 20 Stunden gedauert.
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 68

PostPosted: Tue Dec 05, 2017 8:33 pm    Post subject: profil 17 Reply with quote

Jo, ich habe mich damit am letzten WE beschäftigt. Ein völlig stable Gentookiste ist auf Anhieb mit emerge -e world gem. News-beschreibung durchgelaufen. Meine mixed Experimentierkiste mit stable und aktuellstem Plasma, Firefox und xorgserver etc. pp. machte da mehr Probleme (1096 Pakete). 8 Anläufe für Profil 17 nach erfolgreichem worldupdate unter Profil13, weil unterwegs immer irgendwas anderes mit Fehler abgebrochen ist. War immer mit dem demaskieren einer aktuelleren Version zu beheben. Der letzte (7.) Hänger war dann 958 von 1096. Gibt es eigentlich eine Methode, das in eine Datei geschriebene Ergebnis von emerge -pe world als eine Art "Datensatz" in eine Datei zu schreiben und dann nur die Pakete ab dem Hänger neu zu emergen? 7 mal Teildurchlauf und beim 8. erfolgreich ist halt ziemlich zeitintensiv.

Momentan sitze ich vor einer Kiste (nicht die im Impressum), wo qtwebengine 5.9.3 abschmiert und ich noch nichts wirklich hilfreiches per Suche gefunden habe.

Code:
fno-exceptions -c ../../3rdparty/chromium/gpu/command_buffer/service/gles2_cmd_decoder.cc -o obj/gpu/command_buffer/service/service_sources/gles2_cmd_decoder.o
ninja: build stopped: subcommand failed.
make[3]: *** [Makefile.gn_run:668: run_ninja] Error 1
make[3]: Leaving directory '/var/tmp/notmpfs/portage/dev-qt/qtwebengine-5.9.3/work/qtwebengine-opensource-src-5.9.3/src/core'
make[2]: *** [Makefile:80: sub-gn_run-pro-make_first] Error 2
make[2]: Leaving directory '/var/tmp/notmpfs/portage/dev-qt/qtwebengine-5.9.3/work/qtwebengine-opensource-src-5.9.3/src/core'
make[1]: *** [Makefile:79: sub-core-make_first] Error 2
make[1]: Leaving directory '/var/tmp/notmpfs/portage/dev-qt/qtwebengine-5.9.3/work/qtwebengine-opensource-src-5.9.3/src'
make: *** [Makefile:47: sub-src-make_first] Error 2
 * ERROR: dev-qt/qtwebengine-5.9.3::gentoo failed (compile phase):
 *   emake failed

weiter oben im Output war noch

Code:
mponents/url_formatter/url_formatter/url_formatter.o
../../3rdparty/chromium/components/url_formatter/url_formatter.cc:511:2: error: #error "Update aspirational_scripts per Unicode 10.0"
 #error "Update aspirational_scripts per Unicode 10.0"


und ganz zum Schluß gibt es noch

Code:
existing preserved libs:
>>> package: dev-libs/icu-60.1
 *  - /usr/lib64/libicui18n.so.58
 *  - /usr/lib64/libicui18n.so.58.2
 *      used by /usr/lib64/libQt5WebEngineCore.so.5.9.3 (dev-qt/qtwebengine-5.9.3)
 *      used by /usr/lib64/qt5/bin/qwebengine_convert_dict (dev-qt/qtwebengine-5.9.3)
 *  - /usr/lib64/libicudata.so.58
 *  - /usr/lib64/libicudata.so.58.2
 *  - /usr/lib64/libicuuc.so.58
 *  - /usr/lib64/libicuuc.so.58.2
 *      used by /usr/lib64/libQt5WebEngineCore.so.5.9.3 (dev-qt/qtwebengine-5.9.3)
 *      used by /usr/lib64/qt5/bin/qwebengine_convert_dict (dev-qt/qtwebengine-5.9.3)
Use emerge @preserved-rebuild to rebuild packages using these libraries


emerge @preserved-rebuild will auch nur die qtwebengine-5.9.3 neu bauen - natürlich mit dem gleichen Abbruch. Ich denke, dass die Hängepartie durch icu-60.1 entsteht. Neubau von icu bringt aber auch nichts.

Gruß an alle Stromgroßverbraucher und Compilierorgienfeierer.

demiurg
_________________
Kernel 4.17.xx-gentoo
GCC 7.xx
Profile amd64/17.0/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F23f
ATI RX580
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6449
Location: Austria

PostPosted: Tue Dec 05, 2017 8:40 pm    Post subject: Reply with quote

emerge --sync.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 394
Location: 09xxx

PostPosted: Tue Dec 05, 2017 9:57 pm    Post subject: Reply with quote

Danke für den Thread, bei mir sind es 962 Pakete. ;)
_________________
Linux ryzen 4.14.65-gentoo #2 SMP Wed Aug 29 11:46:11 CEST 2018 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 411
Location: LB

PostPosted: Tue Dec 05, 2017 10:23 pm    Post subject: Reply with quote

Quote:
nur die Pakete ab dem Hänger neu zu emergen


Code:
emerge --resume

macht da weiter wo du emerge abgebrochen hat

wird aber meist wegen dem Hänger dann mit
Code:
emerge --resume --skipfirst

macht da weiter wo du emerge abgebrochen hat und überspringt das erste Packet, also normal dasjenige, welches abgebrochen hatte


gemacht, oder mach einfach immer ein

Code:
emerge --keep-going  plus dein Zeugs
:D

Code:
emerge --resume --skipfirst --keep-going
:)
müsste auch funktionieren
_________________
Samsung 245B 1920x1200 GeForce GT710
4.12.12-gentoo #1 SMP 2017 DEZ 06 x86_64 AMD FX(tm)-8350 Eight-Core Processor AuthenticAMD GNU/Linux
WM : E16
achim
Back to top
View user's profile Send private message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 68

PostPosted: Tue Dec 05, 2017 11:56 pm    Post subject: Profil17 Reply with quote

Danke für die Tipps mit den emerge Optionen. Das werde ich jetzt mal gleich ausprobieren.

Das icu/qtwebengine Problem habe ich gelöst bekommen. Mit stable icu-58.2-r1 läuft qtwebengine-5.9.3 durch.

icu-60.1wird von spidermonkey-24.xxx verlangt. Firefox kommt inzwischen ohne spidermonkey aus. ich habe alle Versionen von spidermonkey auf dem system entfernt. und die automatische Prüfung auf preserved libs brachte die Info, dass sys-auth/polkit-0.113-r4 von spidermonkey-1.8.x abhängig ist. Also polkit neu gebaut und spidermonkey-1.8.x wieder mitgezogen. Eine Kontrolle mit emerge -puD World ergibt, dass keine aktuellere version von spidermonkey von irgendeinem Programm benötigt wird und damit icu-58.2-r1 für das System ausreicht.

Das sind dann wohl mal so "Kleinigkeiten" von 8 Jahren rollig Release. Es bleiben solche nicht mehr notwendigen Altabhängugkeiten übrig, die nicht zwangsläufig auffallen.

emerge --resume funktioniert jetzt nicht mehr, weil ich zwischenzeitlich in der Konsole zig emerge laufen hatte, um das Problem mit qtwebengine zu lösen.

Also alles auf Anfang und schauen, was passiert.

Gruß demiurg
_________________
Kernel 4.17.xx-gentoo
GCC 7.xx
Profile amd64/17.0/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F23f
ATI RX580
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 411
Location: LB

PostPosted: Wed Dec 06, 2017 6:56 am    Post subject: Reply with quote

@demiurg
Hatte vergessen dazuzuschreiben, dass es das Logfile unter
Code:
/var/log/portage/elog

gibt.

Wenn du da dann Fehler drin hast einfach diese Pakete nochmals emergen
_________________
Samsung 245B 1920x1200 GeForce GT710
4.12.12-gentoo #1 SMP 2017 DEZ 06 x86_64 AMD FX(tm)-8350 Eight-Core Processor AuthenticAMD GNU/Linux
WM : E16
achim
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6449
Location: Austria

PostPosted: Wed Dec 06, 2017 2:17 pm    Post subject: Re: Profil17 Reply with quote

demiurg wrote:
Das icu/qtwebengine Problem habe ich gelöst bekommen. Mit stable icu-58.2-r1 läuft qtwebengine-5.9.3 durch.

Code:
$ emerge --sync

Wie oft denn noch.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
michael_w
Guru
Guru


Joined: 22 Feb 2006
Posts: 394
Location: 09xxx

PostPosted: Wed Dec 06, 2017 4:05 pm    Post subject: Reply with quote

Bei mir ist alles in einem Rutsch ohne Probleme durchgelaufen. Hatte allerdings schon vorher auf gcc-6.4 umgestellt.
_________________
Linux ryzen 4.14.65-gentoo #2 SMP Wed Aug 29 11:46:11 CEST 2018 x86_64 AMD Ryzen 7 1800X Eight-Core Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 411
Location: LB

PostPosted: Wed Dec 06, 2017 4:08 pm    Post subject: Reply with quote

ok also 1647 Packete sind durch
allerdings hängt es jetzt noch an ein paar Packeten
Code:
Calculating dependencies... done!
[ebuild   R    ] dev-python/six-1.10.0::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python3_5 (-pypy) (-pypy3) -python2_7* -python3_4 -python3_6" 0 KiB
[ebuild   R    ] dev-python/pyparsing-2.2.0::gentoo  USE="-doc -examples" PYTHON_TARGETS="python3_5 (-pypy) (-pypy3) -python2_7* -python3_4 -python3_6" 0 KiB
[ebuild   R    ] dev-python/pytz-2017.2::gentoo  PYTHON_TARGETS="python3_5 (-pypy) (-pypy3) -python2_7* -python3_4 -python3_6" 0 KiB
[ebuild   R    ] dev-python/python-dateutil-2.6.1::gentoo  PYTHON_TARGETS="python3_5 (-pypy) (-pypy3) -python2_7* -python3_4 -python3_6" 0 KiB
[ebuild   R    ] dev-python/ssl-fetch-0.4::gentoo  PYTHON_TARGETS="python3_5 (-pypy) -python2_7* -python3_4 -python3_6" 0 KiB
[ebuild     U ~] dev-python/numpy-1.13.3::gentoo [1.10.4::gentoo] USE="lapack -doc {-test}" PYTHON_TARGETS="python3_5 -python2_7* -python3_4 -python3_6" 4.904 KiB
[ebuild   R    ] dev-python/pycairo-1.15.3::gentoo  USE="xcb -doc -examples {-test}" PYTHON_TARGETS="python3_5 -python2_7* -python3_4 -python3_6" 0 KiB
[ebuild   R    ] dev-python/PyQt5-5.7.1::gentoo  USE="bluetooth dbus declarative gui network opengl printsupport svg widgets -debug -designer -doc -examples (-gles2) -help -location -multimedia -positioning -sensors -serialport -sql -testlib -webchannel -webengine -webkit -websockets -x11extras -xmlpatterns" PYTHON_TARGETS="python3_5 -python2_7* -python3_4 -python3_6" 0 KiB


:idea:
ich denk mal, dass es auch Sinn macht den Kernel neu zu kompilieren, steht zwar nicht in den NEWS, aber wäre ja unlogisch, wenn alles mit PIE compiliert ist und der kernel nicht
_________________
Samsung 245B 1920x1200 GeForce GT710
4.12.12-gentoo #1 SMP 2017 DEZ 06 x86_64 AMD FX(tm)-8350 Eight-Core Processor AuthenticAMD GNU/Linux
WM : E16
achim
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 411
Location: LB

PostPosted: Wed Dec 06, 2017 4:10 pm    Post subject: Reply with quote

michael_w wrote:
Bei mir ist alles in einem Rutsch ohne Probleme durchgelaufen. Hatte allerdings schon vorher auf gcc-6.4 umgestellt.


den gcc-6.4 hatte ich auch schon drin.
_________________
Samsung 245B 1920x1200 GeForce GT710
4.12.12-gentoo #1 SMP 2017 DEZ 06 x86_64 AMD FX(tm)-8350 Eight-Core Processor AuthenticAMD GNU/Linux
WM : E16
achim
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6449
Location: Austria

PostPosted: Wed Dec 06, 2017 4:22 pm    Post subject: Reply with quote

artbody wrote:
:idea:
ich denk mal, dass es auch Sinn macht den Kernel neu zu kompilieren, steht zwar nicht in den NEWS, aber wäre ja unlogisch, wenn alles mit PIE compiliert ist und der kernel nicht

Der Kernel baut sich ohnehin nach seinen eigenen Regeln.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 411
Location: LB

PostPosted: Wed Dec 06, 2017 6:56 pm    Post subject: Reply with quote

@asturm
Quote:
Der Kernel baut sich ohnehin nach seinen eigenen Regeln.

Danke

aber schaden kann es auch nicht :D
_________________
Samsung 245B 1920x1200 GeForce GT710
4.12.12-gentoo #1 SMP 2017 DEZ 06 x86_64 AMD FX(tm)-8350 Eight-Core Processor AuthenticAMD GNU/Linux
WM : E16
achim
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 411
Location: LB

PostPosted: Thu Dec 07, 2017 8:02 am    Post subject: Reply with quote

trotz 8Core AMD 20 Stunden für das
Code:
emerge -e --keep-going @world


Quote:
der Kernel baut nach eigenen Regeln


Hach ja sowas hat der bei mir gerade auch gemacht 8O

Rsync eines systemd gentoo :arrow: OK
update auf profile 17 :arrow: OK
Kernel 4.12.12 kompiliert :arrow: soweit auch ok

REBOOT :arrow: ok .... und was ist das :arrow: starting openrc 8O :twisted: :evil:
profile 17 hatte ich aber kde mit systemd ausgewählt :arrow: nachschauen OK war richtig :?: :?: :?:
:?: :arrow: :idea: kernel und systemd, da war doch was
aha siehe da hier liegt das Problem
also nochmal Kernel compilieren.
_________________
Samsung 245B 1920x1200 GeForce GT710
4.12.12-gentoo #1 SMP 2017 DEZ 06 x86_64 AMD FX(tm)-8350 Eight-Core Processor AuthenticAMD GNU/Linux
WM : E16
achim
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 411
Location: LB

PostPosted: Thu Dec 07, 2017 10:51 am    Post subject: Reply with quote

Code:
(chroot) artbody / # eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/13.0
  [2]   default/linux/amd64/13.0/selinux
  [3]   default/linux/amd64/13.0/desktop
  [4]   default/linux/amd64/13.0/desktop/gnome
  [5]   default/linux/amd64/13.0/desktop/gnome/systemd
  [6]   default/linux/amd64/13.0/desktop/plasma
  [7]   default/linux/amd64/13.0/desktop/plasma/systemd
  [8]   default/linux/amd64/13.0/developer
  [9]   default/linux/amd64/13.0/no-multilib
  [10]  default/linux/amd64/13.0/systemd
  [11]  default/linux/amd64/13.0/x32
  [12]  default/linux/amd64/17.0
  [13]  default/linux/amd64/17.0/selinux
  [14]  default/linux/amd64/17.0/hardened
  [15]  default/linux/amd64/17.0/hardened/selinux
  [16]  default/linux/amd64/17.0/desktop
  [17]  default/linux/amd64/17.0/desktop/gnome
  [18]  default/linux/amd64/17.0/desktop/gnome/systemd
  [19]  default/linux/amd64/17.0/desktop/plasma
  [20]  default/linux/amd64/17.0/desktop/plasma/systemd *
  [21]  default/linux/amd64/17.0/developer
  [22]  default/linux/amd64/17.0/no-multilib
  [23]  default/linux/amd64/17.0/no-multilib/hardened
  [24]  default/linux/amd64/17.0/no-multilib/hardened/selinux
  [25]  default/linux/amd64/17.0/systemd
  [26]  default/linux/amd64/17.0/x32
  [27]  hardened/linux/amd64
  [28]  hardened/linux/amd64/selinux
  [29]  hardened/linux/amd64/no-multilib
  [30]  hardened/linux/amd64/no-multilib/selinux
  [31]  hardened/linux/amd64/x32
  [32]  hardened/linux/musl/amd64
  [33]  hardened/linux/musl/amd64/x32
  [34]  default/linux/uclibc/amd64
  [35]  hardened/linux/uclibc/amd64


8O krass also bei profile select hatte ich systemd angegeben, das rsync war von einem systemd system [7] default/linux/amd64/13.0/desktop/plasma/systemd
systemd ist auch installiert
Code:
Calculating dependencies... done!
[ebuild   R    ] sys-apps/systemd-233-r6:0/2::gentoo  USE="acl gcrypt kmod lz4 pam (policykit) seccomp ssl (-apparmor) -audit -build -cryptsetup -curl -doc -elfutils -gnuefi -http -idn -importd -lzma -nat -qrcode (-selinux) -sysv-utils {-test} -vanilla -xkb" ABI_X86="32 (64) (-x32)" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB


.config
Code:
#
# Support for init systems, system and service managers
#
# CONFIG_GENTOO_LINUX_INIT_SCRIPT is not set
CONFIG_GENTOO_LINUX_INIT_SYSTEMD=y
CONFIG_64BIT=y


Code:
 emerge --info
Portage 2.3.13 (python 3.5.4-final-0, default/linux/amd64/17.0/desktop/plasma/systemd, gcc-6.4.0, glibc-2.25-r9, 4.9.6-gentoo-r1 x86_64)
=================================================================
System uname: Linux-4.9.6-gentoo-r1-x86_64-AMD_FX-tm-8350_Eight-Core_Processor-with-gentoo-2.4.1
KiB Mem:    16344364 total,  12875452 free
KiB Swap:   20479992 total,  20479992 free
Timestamp of repository gentoo: Thu, 07 Dec 2017 08:00:01 +0000
Head commit of repository gentoo: ac94bbdfb348d04f8e1499288e589939d6766de4
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.4.5::gentoo, 3.5.4-r1::gentoo, 3.6.3-r1::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.11::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.11.6-r2::gentoo, 1.15.1-r1::gentoo
sys-devel/binutils:       2.29.1-r1::gentoo
sys-devel/gcc:            4.8.5::gentoo, 6.4.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:

localrepo
    location: /usr/local/portage
    masters: gentoo

eclipse
    location: /var/lib/layman/eclipse
    masters: gentoo
    priority: 50

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 50
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2  -march=bdver2 --param l1-cache-line-size=64 --param l1-cache-size=16 --param l2-cache-size=2048 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2  -march=bdver2 --param l1-cache-line-size=64 --param l1-cache-size=16 --param l2-cache-size=2048 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask-write"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities aes alsa amd64 apache2 berkdb bluetooth branding bzip2 cairo cdda cdr cgi cli cracklib crypt cups cxx dbus declarative dri driver dts dvd dvdr emboss encode exif extraengine fam ffmpeg firefox flac fortran gd gdbm gif glamor gpm gtk iconv ipv6 jpeg kde kipi kwallet lcms ldap libnotify lm_sensors mabm mad mcx16 mlzcnt mmx mmxext mng mod modules mp3 mp4 mpeg msahf mtp multilib mysql mysqli ncurses nls nptl nvidia odbc ogg opengl openmp pam pango pcre pdf perl phonon php pie plasma png policykit popcnt ppds pulseaudio python qml qt3support qt5 readline sdl seccomp semantic-desktop session sound spell sse sse2 sse3 sse4.1 sse4.2 sse4a ssl ssse3 startup-notification svg systemd tcpd tiff truetype udev udisks unicode upower usb vorbis widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xv xvid zip zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling socache_shmcb suexec status unixd unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx fma3 fma4 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 xop" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" L10N="de en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de,en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



in der make.conf ist aber systemd angegeben
Code:
USE="acpi apache2  -guile cgi driver  extraengine ffmpeg gd lm_sensors mod multilib  mmx mysql mysqli mtp nls odbc perl  php python -sddm sse sse2 systemd  nvidia  truetype udisks unicode xml X zip  aes mtp mabm mcx16 mlzcnt mmxext msahf pie pulseaudio popcnt sound sse sse2 sse3 sse4.1 sse4.2 sse4a ssse3 



:cry: aber das system started mit openrc :?: :?: :?:

hat da vieleicht jeman eine Idee dazu ?
_________________
Samsung 245B 1920x1200 GeForce GT710
4.12.12-gentoo #1 SMP 2017 DEZ 06 x86_64 AMD FX(tm)-8350 Eight-Core Processor AuthenticAMD GNU/Linux
WM : E16
achim
Back to top
View user's profile Send private message
artbody
Guru
Guru


Joined: 15 Sep 2006
Posts: 411
Location: LB

PostPosted: Thu Dec 07, 2017 12:46 pm    Post subject: Reply with quote

Übeltäter gefunden
Code:
grub-mkconfig -o /boot/grub/grub.cfg

:D
Code:
### BEGIN /etc/grub.d/10_linux ###
menuentry 'Gentoo GNU/Linux' --class gentoo --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-d476f48c-82cb-4f96-9873-200c5b438f24' {
   load_video
   insmod gzio
   insmod part_gpt
   insmod ext2
   set root='hd2,gpt2'
   if [ x$feature_platform_search_hint = xy ]; then
     search --no-floppy --fs-uuid --set=root --hint-bios=hd2,gpt2 --hint-efi=hd2,gpt2 --hint-baremetal=ahci2,gpt2  5b65c374-e4b3-4a4c-b843-edb94332f0f1
   else
     search --no-floppy --fs-uuid --set=root 5b65c374-e4b3-4a4c-b843-edb94332f0f1
   fi
   echo   'Linux x86_64-4.12.12-gentoo wird geladen …'
   linux   /kernel-genkernel-x86_64-4.12.12-gentoo root=UUID=d476f48c-82cb-4f96-9873-200c5b438f24 ro 
   echo   'Initiale Ramdisk wird geladen …'
   initrd   /initramfs-genkernel-x86_64-4.12.12-gentoo
}


da sollte systemd dabei sein :?:
Code:

linux   /kernel-genkernel-x86_64-4.9.6-gentoo-r1-sda4 root=UUID=8207e13a-2f9e-42ba-811e-0b6196e4f13e ro rootfstype=ext4 real_init=/usr/lib/systemd/systemd vga=791 quiet

_________________
Samsung 245B 1920x1200 GeForce GT710
4.12.12-gentoo #1 SMP 2017 DEZ 06 x86_64 AMD FX(tm)-8350 Eight-Core Processor AuthenticAMD GNU/Linux
WM : E16
achim
Back to top
View user's profile Send private message
demiurg
n00b
n00b


Joined: 26 Jul 2005
Posts: 68

PostPosted: Thu Dec 07, 2017 4:51 pm    Post subject: Re: Profil17 Reply with quote

@asturm
asturm wrote:
demiurg wrote:
Das icu/qtwebengine Problem habe ich gelöst bekommen. Mit stable icu-58.2-r1 läuft qtwebengine-5.9.3 durch.

Code:
$ emerge --sync

Wie oft denn noch.


Das interessiert mich jetzt aber doch einmal, was das Ergebnis Deiner Empfehlung für mich sein sein soll.

Ich habe mit profile 13 ein eix-sync und anschließend emerge -uD --newuse world gemacht und es ist alles problemlos durchgelaufen. Dann Umstellung auf Profile 17 und abarbeiten der Schritte der zugehörigen News mit emerge -e world am Ende hat erst das "Problem" zu Tage gefördert. Es wäre mir neu, dass mit einem erneuten emerge --sync solche Konstellationen aufgelöst werden könnten. Zumal hier ein System läuft, das seit 8 Jahren rolling Release im Mix stable und testing Pakete im 2-Tage Rythmus aktualisiert wird.

Gruß
demiurg
_________________
Kernel 4.17.xx-gentoo
GCC 7.xx
Profile amd64/17.0/desktop/plasma
Ryzen 1700
GA AX370-Gaming K7 BIOS F23f
ATI RX580
Back to top
View user's profile Send private message
ManfredB
Apprentice
Apprentice


Joined: 27 Dec 2007
Posts: 184

PostPosted: Sun Jan 07, 2018 6:01 am    Post subject: Reply with quote

Hallo zusammen,

ich habe vorgestern eine komplette Neuinstallation von gentoo-unstable mit Profil 17.0 plasma durchgeführt (Profil-Nr 19).

Bei der Basis-Installation nach Entpacken der stage3 war gcc-6.4.0 Standard.

Nach reboot ins neue System habe ich das System aktualisiert, es waren etwas mehr als 300 Pakete,
erst gegen Ende wurde gcc-7.2.0 installiert.

Als das Update fehlerfrei zu Ende war, habe ich von 6.4.0 auf 7.2.0 umgestellt per gcc-config -l und -f.

Um sicherzugehen, daß danach keiner Fehler auftauchen, habe ich
env-update && source /etc/profile
und dann
emerge -avuDN world
ausgeführt.
Genau 2 Pakete wurden nur reinstalliert.

Danach liefen kde-plasma/plasman-meta und dann kde-apps/kde-apps-meta ohne Fehler durch.

75 Min. für libreoffice, das nur nebenbei.

Ein Problem allerdings habe ich nun:
Starte ich sddm, taucht das Login-Fenster auf, das sehr blaß daherkommt, bei der stable-Version ist das viel kräftiger.
Außerdem kann ich zuerst beim Schreiben des Passwortes keine Punkte in der entsprechenden Zeile sehen,
erst wenn ich ENTER drücke, taucht kurz das ausgefüllte Fenster auf.

Was aber noch viel auffälliger ist: Alle anderen Distributionen bieten beim Ausloggen sowohl Reboot als auch Poweroff an,
hier bei unstable aber nur Ausloggen.
Logge ich mich aus, taucht eine riesige Tastatur auf, die fast den ganzen Monitor füllt. Diese kann ich nicht beseitigen,
sondern nur das Passwort ernuet eingeben, um wieder eingeloggt zu werden.

Also bleibt mir nichts anderes übrig als eine konsole zu öffnen, mich als root einzuloggen und entweder reboot
oder poweroff einzugeben.

Was kann da passiert sein? So eine Erscheinung habe ich noch nie gesehen.

Hat jemand eine Idee, was da vorgegangen sein kann?

Danke im voraus.

Gruß
Manfred

P.S. ich habe das Problem lösen können: sddm.conf von gentoo-stable kopiert und damit ist alles paletti.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3465
Location: Germany

PostPosted: Sun Jan 07, 2018 12:55 pm    Post subject: Reply with quote

@ManfredB,
ja, in sddm-0.17.0 hat man dieses "qtvirtualkeyboard" nun als default gesetzt :-/
Ich frage mich ehrlich gesagt auch was das soll (ist nun vermutlich fürs Smartphone optimiert?).

Für eine normale Desktop_Workstation half es hier in der /etc/sddm.conf unter
[General]
InputMethod=""

zu setzen.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6449
Location: Austria

PostPosted: Sun Jan 07, 2018 3:12 pm    Post subject: Reply with quote

https://gitweb.gentoo.org/repo/gentoo.git/commit/x11-misc/sddm/sddm-0.17.0-r1.ebuild?id=9cb18946f8293ba878c9e3763fd6e1c001fa3e6b
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3465
Location: Germany

PostPosted: Sun Jan 07, 2018 3:53 pm    Post subject: Reply with quote

asturm wrote:
https://gitweb.gentoo.org/repo/gentoo.git/commit/x11-misc/sddm/sddm-0.17.0-r1.ebuild?id=9cb18946f8293ba878c9e3763fd6e1c001fa3e6b


Huh ja prima, dankeschön! :)
Back to top
View user's profile Send private message
ManfredB
Apprentice
Apprentice


Joined: 27 Dec 2007
Posts: 184

PostPosted: Sun Jan 07, 2018 9:22 pm    Post subject: Reply with quote

Hallo zusammen,

ich sage hier einfach einmal vielen tausend Dank für diesen Hinweis.

Was habe ich alles schon im Netz gesucht und nichts dergleichen gefunden,
daher habe ich mich hier in diesem Thread einfach eingemischt, und siehe da:
die Lösung wird mir wie auf einem Tablett serviert.

Ich kann gar nicht sagen, wie mich das freut und wie dankbar ich bin
über ein Forum, das einem solche Hilfe zuteil werden läßt.

Vor allem Josef.95, der mir schon in vielen Punkten eine große Hilfe war.

Allen hier noch einen schönen Abend und nicht zu vergessen ein gutes und erfolgreiches Jahr 2018.

Gruß
Manfred
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3465
Location: Germany

PostPosted: Sun Jan 07, 2018 10:12 pm    Post subject: Reply with quote

ManfredB,

hehe, danke für die Blumen - gern geschehen :)
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2155
Location: Germany

PostPosted: Mon Jan 08, 2018 4:23 pm    Post subject: Reply with quote

Im zuge der Meltdown Updates auf den neuen Kernel hab ich bei den meisten Systemen am Samstag auch den Profilwechsel nach 17.0 vollzogen.

Dabei sind fast keine Probleme aufgetreten bis auf das sich auf meinem ~amd64 System das Pakete app-text/texlive-core-2016-r5 nicht mehr bauen lässt.
Aber ich hab noch eine Version installiert die scheind noch zu funktionieren.

Bis auf bei meinem Notebook, bei dem ich mir gleich emerge Zerschossen hab. Ursache keine Ahnung? Evtl gcc-6.x Update war keine gute idee?
Geklagt darüber hab ich in einem Thread der den Prozessor N5340 von Intel behandelt.
Correct / safe cflags for core i5 3450


Ich erwähne das hier nur falls jemand von euch so ein System hat und noch update muss. Seid vorsichtig!

Die nächsten Tage werde ich da wohl der Rettung entgegen schreiten.

Sonst hatte ich keine Problem. Bei einem System dem update auf 4.14.11-r2 musste ich USB neu konfigurieren, weil das System immer ohne Tastatur und Maus startete. Aber durch USB entfernen. Speichern, USB in der Kernel-Konfiguration (.config) wieder setzen und neu bauen, hatte geholfen.

Oh wobei bei einem anderen System scheint die Netzwerkkarte nicht erkannt zu werden und da komm ich jetzt auch nicht mehr drauf weil SSH nicht geht. aber das lässt sich durch Booten des alten Kernels und erneuten Update bestimmt auch beheben.

An alle die noch Update: Macht Backups und denkt an Hardware-direkt-Zugriff um Turnschuh-Administration zu minimieren.

Edit: Ich hab den Fehler bei meinem Notebook update gefunden! Zwar wurde es durch ungünstiges Autoclean ausgelöst. Zuvor hab ich natürlich das Profil gewechselt UND auf den neuen gcc-6.40 dabei soll man ja bei einem Schritt folgenden Befehl ausführen:

Code:
# revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc


Da hatte ich entweder ein Problem mit den Anführungsstrichen, oder das ganze - weil da ein Fehler im Howto war mit Escape-Sequenzen für die

quasi: revdep-rebuild --library 'libstdc\+\+.so.6' -- --exclude gcc

verwendet. Was dann zwar revdep-rebuild ausführte aber behauptete es ist alles in Ordnung und gibt nichts zu tun.

Wahrscheinlicher ist die Variante mit ' statt ' Anführungszeichen. Wenn man so einen Befehl abschreibt ist das halt blöd wenn man die falschen verwendet weil beide gleich aus sehen.

In zweiter Instanz hat autoclean dann wahrscheinlich sogar python-exec unemerged. Oder irgendwas war mit meinem Portage-Tree nicht in Ordnung.

Habe den Laptop aber mit Chroot und stage3 und das System komplett neu Aufsetzen ganz in den Griff bekommen.

Aber mein guter Vorsatz für 2018 oder später 2019: Einen lokalen Binary-Mirror Server aufsetzen der die Packages baut und Versioniert, vielleicht sogar per NFS /usr/portage Netmount für die Systeme.

Dann hätte ich wahrscheinlich das Problem viel schneller mit einem Backup gelöst.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum