Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Strange KDE Printing problem
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message

Joined: 09 Dec 2014
Posts: 4

PostPosted: Fri Dec 01, 2017 3:04 pm    Post subject: [Solved] Strange KDE Printing problem Reply with quote

Hi everyone,

my KDE install suddenly developed strange printing problems.
My printers are all attached to my homeserver and are advertised through avahi on the local network.
On my KDE-machine I can add the printers through the cups webinterface and print a testpage without problems.
When I open a PDF File in Okular through a terminal and try to print it I get an error message saying
lpr printer or class does not exist
Also the printer which is marked as default never is selected automatically in the kde printing dialog (tried with konsole and okular), instead it offers printing to a file as default.
Printing from Evince, Libreoffice or Firefox does work though - so apparently this is a KDE / QT problem but I have no idea how to track it down and it used to work at least a few weeks back (I don't need to print documents regularly).
lpr definitely does find the printer
lpstat -v
device for HP_LJ_6L: dnssd://HP%20LaserJet%206L%20an%20HP-Server%20%40%20debian._ipp._tcp.local/cups?uuid=d2456f6a-2a83-3616-7d93-6fbc920a01f6

Maybe someone has an idea how to solve this...
Thank you

I'm editing this as apparently the problem is not connected to KDE but rather to the user (as in most cases...).
I hadn't read the gentoo printing guide thoroughly enough and always configured either a raw queue on the server or on the client to avoid problems which arise when sending the print job twice through a filter and apparently this stopped working at some point.
The solution was right there in the printing guide, I simply needed to put the server name in the cups client.conf file, after a cups-restart I was able to use the printers attached to the server without the need of configuring them again on the client machine thus avoiding the raw printer queue completely and now everything works without problems.
Maybe this is of use to someone else who hasn't read the whole printing guide but is able to use google :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum