Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VirtualBox 5.1.* NS_ERROR_FAILURE 0x80004005 [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
HeXiLeD
Veteran
Veteran


Joined: 20 Aug 2005
Posts: 1053
Location: Online

PostPosted: Thu Nov 30, 2017 9:52 pm    Post subject: VirtualBox 5.1.* NS_ERROR_FAILURE 0x80004005 [SOLVED] Reply with quote

Related to old dead topic here

Maybe related to (things i looked into):
virtualbox update v4.0.8 trouble
VirtualBox not detecting 3d acceleration
Nvidia 337.88 Breaks 3d Acceleration with Virtualbox

This problem, although not usb related comes in the sequence of events of upgrading kernels described here.

Problem does not happen with kernel gentoo sources 4.9.65. Problem happens with kernels above that version such as:
    linux-4.12.12-gentoo
    linux-4.12.5-gentoo
    linux-4.14.2-gentoo


Currently using: 4.12.12-gentoo

/ filesystem is ext4 on solid-state-drive mounted with default options and raid-1
VirtualBox VM's are on ext4 sata drives mounted with default options and raid-1

# lsmod
Code:
Module                  Size  Used by
vboxpci                24576  0
vboxnetadp             28672  0
vboxnetflt             28672  0
vboxdrv               401408  3 vboxnetadp,vboxnetflt,vboxpci


# cat /etc/conf.d/modules | grep modules=
Code:

modules="sky2 nvidia nvidia-uvm vboxnetadp vboxpci vboxdrv vboxnetflt batman-adv"


Code:
Unresolved (unknown) host platform error. (VERR_UNRESOLVED_ERROR).

Result Code:
NS_ERROR_FAILURE (0x80004005)
Component:
ConsoleWrap
Interface:
IConsole {872da645-4a9b-1727-bee2-5585105b9eed}


# dmesg |grep [Vv][Bb][Oo][Xx]
Code:
[    3.796776] vboxdrv: loading out-of-tree module taints kernel.
[    3.797342] vboxdrv: Found 4 processor cores
[    3.798955] vboxdrv: fAsync=0 offMin=0x558 offMax=0x23c8
[    3.899025] vboxdrv: TSC mode is Synchronous, tentative frequency 3200112927 Hz
[    3.899026] vboxdrv: Successfully loaded version 5.1.26 (interface 0x002a0000)
[    3.899634] VBoxNetFlt: Successfully started.
[    3.903159] VBoxNetAdp: Successfully started.
[    3.908518] VBoxPciLinuxInit
[    3.908521] vboxpci: IOMMU not found (not registered)
[  400.146405] vboxdrv: ffffffffa0f4a020 VMMR0.r0
[  413.583867] vboxdrv: ffffffffa0f4a020 VMMR0.r0
[  484.617640] vboxdrv: ffffffffa0f4a020 VMMR0.r0
[  545.510828] vboxdrv: ffffffffa0f4a020 VMMR0.r0
[  588.262178] vboxdrv: ffffffffa0f4a020 VMMR0.r0
[  608.317907] vboxdrv: ffffffffa0f4a020 VMMR0.r0
[ 1442.590495] VBoxPciLinuxLinuxUnload
[ 5583.054664] vboxdrv: Found 4 processor cores
[ 5583.054899] vboxdrv: fAsync=0 offMin=0x188 offMax=0x23a8
[ 5583.154997] vboxdrv: TSC mode is Synchronous, tentative frequency 3200112911 Hz
[ 5583.154998] vboxdrv: Successfully loaded version 5.1.30 (interface 0x002a0000)
[ 5591.078127] VBoxNetFlt: Successfully started.
[ 5597.605968] VBoxNetAdp: Successfully started.
[ 5602.710003] VBoxPciLinuxInit
[ 5602.710009] vboxpci: IOMMU not found (not registered)
[ 5612.828815] vboxdrv: ffffffffa0f4a020 VMMR0.r0
[ 5801.311709] vboxdrv: ffffffffa0f4a020 VMMR0.r0
[ 6163.944466] vboxdrv: ffffffffa0f4a020 VMMR0.r0


IOMMU does not exist in the system or hardware.

# eix -I | grep app-emulation/virtualbox
Code:
[I] app-emulation/virtualbox
[I] app-emulation/virtualbox-additions
[I] app-emulation/virtualbox-extpack-oracle
[I] app-emulation/virtualbox-guest-additions
[I] app-emulation/virtualbox-modules


VirtualBox versions tested and installed from portage:
Code:
5.1.26{tbz2} ~5.1.28 (~)5.1.30


All/several operating systems do not load on virtual box. linux, bsd and windows.

Video cards drivers if relevant:

    x11-drivers/nvidia-drivers-387.22
    x11-drivers/nvidia-drivers-387.34


3D acceleration on or of does not make a difference

The possibility of some links being broken in /usr/lib/virtualbox/ or elsewhere shouldn't be excluded and if so I am unaware how to fix them.

virtualbox # find . -xtype l
Code:
./VRDPAuth.so


Seems broken:
Code:
VRDPAuth.so -> VBoxAuth.so


Right now I am out of ideas. Good on topic feedback is welcome
_________________
443640, Questioning, Unsolved, BinHost


Last edited by HeXiLeD on Tue Dec 05, 2017 3:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
HeXiLeD
Veteran
Veteran


Joined: 20 Aug 2005
Posts: 1053
Location: Online

PostPosted: Tue Dec 05, 2017 3:34 pm    Post subject: VirtualBox 5.1.* NS_ERROR_FAILURE 0x80004005 [SOLVED] Reply with quote

It appears that the problem had to do with driver permissions after kernel upgrade from 4.9.* to 4.12.*
There are a few topics around addressing the issue which may be related to udev and it's virtualbox rules.

The only solution that worked for me was to unmerge/uninstall all virtualbox software, make sure all virtualbox drivers were were removed from the kernel and the system, reboot, install virtualbox software again and load the drivers.

my current permissions in /dev/vbox*
# ls -lah /dev/vbox*
Code:
crw------- 1 root root      10, 56 Dec  5 05:21 /dev/vboxdrv
crw------- 1 root root      10, 55 Dec  5 05:21 /dev/vboxdrvu
crw------- 1 root root      10, 54 Dec  5 05:21 /dev/vboxnetctl

/dev/vboxusb:
total 0
drwxr-x---  8 root vboxusers  160 Dec  5 05:21 .
drwxr-xr-x 22 root root      4.5K Dec  5 10:21 ..
drwxr-x---  2 root vboxusers  140 Dec  5 05:21 001
drwxr-x---  2 root vboxusers   80 Dec  5 05:21 002
drwxr-x---  2 root vboxusers   60 Dec  5 05:21 004
drwxr-x---  2 root vboxusers   60 Dec  5 05:21 006
drwxr-x---  2 root vboxusers   80 Dec  5 05:21 008
drwxr-x---  2 root vboxusers   60 Dec  5 05:21 009


Everything is working again with version 5.1.30

# eix -I | grep app-emulation/virtualbox
Code:
[I] app-emulation/virtualbox
[I] app-emulation/virtualbox-additions
[I] app-emulation/virtualbox-extpack-oracle
[I] app-emulation/virtualbox-guest-additions
[I] app-emulation/virtualbox-modules


This problem is SOLVED
_________________
443640, Questioning, Unsolved, BinHost
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum