Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] AfterShot and Gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
grooveman
Veteran
Veteran


Joined: 24 Feb 2003
Posts: 1126

PostPosted: Thu Nov 30, 2017 8:45 pm    Post subject: [Solved] AfterShot and Gentoo Reply with quote

Hello,

I've been using Corel AfterShot pro on Gentoo systems since it was first released -- and Bibble Pro even before that. It has always just worked without a hitch.

The installers come in debian or rpm format, and I always go with the rpm. Typically I install with rpm -ivh --nodeps, and it works just fine... upgrading with rpm -uvh.

However, I recently discovered that AfterShot no longer works on Gentoo... I have kept all my installs since Bibble 5, and all of them have stopped working (Bibble 5, APS 1, APS 2 and APS 3). I thought, perhaps, I did something weird on my system, so went to my laptop, and the same thing occurs. None of the versions work any longer.

I'm using KDE on 64 bit platform with KDE Plasma as my primary desktop.

When I try to start Aftershot, I get the following output:
Code:

Fatal: This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Reinstalling the application may fix this problem.
This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "".

Reinstalling the application may fix this problem.
Aborted


Of course, reinstalling does not fix the problem. I have also tried to install every package in portage involving xcb... still no good. I'm not even convinced it is the right error. libqxcb.so lives where it always does in AfterShot, in /opt/AfterShot3(64-bit)/lib/plugins/platforms.


My qt.conf in my /opt/AfterShot3(64-bit)/bin directory contains the following (which is stock with the install):
Code:
[Paths]
Plugins=/opt/AfterShot3(64-bit)/lib/plugins

[Platforms]
WindowsArguments = dpiawareness=0


I've tried messing with the qt.conf, changing the path, commenting things out... it always results in the same thing. I really thought changing the path to/opt/AfterShot3(64-bit)/lib/plugins/platforms
or /opt/AfterShot3(64-bit)/lib/plugins would do it.. but nope. If I get rid of the qt.conf file altogether, and run APS, I get:

Code:
I have SSE2
Loading plugins
Initialising  Wavelet Denoise 2  filter
Warning: slow tiles used because plugin is not white listed:  "WaveletDenoise2"
Initialising  Wavelet Sharpen 3  filter
Warning: slow tiles used because plugin is not white listed:  "WaveletSharpen2"
Warning: slow tiles used because plugin is not white listed:  "zChannelMixer"
zFrame: no calibration file available
Warning: slow tiles used because plugin is not white listed:  "zFrame"
Warning: slow tiles used because plugin is not white listed:  "Zone"
Warning: slow tiles used because plugin is not white listed:  "zPerspector"
Warning: slow tiles used because plugin is not white listed:  "zShadow"
Warning: slow tiles used because plugin is not white listed:  "zSoften"
Warning: slow tiles used because plugin is not white listed:  "zText"
Loading camera modules from "/opt/AfterShot3(64-bit)/supportfiles/cameras"
Loading camera modules from "/home/chris/.AfterShot Pro 3/Cameras (64-bit)"
Bibble program arguments ("./AfterShot")
AfterShot2 Pro New key used. 20
AfterShot2 Pro New key used. 20
AfterShot2 Pro New key used. 20
AfterShot vers.: 3.3.0.234
Built on: "Tue Apr 11 2017"
Language: en
App Path: /opt/AfterShot3(64-bit)/bin/AfterShot
System Home: /opt/AfterShot3(64-bit)/supportfiles
User Home: /home/chris/.AfterShot Pro 3
Prefs Home: /home/chris/.config/Corel/AfterShot Pro v3.conf
Platform:     Linux
Issue: ""
Kernel: "Linux version 4.12.12-gentoo (root@izzy-lin) (gcc version 5.4.0 (Gentoo 5.4.0-r3 p1.4, pie-0.6.5) ) #1 SMP Sun Oct 29 19:20:35 EDT 2017"
Build Mode:   Release
Product Name: "AfterShot Pro 3"
AfterShot2 Pro New key used. 20
Registered Version
AfterShot2 Pro New key used. 20
Initializing
Cpu Manager init: 8
****    Making CLManager
Got 0 platforms
OpenCL is disabled in low mem mode
"Could not select an OpenCL platform"
****    CLManager not initialized
tileSize: 256
"MemTotal:       16268352 kB"
Memory:  3
====================================================
Asset: 2147483647 purge
====================================================
Heavy Asset: 2147483647 purge
====================================================
NoiseEngine: 150 purge
NoiseEngine: 75 cache (50 min)
====================================================
Histogram: 24 purge
Histogram: 12 cache (12 min)
====================================================
PluginData: 9 purge
PluginData: 9 cache (8 min)
====================================================
ImageMaster: 600 purge
ImageMaster: 300 cache (50 min)
====================================================
NContainer: 2147483647 purge
====================================================
Path: 2147483647 purge
Path: 2147483647 cache (2147483647 min)
====================================================
RawData: 25165821 purge
====================================================
UncompressedRawData: 9 purge
UncompressedRawData: 9 cache (8 min)
====================================================
Version: 600 purge
Version: 300 cache (50 min)
====================================================
PerfectlyClear: 6 purge
PerfectlyClear: 4 cache (4 min)
====================================================
TileStack: 24 purge
TileStack: 12 cache (12 min)
====================================================
StackTile: 3000 purge
Created 626 buffers of 857472
FALLBACK to 1252 tiles
====================================================
BImageTile: 1800 purge
====================================================
BTiledImage: 2147483647 purge
====================================================
RegionImageTile: 3000 purge
====================================================
Allocate Asset manager
Option group -  ""  - already contains an option with name -  "TIFFTAG_AFMODE"
  Option was not registered.
Option group -  ""  - already contains an option with name -  "TIFFTAG_FLASHMODE"
  Option was not registered.
Globals: systemhome /opt/AfterShot3(64-bit)/supportfiles
Globals: userhome /home/chris/.AfterShot Pro 3

====================  Plugins  =====================
      Name:
Identifier:
   Version: 1.0.0
      Path:


      Name: Grid-64
Identifier: Grid-64
   Version: 1.0.0
      Path: <User Home>/Plugins (64-bit)/Grid-64.afplugin


      Name: Mix3
Identifier: com.ferdinand-paris.mix3
   Version: 1.0.1
      Path: <User Home>/Plugins (64-bit)/Mix364.afplugin


      Name: Vigne
Identifier: com.corel.vigne
   Version: 1.1.0
      Path: <User Home>/Plugins (64-bit)/Vigne.afplugin


      Name: Wavelet Denoise
Identifier: sph.waveletdenoise
   Version: 0.31.0
      Path: <User Home>/Plugins (64-bit)/Wavelet Denoise.afplugin


      Name: WaveletSharpen2
Identifier: sph.waveletsharpen
   Version: 1.34.1
      Path: <User Home>/Plugins (64-bit)/WaveletSharpen2.afplugin


      Name: zChannelMixer64
Identifier: tin.tin.zchannelmixer
   Version: 3.1.0
      Path: <User Home>/Plugins (64-bit)/zChannelMixer64.afplugin


      Name: zFrame64
Identifier: tin.tin.zFrame
   Version: 4.1.0
      Path: <User Home>/Plugins (64-bit)/zFrame64.afplugin


      Name: Zone-64
Identifier: Zone-64
   Version: 1.0.1
      Path: <User Home>/Plugins (64-bit)/Zone-64.afplugin


      Name: zPerspector64
Identifier: tin.tin.zPerspector
   Version: 3.1.0
      Path: <User Home>/Plugins (64-bit)/zPerspector64.afplugin


      Name: zShadow64
Identifier: tin.tin.zShadow
   Version: 3.1.0
      Path: <User Home>/Plugins (64-bit)/zShadow64.afplugin


      Name: zSoften64
Identifier: tin.tin.zSoften
   Version: 2.1.0
      Path: <User Home>/Plugins (64-bit)/zSoften64.afplugin


      Name: zText64
Identifier: tin.tin.zText
   Version: 3.1.0
      Path: <User Home>/Plugins (64-bit)/zText64.afplugin


      Name: Black and White
Identifier: com.corel.BlackAndWhite
   Version: 1.0.0
      Path: <System Home>/plugins/Black and White.afplugin


      Name: Equalizer
Identifier: com.corel.equalizer
   Version: 1.0.5
      Path: <System Home>/plugins/Equalizer.afplugin


====================================================

load lens IDs from table file: /opt/AfterShot3(64-bit)/supportfiles/Profiles/LensProfiles/profile_canonlenstable.txt
load lens IDs from table file: /opt/AfterShot3(64-bit)/supportfiles/Profiles/LensProfiles/profile_nikonlenstable.txt
load lens IDs from table file: /opt/AfterShot3(64-bit)/supportfiles/Profiles/LensProfiles/profile_pentaxlenstable.txt
load lens IDs from table file: /opt/AfterShot3(64-bit)/supportfiles/Profiles/LensProfiles/profile_minoltalenstable.txt
load lens IDs from table file: /opt/AfterShot3(64-bit)/supportfiles/Profiles/LensProfiles/profile_olympuslenstable.txt
load lens IDs from table file: /opt/AfterShot3(64-bit)/supportfiles/Profiles/LensProfiles/profile_panasoniclenstable.txt
load lens IDs from table file: /opt/AfterShot3(64-bit)/supportfiles/Profiles/LensProfiles/profile_sonylenstable.txt
load lens IDs from table file: /opt/AfterShot3(64-bit)/supportfiles/Profiles/LensProfiles/profile_samsunglenstable.txt
Couldn't open lens table file: /opt/AfterShot3(64-bit)/supportfiles/Profiles/LensProfiles/profile_fujifilmlenstable.txt
LensDB - Loading lens entries from "/opt/AfterShot3(64-bit)/supportfiles/Profiles/LensProfiles/lens-cameras-db.xml" | Cameras found: 546 and updated: 546 | Lens found: 0 and updated: 0
New lens exif id/value info: "18 18 2 2" | "Fujinon XF 18mm f/2 R" added into lookup table: "Fujifilm"
New lens exif id/value info: "18 55 2.8 4" | "Fujinon XF 18-55mm f/2.8-4 R LM OIS" added into lookup table: "Fujifilm"
New lens exif id/value info: "23 23 1.4 1.4" | "Fujinon XF 23mm f/1.4 R" added into lookup table: "Fujifilm"
New lens exif id/value info: "23 23 2 2" | "Fujinon XF 23mm f/2 R WR" added into lookup table: "Fujifilm"
New lens exif id/value info: "4 231" | "Tamron 16-300mm f/3.5-6.3 Di II VC PZD B016 Macro" added into lookup table: "Pentax"
New lens exif id/value info: "0 18 16" | "Zuiko Digital 60mm f/2.8 Macro" added into lookup table: "Olympus"
New lens exif id/value info: "60 60 2.8 2.8" | "Zuiko Digital 60mm f/2.8 Macro" added into lookup table: "Olympus"
New lens exif id/value info: "0 34 16" | "Zuiko Digital 25mm f/1.8" added into lookup table: "Olympus"
New lens exif id/value info: "25 25 1.8 1.8" | "Zuiko Digital 25mm f/1.8" added into lookup table: "Olympus"
New lens exif id/value info: "0 33 16" | "Zuiko Digital ED 14-42mm f/3.5-5.6 EZ" added into lookup table: "Olympus"
New lens exif id/value info: "0 7 16" | "M.Zuiko Digital ED 12mm f/2.0" added into lookup table: "Olympus"
New lens exif id/value info: "12 12 2 2" | "M.Zuiko Digital ED 12mm f/2.0" added into lookup table: "Olympus"
New lens exif id/value info: "0 24 16" | "M.Zuiko Digital ED 75-300mm f/4.8-6.7 II" added into lookup table: "Olympus"
New lens exif id/value info: "75 300 4.8 6.7" | "M.Zuiko Digital ED 75-300mm f/4.8-6.7 II" added into lookup table: "Olympus"
New lens exif id/value info: "00 54 44 44 0C 0C 00 00" | "Nikkor 35mm f/1.8G" added into lookup table: "Nikon"
New lens exif id/value info: "00 54 44 44 0C 0C 00 00" | "Nikkor 35mm f/1.4 AiS" added into lookup table: "Nikon"
New lens exif id/value info: "66 40 2D 44 2C 34 6C 02" | "Nikkor 18-300mm f/3.5-6.3G DX ED VR" added into lookup table: "Nikon"
New lens exif id/value info: "66 40 2D 44 2C 34 6C 02" | "Nikkor 18-35mm f/3.5-4.5D IF-ED AF Zoom" added into lookup table: "Nikon"
New lens exif id/value info: "2 18 16" | "Leica DG Summilux 25mm f/1.4 Asph." added into lookup table: "Olympus"
New lens exif id/value info: "25 25 1.4 1.4" | "Leica DG Summilux 25mm f/1.4 Asph." added into lookup table: "Olympus"
New lens exif id/value info: "LUMIX G VARIO 12-35/F2.8" | "Lumix G Vario 12-35/f2.8" added into lookup table: "Panasonic"
New lens exif id/value info: "4 231" | "smc PENTAX-DA 18-250mm f/3.5-6.3 ED AL [IF]" added into lookup table: "Pentax"
LensDB - Loading lens entries from "/opt/AfterShot3(64-bit)/supportfiles/Profiles/LensProfiles/lens-db.xml" | Cameras found: 0 and updated: 0 | Lens found: 1220 and updated: 1220
/home/chris/.AfterShot Pro 3/bibbledebug
AfterShot2 Pro New key used. 20
Creating main window
AfterShot2 Pro New key used. 20
Starting Catalog Manager
Fatal: Cannot mix incompatible Qt library (version 0x50400) with this library (version 0x50701)
Cannot mix incompatible Qt library (version 0x50400) with this library (version 0x50701)
Aborted


My environment:
Code:
__GL_YIELD=USLEEP
MANPATH=/etc/java-config-2/current-system-vm/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/5.4.0/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.29.1/man:/etc/java-config-2/current-system-vm/man/:/usr/local/share/man:/usr/share/man
TERM=xterm-256color
SHELL=/bin/bash
CG_INC_PATH=/opt/nvidia-cg-toolkit/include
XDG_SESSION_COOKIE=izzy-lin-1512073453.158909-1873855218
SSH_CLIENT=75.147.250.153 58852 22
OLDPWD=/opt/AfterShot3(64-bit)
SSH_TTY=/dev/pts/2
ANT_HOME=/usr/share/ant
USER=chris
__GL_THREADED_OPTIMIZATIONS=1
LS_COLORS=<redacted for format>
PRELINK_PATH_MASK=/usr/lib64/klibc
PAGER=/usr/bin/less
CONFIG_PROTECT_MASK=/etc/sandbox.d /etc/fonts/fonts.conf /etc/gentoo-release /etc/gconf /etc/terminfo /etc/dconf /etc/ca-certificates.conf /etc/revdep-rebuild
XDG_CONFIG_DIRS=/etc/xdg
MAIL=/var/mail/chris
PATH=/usr/x86_64-pc-linux-gnu/gcc-bin/5.4.0:/usr/local/bin:/usr/bin:/bin:/opt/bin:/opt/nvidia-cg-toolkit/bin:/usr/games/bin
PWD=/opt/AfterShot3(64-bit)/bin
JAVA_HOME=/etc/java-config-2/current-system-vm
JAVAC=/etc/java-config-2/current-system-vm/bin/javac
EDITOR=/usr/bin/vi
CG_LIB_PATH=/opt/nvidia-cg-toolkit/lib32:/opt/nvidia-cg-toolkit/lib64
LANG=en_US.utf8
GSETTINGS_BACKEND=dconf
QT_GRAPHICSSYSTEM=raster
JDK_HOME=/etc/java-config-2/current-system-vm
SHLVL=1
HOME=/home/chris
CG_COMPILER_EXE=/opt/bin/cgc
LESS=-R -M --shift 5
LOGNAME=chris
GCC_SPECS=
XDG_DATA_DIRS=/usr/local/share:/usr/share
SSH_CONNECTION=XX.xx.xx.xx
LESSOPEN=|lesspipe %s
INFOPATH=/usr/share/gcc-data/x86_64-pc-linux-gnu/5.4.0/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.29.1/info:/usr/share/info
XDG_RUNTIME_DIR=/var/run/user/1000
DISPLAY=localhost:10.0
QT_PLUGIN_PATH=/usr/lib64/kde4/plugins
OPENGL_PROFILE=nvidia
CONFIG_PROTECT=/etc/stunnel/stunnel.conf /usr/share/gnupg/qualified.txt /var/lib/hsqldb /usr/share/config /usr/lib64/libreoffice/program/sofficerc /usr/share/themes/oxygen-gtk/gtk-2.0
OPENCL_PROFILE=nvidia
_=/usr/bin/env


I assume that bombs out because the QT version of APS is older than my system QT version. I tried adding the path the plugins under the AfterShot directory to my QT_PLUGIN_PATH, but that didn't help either.

I've run an strace... but couldn't find anything useful there either... Something has gotten very far out of step here with Gentoo and APS, and I'm not sure what it is... I always though that APS used its own QT libraries... so I don't know if it should matter that I'm on the latest stable plasma.

Any thoughts? Suggestions? Insights?

Thanks!

G

MODERATOR EDIT: LS_COLORS redacted to preserve format as the information isn't relevant here.
_________________
To look without without looking within is like looking without without looking at all.


Last edited by grooveman on Tue Dec 12, 2017 1:24 am; edited 1 time in total
Back to top
View user's profile Send private message
grooveman
Veteran
Veteran


Joined: 24 Feb 2003
Posts: 1126

PostPosted: Mon Dec 04, 2017 8:07 pm    Post subject: Reply with quote

Bump?
_________________
To look without without looking within is like looking without without looking at all.
Back to top
View user's profile Send private message
grooveman
Veteran
Veteran


Joined: 24 Feb 2003
Posts: 1126

PostPosted: Thu Dec 07, 2017 9:57 pm    Post subject: Reply with quote

No Gentoo-using photographers out there, huh?

What a bummer. I use this software extensively. It is a real show-stopper for me.

I guess I will try on the aftershot fourm... but, of course, they will tell me to use Ubuntu or fedora... maybe I'll get lucky.
_________________
To look without without looking within is like looking without without looking at all.
Back to top
View user's profile Send private message
grooveman
Veteran
Veteran


Joined: 24 Feb 2003
Posts: 1126

PostPosted: Tue Dec 12, 2017 1:23 am    Post subject: Reply with quote

Ok. I figured this one out...

Add the gstreamer010 flag in /etc/portage/package.use for dev-qt/qtwebkit.

That works.

G
_________________
To look without without looking within is like looking without without looking at all.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum