Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plymouth and UEFI without GRUB2. How to?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
g-virus
n00b
n00b


Joined: 26 Aug 2017
Posts: 27

PostPosted: Mon Nov 27, 2017 5:30 pm    Post subject: Plymouth and UEFI without GRUB2. How to? Reply with quote

Hello everyone! I'm trying to setup the plymouth on my UEFI laptop and it's not working. I have installed sys-boot/plymouth package and OpenRC-plugin. I have also chosen a theme and disabled rc_interactive. Also disabled a Boot Logo. Well I guess I've done everything according to Gentoo Wiki. But the Plymouth doesn't work, I still see text-mode but without the logo. What should I do more? I don't have any bootloader. my system loads from /boot/EFI/Gentoo/linux,efi file

Thanks in advance
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2446

PostPosted: Mon Nov 27, 2017 5:54 pm    Post subject: Reply with quote

How did you create the initramfs?
Back to top
View user's profile Send private message
g-virus
n00b
n00b


Joined: 26 Aug 2017
Posts: 27

PostPosted: Mon Nov 27, 2017 10:43 pm    Post subject: Reply with quote

charles17 wrote:
How did you create the initramfs?


I don't have it actually
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2446

PostPosted: Tue Nov 28, 2017 7:52 am    Post subject: Reply with quote

g-virus wrote:
I don't have it actually

Do you think plymouth works without initramfs?
Back to top
View user's profile Send private message
g-virus
n00b
n00b


Joined: 26 Aug 2017
Posts: 27

PostPosted: Tue Nov 28, 2017 9:36 pm    Post subject: Reply with quote

charles17 wrote:
g-virus wrote:
I don't have it actually

Do you think plymouth works without initramfs?


I thought so actually because I don't need the initramfs and I thought it is an optional way. So I guess I will have to setup it? Does it work without grub, lilo etc?
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2446

PostPosted: Wed Nov 29, 2017 6:17 pm    Post subject: Reply with quote

Reading https://www.freedesktop.org/wiki/Software/Plymouth/ might give you an idea. Unfortunately the Gentoo wiki article is not very clear about the requirements.
Back to top
View user's profile Send private message
g-virus
n00b
n00b


Joined: 26 Aug 2017
Posts: 27

PostPosted: Fri Dec 08, 2017 4:54 pm    Post subject: Reply with quote

charles17 wrote:
Reading https://www.freedesktop.org/wiki/Software/Plymouth/ might give you an idea. Unfortunately the Gentoo wiki article is not very clear about the requirements.


Well ok, I've installed the initramfs by dracut.

Config file /etc/dracut.conf.d/initramfs.conf
Code:

hostonly="yes"
dracutmodules+="plymouth"


the img-file was generated successfully, 12M size.

I've also added it to EFI according to this article https://wiki.gentoo.org/wiki/EFI_stub_kernel so seems like everything is ok, but still no Plymouth during the boot.
Back to top
View user's profile Send private message
g-virus
n00b
n00b


Joined: 26 Aug 2017
Posts: 27

PostPosted: Tue Dec 12, 2017 5:29 pm    Post subject: Reply with quote

Any ideas, guys?
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2446

PostPosted: Tue Dec 12, 2017 6:10 pm    Post subject: Reply with quote

g-virus wrote:
the img-file was generated successfully, 12M size.

And is it used at all? Or are you booting without your new initramfs?
Back to top
View user's profile Send private message
g-virus
n00b
n00b


Joined: 26 Aug 2017
Posts: 27

PostPosted: Fri Dec 15, 2017 5:48 pm    Post subject: Reply with quote

charles17 wrote:
g-virus wrote:
the img-file was generated successfully, 12M size.

And is it used at all? Or are you booting without your new initramfs?


g-virus wrote:

I've also added it to EFI according to this article https://wiki.gentoo.org/wiki/EFI_stub_kernel


I'm not sure I could add successfully wrong :) Probably my UEFI doesn't work with external initramfs files. If I rename the initramfs will my laptop fail on boot? If yes I will try it[/quote]
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 2446

PostPosted: Fri Dec 15, 2017 7:09 pm    Post subject: Reply with quote

g-virus wrote:
Probably my UEFI doesn't work with external initramfs files. ...

This should be tested, of course. But why not try internal initramfs ( did I tell you the link )?
Back to top
View user's profile Send private message
g-virus
n00b
n00b


Joined: 26 Aug 2017
Posts: 27

PostPosted: Fri Dec 15, 2017 7:35 pm    Post subject: Reply with quote

charles17 wrote:
g-virus wrote:
Probably my UEFI doesn't work with external initramfs files. ...

This should be tested, of course. But why not try internal initramfs ( did I tell you the link )?


I didn't try the internal variant because I don't know how to enable it correctly with non-grub-like booting so I've tried the external variant first

I've tried to delete the initramfs file /boot/efi/gentoo/initramfs.img and the system doesn't boot so the external file works good. Any ideas?
Back to top
View user's profile Send private message
g-virus
n00b
n00b


Joined: 26 Aug 2017
Posts: 27

PostPosted: Sun Dec 17, 2017 10:19 pm    Post subject: Reply with quote

Probably it is a reason of the problem - I use official nvidia drivers (nvidia-drivers package). Could Plymouth stop work because of these drivers?

I've tried to run these commands to test Plymouth

Code:

# plymouthd
# plymouth --show-splash


A screen has fade to black, I can see a login prompt but I cannot enter login/password so I have to switch to another terminal and restart X server.
Back to top
View user's profile Send private message
tberger2
n00b
n00b


Joined: 05 Feb 2013
Posts: 56

PostPosted: Mon Dec 18, 2017 10:37 am    Post subject: Reply with quote

For some reasons I use a custom initramfs (busybox) made by myself. Does anyone use plymouth/UEFI not created by dracut? If yes or somebody knows, what files are needed and what has to be added to the init script?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum