Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Qt 5.9
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 214
Location: Kenzingen, Germany

PostPosted: Thu Nov 23, 2017 12:07 pm    Post subject: Qt 5.9 Reply with quote

Hat jemand schon Qt 5.9 installiert?

Ich habe Qt 5.7.1 und ein Update wird mir von Portage nicht angeboten, wenn ich die normalen Kommandos nutze. Statt dessen gibt es eine längere Ausgabe bezüglich Blocker-Konstellationen.
_________________
Languages: English, German
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3516
Location: Germany

PostPosted: Fri Nov 24, 2017 1:45 pm    Post subject: Reply with quote

Puh, mit dieser Umfrage und Beschreibung wird vermutlich niemand weiterhelfen können.
Versuche doch bitte ein wenig genauer zu beschreiben was du vor hast, was genau schon gemacht wurde, und was das aktuelle Problem ist.
Quote:
wenn ich die normalen Kommandos nutze.
Schreib bitte dazu welches Kommando tatsächlich genutzt wurde, und poste dazu die original Ausgabe.
Ohne Original-Ausgaben (nur so von Erzählungen) wir es sehr schwer (bis unmöglich) weiterzuhelfen.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3087
Location: Berlin

PostPosted: Sat Nov 25, 2017 4:55 pm    Post subject: Reply with quote

Seit geraumer Zeit habe ich 5.9.2 und alles funktioniert.
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 214
Location: Kenzingen, Germany

PostPosted: Sun Nov 26, 2017 11:38 am    Post subject: Reply with quote

Es sieht so aus:

Code:
emerge --ask --ignore-built-slot-operator-deps=y qupzilla
Error during set creation: Could not import 'smartliverebuild.sets.SmartLiveRebuildSet' for section 'smart-live-rebuild'

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-qt/qtcore-5.9.3 [5.7.1-r3]
[ebuild     U  ] dev-qt/qtxml-5.9.3 [5.7.1]
[ebuild     U  ] dev-qt/qtconcurrent-5.9.3 [5.7.1]
[ebuild     U  ] dev-qt/qtsql-5.9.3 [5.7.1-r1]
[ebuild     U  ] dev-qt/qttest-5.9.3 [5.7.1]
[ebuild     U  ] dev-qt/qtdbus-5.9.3 [5.7.1]
[ebuild     U  ] dev-qt/qtnetwork-5.9.3 [5.7.1]
[ebuild     U  ] dev-qt/qtxmlpatterns-5.9.3 [5.7.1]
[ebuild     U  ] dev-qt/qtgui-5.9.3 [5.7.1-r1] USE="libinput* -vnc%"
[ebuild     U  ] dev-qt/qtwidgets-5.9.3 [5.7.1] USE="gtk%*"
[ebuild     U  ] dev-qt/qtx11extras-5.9.3 [5.7.1]
[ebuild     U  ] dev-qt/qtdeclarative-5.9.3 [5.7.1-r1]
[ebuild     U  ] dev-qt/linguist-tools-5.9.3 [5.7.1]
[ebuild     U  ] dev-qt/qtwebchannel-5.9.3 [5.7.1]
[ebuild     U  ] dev-qt/qtprintsupport-5.9.3 [5.7.1]
[ebuild     U  ] dev-qt/qtwebengine-5.9.3 [5.7.1-r2]
[ebuild     U  ] www-client/qupzilla-2.2.1 [2.1.2] LINGUAS="-es_419% -sl_SI%"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.9.3 required by (dev-qt/qtnetwork-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    >=dev-qt/qtcore-5.8:5 required by (www-client/qupzilla-2.2.1:0/0::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^                                                                                                                                                         
    (and 14 more with the same problems)

  (dev-qt/qtcore-5.7.1-r3:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/designer-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                   
    (and 34 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.9.3 required by (dev-qt/qtgui-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    >=dev-qt/qtdbus-5.8:5 required by (www-client/qupzilla-2.2.1:0/0::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^                                                                                                                                                         
    (and 1 more with the same problems)

  (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qtbluetooth-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                       
    (and 4 more with the same problem)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.9.3 required by (dev-qt/qtwebengine-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                       
    >=dev-qt/qtgui-5.8:5 required by (www-client/qupzilla-2.2.1:0/0::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^                                                                                                                                                         
    (and 5 more with the same problems)

  (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.7.1 required by (dev-qt/assistant-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                     
    (and 19 more with the same problem)

dev-qt/qtdeclarative:5

  (dev-qt/qtdeclarative-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdeclarative-5.9.3 required by (dev-qt/qtwebengine-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                       
    >=dev-qt/qtdeclarative-5.8:5[widgets] required by (www-client/qupzilla-2.2.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^                                                                                                                                                                   
    (and 2 more with the same problems)

  (dev-qt/qtdeclarative-5.7.1-r1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtdeclarative-5.7.1 required by (dev-qt/qtwayland-5.7.1:5/5.7::gentoo, installed)
    ^                     ^^^^^                                                                                                                     
    (and 10 more with the same problem)

dev-qt/qtsql:5

  (dev-qt/qtsql-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtsql-5.8:5[sqlite] required by (www-client/qupzilla-2.2.1:0/0::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^                                                                                                                                                                 

  (dev-qt/qtsql-5.7.1-r1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtsql-5.7.1[sqlite] required by (dev-qt/qthelp-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                         
    (and 2 more with the same problem)

dev-qt/qttest:5

  (dev-qt/qttest-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttest-5.9.3 required by (dev-qt/qtdeclarative-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         

  (dev-qt/qttest-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qttest-5.7.1 required by (dev-qt/qtdeclarative-5.7.1-r1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                           

dev-qt/qtxmlpatterns:5

  (dev-qt/qtxmlpatterns-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-5.9.3 required by (dev-qt/qtdeclarative-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                         

  (dev-qt/qtxmlpatterns-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtxmlpatterns-5.7.1 required by (dev-qt/qtdeclarative-5.7.1-r1:5/5.7::gentoo, installed)
    ^                     ^^^^^                                                                                                                           

dev-qt/qtxml:5

  (dev-qt/qtxml-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxml-5.9.3 required by (dev-qt/linguist-tools-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                           

  (dev-qt/qtxml-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtxml-5.7.1 required by (dev-qt/qdbus-5.7.1:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                 
    (and 3 more with the same problem)

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.9.3[gles2=] required by (dev-qt/qtprintsupport-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                                   
    >=dev-qt/qtwidgets-5.8:5 required by (www-client/qupzilla-2.2.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^                                                                                                                                                         
    (and 2 more with the same problems)

  (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.7.1 required by (dev-qt/assistant-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                     
    (and 12 more with the same problem)

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.9.3 required by (dev-qt/qtwebengine-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                       
    >=dev-qt/qtnetwork-5.8:5[ssl] required by (www-client/qupzilla-2.2.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^                                                                                                                                                               
    (and 2 more with the same problems)

  (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtnetwork-5.7.1 required by (dev-qt/pixeltool-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                     
    (and 8 more with the same problem)

dev-qt/qtprintsupport:5

  (dev-qt/qtprintsupport-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtprintsupport-5.8:5 required by (www-client/qupzilla-2.2.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                      ^^^^^                                                                                                                                                         
    ~dev-qt/qtprintsupport-5.9.3 required by (dev-qt/qtwebengine-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^                      ^^^^^                                                                                                                                       

  (dev-qt/qtprintsupport-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtprintsupport-5.7.1 required by (dev-qt/assistant-5.7.1:5/5.7::gentoo, installed)
    ^                      ^^^^^                                                                                                                     
    (and 2 more with the same problem)

dev-qt/qtconcurrent:5

  (dev-qt/qtconcurrent-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtconcurrent-5.8:5 required by (www-client/qupzilla-2.2.1:0/0::gentoo, ebuild scheduled for merge)
    ^^                    ^^^^^                                                                                                                                                         

  (dev-qt/qtconcurrent-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtconcurrent-5.7.1 required by (dev-qt/qtbluetooth-5.7.1:5/5.7::gentoo, installed)
    ^                    ^^^^^                                                                                                                       

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- app-misc/anki-2.0.43::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas Sturmlechner <asturm@gentoo.org> (16 Nov 2017)
# Depends on dead Qt4WebKit. Masked for removal in 30 days. Bug #620826

- app-admin/python-updater-0.14::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Mike Gilbert <floppym@gentoo.org> (13 Nov 2017)
# python-updater is obsolete. Utilize PYTHON_TARGETS and
# emerge --changed-use to rebuild packages instead.
# Removal in 30 days.

- dev-dotnet/referenceassemblies-pcl-4.6::gentoo (masked by: package.mask, dotnet-eula license(s))
/usr/portage/profiles/package.mask:
# Mikhail Pukhlikov <cynede@gentoo.org> (20 Jul 2017)
# Old mono/dotnet packages (used on GNOME2 stack)
# also some deprecated forks used for monodevelop
# awhile they are very unstable they will live in dotnet overlay

A copy of the 'dotnet-eula' license is located at '/usr/portage/licenses/dotnet-eula'.

- dev-qt/qtwebkit-4.8.7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas Sturmlechner <asturm@gentoo.org> (16 Nov 2017)
# Qt4WebKit is ancient and full of security holes.
# Masked for removal in 30 days. Bug #620684

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

_________________
Languages: English, German
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6624
Location: Austria

PostPosted: Sun Nov 26, 2017 11:55 am    Post subject: Reply with quote

Code:
It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

^ Portage schlägt eine Lösung vor. Die wird aber u.U. nicht funktionieren, weil man Qt nur *als ganzes* updaten kann. D.h. world upgrade statt single package.

Code:
!!! The following installed packages are masked:
- app-misc/anki-2.0.43::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas Sturmlechner <asturm@gentoo.org> (16 Nov 2017)
# Depends on dead Qt4WebKit. Masked for removal in 30 days. Bug #620826

- app-admin/python-updater-0.14::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Mike Gilbert <floppym@gentoo.org> (13 Nov 2017)
# python-updater is obsolete. Utilize PYTHON_TARGETS and
# emerge --changed-use to rebuild packages instead.
# Removal in 30 days.

- dev-dotnet/referenceassemblies-pcl-4.6::gentoo (masked by: package.mask, dotnet-eula license(s))
/usr/portage/profiles/package.mask:
# Mikhail Pukhlikov <cynede@gentoo.org> (20 Jul 2017)
# Old mono/dotnet packages (used on GNOME2 stack)
# also some deprecated forks used for monodevelop
# awhile they are very unstable they will live in dotnet overlay

A copy of the 'dotnet-eula' license is located at '/usr/portage/licenses/dotnet-eula'.

- dev-qt/qtwebkit-4.8.7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Andreas Sturmlechner <asturm@gentoo.org> (16 Nov 2017)
# Qt4WebKit is ancient and full of security holes.
# Masked for removal in 30 days. Bug #620684

Portage möchte dir sagen, dass dein System aufgeräumt werden sollte.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 214
Location: Kenzingen, Germany

PostPosted: Sun Nov 26, 2017 12:16 pm    Post subject: Reply with quote

Ich kann mich nicht erinnern beim Update von Qt 5.6 auf 5.7 ähnliche Probleme gehabt zu haben.
_________________
Languages: English, German
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6624
Location: Austria

PostPosted: Sun Nov 26, 2017 8:20 pm    Post subject: Reply with quote

Das ist kein Update:
Code:
emerge --ask --ignore-built-slot-operator-deps=y qupzilla

Das ist ein Update:
Code:
emerge -uvaD world

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 214
Location: Kenzingen, Germany

PostPosted: Mon Nov 27, 2017 2:32 pm    Post subject: Reply with quote

Ganz so einfach ist es offenbar nicht:

Code:
emerge -uvaD world
Error during set creation: Could not import 'smartliverebuild.sets.SmartLiveRebuildSet' for section 'smart-live-rebuild'

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.9.3 required by (dev-qt/qtbluetooth-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                       
    (and 3 more with the same problem)

  (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                     
    (and 1 more with the same problem)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.9.3[gles2=] required by (dev-qt/qtdeclarative-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                 
    >=dev-qt/qtgui-5.9.1:5 required by (dev-qt/qtwebkit-5.9.1:5/5.9::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                                                                       
    (and 17 more with the same problems)

  (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.7.1 required by (dev-qt/qtwebengine-5.7.1-r2:5/5.7::gentoo, installed)
    ^             ^^^^^                                                                                                                         
    (and 2 more with the same problem)

dev-qt/qtcore:5

  (dev-qt/qtcore-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.9.3 required by (dev-qt/qtxml-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    >=dev-qt/qtcore-5.9.1:5[icu] required by (dev-qt/qtwebkit-5.9.1:5/5.9::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^                                                                                                                                                             
    (and 26 more with the same problems)

  (dev-qt/qtcore-5.7.1-r3:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qttest-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                 
    >=dev-qt/qtcore-5.6.1:5/5.7= required by (app-office/calligra-3.0.1:5/5::gentoo, installed)
                         ^^^^^^^                                                                                                   
    (and 8 more with the same problems)

dev-qt/qtdeclarative:5

  (dev-qt/qtdeclarative-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdeclarative-5.9.3 required by (dev-qt/linguist-tools-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                           
    >=dev-qt/qtdeclarative-5.9.1:5 required by (dev-qt/qtwebkit-5.9.1:5/5.9::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^^^                                                                                                                                                       
    (and 8 more with the same problems)

  (dev-qt/qtdeclarative-5.7.1-r1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtdeclarative-5.7.1 required by (dev-qt/qtwebengine-5.7.1-r2:5/5.7::gentoo, installed)
    ^                     ^^^^^                                                                                                                         
    >=dev-qt/qtdeclarative-5.7.1:5/5.7= required by (kde-frameworks/plasma-5.40.0:5/5.40::gentoo, installed)
                                ^^^^^^^                                                                                                         
    (and 2 more with the same problems)

dev-qt/qtxmlpatterns:5

  (dev-qt/qtxmlpatterns-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-5.9.3 required by (dev-qt/qtdeclarative-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                         

  (dev-qt/qtxmlpatterns-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtxmlpatterns-5.7.1 required by (dev-qt/qtdeclarative-5.7.1-r1:5/5.7::gentoo, installed)
    ^                     ^^^^^                                                                                                                           

dev-qt/qttest:5

  (dev-qt/qttest-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttest-5.9.3 required by (dev-qt/qtdeclarative-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         

  (dev-qt/qttest-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qttest-5.7.1 required by (dev-qt/qtdeclarative-5.7.1-r1:5/5.7::gentoo, installed)
    ^              ^^^^^                                                                                                                           

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtnetwork-5.9.3 required by (dev-qt/qtdeclarative-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                         
    >=dev-qt/qtnetwork-5.9.1:5 required by (dev-qt/qtwebkit-5.9.1:5/5.9::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^                                                                                                                                                       
    (and 6 more with the same problems)

  (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtnetwork-5.7.1 required by (dev-qt/qtxmlpatterns-5.7.1:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                         
    (and 2 more with the same problem)

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.9.3 required by (dev-qt/qtsvg-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                 
    >=dev-qt/qtwidgets-5.9.1:5 required by (dev-qt/qtwebkit-5.9.1:5/5.9::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^                                                                                                                                                       
    (and 11 more with the same problems)

  (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.7.1 required by (dev-qt/qtwebengine-5.7.1-r2:5/5.7::gentoo, installed)
    ^                 ^^^^^                                                                                                                         
    (and 1 more with the same problem)

app-text/poppler:0

  (app-text/poppler-0.57.0-r1:0/68::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-text/poppler-0.51.0:0/66::gentoo, installed) pulled in by
    app-text/poppler:0/66=[qt5] required by (app-office/calligra-3.0.1:5/5::gentoo, installed)
                    ^^^^^^                                                                                                       
    (and 1 more with the same problem)

dev-libs/boost:0

  (dev-libs/boost-1.65.0:0/1.65.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.62.0-r1:0/1.62.0::gentoo, installed) pulled in by
    dev-libs/boost:0/1.62.0= required by (x11-misc/fracplanet-0.5.1:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                                   

dev-util/boost-build:0

  (dev-util/boost-build-1.65.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.65* required by (dev-libs/boost-1.65.0:0/1.65.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                       

  (dev-util/boost-build-1.62.0-r1:0/0::gentoo, installed) pulled in by
    =dev-util/boost-build-1.62* required by (dev-libs/boost-1.62.0-r1:0/1.62.0::gentoo, installed)
    ^                     ^^^^^                                                                                                                         

dev-qt/qtwebengine:5

  (dev-qt/qtwebengine-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtwebengine-5.7.1-r2:5/5.7::gentoo, installed) pulled in by
    >=dev-qt/qtwebengine-5.7.1:5/5.7=[widgets] required by (kde-apps/konqueror-17.08.3:5/5::gentoo, installed)
                              ^^^^^^^                                                                                                             

app-arch/snappy:0

  (app-arch/snappy-1.1.7:0/1::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (app-arch/snappy-1.1.3-r1:0/0::gentoo, installed) pulled in by
    app-arch/snappy:0/0= required by (dev-qt/qtwebengine-5.7.1-r2:5/5.7::gentoo, installed)
                   ^^^^^                                                                                                       

dev-qt/qtwebchannel:5

  (dev-qt/qtwebchannel-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwebchannel-5.9.3[qml] required by (dev-qt/qtwebengine-5.9.3:5/5.9::gentoo, ebuild scheduled for merge)
    ^                    ^^^^^                                                                                                                                             

  (dev-qt/qtwebchannel-5.7.1:5/5.7::gentoo, installed) pulled in by
    ~dev-qt/qtwebchannel-5.7.1[qml] required by (dev-qt/qtwebengine-5.7.1-r2:5/5.7::gentoo, installed)
    ^                    ^^^^^                                                                                                                               

dev-libs/protobuf:0

  (dev-libs/protobuf-3.4.1:0/14::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-libs/protobuf-3.4.1 required by (dev-java/protobuf-java-3.4.1:0/14::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^                                                                                                                                           

  (dev-libs/protobuf-3.1.0:0/11::gentoo, installed) pulled in by
    dev-libs/protobuf:0/11=[abi_x86_32(-),abi_x86_64(-)] required by (media-libs/opencv-3.3.0-r4:0/3.3::gentoo, installed)
                     ^^^^^^                                                                                                                                   
    (and 1 more with the same problem)

media-gfx/imagemagick:0

  (media-gfx/imagemagick-7.0.7.8:0/7.0.7.8::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-gfx/imagemagick-7.0.7.6:0/7.0.7.6::gentoo, installed) pulled in by
    >=media-gfx/imagemagick-6.6.2:0/7.0.7.6= required by (app-editors/emacs-25.3:25/25::gentoo, installed)
                                 ^^^^^^^^^^^                                                                                                 
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


emerge: there are no ebuilds to satisfy "sys-libs/zlib:0/0=".
(dependency required by "app-text/podofo-0.9.4::gentoo" [installed])
(dependency required by "app-text/calibre-3.8.0::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

_________________
Languages: English, German
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6624
Location: Austria

PostPosted: Mon Nov 27, 2017 4:44 pm    Post subject: Reply with quote

Code:
... You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3087
Location: Berlin

PostPosted: Mon Nov 27, 2017 5:54 pm    Post subject: Reply with quote

Ich habe zum einen die dev/qt 5.7* deinstalliert und dann das Update mit der Option --backtrack=30 durchgeführt (möglicherweise hatte ich auch eine etwas höhere zahl als 30 ausprobiert?)
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 214
Location: Kenzingen, Germany

PostPosted: Mon Nov 27, 2017 6:27 pm    Post subject: @flammenflitzer Reply with quote

Also mehr oder weniger das Verfahren, welches auch für das Update von Tex 2015 auf Tex 2016 oder 2017 nötig war (?)
Dort bin ich auch nur mit einem vorherigen Unmerge zum Ziel gekommen.
_________________
Languages: English, German


Last edited by YPenguin on Tue Nov 28, 2017 10:02 am; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6624
Location: Austria

PostPosted: Mon Nov 27, 2017 6:35 pm    Post subject: Reply with quote

Nein:
asturm wrote:
Code:
... You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 214
Location: Kenzingen, Germany

PostPosted: Thu Dec 07, 2017 4:53 pm    Post subject: Reply with quote

Das Problem ist mit Backtracking offenbar nicht zu lösen:

Code:
emerge --ask --backtrack=1000 pixeltool
Error during set creation: Could not import 'smartliverebuild.sets.SmartLiveRebuildSet' for section 'smart-live-rebuild'

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-qt/pixeltool-5.7.1

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.9.3:5/5.9::gentoo, ebuild scheduled for merge) conflicts with
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qthelp-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtscxml-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qdbus-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qdbusviewer-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qdoc-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtvirtualkeyboard-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtxml-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtprintsupport-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtgraphicaleffects-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtmultimedia-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtserialport-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtpositioning-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtimageformats-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtwebengine-5.7.1-r2:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtconcurrent-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtwebchannel-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtscript-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtquickcontrols2-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qttest-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtbluetooth-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtsvg-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtx11extras-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtwayland-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtquickcontrols-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/designer-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtdeclarative-5.7.1-r1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/assistant-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtopengl-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/linguist-tools-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtsql-5.7.1-r1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtpaths-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtdiag-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^
    >=dev-qt/qtcore-5.6.1:5/5.7= required by (app-office/calligra-3.0.1:5/5::gentoo, installed)
                         ^^^^^^^
    ~dev-qt/qtcore-5.7.1[icu] required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^     
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtxmlpatterns-5.7.1:5/5.7::gentoo, installed)
    ^              ^^^^^


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

dev-qt/pixeltool:5

!!! The following installed packages are masked:
- dev-dotnet/referenceassemblies-pcl-4.6::gentoo (masked by: package.mask, dotnet-eula license(s))
/usr/portage/profiles/package.mask:
# Mikhail Pukhlikov <cynede@gentoo.org> (20 Jul 2017)
# Old mono/dotnet packages (used on GNOME2 stack)
# also some deprecated forks used for monodevelop
# awhile they are very unstable they will live in dotnet overlay

A copy of the 'dotnet-eula' license is located at '/usr/portage/licenses/dotnet-eula'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Would you like to merge these packages? [Yes/No] no

Quitting.

i7 ~ #

_________________
Languages: English, German
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3516
Location: Germany

PostPosted: Thu Dec 07, 2017 6:47 pm    Post subject: Reply with quote

YPenguin wrote:
Das Problem ist mit Backtracking offenbar nicht zu lösen:
Code:
emerge --ask --backtrack=1000 pixeltool
Das ist doch wieder nur ein single package.
Versuche es bitte mal wie schon vorgeschlagen via einem normalen @world Update.
Beispiel:
Code:
emerge -avuDN @world --backtrack=200


/edit:
YPenguin wrote:
Code:
!!! The following installed packages are masked:
- dev-dotnet/referenceassemblies-pcl-4.6::gentoo (masked by: package.mask, dotnet-eula license(s))
/usr/portage/profiles/package.mask:
# Mikhail Pukhlikov <cynede@gentoo.org> (20 Jul 2017)
# Old mono/dotnet packages (used on GNOME2 stack)
# also some deprecated forks used for monodevelop
# awhile they are very unstable they will live in dotnet overlay

A copy of the 'dotnet-eula' license is located at '/usr/portage/licenses/dotnet-eula'.
Und kümmere dich vorher besser noch um diesen Hinweis, sprich entweder demaskieren und die license annehmen/bestätigen, oder deinstallieren.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3087
Location: Berlin

PostPosted: Sat Dec 16, 2017 7:38 am    Post subject: Reply with quote

Bin gestern auch auf Qt 5.9 umgestiegen. Vorher musste ich auch alle vorhandenen Qt ebuilds (einzeln - mittels porthole halbwegs komfortabel) entfernen. (Gibt vielleicht auch dafür ein Script?)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6624
Location: Austria

PostPosted: Sat Dec 16, 2017 8:19 am    Post subject: Reply with quote

Nein, dafür braucht es kein Script und kein deinstallieren, sondern einfach nur eine vollständige dev-qt/*:5/5.9 package.keywords und world update.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3087
Location: Berlin

PostPosted: Sat Dec 16, 2017 1:33 pm    Post subject: Reply with quote

Ich hatte die benötigten Pakete einzeln in der /etc/portage/package.keywords eingetragen. Danach ein emerge -uDNtv system --backtrack=300 dann wurden die blockierenden Einzelheiten gelistet und Ende.
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 214
Location: Kenzingen, Germany

PostPosted: Wed Dec 27, 2017 10:28 am    Post subject: Reply with quote

Ich habe heute einen Befehl gefunden, mit dem ich installieren kann, ohne vorher ein Unmerge zu machen:

emerge --ask -v1 $(qlist -IC dev-qt-*)

Fragt mich nicht, warum es anders nicht ging.
_________________
Languages: English, German
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6624
Location: Austria

PostPosted: Wed Dec 27, 2017 10:35 am    Post subject: Reply with quote

YPenguin wrote:
Fragt mich nicht, warum es anders nicht ging.

Weil du hier ständig versucht hast, Einzelpakete zu installieren.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 214
Location: Kenzingen, Germany

PostPosted: Wed Dec 27, 2017 12:54 pm    Post subject: @astrum Reply with quote

Die Ergebnisse mit world-update und system-update waren ja die gleichen.
(Siehe auch mein Posting von 27. November.)
_________________
Languages: English, German
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6624
Location: Austria

PostPosted: Wed Dec 27, 2017 12:57 pm    Post subject: Reply with quote

Nein, nicht wenn du --backtrack mit world verwendet hättest.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 214
Location: Kenzingen, Germany

PostPosted: Wed Dec 27, 2017 1:42 pm    Post subject: Reply with quote

Ich habe nicht alle Versuche hier gepostet.

Ich benutze eine neue Portage-Version, die vielleicht im Verhalten noch etwas unausgereift ist:
Portage 2.3.19 (python 3.6.3-final-0, default/linux/amd64/17.0/desktop/plasma, gcc-6.4.0, glibc-2.26-r3, 4.1.43-gentoo-r1 x86_64)
_________________
Languages: English, German
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6624
Location: Austria

PostPosted: Wed Dec 27, 2017 6:48 pm    Post subject: Reply with quote

YPenguin wrote:
Ich habe nicht alle Versuche hier gepostet.

...und wie soll man dir helfen wenn aus deinen Posts hervorgeht, dass du nicht auf Ratschläge eingehst...

YPenguin wrote:
Ich benutze eine neue Portage-Version, die vielleicht im Verhalten noch etwas unausgereift ist: Portage 2.3.19

Nein, das ist irrelevant. Ganz abgesehen davon dass alle deine Fehlschläge älter als diese Version sind.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 214
Location: Kenzingen, Germany

PostPosted: Thu Dec 28, 2017 1:46 pm    Post subject: Reply with quote

Ich hatte einige Qt-Utilities in das World-File aufgenommen - den Designer beispielsweise. Tatsächlich war Portage auch nur zu dem Update-Prozess bereit, wenn diese mit in der Liste waren.
Man kann also fragen: Warum zieht Portage die nicht selbst rein?
_________________
Languages: English, German
Back to top
View user's profile Send private message
YPenguin
Apprentice
Apprentice


Joined: 26 Apr 2014
Posts: 214
Location: Kenzingen, Germany

PostPosted: Sat Feb 10, 2018 4:21 pm    Post subject: Portage-set Reply with quote

Ich habe mir jetzt ein Portage-Set gemacht um das Problem dauerhaft zu lösen:

Code:
# dev-qt set
dev-qt/designer
dev-qt/linguist-tools
dev-qt/qdbus
dev-qt/qdoc
dev-qt/qtbluetooth
dev-qt/qtconcurrent
dev-qt/qtdbus
dev-qt/qtdeclarative
dev-qt/qtdiag
dev-qt/qtgraphicaleffects
dev-qt/qtgui
dev-qt/qthelp
dev-qt/qtimageformats
dev-qt/qtmultimedia
dev-qt/qtnetwork
dev-qt/qtopengl
dev-qt/qtpaths
dev-qt/qtplugininfo
dev-qt/qtpositioning
dev-qt/qtprintsupport
dev-qt/qtquickcontrols
dev-qt/qtquickcontrols2
dev-qt/qtscript
dev-qt/qtscxml
dev-qt/qtserialport
dev-qt/qtspeech
dev-qt/qtsql
dev-qt/qtsvg
dev-qt/qttest
dev-qt/qtvirtualkeyboard
dev-qt/qtwayland
dev-qt/qtwebchannel
dev-qt/qtwebengine
dev-qt/qtwidgets
dev-qt/qtx11extras
dev-qt/qtxml
dev-qt/qtxmlpatterns

_________________
Languages: English, German
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum