Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot use ath9k in kernel 4.12.12
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
LiamNPRG
n00b
n00b


Joined: 22 Nov 2017
Posts: 4

PostPosted: Wed Nov 22, 2017 3:47 pm    Post subject: Cannot use ath9k in kernel 4.12.12 Reply with quote

I have been having trouble using wireless in kernel 4.12.12 using the ath9k module. This wireless interface has worked before in gentoo linux, and in linux from scratch, but kernel 4.12.12 has some missing options that are required for the module to load. According to https://wireless.wiki.kernel.org/en/users/drivers/ath9k , we need the following options:
Code:

Networking  --->
  Wireless  --->
    <M> Improved wireless configuration API
    <M> Generic IEEE 802.11 Networking Stack (mac80211)
Device Drivers  --->
  [*] Network device support  --->
        Wireless LAN  --->
          Atheros Wireless Cards ---->
            <M>   Atheros 802.11n wireless cards support

I cannot for the life of me find Improved wireless configuration API in the menuconfig. I also tried googling this specific option, but found nothing that helped. I also tried to compile ath9k as a module, then load it to see if there were any errors, and found it complaining about a TON of missing symbols to dmesg. I have everything but "improved wireless configuration api" selected in my kernel settings, as well as I have "cfg80211 - wireless configuration API" being built into the kernel.

I hope you people know the answer, thank you all :D
Back to top
View user's profile Send private message
bec
Apprentice
Apprentice


Joined: 30 Sep 2004
Posts: 202
Location: Cali - Colombia

PostPosted: Wed Nov 22, 2017 4:41 pm    Post subject: Reply with quote

Have you installed atheros firmware from a package like sys-kernel/linux-firmware ?
_________________
abe
Back to top
View user's profile Send private message
LiamNPRG
n00b
n00b


Joined: 22 Nov 2017
Posts: 4

PostPosted: Wed Nov 22, 2017 4:55 pm    Post subject: Reply with quote

I have sys-kernel/linux-firmware-20170314 installed

Edit: How do you put large files into a forum post like a dmesg log
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 11424

PostPosted: Thu Nov 23, 2017 3:39 am    Post subject: Reply with quote

You don't. You install app-text/wgetpaste, use it to upload the file to a pastebin, and post the link here.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 5958
Location: Saint Amant, Acadiana

PostPosted: Thu Nov 23, 2017 4:20 am    Post subject: Reply with quote

Missing symbols means usually the modules are not built for running kernel. Which, in turn, is often happening because novice users do not pay attention to mount options in fstab. Just guessing.
_________________
Please learn how to denote units correctly!

Political Correctness is all about replacing imaginary injustice with real injustice.
Back to top
View user's profile Send private message
LiamNPRG
n00b
n00b


Joined: 22 Nov 2017
Posts: 4

PostPosted: Fri Nov 24, 2017 3:53 am    Post subject: Reply with quote

I found the solution, Thank you jag for helping me figure it out with the incorrect kernel version tip.

The problem
========

/boot was mounted as ext2 in fstab, and it should have been ext4, so it wasn't getting mounted properly at boot time from inside linux. Whenever I compiled my kernel, and ran "make install" it would just shove all of those new files into a directory that happened to be called /boot, but was not the actual /boot. The actual /boot contained the first version of the kernel I compiled, and that is why most modules worked, but then when I added new options, it failed because my new kernel config's were not getting compiled in.

The solution
========

Fix fstab,remove the fake /boot, run `make` in /usr/src/linux, then `make modules_install` then `make install`. After `init 6`-ing the problem was solved, and the module loads, as well as my wireless interface shows up. YAY!

Thank you all for helping :D
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 5958
Location: Saint Amant, Acadiana

PostPosted: Fri Nov 24, 2017 4:18 am    Post subject: Reply with quote

Correction. :) This is not ext2 problem (although you need support for ext2 in your kernel to mount it), it is the noauto option in the fstab causing /boot not mounted automatically.
_________________
Please learn how to denote units correctly!

Political Correctness is all about replacing imaginary injustice with real injustice.
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2337

PostPosted: Fri Nov 24, 2017 6:11 am    Post subject: Reply with quote

This has absolutely nothing to do with the problem at hand, but I just have to.

/boot is best served as an ext2 file system. ext4 adds a ton of extra features, most notably journaling, which are useless on /boot and take up a ton of space. Flash drives as well ;)
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
LiamNPRG
n00b
n00b


Joined: 22 Nov 2017
Posts: 4

PostPosted: Fri Nov 24, 2017 9:29 pm    Post subject: Reply with quote

I know The Doctor, you can blame Debian for that one. I am dual booting with it, and ext4 is just what it chose to use :(

Thank you Jag for the correction, I am pretty terrible with mount options and filesystem stuff beyond the surface.

EDIT: I could change the ext4 into ext2, but I am just too lazy to do that.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 5958
Location: Saint Amant, Acadiana

PostPosted: Fri Nov 24, 2017 9:37 pm    Post subject: Reply with quote

But then again, one can turn off journaling in ext4. I did it for my RPi running off a SD card.
_________________
Please learn how to denote units correctly!

Political Correctness is all about replacing imaginary injustice with real injustice.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum