Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trying to emerge acestream-player-3.0.2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Elleni
Guru
Guru


Joined: 23 May 2006
Posts: 573

PostPosted: Sat Mar 31, 2018 8:46 pm    Post subject: Trying to emerge acestream-player-3.0.2 Reply with quote

When trying to emerge media-video/acestream-player-3.0.2 I get different blockers, and I don't know how I could solve them. The first one is about libdvbpsi. While acestream-player-data-3.0.2 expects libdvbpsi-1.0.0. vlc-2.2.8-r1 needs 1.3.1 aparently.
emerge --info
Code:

Portage 2.3.24 (python 3.5.4-final-0, default/linux/amd64/17.0/desktop/plasma, gcc-7.3.0, glibc-2.25-r10, 4.15.13-gentoo x86_64)
=================================================================
System uname: Linux-4.15.13-gentoo-x86_64-AMD_Ryzen_5_1600_Six-Core_Processor-with-gentoo-2.4.1
KiB Swap:   33554428 total,  33554428 free
Timestamp of repository gentoo: Sun, 25 Mar 2018 17:30:01 +0000
Head commit of repository gentoo: 3fd4c45706e923edd1b310d8c9a91c0084ac090f
sh bash 4.4_p12
ld GNU ld (Gentoo 2.30 p1) 2.30.0
app-shells/bash:          4.4_p12::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.4-r1::gentoo, 3.6.3-r1::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.29::dantrell-gnome
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.15.1-r2::gentoo
sys-devel/binutils:       2.30::gentoo
sys-devel/gcc:            7.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r10::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: no
    sync-rsync-extra-opts:

seden
    location: /var/lib/layman/seden
    masters: gentoo
    priority: 50

dantrell-gnome-3-26
    location: /var/lib/layman/dantrell-gnome-3-26
    masters: gentoo
    priority: 100

test
    location: /usr/local/portage
    masters: gentoo
    priority: 100

dantrell-gnome
    location: /var/lib/layman/dantrell-gnome
    masters: gentoo
    priority: 150

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=znver1"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/chromium/policies/managed/chrome-gnome-shell.json /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/opt/chrome/policies/managed/chrome-gnome-shell.json /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=znver1"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs candy config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_CH.UTF-8"
LC_ALL="de_CH.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de de_DE el en fr fr_FR it tr"
MAKEOPTS="-j13"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities aes alsa amd64 avx avx2 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord crypt cups cxx d3d9 dbus declarative dri dri3 dts dvd dvdr eds elogind emboss encode evo exif fam ffmpeg flac fma3 fortran frei0r gdbm gif glamor gles1 gnome gnome-keyring gnome-online-accounts gnutls gpm gtk gtk3 gtkstyle iconv icu introspection ipv6 jpeg kde kipi kwallet lcms ldap libnotify libsecret llvm lm_sensors mad mmx mmxext mng modules mp3 mp4 mpeg mtp multilib nautilus ncurses nls nptl ocr ogg openal opencl opengl openmax openmp osmesa pam pango pclmul pcre pdf pdfpopcnt phonon plasma png policykit ppds pulseaudio qml qt3support qt5 readline realtime s3tc scanner sdl seccomp semantic-desktop spell spice sse sse2 sse3 sse4_1 sse4_2 sse4a ssh ssl ssse3 staging startup-notification svg tcpd theora tiff tracker truetype udev udisks unicode upower usb uxa vaapi vdpau vhost-net vorbis vpx webrtc-aec widgets wxwidgets x264 xa xattr xcb xcomposite xml xv xvid xvmc zlib" ABI_X86="64 32" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext smp sse sse2 sse3 sse4_1 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" L10N="de el en fr it tr" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby22 ruby23" SANE_BACKENDS="pixma" USERLAND="GNU" VIDEO_CARDS="amdgpu radeonsi virgl" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Code:
emerge acestream-player -av

These are the packages that would be merged, in order:

Calculating dependencies                      ... done!
[ebuild     UD~] media-libs/libdvbpsi-1.0.0:0/0::test [1.3.1:0/10::gentoo] USE="-doc -static-libs" 0 KiB
[ebuild  N     ] media-plugins/live-2017.10.28:0/7::gentoo  USE="-examples -static-libs" ABI_X86="32 (64) (-x32)" 616 KiB
[ebuild  N     ] media-libs/libcddb-1.3.2-r1::gentoo  USE="-doc -static-libs" ABI_X86="32 (64) (-x32)" 345 KiB
[ebuild  N     ] media-libs/vo-aacenc-0.1.3::gentoo  USE="-examples -static-libs" ABI_X86="32 (64) (-x32)" 599 KiB
[ebuild  NS    ] media-libs/libpng-1.2.57:1.2::gentoo [1.6.29:0/16::gentoo] ABI_X86="32 (64) (-x32)" 642 KiB
[ebuild  N     ] media-libs/acestream-x264-0.0.20110831::test  USE="interlaced threads -10bit -custom-cflags -debug -pic -static-libs" 0 KiB
[ebuild  NS    ] sys-libs/ncurses-5.9-r101:5::gentoo [6.1-r1:0/6::gentoo] USE="gpm unicode -tinfo" ABI_X86="32 (64) (-x32)" 2'761 KiB
[ebuild  N     ] dev-python/python-xlib-0.15_rc1-r2::gentoo  USE="-doc" PYTHON_TARGETS="python2_7 (-pypy)" 185 KiB
[ebuild  N     ] dev-python/apsw-3.19.3_p1::gentoo  USE="-doc" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 664 KiB
[ebuild  N     ] dev-libs/libgcrypt-compat-1.5.4:0/11::test  USE="-static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  NS    ] dev-libs/libgcrypt-1.5.4-r100:11::test [1.8.2-r2:0/20::dantrell-gnome] ABI_X86="32" 0 KiB
[ebuild  N     ] media-libs/aalib-1.4_rc5-r6::gentoo  USE="X gpm -slang -static-libs" ABI_X86="32 (64) (-x32)" 382 KiB
[ebuild  N     ] media-libs/schroedinger-1.0.11-r1::gentoo  USE="-static-libs" ABI_X86="32 (64) (-x32)" 996 KiB
[ebuild  N     ] media-libs/libshout-2.4.1-r1::gentoo  USE="theora -libressl -speex -static-libs" ABI_X86="32 (64) (-x32)" 505 KiB
[ebuild  N     ] media-sound/twolame-0.3.13-r2::gentoo  USE="-static-libs" ABI_X86="32 (64) (-x32)" 645 KiB
[ebuild  N     ] media-libs/liboggz-1.1.1::gentoo  USE="-doc -static-libs {-test}" 686 KiB
[ebuild  N     ] media-libs/ftgl-2.1.3_rc5::gentoo  USE="-static-libs" 692 KiB
[ebuild  N     ] dev-python/pyopengl-3.1.0::gentoo  USE="-tk" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 1'146 KiB
[ebuild  N     ] media-libs/libcaca-0.99_beta19::gentoo  USE="X cxx ncurses opengl truetype -doc -imlib (-java) (-mono) -python (-ruby) -slang -static-libs {-test}" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 1'176 KiB
[ebuild  N     ] dev-libs/libdbusmenu-12.10.2-r2::gentoo  USE="gtk gtk3 introspection -debug" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 719 KiB
[ebuild  N    ~] dev-libs/acestream-libindicator-12.10.1:2::test  0 KiB
[ebuild  N    ~] dev-libs/acestream-libappindicator-12.10.0:3::test  0 KiB
[ebuild  N    ~] dev-libs/acestream-python-appindicator-12.10.0-r1:3::test  0 KiB
[ebuild  N     ] net-p2p/acestream-engine-3.0.5::test  USE="gtk" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild  N     ] dev-python/wxpython-3.0.2.0:3.0::gentoo  USE="cairo libnotify opengl -examples" PYTHON_TARGETS="python2_7" 56'939 KiB
[ebuild  N     ] media-libs/libkate-0.4.1-r3::gentoo  USE="wxwidgets -debug -doc" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 886 KiB
[ebuild  N     ] media-video/libav-11.8:0/11::gentoo  USE="X aac alsa bzip2 encode frei0r gpl hardcoded-tables mp3 network pulseaudio sdl ssl theora truetype vaapi vdpau vorbis vpx x264 xvid zlib (-altivec) -amr (-armv5te) (-armv6) (-armv6t2) (-armvfp) -bs2b -cdio -cpudetection -custom-cflags -debug -doc -faac -fdk -fontconfig -gsm -ieee1394 -jack -jpeg2k -libressl (-neon) -openssl -opus -oss -pic -rtmp -schroedinger -speex -static-libs {-test} -threads -tools -twolame -v4l -wavpack -webp -x265" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3 -3dnow -3dnowext -avx -avx2 -fma3 -fma4 -sse4_2 -xop" 4'752 KiB
[ebuild  N    ~] media-video/acestream-player-data-3.0.2::test  USE="aac cdda dvd flac mad mpeg mtp ncurses ogg pulseaudio theora vaapi vorbis -avahi -cddb -dirac -ieee1394 -jack -libproxy -linguas_ach -linguas_af -linguas_am -linguas_ar -linguas_ast -linguas_be -linguas_bg -linguas_bn -linguas_br -linguas_ca -linguas_cgg -linguas_ckb -linguas_co -linguas_cs -linguas_da -linguas_de -linguas_el -linguas_en_GB -linguas_es -linguas_et -linguas_eu -linguas_fa -linguas_ff -linguas_fi -linguas_fr -linguas_fur -linguas_ga -linguas_gl -linguas_he -linguas_hi -linguas_hr -linguas_hu -linguas_hy -linguas_id -linguas_is -linguas_it -linguas_ja -linguas_ka -linguas_kk -linguas_km -linguas_ko -linguas_lg -linguas_lt -linguas_lv -linguas_mk -linguas_ml -linguas_mn -linguas_ms -linguas_my -linguas_nb -linguas_ne -linguas_nl -linguas_nn -linguas_oc -linguas_pa -linguas_pl -linguas_ps -linguas_pt_BR -linguas_pt_PT -linguas_ro -linguas_ru -linguas_si -linguas_sk -linguas_sl -linguas_sq -linguas_sr -linguas_sv -linguas_ta -linguas_tet -linguas_th -linguas_tl -linguas_tr -linguas_uk -linguas_vi -linguas_wa -linguas_zh_CN -linguas_zh_TW -linguas_zu -lirc -matroska -modplug -musepack -portaudio -samba -speex -upnp -v4l -vcdx" 0 KiB
[ebuild  N    ~] media-video/acestream-player-3.0.2::test  0 KiB
[blocks B      ] media-video/ffmpeg:0 ("media-video/ffmpeg:0" is blocking media-video/libav-11.8)

Total: 29 packages (1 downgrade, 25 new, 3 in new slots), Size of downloads: 75'325 KiB
Conflict: 1 block (1 unsatisfied)


Code:
media-libs/libdvbpsi:0

  (media-libs/libdvbpsi-1.0.0:0/0::test, ebuild scheduled for merge) pulled in by
    =media-libs/libdvbpsi-1.0.0 required by (media-video/acestream-player-data-3.0.2:0/0::test, ebuild scheduled for merge)
    ^                     ^^^^^

  (media-libs/libdvbpsi-1.3.1:0/10::gentoo, installed) pulled in by
    >=media-libs/libdvbpsi-1.0.0:0/10= required by (media-video/vlc-2.2.8-r1:0/5-8::gentoo, installed)


Could the following ebuild be modified so it works with newer libdvbpsi too? Or would that not work?
https://data.gpo.zugaina.org/ROKO__/media-video/acestream-player-data/acestream-player-data-3.0.2.ebuild

The other problem is that acrestream-player-data-3.0.2 aparently also depends on libav and thus conflicts with my system which is build with ffmpeg default.
Code:
[blocks B      ] media-video/ffmpeg:0 ("media-video/ffmpeg:0" is blocking media-video/libav-11.8)


Code:
(media-video/ffmpeg-3.3.6:0/55.57.57::gentoo, installed) pulled in by
    media-video/ffmpeg:0=[vdpau?] (media-video/ffmpeg:0=) required by (media-libs/mlt-6.4.1-r6:0/0::gentoo, installed)
    >=media-video/ffmpeg-3.0:0=[vdpau?] (>=media-video/ffmpeg-3.0:0=[vdpau]) required by (media-video/mplayer-1.3.0-r4:0/0::gentoo, installed)
    media-video/ffmpeg:0/55.57.57= required by (media-video/gpac-0.6.1-r2:0/0::gentoo, installed)
    media-video/ffmpeg:0/55.57.57= required by (media-plugins/alsa-plugins-1.1.1-r1:0/0::gentoo, installed)
    media-video/ffmpeg:0[postproc(-)] required by (media-video/cinelerra-2.3:0/0::gentoo, installed)
    media-video/ffmpeg:0= required by (app-misc/tracker-2.0.3:0/100::dantrell-gnome-3-26, installed)
    >=media-video/ffmpeg-3.2.6:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-video/ffmpeg-3.2.6:0=[abi_x86_32(-),abi_x86_64(-)]) required by (media-plugins/gst-plugins-libav-1.12.4:1.0/1.0::gentoo, installed)
    >=media-video/ffmpeg-3:0/55.57.57= required by (www-client/chromium-65.0.3325.146:0/0::gentoo, installed)
    media-video/ffmpeg:0= required by (kde-apps/ffmpegthumbs-17.08.3:5/5::gentoo, installed)
    >=media-video/ffmpeg-3:= required by (www-client/chromium-65.0.3325.146:0/0::gentoo, installed)
    >=media-video/ffmpeg-3.2.6:0/55.57.57=[abi_x86_32(-),abi_x86_64(-)] required by (media-plugins/gst-plugins-libav-1.12.4:1.0/1.0::gentoo, installed)
    media-video/ffmpeg[vorbis?,vpx?,x264?,mp3?,theora?] (media-video/ffmpeg[vorbis,vpx,x264,mp3,theora]) required by (media-video/simplescreenrecorder-0.3.9-r1:0/0::gentoo, installed)
    media-video/ffmpeg:0/55.57.57= required by (media-libs/opencv-2.4.13-r3:0/2.4::gentoo, installed)
    media-video/ffmpeg:0= required by (net-misc/freerdp-2.0.0_rc1-r1:0/2::gentoo, installed)
    media-video/ffmpeg:0= required by (media-video/gpac-0.6.1-r2:0/0::gentoo, installed)
    >=media-video/ffmpeg-2.7:0/55.57.57= required by (media-video/ffmpegthumbnailer-2.2.0:0/0::gentoo, installed)
    media-video/ffmpeg:0/55.57.57= required by (kde-frameworks/kfilemetadata-5.43.0:5/5.43::gentoo, installed)
    >=media-video/ffmpeg-2.7:0= required by (media-video/ffmpegthumbnailer-2.2.0:0/0::gentoo, installed)
    media-video/ffmpeg:0/55.57.57= required by (media-libs/mlt-6.4.1-r6:0/0::gentoo, installed)
    >=media-video/ffmpeg-2.8:0= required by (media-video/guvcview-2.0.5:0/0::gentoo, installed)
    media-video/ffmpeg:0= required by (kde-apps/k3b-17.08.3:5/5::gentoo, installed)
    media-video/ffmpeg:0= required by (dev-qt/qtwebengine-5.9.4:5/5.9::gentoo, installed)
    >=media-video/ffmpeg-1.2.6-r1:0[X?,encode?,gsm?,jpeg2k?,mp3?,opus?,sdl?,speex?,theora?,
threads?,truetype?,vaapi?,vdpau?,x264?] (>=media-video/ffmpeg-1.2.6-r1:0[X,encode,mp3,sdl,theora,threads,truetype,vaapi,vdpau,
x264]) required by (virtual/ffmpeg-9-r2:0/0::gentoo, installed)
    >=media-video/ffmpeg-3.0:0/55.57.57=[vdpau] required by (media-video/mplayer-1.3.0-r4:0/0::gentoo, installed)
    media-video/ffmpeg:0= required by (media-libs/opencv-2.4.13-r3:0/2.4::gentoo, installed)
    media-video/ffmpeg:0/55.57.57= required by (media-video/vlc-2.2.8-r1:0/5-8::gentoo, installed)
    media-video/ffmpeg:0/55.57.57= required by (app-misc/tracker-2.0.3:0/100::dantrell-gnome-3-26, installed)
    media-video/ffmpeg:0/55.57.57= required by (net-misc/freerdp-2.0.0_rc1-r1:0/2::gentoo, installed)
    media-video/ffmpeg[-samba] required by (www-client/chromium-65.0.3325.146:0/0::gentoo, installed)
    >=media-video/ffmpeg-2.8:0/55.57.57= required by (media-libs/gegl-0.3.28:0.3/0.3::dantrell-gnome, installed)
    media-video/ffmpeg:0/55.57.57=[vaapi] required by (media-video/vlc-2.2.8-r1:0/5-8::gentoo, installed)
    media-video/ffmpeg:0/55.57.57= required by (kde-apps/k3b-17.08.3:5/5::gentoo, installed)
    media-video/ffmpeg:0/55.57.57= required by (kde-apps/ffmpegthumbs-17.08.3:5/5::gentoo, installed)
    media-video/ffmpeg:0= required by (media-video/vlc-2.2.8-r1:0/5-8::gentoo, installed)
    media-video/ffmpeg:0= required by (media-plugins/alsa-plugins-1.1.1-r1:0/0::gentoo, installed)
    >=media-video/ffmpeg-2.8:0= required by (media-libs/gegl-0.3.28:0.3/0.3::dantrell-gnome, installed)
    media-video/ffmpeg:0= required by (media-libs/gegl-0.2.0-r4:0/0::dantrell-gnome, installed)
    media-video/ffmpeg:0/55.57.57= required by (dev-qt/qtwebengine-5.9.4:5/5.9::gentoo, installed)
    media-video/ffmpeg:0= required by (kde-frameworks/kfilemetadata-5.43.0:5/5.43::gentoo, installed)
    media-video/ffmpeg:0=[vaapi] required by (media-video/vlc-2.2.8-r1:0/5-8::gentoo, installed)
    media-video/ffmpeg:0/55.57.57= required by (media-libs/gegl-0.2.0-r4:0/0::dantrell-gnome, installed)
    >=media-video/ffmpeg-2.8:0/55.57.57= required by (media-video/guvcview-2.0.5:0/0::gentoo, installed)

  (media-video/libav-11.8:0/11::gentoo, ebuild scheduled for merge) pulled in by
    >=media-video/libav-9.17 required by (media-video/acestream-player-data-3.0.2:0/0::test, ebuild scheduled for merge)


Is there an easy solution for this, or would I need to switch to libav and unmerge vlc in order to be able to compile acestream-player?

[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19441
Location: here

PostPosted: Sun Apr 01, 2018 7:50 am    Post subject: Re: Trying to emerge acestream-player-3.0.2 Reply with quote

Elleni wrote:
Is there an easy solution for this, or would I need to switch to libav and unmerge vlc in order to be able to compile acestream-player?

From ebuild seem that libav is not strictly required
acestream-player-data-3.0.2.ebuild:
                || ( media-video/acestream-ffmpeg[jack=,aac=,modplug=,ieee1394=,speex=,theora=,v4l=,vaapi=,vorbis=,alsa] >=media-video/libav-9.17 )

you can also try to install media-video/acestream-ffmpeg instead of media-video/libav
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Elleni
Guru
Guru


Joined: 23 May 2006
Posts: 573

PostPosted: Sun Apr 01, 2018 9:05 am    Post subject: Reply with quote

Tried to emerge acestream-ffmpeg-0.10.7-r6 from stuff overlay. It fails with
Code:
>>> Configuring source in /var/tmp/portage/media-video/acestream-ffmpeg-0.10.7-r6/work/ffmpeg-0.10.7 ...
ERROR: freetype2 not found


acestream-ffmpeg-1.2.12 is relying on libvpx-1.4.0 which then conflicts with current ffmpeg.

I don't know how to go on here.

Besides that I think the ebuild would need some rework anyway because of the libdvbpsi conflict with current ffmpeg.

Maybe someone could have a look at it? I don't know howto modify ebuilds.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19441
Location: here

PostPosted: Sun Apr 01, 2018 2:52 pm    Post subject: Reply with quote

Elleni wrote:
Tried to emerge acestream-ffmpeg-0.10.7-r6 from stuff overlay. It fails with
Code:
>>> Configuring source in /var/tmp/portage/media-video/acestream-ffmpeg-0.10.7-r6/work/ffmpeg-0.10.7 ...
ERROR: freetype2 not found


acestream-ffmpeg-1.2.12 is relying on libvpx-1.4.0 which then conflicts with current ffmpeg.

In my system with ffmpeg installed compile without problem
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Elleni
Guru
Guru


Joined: 23 May 2006
Posts: 573

PostPosted: Sun Apr 08, 2018 4:27 pm    Post subject: Reply with quote

Hm, ok. Here I have this freetype2 not found error.

What Useflags did you use ? Mine are:

emerge acestream-ffmpeg -1pv
Code:

These are the packages that would be merged, in order:

Calculating dependencies                                 ... done!
[ebuild  N    ~] media-video/acestream-ffmpeg-0.10.7-r6::test  USE="X aac alsa bzip2 encode frei0r gnutls hardcoded-tables mp3 openal pulseaudio sdl theora truetype vaapi vdpau vorbis vpx xvid zlib -aacplus (-altivec) -amr -bindist -cdio -celt -cpudetection -debug -dirac -doc -faac -gsm -ieee1394 -jack -jpeg2k -libass -libv4l -modplug (-neon) -network -openssl -oss -pic -rtmp -schroedinger -speex -static-libs {-test} -threads -v4l (-vis)" CPU_FLAGS_X86="mmx mmxext sse3 -3dnow -3dnowext -avx" 0 KiB
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19441
Location: here

PostPosted: Sun Apr 08, 2018 4:44 pm    Post subject: Reply with quote

Elleni wrote:
Hm, ok. Here I have this freetype2 not found error.

What Useflags did you use ? Mine are:

emerge acestream-ffmpeg -1pv

I don't use acestream I've only tried to compile acestream-ffmpeg. Anyway compile fine with these use flags
Code:
[ebuild  N     ] media-video/acestream-ffmpeg-1.2.12::ROKO__  USE="X aac alsa bzip2 encode hardcoded-tables iconv ieee1394 mp3 network pulseaudio sdl threads truetype v4l vaapi vorbis x264 xvid zlib -aacplus (-altivec) -amr -bluray -cdio -celt -cpudetection -debug -doc -examples -faac -fdk -flite -fontconfig -frei0r -gnutls -gsm -iec61883 -jack -jpeg2k -libass -libcaca -libsoxr -libv4l -modplug (-neon) -openal -openssl -opus -oss -pic -rtmp -schroedinger -speex -static-libs {-test} -theora -twolame -vdpau (-vis) -vpx" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="avx mmx mmxext ssse3 -3dnow -3dnowext" FFTOOLS="aviocat cws2fws ffescape ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher" 0 KiB

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Elleni
Guru
Guru


Joined: 23 May 2006
Posts: 573

PostPosted: Sun Apr 08, 2018 5:47 pm    Post subject: Reply with quote

Well, the version you tried I abandoned trying because of conflicts of libvpx:

Code:
emerge acestream-ffmpeg -av1

These are the packages that would be merged, in order:

Calculating dependencies                     ... done!
[ebuild     UD ] media-libs/libvpx-1.4.0:0/2::test [1.5.0:0/3::gentoo] USE="threads (-altivec) -doc -postproc -static-libs {-test} (-svc%*)" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="mmx sse sse2 sse3 sse4_1 ssse3 -avx -avx2" 0 KiB
[ebuild  N     ] media-video/acestream-ffmpeg-1.2.12::ROKO__  USE="X aac alsa bzip2 encode frei0r gnutls hardcoded-tables iconv mp3 network openal pulseaudio sdl theora truetype vaapi vdpau vorbis vpx x264 xvid zlib -aacplus (-altivec) -amr -bluray -cdio -celt -cpudetection -debug -doc -examples -faac -fdk -flite -fontconfig -gsm -iec61883 -ieee1394 -jack -jpeg2k -libass -libcaca -libsoxr -libv4l -modplug (-neon) -openssl -opus -oss -pic -rtmp -schroedinger -speex -static-libs {-test} -threads -twolame -v4l (-vis)" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="mmx mmxext ssse3 -3dnow -3dnowext -avx" FFTOOLS="aviocat cws2fws ffescape ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher" 0 KiB

Total: 2 packages (1 downgrade, 1 new), Size of downloads: 0 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libvpx:0

  (media-libs/libvpx-1.4.0:0/2::test, ebuild scheduled for merge) pulled in by
    =media-libs/libvpx-1.4.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-video/acestream-ffmpeg-1.2.12:0/0::ROKO__, ebuild scheduled for merge)
    ^                  ^^^^^

  (media-libs/libvpx-1.5.0:0/3::gentoo, installed) pulled in by
    >=media-libs/libvpx-1.4.0:0/3=[abi_x86_32(-),abi_x86_64(-)] required by (media-video/ffmpeg-3.3.6:0/55.57.57::gentoo, installed)
                             ^^^^^
    >=media-libs/libvpx-1.5:=[svc] required by (dev-qt/qtwebengine-5.9.4:5/5.9::gentoo, installed)
    ^^                  ^^^
    (and 3 more with the same problems)


So I tried the ebuild of stuff overlay, with above freetype2 not found error. Still hoping, there is someone interested in this who has the knowledge to modify ebuild so it compiles fine with actual tree versions of dependencies. :)

If not, its not of a high importance anyways :)

[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 736

PostPosted: Thu Apr 19, 2018 9:12 pm    Post subject: Reply with quote

Interesting. I've tried the ROKO__ overlay here, and I'm getting very different errors. Stuck at emerging acestream-player-data:
Code:

 * acestream-player-data_3.0.2-1trusty2_amd64.deb SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                         [ ok ]
>>> Unpacking source...
>>> Unpacking acestream-player-data_3.0.2-1trusty2_amd64.deb to /var/tmp/portage/media-video/acestream-player-data-3.0.2/work
>>> Source unpacked in /var/tmp/portage/media-video/acestream-player-data-3.0.2/work
/dev/fd/63: line 400: syntax error near unexpected token `fi'
/dev/fd/63: line 400: `fi #_EPATCH_ECLASS'
>>> Preparing source in /var/tmp/portage/media-video/acestream-player-data-3.0.2/work ...
>>> Unpacking acestream-player-data_3.0.2-1trusty2_amd64.deb to /var/tmp/portage/media-video/acestream-player-data-3.0.2/work
>>> Unpacking ./data.tar.xz to /var/tmp/portage/media-video/acestream-player-data-3.0.2/work
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/media-video/acestream-player-data-3.0.2/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/media-video/acestream-player-data-3.0.2/work ...
>>> Source compiled.
>>> Test phase [not enabled]: media-video/acestream-player-data-3.0.2

>>> Install acestream-player-data-3.0.2 into /var/tmp/portage/media-video/acestream-player-data-3.0.2/image/ category media-video
rm: cannot remove '/var/tmp/portage/media-video/acestream-player-data-3.0.2/image//usr/lib/acestreamplayer/plugins/audio_output/libportaudio_plugin.so': No such file or directory
>>> Completed installing acestream-player-data-3.0.2 into /var/tmp/portage/media-video/acestream-player-data-3.0.2/image/

 * Final size of build directory: 98216 KiB (95.9 MiB)
 * Final size of installed tree:  74036 KiB (72.3 MiB)

making executable: usr/lib/libtsplayercore.so.7.0.0
making executable: usr/lib/libtsplayer.so.5.4.0
making executable: usr/lib64/liblua5.2.so.0.0.0

 * QA Notice: Found an absolute symlink in a library directory:
 *            usr/lib64/liba52-0.7.4.so -> /usr/lib64/liba52.so.0.0.0
 *            It should be a relative symlink if in the same directory
 *            or a linker script if it crosses the /usr boundary.
Files matching a file type that is not allowed:
   usr/lib/libtsplayercore.so.7.0.0
   usr/lib/libtsplayer.so.5.4.0
 * ERROR: media-video/acestream-player-data-3.0.2::ROKO__ failed:
 *   multilib-strict check failed!
 *
 * Call stack:
 *   misc-functions.sh, line 666:  Called install_qa_check
 *   misc-functions.sh, line 217:  Called source 'install_symlink_html_docs'
 *   80multilib-strict, line  46:  Called multilib_strict_check
 *   80multilib-strict, line  42:  Called die
 * The specific snippet of code:
 *         [[ ${abort} == yes ]] && die "multilib-strict check failed!"
 *
 * If you need support, post the output of `emerge --info '=media-video/acestream-player-data-3.0.2::ROKO__'`,
 * the complete build log and the output of `emerge -pqv '=media-video/acestream-player-data-3.0.2::ROKO__'`.
 * The complete build log is located at '/var/tmp/portage/media-video/acestream-player-data-3.0.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/acestream-player-data-3.0.2/temp/environment'.
 * Working directory: '/var/tmp/portage/media-video/acestream-player-data-3.0.2/image'
 * S: '/var/tmp/portage/media-video/acestream-player-data-3.0.2/work'
!!! post install failed; exiting.

Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19441
Location: here

PostPosted: Fri Apr 20, 2018 6:04 am    Post subject: Reply with quote

The problem is line
Code:
use portaudio || rm "${D}/usr/lib/acestreamplayer/plugins/audio_output/libportaudio_plugin.so"

in ebuild. You should check on /var/tmp/portage/media-video/acestream-player-data/image/ if exist libportaudio_plugin.so in some other path if not you can comment the line in ebuild
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Blind_Sniper
n00b
n00b


Joined: 20 Apr 2018
Posts: 37

PostPosted: Fri Apr 20, 2018 10:36 am    Post subject: Reply with quote

I already went a way you're trying to pass. There is nothing at the end...
Started from stuffs overlay (which got abandoned for few years now) and continued with the ROKO__ (which contains a bit less, but still outdated software).

Finally I installed it "by hand". I noticed that package in ROKO overlay is just a debian binaries packed into deb. So I found latest acestream deb package here: http://wiki.acestream.org/wiki/index.php/Download and downloaded it: http://dl.acestream.org/linux/acestream_3.1.16_debian_8.7_x86_64.tar.gz
Then I created /opt/acestream/ directory and extracted tarball content there. So these binaries will not harm your @system or @world in any way.
Ran
Code:
/opt/acestream/start-engine --client-console
command and got an error due to missing m2crypto package. After emerging dev-python/m2crypto I got similar error message for apsw package, so I installed dev-python/apsw too.
After that engine started successfully.
Then I proceeded with browser's Magic Player plugin installation. Since this plugin is missing in google store, I installed it from plugin's home page: http://magicplayer.torrentstream.org/?lang=en. At this point I was able to watch TV from browser.

But there are a lot of channels (especially sport channells) which has no permanent web page location, it can be watched from local video player only.
Using local player for links like "acestream://XXXXXXXXXXXXXX" is a bit tricky. I can't open these links with mplayer at all, so I switched to VLC.
You can't open it directly from File (or Open) menu due to MRL error. You have to launch VLC from konsole (terminal emulator) in this way:
Code:
vlc http://127.0.0.1:6878/ace/getstream?id=XXXXXXXXXXXXXX

here XXXXXXXXXXXXXX is ContentID extracted from link.

It's not very convenient to launch terminal and type a long command there, so I wrote a small wrapper bash script which takes a link from clipboard, extracts ContentID, composes a vlc compatible xspf playlist and launches vlc with path to playlist as command line parameter.

That's all.
May be my experience will be helpful.
Good luck.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum