Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gcc-6.4.0
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1915
Location: Heidelberg - Germany

PostPosted: Mon Nov 20, 2017 7:41 am    Post subject: Gcc-6.4.0 Reply with quote

Gibt es für den GCC Upgrade von 5* auf 6.4.0 irgendetwas besonderes zu beachten? Da es sich um eine Major Update handelt, ist recompilierung des ganzen Systems notwendig, richtig?
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000 + ganz viele Modellflugzeuge, ein Tandem, Rennrad und DFXL ;)
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5755
Location: Austria

PostPosted: Mon Nov 20, 2017 8:53 am    Post subject: Reply with quote

Nein, überhaupt nicht nötig.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1915
Location: Heidelberg - Germany

PostPosted: Mon Nov 20, 2017 10:12 am    Post subject: Reply with quote

Umso besser, kann man also einfach gcc umstellen und weitermachen? Das wäre ja schön einfach ..
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000 + ganz viele Modellflugzeuge, ein Tandem, Rennrad und DFXL ;)
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5755
Location: Austria

PostPosted: Mon Nov 20, 2017 12:02 pm    Post subject: Reply with quote

Die üblichen Kleinigkeiten ausgenommen: https://wiki.gentoo.org/wiki/Upgrading_GCC
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1445
Location: Schweiz

PostPosted: Mon Nov 20, 2017 12:20 pm    Post subject: Reply with quote

So ganz Problemlos scheint es mir dann doch nicht zu sein.

Vor kurzem habe ich mal wieder versucht meinen Dolphin-Emulator zu starten und bekam promt sowas:
Code:
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1002,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1008,wx containers,compatible with 2.8).

Nach einer Google-Suche fand ich dann heraus das ich das installierte wxGTK neu bauen musste.
An dieser Stelle waren dann auch die folgenden beiden Links wichtig:
https://bugs.gentoo.org/619778
https://github.com/wxWidgets/wxWidgets/commit/73e9e18ea09ffffcaac50237def0d9728a213c02.patch

Ist wohl ein ABI-Bruch der beim Wechsel von GCC 5 zu 6 entstand. Und nein, weder Portage noch revdep-rebuild bemerkten das.
_________________
GPG: B5114B6154A19454
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3058
Location: Berlin

PostPosted: Tue Nov 21, 2017 8:09 pm    Post subject: Reply with quote

Nehme ich
Code:
revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc
oder besser
Code:
fix_libtool_files.sh
?
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5755
Location: Austria

PostPosted: Tue Nov 21, 2017 9:04 pm    Post subject: Reply with quote

Keins von beiden - aufmerksamer lesen. (Obwohl es der wiki-Eintrag nicht unbedingt anfängerfreundlich macht)

libtool rebuild ist wichtig, ansonsten: https://wiki.gentoo.org/wiki/Upgrading_GCC#Which_packages_are_known_to_need_a_rebuild.3F
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3058
Location: Berlin

PostPosted: Wed Nov 22, 2017 7:04 pm    Post subject: Reply with quote

Danke
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum