Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]: qt4 and qt5
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16880
Location: here

PostPosted: Tue Nov 28, 2017 1:49 pm    Post subject: Reply with quote

Code:
[blocks B ] <dev-util/gtk-builder-convert-2.24.31 ("<dev-util/gtk-builder-convert-2.24.31" is blocking x11-libs/gtk+-2.24.31-r1)


What version of dev-util/gtk-builder-convert you have in portage tree (ls -1 /usr/portage/dev-util/gtk-builder-convert)?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Tue Nov 28, 2017 2:19 pm    Post subject: Reply with quote

Hi,
The version is 2.24.31.

Thank you.

P.S.: I lost my net connection. If needed I will reboot to the console since KDE environment right now is pretty much unusable. ;-)
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16880
Location: here

PostPosted: Tue Nov 28, 2017 2:28 pm    Post subject: Reply with quote

You need to re-sync portage tree because x11-libs/gtk+-2.24.31-r1 need same version of gtk-builder-convert namely 2.24.31-r1.
In my tree
Code:
$ ls -1 /usr/portage/dev-util/gtk-builder-convert/
Manifest
gtk-builder-convert-2.24.31-r1.ebuild
metadata.xml

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Tue Nov 28, 2017 2:33 pm    Post subject: Reply with quote

Oops, sorry this is the version - 2.24.31-r1.

Apologies for the confusion.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16880
Location: here

PostPosted: Tue Nov 28, 2017 3:09 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
Oops, sorry this is the version - 2.24.31-r1.

Strange here no blocking problem
Code:
# emerge -p gtk-builder-convert

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-util/gtk-builder-convert-2.24.31-r1::gentoo  PYTHON_TARGETS="python2_7" 0 KiB
# qlist -Iv x11-libs/gtk+
x11-libs/gtk+-2.24.31-r1
x11-libs/gtk+-3.22.16

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5561
Location: Austria

PostPosted: Tue Nov 28, 2017 6:03 pm    Post subject: Reply with quote

Both need to be at 2.24.31-r1. Please apply previously gained knowledge:

asturm wrote:
If in doubt, just ask portage:

Code:
$ equery l -p gtk-builder-convert
$ equery l -p gtk+


Also, at this point I need to ask if you have any cruft inside package.use and package.mask, since for some reason the kdelibs upgrade is not advertised.
Code:
grep -R kde /etc/portage/package*

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Tue Nov 28, 2017 6:52 pm    Post subject: Reply with quote

Hi, guys,
@fedeliallalinea:
If you look at the blocker, the message says:

Quote:

<dev-util/gtk-builder-convert-2.24.31 (actually 2.24.29) is blocking x11-libs/gtk+-2.24.31-r1


I read it as:

Portage is trying to install GTK+2.24.31-r1, but version of gtk-builder-convert is incompatible and there is a dependency on the older version from @selected

@asturm,

Will do that and post the results later in the evening.

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Wed Nov 29, 2017 12:38 am    Post subject: Reply with quote

Hi,
asturm wrote:

Both need to be at 2.24.31-r1. Please apply previously gained knowledge:

asturm wrote:

If in doubt, just ask portage:

Code:

$ equery l -p gtk-builder-convert



Code:

 * Searching for gtk-builder-convert
[-P-] [ ] dev-util/gtk-builder-convert-2.24.31-r1 0


asturm wrote:

Code:

$ equery l -p gtk+



Code:

Searching for gtk+
[-P-]  [   ] x11-libs/gtk+-2.24.31-r1 2
[-P-]  [   ]  x11-libs/gtk+-3.22.15    3
[IP-]  [   ] x11-libs/gtk+-3..22.16    3
[-P-]  [ ~] x11-libs/gtk+-3.22.17    3
[-P-]  [ ~] x11-libs/gtk+-3.22.19    3


asturm wrote:

Also, at this point I need to ask if you have any cruft inside package.use and package.mask, since for some reason the kdelibs upgrade is not advertised.
Code:

grep -R kde /etc/portage/package*



This grep does not return any rows.
However in the /etc/portage/package.use there are 2 lines:

Code:

dev-python/PyQT4 help
dev-qt/qtdeclarative webkit


And package.keywords doesn't contain anything kde or qt related.

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Wed Nov 29, 2017 3:50 am    Post subject: Reply with quote

Hi,
The GTK/gtk-builder-convert conflict is resolved.
The emerge world command I'm using is not pulling up the upgrade of GTK+to 2.24.31-r1.

So I did "emerge =gtk+-2.24.31-r1 =gtk-builder-convert-2.24.31-r1" it starts building and it will take care of the blocker.

Now I believe the last blocker depends on tghe qt libraries. Any idea how to resolve this?

Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16880
Location: here

PostPosted: Wed Nov 29, 2017 7:04 am    Post subject: Reply with quote

You can re-post emerge output (I'm lazy)?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Wed Nov 29, 2017 2:09 pm    Post subject: Reply with quote

Here it is: https://bpaste.net/show/5c679b0b759c.

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5561
Location: Austria

PostPosted: Wed Nov 29, 2017 2:12 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
Now I believe the last blocker depends on tghe qt libraries. Any idea how to resolve this?

I don't see any. Only pay attention to the 'B' blockers.

There is only one blocker left. Just `emerge -1 libproxy`? And if there's a strange blocker, add signond and signon-ui to the same upgrade command?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Wed Nov 29, 2017 2:42 pm    Post subject: Reply with quote

Hi,
Here is what I got:

Code:

IgorDellGentoo /home/igor/dbhandler # emerge -1p libproxy

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.7.1-r3:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/linguist-tools-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                           
    (and 1 more with the same problem)

  (dev-qt/qtcore-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.9.2 required by (dev-qt/qtgui-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-qt/qtgui-5.9.2::gentoo[dbus]
# required by kde-frameworks/kconfig-5.37.0::gentoo
# required by net-libs/libproxy-0.4.13-r2::gentoo[kde]
# required by libproxy (argument)
=dev-qt/qtdbus-5.9.2 ~amd64
# required by kde-frameworks/kconfig-5.37.0::gentoo
# required by net-libs/libproxy-0.4.13-r2::gentoo[kde]
# required by libproxy (argument)
=dev-qt/qtgui-5.9.2 ~amd64
# required by dev-qt/qtdbus-5.9.2::gentoo
# required by dev-qt/qtgui-5.9.2::gentoo[dbus]
# required by kde-frameworks/kconfig-5.37.0::gentoo
# required by net-libs/libproxy-0.4.13-r2::gentoo[kde]
# required by libproxy (argument)
=dev-qt/qtcore-5.9.2 ~amd64

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! All ebuilds that could satisfy "~dev-qt/qtgui-5.7.1[gles2=]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-qt/qtgui-5.7.1-r1::gentoo (masked by: backtracking: missing dependency)

(dependency required by "dev-qt/qtdeclarative-5.7.1-r1::gentoo" [ebuild])
(dependency required by "dev-qt/linguist-tools-5.7.1::gentoo[qml]" [ebuild])
(dependency required by "kde-frameworks/kconfig-5.37.0::gentoo[nls]" [ebuild])
(dependency required by "net-libs/libproxy-0.4.13-r2::gentoo[kde]" [ebuild])
(dependency required by "libproxy" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

IgorDellGentoo /home/igor/dbhandler #


Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5561
Location: Austria

PostPosted: Wed Nov 29, 2017 2:44 pm    Post subject: Reply with quote

Hint:
Code:
(dependency required by "net-libs/libproxy-0.4.13-r2::gentoo[kde]" [ebuild])

What could you do to temporarily get rid of this blocker?

Also, what profile are you using?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Wed Nov 29, 2017 4:14 pm    Post subject: Reply with quote

Hi, asturm,
My current profile is:

Code:

default/linux/amd64/13.0/desktop/plasma


So I should temporarily add those keywords Portage complain about?
The only question is - why does he wants to go to Qt-unstable?

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5561
Location: Austria

PostPosted: Wed Nov 29, 2017 4:16 pm    Post subject: Reply with quote

Did you bother to read my comment? No?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Wed Nov 29, 2017 5:09 pm    Post subject: Reply with quote

Hi,
Yes, I did as I replied with my current profile.

But I'm actually looking at this piece of the output:

Quote:

The following keyword changes are necessary to proceed:
(see "package.accept_keywords" in the portage(5) man page for more details)
.

The weird thing is that "emerge world" and "emrge libproxy" are trying to pull 2 different versions.

But I think you are ferring to turning off the kde USE-flag temporarily. Run the "emerge world", then after turn it back on and continue with the upgrade.

This what I will do tonight.

Now what I should do about all those conflicts with boost/qt/giflib/libvpx/poppler? I think they will prevent me running the "emerge world".

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5561
Location: Austria

PostPosted: Wed Nov 29, 2017 5:12 pm    Post subject: Reply with quote

No they won't, because as I said:
Quote:
I don't see any. Only pay attention to the 'B' blockers.

Basically, everything should be good to go after overcoming the libproxy blocker.

ONEEYEMAN wrote:
But I think you are ferring to turning off the kde USE-flag

Bin...
ONEEYEMAN wrote:
Run the "emerge world", then after turn it back on

...nope, only for libproxy.
ONEEYEMAN wrote:
and continue with the upgrade.

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Thu Nov 30, 2017 12:33 am    Post subject: Reply with quote

Hi,
The last blocker is resolved.

However, this is what I received trying to rebuild the world:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtgui-4.8.6[-aqua,-debug,abi_x86_64(-)] required by (dev-qt/qthelp-4.8.6-r3:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                               
    (and 2 more with the same problem)

  (dev-qt/qtgui-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-4.8.7[aqua=,debug=,glib=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtcore-4.8.7-r3:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                                 
    >=dev-qt/qtgui-4.8.7:4 required by (media-libs/phonon-vlc-0.9.1-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                                                                               
    (and 7 more with the same problems)

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.7-r3:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                               
    >=dev-qt/qtcore-4.8.7-r2:4 required by (media-libs/phonon-vlc-0.9.1-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^^^^                                                                                                                                                               
    (and 13 more with the same problems)

  (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,glib,qt3support,abi_x86_64(-)] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                                                             
    (and 6 more with the same problem)

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                ^^^^^                                                                                                                                                                                                                                                                                                               
    (and 2 more with the same problem)

  (dev-qt/qtscript-4.8.6-r2:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.6[-aqua,-debug,abi_x86_64(-)] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
    ^                ^^^^^                                                                                                                                             

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.7[accessibility=,aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^                                                                                                                                                                                                                                                                                                                                   
    (and 2 more with the same problem)

  (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.6[-aqua,-debug,abi_x86_64(-)] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
    ^                  ^^^^^                                                                                                                                             

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.7-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.7[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                                 
    (and 1 more with the same problem)

  (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.6[-aqua,-debug,sqlite,abi_x86_64(-)] required by (dev-qt/qthelp-4.8.6-r3:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                                     
    (and 1 more with the same problem)

dev-qt/qttranslations:4

  (dev-qt/qttranslations-4.8.6-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qttranslations-4.8.6 required by (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed)
    ^                      ^^^^^                                                                                                                   

  (dev-qt/qttranslations-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttranslations-4.8.7 required by (dev-qt/qtcore-4.8.7-r3:4/4::gentoo, ebuild scheduled for merge)
    ^                      ^^^^^                                                                                                                                   

media-libs/libvpx:0

  (media-libs/libvpx-1.3.0:0/0::gentoo, installed) pulled in by
    media-libs/libvpx:0/0= required by (app-emulation/virtualbox-5.1.26:0/0::gentoo, installed)
                     ^^^^^                                                                                                         

  (media-libs/libvpx-1.5.0:0/3::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libvpx-1.5:=[svc] required by (dev-qt/qtwebengine-5.7.1-r2:5/5.7::gentoo, ebuild scheduled for merge)
    ^^                  ^^^                                                                                                                                                                     

media-libs/giflib:0

  (media-libs/giflib-5.1.4:0/7::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/giflib:0/7 required by (dev-java/icedtea-bin-3.6.0:8/8::gentoo, ebuild scheduled for merge)
                     ^^^^                                                                                                                     

  (media-libs/giflib-4.1.6-r3:0/0::gentoo, installed) pulled in by
    media-libs/giflib:0/0= required by (media-libs/libwebp-0.5.2:0/6::gentoo, installed)
                     ^^^^^                                                                                                 
    (and 1 more with the same problem)

app-text/poppler:0

  (app-text/poppler-0.57.0:0/68::gentoo, ebuild scheduled for merge) pulled in by
    app-text/poppler[qt5,-exceptions(-)] required by (kde-apps/okular-17.04.3:5/5::gentoo, ebuild scheduled for merge)
                     ^^^                                                                                                                                 
    app-text/poppler[qt5] required by (kde-frameworks/kfilemetadata-5.37.0:5/5.37::gentoo, ebuild scheduled for merge)
                     ^^^                                                                                                                                 

  (app-text/poppler-0.32.0:0/51::gentoo, installed) pulled in by
    >=app-text/poppler-0.24.3:0/51= required by (sci-libs/gdal-2.0.3:0/2::gentoo, installed)
                             ^^^^^^                                                                                             

dev-libs/boost:0

  (dev-libs/boost-1.63.0:0/1.63.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, installed) pulled in by
    dev-libs/boost:0/1.56.0= required by (dev-db/mysql-connector-c++-1.1.6:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                                         

dev-util/boost-build:0

  (dev-util/boost-build-1.63.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.63* required by (dev-libs/boost-1.63.0:0/1.63.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                       

  (dev-util/boost-build-1.56.0:0/0::gentoo, installed) pulled in by
    =dev-util/boost-build-1.56* required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, installed)
    ^                     ^^^^^                                                                                                                         

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



So I have to resolve those "Multiple packages" issues...

For the reference, here is the command I used:

Code:

emerge --ask --newuse --newrepo --deep --backtrack=500 --autounmask-backtrack=y world


Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5561
Location: Austria

PostPosted: Thu Nov 30, 2017 12:55 am    Post subject: Reply with quote

Please try once again with --verbose-conflicts and --backtrack=1000.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Thu Nov 30, 2017 2:06 am    Post subject: Reply with quote

Hi,
Here is the output:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtgui-4.8.6[-aqua,-debug,abi_x86_64(-)] required by (dev-qt/qthelp-4.8.6-r3:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                               
    ~dev-qt/qtgui-4.8.6[accessibility,-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                                                           
    ~dev-qt/qtgui-4.8.6[-aqua,-debug,glib,qt3support,abi_x86_64(-)] required by (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                                               

  (dev-qt/qtgui-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-4.8.7[aqua=,debug=,glib=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtcore-4.8.7-r3:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                                 
    ~dev-qt/qtgui-4.8.7[accessibility=,aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                                           
    >=dev-qt/qtgui-4.8.7:4 required by (kde-plasma/oxygen-5.10.5:5/5::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                                                                         
    ~dev-qt/qtgui-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                               
    >=dev-qt/qtgui-4.8.7:4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/phonon-4.9.1-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                                                                                                                                                                                                                                           
    ~dev-qt/qtgui-4.8.7[accessibility=,aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                                               
    >=dev-qt/qtgui-4.8.7:4 required by (media-libs/phonon-vlc-0.9.1-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^                                                                                                                                                               
    ~dev-qt/qtgui-4.8.7[accessibility=,aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtsvg-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                           
    ~dev-qt/qtgui-4.8.7[aqua=,debug=,egl=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtopengl-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                                 

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.7-r3:4/4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtcore-4.8.7-r2:4 required by (kde-plasma/oxygen-5.10.5:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^^^^                                                                                                                                                         
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,glib=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                                               
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtscript-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                               
    >=dev-qt/qtcore-4.8.7-r2:4 required by (app-crypt/qca-2.1.3-r1:2/2::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^^^^                                                                                                                                                       
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                                                 
    >=dev-qt/qtcore-4.8.7-r2:4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/phonon-4.9.1-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^^^^                                                                                                                                                                                                                                                                                                                           
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdbus-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                             
    ~dev-qt/qtcore-4.8.7 required by (dev-qt/qttranslations-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                         
    >=dev-qt/qtcore-4.8.7-r2:4 required by (media-libs/phonon-vlc-0.9.1-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^^^^                                                                                                                                                               
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtsvg-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                             
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtopengl-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                                           
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtsql-4.8.7-r1:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                                           
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                               
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                                             
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtxmlpatterns-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                                                                                                                                                                                                     

  (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,glib,qt3support,abi_x86_64(-)] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                                                             
    ~dev-qt/qtcore-4.8.6 required by (dev-qt/qttranslations-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                           
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                                                         
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                                                             
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,abi_x86_64(-)] required by (dev-qt/qthelp-4.8.6-r3:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                                               
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,abi_x86_64(-)] required by (dev-qt/qtscript-4.8.6-r2:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                                                 
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,abi_x86_64(-)] required by (dev-qt/qttest-4.8.6-r1:4/4::gentoo, installed)
    ^              ^^^^^                                                                                                                                               

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                ^^^^^                                                                                                                                                                                                                                                                                                             
    ~dev-qt/qtscript-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                ^^^^^                                                                                                                                                                                                                                                                                                                     
    ~dev-qt/qtscript-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                ^^^^^                                                                                                                                                                                                                                                                                                               

  (dev-qt/qtscript-4.8.6-r2:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.6[-aqua,-debug,abi_x86_64(-)] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
    ^                ^^^^^                                                                                                                                             

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^                                                                                                                                                                                                                                                                                                               
    ~dev-qt/qt3support-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtgui-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^                                                                                                                                                                                                                                                                                                             
    ~dev-qt/qt3support-4.8.7[accessibility=,aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^                                                                                                                                                                                                                                                                                                                                   

  (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.6[-aqua,-debug,abi_x86_64(-)] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
    ^                  ^^^^^                                                                                                                                             

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.7-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.7[aqua=,debug=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qt3support-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                             
    ~dev-qt/qtsql-4.8.7[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                                                                                                                                                                                                 

  (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.6[-aqua,-debug,sqlite,abi_x86_64(-)] required by (dev-qt/qthelp-4.8.6-r3:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                                     
    ~dev-qt/qtsql-4.8.6[-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
    ^             ^^^^^                                                                                                                                                             

dev-qt/qttranslations:4

  (dev-qt/qttranslations-4.8.6-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qttranslations-4.8.6 required by (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed)
    ^                      ^^^^^                                                                                                                   

  (dev-qt/qttranslations-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttranslations-4.8.7 required by (dev-qt/qtcore-4.8.7-r3:4/4::gentoo, ebuild scheduled for merge)
    ^                      ^^^^^                                                                                                                                   

media-libs/libvpx:0

  (media-libs/libvpx-1.3.0:0/0::gentoo, installed) pulled in by
    media-libs/libvpx:0/0= required by (app-emulation/virtualbox-5.1.26:0/0::gentoo, installed)
                     ^^^^^                                                                                                         

  (media-libs/libvpx-1.5.0:0/3::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libvpx-1.5:=[svc] required by (dev-qt/qtwebengine-5.7.1-r2:5/5.7::gentoo, ebuild scheduled for merge)
    ^^                  ^^^                                                                                                                                                                     

media-libs/giflib:0

  (media-libs/giflib-5.1.4:0/7::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/giflib:0/7 required by (dev-java/icedtea-bin-3.6.0:8/8::gentoo, ebuild scheduled for merge)
                     ^^^^                                                                                                                     

  (media-libs/giflib-4.1.6-r3:0/0::gentoo, installed) pulled in by
    media-libs/giflib:0/0= required by (media-libs/libwebp-0.5.2:0/6::gentoo, installed)
                     ^^^^^                                                                                                 
    media-libs/giflib:0/0= required by (sci-libs/gdal-2.0.3:0/2::gentoo, installed)
                     ^^^^^                                                                                             

app-text/poppler:0

  (app-text/poppler-0.57.0:0/68::gentoo, ebuild scheduled for merge) pulled in by
    app-text/poppler[qt5,-exceptions(-)] required by (kde-apps/okular-17.04.3:5/5::gentoo, ebuild scheduled for merge)
                     ^^^                                                                                                                                 
    app-text/poppler[qt5] required by (kde-frameworks/kfilemetadata-5.37.0:5/5.37::gentoo, ebuild scheduled for merge)
                     ^^^                                                                                                                                 

  (app-text/poppler-0.32.0:0/51::gentoo, installed) pulled in by
    >=app-text/poppler-0.24.3:0/51= required by (sci-libs/gdal-2.0.3:0/2::gentoo, installed)
                             ^^^^^^                                                                                             

dev-libs/boost:0

  (dev-libs/boost-1.63.0:0/1.63.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, installed) pulled in by
    dev-libs/boost:0/1.56.0= required by (dev-db/mysql-connector-c++-1.1.6:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                                         

dev-util/boost-build:0

  (dev-util/boost-build-1.63.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.63* required by (dev-libs/boost-1.63.0:0/1.63.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                       

  (dev-util/boost-build-1.56.0:0/0::gentoo, installed) pulled in by
    =dev-util/boost-build-1.56* required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, installed)
    ^                     ^^^^^                                                                                                                         


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5561
Location: Austria

PostPosted: Thu Nov 30, 2017 2:16 am    Post subject: Reply with quote

It is really strange, one step forward and two steps back.

Remove qttest:4 and qthelp:4, it seems they are not up for emerge but an old version is still lingering around, which may block your upgrade for that reason. You removed qtwebkit:4 already?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Thu Nov 30, 2017 4:29 am    Post subject: Reply with quote

Hi,
Only one of those packages exist:

Code:

IgorDellGentoo /home/igor/dbhandler # emerge --pretend --unmerge qttest qthelp qtwebkit
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

>>> These are the packages that would be unmerged:

 dev-qt/qttest
    selected: 4.8.6-r1
   protected: none
     omitted: none

 dev-qt/qthelp
    selected: 4.8.6-r3
   protected: none
     omitted: none

 dev-qt/qtwebkit
    selected: 4.8.6-r1
   protected: none
     omitted: none

All selected packages: =dev-qt/qttest-4.8.6-r1 =dev-qt/qtwebkit-4.8.6-r1 =dev-qt/qthelp-4.8.6-r3

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.


Unmerging and will retry...

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Thu Nov 30, 2017 4:57 am    Post subject: Reply with quote

OK, now the list becomes smaller:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/libvpx:0

  (media-libs/libvpx-1.3.0:0/0::gentoo, installed) pulled in by
    media-libs/libvpx:0/0= required by (app-emulation/virtualbox-5.1.26:0/0::gentoo, installed)
                     ^^^^^                                                                                                         

  (media-libs/libvpx-1.5.0:0/3::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libvpx-1.5:=[svc] required by (dev-qt/qtwebengine-5.7.1-r2:5/5.7::gentoo, ebuild scheduled for merge)
    ^^                  ^^^                                                                                                                                                                     

media-libs/giflib:0

  (media-libs/giflib-5.1.4:0/7::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/giflib:0/7 required by (dev-java/icedtea-bin-3.6.0:8/8::gentoo, ebuild scheduled for merge)
                     ^^^^                                                                                                                     

  (media-libs/giflib-4.1.6-r3:0/0::gentoo, installed) pulled in by
    media-libs/giflib:0/0= required by (media-libs/libwebp-0.5.2:0/6::gentoo, installed)
                     ^^^^^                                                                                                 
    media-libs/giflib:0/0= required by (sci-libs/gdal-2.0.3:0/2::gentoo, installed)
                     ^^^^^                                                                                             

app-text/poppler:0

  (app-text/poppler-0.57.0:0/68::gentoo, ebuild scheduled for merge) pulled in by
    app-text/poppler[qt5,-exceptions(-)] required by (kde-apps/okular-17.04.3:5/5::gentoo, ebuild scheduled for merge)
                     ^^^                                                                                                                                 
    app-text/poppler[qt5] required by (kde-frameworks/kfilemetadata-5.37.0:5/5.37::gentoo, ebuild scheduled for merge)
                     ^^^                                                                                                                                 

  (app-text/poppler-0.32.0:0/51::gentoo, installed) pulled in by
    >=app-text/poppler-0.24.3:0/51= required by (sci-libs/gdal-2.0.3:0/2::gentoo, installed)
                             ^^^^^^                                                                                             

dev-libs/boost:0

  (dev-libs/boost-1.63.0:0/1.63.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, installed) pulled in by
    dev-libs/boost:0/1.56.0= required by (dev-db/mysql-connector-c++-1.1.6:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                                         

dev-util/boost-build:0

  (dev-util/boost-build-1.63.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-util/boost-build-1.63* required by (dev-libs/boost-1.63.0:0/1.63.0::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^                                                                                                                                       

  (dev-util/boost-build-1.56.0:0/0::gentoo, installed) pulled in by
    =dev-util/boost-build-1.56* required by (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, installed)
    ^                     ^^^^^                                                                                                                         


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16880
Location: here

PostPosted: Thu Nov 30, 2017 7:03 am    Post subject: Reply with quote

Try to build media-libs/libvpx and app-emulation/virtualbox separately.
Code:
# emerge -1 media-libs/libvpx app-emulation/virtualbox

Same thing for dev-util/boost-build, dev-libs/boost and dev-db/mysql-connector-c++
Code:
# emerge -1 dev-util/boost-build dev-libs/boost dev-db/mysql-connector-c++

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6  Next
Page 4 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum