Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]: qt4 and qt5
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Thu Nov 30, 2017 12:42 pm    Post subject: Reply with quote

Hi,
Trued it. Here are the results:

Code:

IgorDellGentoo /home/igor/dbhandler # emerge -pv =giflib-5.1.4 libwebp gdal

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-libs/giflib-5.1.4:0/7::gentoo [4.1.6-r3:0/0::gentoo] USE="-doc% -static-libs (-X%*) (-rle%)" ABI_X86="(64) -32 (-x32)" 625 KiB
[ebuild   R    ] media-libs/libwebp-0.5.2:0/6::gentoo  USE="gif jpeg opengl png tiff -experimental (-neon) -static-libs -swap-16bit-csp" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse2 -avx2 -sse4_1" 0 KiB
[ebuild   R    ] sci-libs/gdal-2.0.3:0/2::gentoo  USE="aux_xml gif jpeg pdf png -armadillo -curl -debug -doc -fits -geos -gml -hdf5 -java -jpeg2k (-mdb) -mysql -netcdf -odbc -ogdi -opencl (-oracle) -perl -postgres -python -spatialite -sqlite -threads -xls" PYTHON_TARGETS="python2_7 python3_4 -python3_5" 0 KiB

Total: 3 packages (1 upgrade, 2 reinstalls), Size of downloads: 625 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/giflib:0

  (media-libs/giflib-5.1.4:0/7::gentoo, ebuild scheduled for merge) pulled in by
    =media-libs/giflib-5.1.4 (Argument)

  (media-libs/giflib-4.1.6-r3:0/0::gentoo, installed) pulled in by
    media-libs/giflib:0/0= required by (kde-frameworks/kdelibs-4.14.16:4/4.14::gentoo, installed)
                     ^^^^^                                                                                                           


!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (kde-frameworks/kdelibs-4.14.16:4/4.14::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- sys-firmware/b43-firmware-6.30.163.46::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# MichaŠGórny <mgorny@gentoo.org> (22 May 2017)
# for Maciej S. Szmigiero <mail@maciej.szmigiero.name>
# Any version above 5.100.138 breaks b43 driver in various ways.
# Also, b43 wiki page says to use 5.100.138. Bug #541080.

- sys-devel/binutils-2.25.1-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# MichaŠGórny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- sys-libs/glibc-2.21-r2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

IgorDellGentoo /home/igor/dbhandler # emerge -pv boost boost-build mysql-connector-c++

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-util/boost-build-1.63.0::gentoo [1.56.0::gentoo] USE="-examples -python {-test}" PYTHON_TARGETS="python2_7" 80063 KiB
[ebuild  r  U  ] dev-libs/boost-1.63.0:0/1.63.0::gentoo [1.56.0-r1:0/1.56.0::gentoo] USE="nls threads -context -debug -doc -icu -mpi -python -static-libs -tools" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 -python3_5% (-python3_6) (-python3_3%)" 0 KiB
[ebuild     U  ] dev-libs/openssl-1.0.2m::gentoo [1.0.2g-r2::gentoo] USE="asm sslv3%* tls-heartbeat zlib -bindist* -gmp -kerberos -rfc3779 -sctp -sslv2% -static-libs {-test} -vanilla" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)" 5248 KiB
[ebuild  N     ] dev-libs/double-conversion-2.0.1:0/1::gentoo  USE="-static-libs" 6850 KiB
[ebuild  N     ] dev-libs/libinput-1.7.3:0/10::gentoo  USE="{-test}" INPUT_DEVICES="-wacom" 901 KiB
[ebuild  N     ] dev-libs/libpcre2-10.30::gentoo  USE="bzip2 jit pcre16 readline recursion-limit unicode zlib -libedit -pcre32 -static-libs" ABI_X86="(64) -32 (-x32)" 1547 KiB
[ebuild     U ~] dev-qt/qtcore-5.9.2:5/5.9::gentoo [5.6.2-r1:5/5.6::gentoo] USE="icu -debug -systemd {-test}" 44091 KiB
[ebuild   R    ] dev-db/mysql-connector-c++-1.1.6::gentoo  USE="-debug -examples -gcov -static-libs" 0 KiB
[ebuild  N    ~] dev-qt/qtnetwork-5.9.2:5/5.9::gentoo  USE="ssl -bindist -connman -debug -libproxy -networkmanager {-test}" 0 KiB
[ebuild  N    ~] dev-qt/qttest-5.9.2:5/5.9::gentoo  USE="-debug {-test}" 0 KiB
[ebuild     U ~] dev-qt/qtdbus-5.9.2:5/5.9::gentoo [5.6.2:5/5.6::gentoo] USE="-debug {-test}" 0 KiB
[ebuild     U ~] dev-qt/qtgui-5.9.2:5/5.9::gentoo [5.6.2:5/5.6::gentoo] USE="dbus egl* gif jpeg libinput* png udev xcb -accessibility -debug -eglfs -evdev (-gles2) -ibus {-test} -tslib -tuio -vnc% (-gtkstyle%)" 0 KiB
[ebuild  NS   ~] dev-qt/qtxmlpatterns-5.9.2:5/5.9::gentoo [4.8.6-r1:4::gentoo] USE="-debug {-test}" 1329 KiB
[ebuild     U ~] dev-qt/qtwidgets-5.9.2:5/5.9::gentoo [5.6.2:5/5.6::gentoo] USE="gtk%* png xcb -debug (-gles2) {-test} (-gtkstyle%)" 0 KiB
[ebuild  NS   ~] dev-qt/qtdeclarative-5.9.2:5/5.9::gentoo [4.8.6-r1:4::gentoo] USE="jit widgets xml -debug (-gles2) -localstorage {-test}" 20934 KiB
[ebuild  r  U  ] media-libs/qt-gstreamer-1.2.0-r2::gentoo [1.2.0-r1::gentoo] USE="qt4 qt5* {-test}" 0 KiB

Total: 16 packages (8 upgrades, 5 new, 2 in new slots, 1 reinstall), Size of downloads: 160961 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtgui:5

  (dev-qt/qtgui-5.6.2:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.6.2[-gles2,-gtkstyle,png,xcb] required by (dev-qt/qtwidgets-5.6.2:5/5.6::gentoo, installed)
    ^             ^^^^^                                                                                                                                               
    (and 3 more with the same problem)

  (dev-qt/qtgui-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.9.2[gles2=,png=,xcb?] required by (dev-qt/qtwidgets-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^             ^^^^^                                                                                                                                                       
    (and 2 more with the same problem)

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.6.2:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.6.2[-gles2] required by (dev-qt/qtopengl-5.6.2:5/5.6::gentoo, installed)
    ^                 ^^^^^                                                                                                                           
    (and 1 more with the same problem)

  (dev-qt/qtwidgets-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtwidgets-5.9.2[gles2=] required by (dev-qt/qtdeclarative-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^                                                                                                                                                 

dev-qt/qtcore:5

  (dev-qt/qtcore-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.9.2 required by (dev-qt/qtwidgets-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     
    (and 6 more with the same problem)

  (dev-qt/qtcore-5.6.2-r1:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtx11extras-5.6.2:5/5.6::gentoo, installed)
    ^              ^^^^^                                                                                                                       
    (and 7 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtdbus-5.9.2 required by (dev-qt/qtgui-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                 

  (dev-qt/qtdbus-5.6.2:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.6.2 required by (dev-qt/qtgui-5.6.2:5/5.6::gentoo, installed)
    ^              ^^^^^                                                                                                                 

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2m:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0=[bindist=] required by (dev-qt/qtnetwork-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
                        ^^^^^^^^                                                                                                                   

  (dev-libs/openssl-1.0.2g-r2:0/0::gentoo, installed) pulled in by
    >=dev-libs/openssl-0.9.8f:0[bindist] required by (net-misc/openssh-7.2_p2:0/0::gentoo, installed)
                                ^^^^^^^                                                                                                 

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following packages are causing rebuilds:

  (dev-libs/boost-1.63.0:0/1.63.0::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (media-libs/qt-gstreamer-1.2.0-r2:0/0::gentoo, ebuild scheduled for merge)

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-qt/qtgui-5.9.2::gentoo[dbus]
# required by dev-qt/qtdeclarative-5.9.2::gentoo
# required by media-libs/qt-gstreamer-1.2.0-r2::gentoo[qt5]
# required by @__auto_slot_operator_replace_installed__ (argument)
=dev-qt/qtdbus-5.9.2 ~amd64
# required by dev-qt/qtdeclarative-5.9.2::gentoo[-test]
# required by media-libs/qt-gstreamer-1.2.0-r2::gentoo[qt5]
# required by @__auto_slot_operator_replace_installed__ (argument)
=dev-qt/qttest-5.9.2 ~amd64
# required by dev-qt/qtdeclarative-5.9.2::gentoo
# required by media-libs/qt-gstreamer-1.2.0-r2::gentoo[qt5]
# required by @__auto_slot_operator_replace_installed__ (argument)
=dev-qt/qtcore-5.9.2 ~amd64
# required by dev-qt/qtdeclarative-5.9.2::gentoo[widgets]
# required by media-libs/qt-gstreamer-1.2.0-r2::gentoo[qt5]
# required by @__auto_slot_operator_replace_installed__ (argument)
=dev-qt/qtwidgets-5.9.2 ~amd64
# required by dev-qt/qtdeclarative-5.9.2::gentoo[xml]
# required by media-libs/qt-gstreamer-1.2.0-r2::gentoo[qt5]
# required by @__auto_slot_operator_replace_installed__ (argument)
=dev-qt/qtxmlpatterns-5.9.2 ~amd64
# required by dev-qt/qtdeclarative-5.9.2::gentoo[xml]
# required by media-libs/qt-gstreamer-1.2.0-r2::gentoo[qt5]
# required by @__auto_slot_operator_replace_installed__ (argument)
=dev-qt/qtnetwork-5.9.2 ~amd64
# required by dev-qt/qtwidgets-5.9.2::gentoo[gtk]
# required by dev-qt/qtdeclarative-5.9.2::gentoo[widgets]
# required by media-libs/qt-gstreamer-1.2.0-r2::gentoo[qt5]
# required by @__auto_slot_operator_replace_installed__ (argument)
=dev-qt/qtgui-5.9.2 ~amd64
# required by media-libs/qt-gstreamer-1.2.0-r2::gentoo[qt5]
# required by @__auto_slot_operator_replace_installed__ (argument)
=dev-qt/qtdeclarative-5.9.2 ~amd64

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! The following installed packages are masked:
- sys-firmware/b43-firmware-6.30.163.46::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# MichaŠGórny <mgorny@gentoo.org> (22 May 2017)
# for Maciej S. Szmigiero <mail@maciej.szmigiero.name>
# Any version above 5.100.138 breaks b43 driver in various ways.
# Also, b43 wiki page says to use 5.100.138. Bug #541080.

- sys-devel/binutils-2.25.1-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# MichaŠGórny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- sys-libs/glibc-2.21-r2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16898
Location: here

PostPosted: Thu Nov 30, 2017 1:05 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
Code:
IgorDellGentoo /home/igor/dbhandler # emerge -pv =giflib-5.1.4 libwebp gdal

Try to add also kdelibs in this command

ONEEYEMAN wrote:
Code:
IgorDellGentoo /home/igor/dbhandler # emerge -pv boost boost-build mysql-connector-c++

In the output of this command the big problem, I think, is bindist use flag. Disable it globally in make.conf and try again (add also -ND option to emerge)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Thu Nov 30, 2017 2:35 pm    Post subject: Reply with quote

fedeliallalinea wrote:

ONEEYEMAN wrote:

Code:

IgorDellGentoo /home/igor/dbhandler # emerge -pv =giflib-5.1.4 libwebp gdal


Try to add also kdelibs in this command


Didn't help:

Code:

IgorDellGentoo /home/igor/dbhandler # emerge -pv =giflib-5.1.4 libwebp gdal kdelibs               

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-misc/xdg-utils:0

  (x11-misc/xdg-utils-1.1.1:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-misc/xdg-utils-1.1.1-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-misc/xdg-utils-1.1.1-r1 required by (kde-frameworks/kf-env-4:5/5::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^                                                                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by kde-plasma/polkit-kde-agent-5.10.5::gentoo
# required by kde-frameworks/kdelibs-4.14.37::gentoo
# required by kdelibs (argument)
=dev-qt/qtgui-5.9.2 ~amd64

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! All ebuilds that could satisfy "~dev-qt/qtgui-5.7.1[gles2=]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-qt/qtgui-5.7.1-r1::gentoo (masked by: backtracking: slot conflict)

(dependency required by "dev-qt/qtdeclarative-5.7.1-r1::gentoo" [ebuild])
(dependency required by "dev-qt/linguist-tools-5.7.1::gentoo[qml]" [ebuild])
(dependency required by "kde-frameworks/kwidgetsaddons-5.37.0::gentoo[nls]" [ebuild])
(dependency required by "kde-plasma/polkit-kde-agent-5.10.5::gentoo" [ebuild])
(dependency required by "kde-frameworks/kdelibs-4.14.37::gentoo" [ebuild])
(dependency required by "kdelibs" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


fedeliallalinea wrote:

ONEEYEMAN wrote:

Code:

IgorDellGentoo /home/igor/dbhandler # emerge -pv boost boost-build mysql-connector-c++


In the output of this command the big problem, I think, is bindist use flag. Disable it globally in make.conf and try again (add also -ND option to emerge)


It is turned off"

Code:

IgorDellGentoo /home/igor/dbhandler # emerge --info | grep bindist
IgorDellGentoo /home/igor/dbhandler # cat /etc/portage/package.use | grep bindist
>=dev-libs/openssl-1.0.21 -bindist
IgorDellGentoo /home/igor/dbhandler #


Last edited by ONEEYEMAN on Thu Nov 30, 2017 3:43 pm; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5569
Location: Austria

PostPosted: Thu Nov 30, 2017 2:55 pm    Post subject: Reply with quote

Yeah, problem is there are one or two packages installed that have it still enabled (at least net-misc/openssh).
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Thu Nov 30, 2017 3:22 pm    Post subject: Reply with quote

asturm,
So I should turn it off explicitly in the /etc/portage/package.use (for this specific one)?

Also what about everything else?

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5569
Location: Austria

PostPosted: Thu Nov 30, 2017 3:22 pm    Post subject: Reply with quote

No, they need to be rebuilt at the same time if you see a blocker like above. an entry in package.use is redundant if you did it already in make.conf...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Thu Nov 30, 2017 3:42 pm    Post subject: Reply with quote

asturm,
Yes, I did turn it off as "emerge --info" says. But apparently it didn't help much, because I added the turn-off after the package was installed.
Or am I wrong here?

Anyway I think doing:

Code:

USE=-bindist emerge openssl openssh


should take care of that. But than we have:

Code:

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2m:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0=[bindist=] required by (dev-qt/qtnetwork-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
                        ^^^^^^^^                                                                                                     


which indicate that bindist USE-flag is required anyway to complete this.

So maybe I should rebuild this conflict with "+bindist"?

Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16898
Location: here

PostPosted: Thu Nov 30, 2017 4:03 pm    Post subject: Reply with quote

You should add also qtnetwork in emerge command
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Thu Nov 30, 2017 4:14 pm    Post subject: Reply with quote

OK, will try to do that tonight.

What about others?

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Thu Nov 30, 2017 11:46 pm    Post subject: Reply with quote

Hi,
Here are the results:

Code:

IgorDellGentoo /home/igor/dbhandler # USE=-bindist emerge -pv openssl openssh qtnetwork

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/openssl-1.0.2m::gentoo [1.0.2g-r2::gentoo] USE="asm sslv3%* tls-heartbeat zlib -bindist* -gmp -kerberos -rfc3779 -sctp -sslv2% -static-libs {-test} -vanilla" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)" 5248 KiB
[ebuild  N     ] dev-libs/double-conversion-2.0.1:0/1::gentoo  USE="-static-libs" 6850 KiB
[ebuild  N     ] dev-libs/libpcre2-10.30::gentoo  USE="bzip2 jit pcre16 readline recursion-limit unicode zlib -libedit -pcre32 -static-libs" ABI_X86="(64) -32 (-x32)" 1547 KiB
[ebuild     U ~] dev-qt/qtcore-5.9.2:5/5.9::gentoo [5.6.2-r1:5/5.6::gentoo] USE="icu -debug -systemd {-test}" 44091 KiB
[ebuild  N    ~] dev-qt/qtnetwork-5.9.2:5/5.9::gentoo  USE="ssl -bindist -connman -debug -libproxy -networkmanager {-test}" 0 KiB
[ebuild     U  ] net-misc/openssh-7.5_p1-r3::gentoo [7.2_p2::gentoo] USE="X hpn* ldap pam pie ssl -X509 -audit% -bindist* -debug -kerberos -ldns -libedit -libressl -livecd% -sctp (-selinux) -skey -ssh1 -static {-test%}" 1523 KiB

Total: 6 packages (3 upgrades, 3 new), Size of downloads: 59258 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.9.2 required by (dev-qt/qtnetwork-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     

  (dev-qt/qtcore-5.6.2-r1:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtx11extras-5.6.2:5/5.6::gentoo, installed)
    ^              ^^^^^                                                                                                                       
    (and 7 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by qtnetwork (argument)
=dev-qt/qtnetwork-5.9.2 ~amd64
# required by dev-qt/qtnetwork-5.9.2::gentoo
# required by qtnetwork (argument)
=dev-qt/qtcore-5.9.2 ~amd64

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

!!! The following installed packages are masked:
- sys-firmware/b43-firmware-6.30.163.46::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# MichaŠGórny <mgorny@gentoo.org> (22 May 2017)
# for Maciej S. Szmigiero <mail@maciej.szmigiero.name>
# Any version above 5.100.138 breaks b43 driver in various ways.
# Also, b43 wiki page says to use 5.100.138. Bug #541080.

- sys-devel/binutils-2.25.1-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# MichaŠGórny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- sys-libs/glibc-2.21-r2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



Thank you.

P.S.: Adding qtcore didn't make any difference.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 11424

PostPosted: Fri Dec 01, 2017 2:16 am    Post subject: Reply with quote

ONEEYEMAN wrote:
Code:

IgorDellGentoo /home/igor/dbhandler # USE=-bindist emerge -pv openssl openssh qtnetwork
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.9.2:5/5.9::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.9.2 required by (dev-qt/qtnetwork-5.9.2:5/5.9::gentoo, ebuild scheduled for merge)
    ^              ^^^^^                                                                                                                                     

  (dev-qt/qtcore-5.6.2-r1:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtx11extras-5.6.2:5/5.6::gentoo, installed)
    ^              ^^^^^                                                                                                                       
    (and 7 more with the same problem)

P.S.: Adding qtcore didn't make any difference.
According to that output, that is expected. That output says that you need to install a version of dev-qt/qtx11extras that is compatible with the newer dev-qt/qtcore.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Fri Dec 01, 2017 3:44 am    Post subject: Reply with quote

Hu,
It looks like I will have to manually merge the whole qt, just to resolve the conflicting version from the output above.
The trouble is that I'm trying to re-merge "world" (again: see the whole thread), and the qt is the huge part of it.

So I don't know if I want to continue adding qt pieces to that command or maybe unmerge all those qt packages and try to merge world and then merge kde/plasma.

What do you think?

Thank you.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Fri Dec 01, 2017 4:20 pm    Post subject: Reply with quote

Any other opinions?

Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16898
Location: here

PostPosted: Fri Dec 01, 2017 4:36 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
So I don't know if I want to continue adding qt pieces to that command or maybe unmerge all those qt packages and try to merge world and then merge kde/plasma.

What do you think?

This is a possibility or you can try to update all installed qt with
Code:
# emerge -u $(qlist -I dev-qt/*)

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Fri Dec 01, 2017 4:49 pm    Post subject: Reply with quote

Hi, fedeliallalinea,
Should I add all other switches to that emerge command - namely --newuse --newrepo and --deep?

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5569
Location: Austria

PostPosted: Fri Dec 01, 2017 5:13 pm    Post subject: Reply with quote

Please, why not try for yourself if it does not work at first... by now you should know what those switches are for and that they can help you under certain circumstances.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Sat Dec 02, 2017 4:03 pm    Post subject: Reply with quote

Hi,
After updating qt and fixing couple more conflicts, I'm down to the last one:

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/giflib:0

  (media-libs/giflib-5.1.4:0/7::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/giflib:0/7 required by (dev-java/icedtea-bin-3.6.0:8/8::gentoo, ebuild scheduled for merge)
                     ^^^^                                                                                                                     

  (media-libs/giflib-4.1.6-r3:0/0::gentoo, installed) pulled in by
    media-libs/giflib:0/0= required by (media-libs/libwebp-0.5.2:0/6::gentoo, installed)
                     ^^^^^                                                                                                 
    media-libs/giflib:0/0= required by (sci-libs/gdal-2.0.3:0/2::gentoo, installed)
                     ^^^^^                                                                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



And yjis is what I get trying to rersolve it:

Code:

IgorDellGentoo /home/igor/dbhandler # emerge -pv =giflib-5.1.4 gdal libwebp

 * IMPORTANT: config file '/etc/portage/package.use' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-libs/giflib-5.1.4:0/7::gentoo [4.1.6-r3:0/0::gentoo] USE="-doc% -static-libs (-X%*) (-rle%)" ABI_X86="(64) -32 (-x32)" 625 KiB
[ebuild   R    ] media-libs/libwebp-0.5.2:0/6::gentoo  USE="gif jpeg opengl png tiff -experimental (-neon) -static-libs -swap-16bit-csp" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse2 -avx2 -sse4_1" 0 KiB
[ebuild   R    ] sci-libs/gdal-2.0.3:0/2::gentoo  USE="aux_xml gif jpeg pdf png -armadillo -curl -debug -doc -fits -geos -gml -hdf5 -java -jpeg2k (-mdb) -mysql -netcdf -odbc -ogdi -opencl (-oracle) -perl -postgres -python -spatialite -sqlite -threads -xls" PYTHON_TARGETS="python2_7 python3_4 -python3_5" 0 KiB

Total: 3 packages (1 upgrade, 2 reinstalls), Size of downloads: 625 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/giflib:0

  (media-libs/giflib-5.1.4:0/7::gentoo, ebuild scheduled for merge) pulled in by
    =media-libs/giflib-5.1.4 (Argument)

  (media-libs/giflib-4.1.6-r3:0/0::gentoo, installed) pulled in by
    media-libs/giflib:0/0= required by (kde-frameworks/kdelibs-4.14.16:4/4.14::gentoo, installed)
                     ^^^^^                                                                                                           


!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (kde-frameworks/kdelibs-4.14.16:4/4.14::gentoo, installed): ebuild is masked or unavailable


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- sys-firmware/b43-firmware-6.30.163.46::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# MichaŠGórny <mgorny@gentoo.org> (22 May 2017)
# for Maciej S. Szmigiero <mail@maciej.szmigiero.name>
# Any version above 5.100.138 breaks b43 driver in various ways.
# Also, b43 wiki page says to use 5.100.138. Bug #541080.

- sys-devel/binutils-2.25.1-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# MichaŠGórny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- sys-libs/glibc-2.21-r2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Should I try to update KDE at this point to resolve this conflict?

Thank you.

Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16898
Location: here

PostPosted: Sat Dec 02, 2017 4:08 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
Should I try to update KDE at this point to resolve this conflict?

Why not? You can try
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Sat Dec 02, 2017 4:16 pm    Post subject: Reply with quote

asturm,
Trying it gives:

Code:

IgorDellGentoo /home/igor/dbhandler # emerge -u1pv $(qlist -I kde-frameworks/*)

 * IMPORTANT: config file '/etc/portage/package.use' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] kde-frameworks/extra-cmake-modules-5.37.0-r1:5/5.37::gentoo  USE="-doc {-test}" 305 KiB
[ebuild     U  ] x11-misc/xdg-utils-1.1.1-r1::gentoo [1.1.1::gentoo] USE="perl -doc" 0 KiB
[ebuild  N     ] kde-frameworks/kf-env-4:5::gentoo  0 KiB
[ebuild  NS    ] dev-qt/qttest-4.8.7:4::gentoo [5.7.1:5/5.7::gentoo] USE="exceptions (-aqua) -debug -pch" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild   R    ] sys-auth/polkit-qt-0.112.0-r1::gentoo  USE="qt4 qt5* -debug -examples" 0 KiB
[ebuild  NS    ] kde-frameworks/oxygen-icons-5.37.0:5/5.37::gentoo [4.14.3:4/4.14::gentoo] USE="{-test}" 228918 KiB
[uninstall     ] kde-frameworks/oxygen-icons-4.14.3:4/4.14::gentoo  USE="(-aqua) -sources"
[blocks b      ] kde-frameworks/oxygen-icons:4 ("kde-frameworks/oxygen-icons:4" is blocking kde-frameworks/oxygen-icons-5.37.0)
[uninstall     ] kde-base/legacy-icons-4.11.22:4/4.11::gentoo  USE="(-aqua)"
[blocks b      ] >=kde-frameworks/oxygen-icons-5.19.0:5 (">=kde-frameworks/oxygen-icons-5.19.0:5" is blocking kde-base/legacy-icons-4.11.22)
[ebuild  N     ] kde-frameworks/kcoreaddons-5.37.0:5/5.37::gentoo  USE="nls -debug -doc (-fam) {-test}" 341 KiB
[ebuild  N     ] kde-frameworks/ki18n-5.37.0:5/5.37::gentoo  USE="-debug -doc {-test}" PYTHON_SINGLE_TARGET="python3_4 -python2_7 -python3_5 (-python3_6)" PYTHON_TARGETS="python2_7 python3_4 -python3_5 (-python3_6)" 573 KiB
[ebuild  N     ] kde-frameworks/kwidgetsaddons-5.37.0:5/5.37::gentoo  USE="nls -debug -doc {-test}" 2125 KiB
[ebuild  N     ] kde-frameworks/kwindowsystem-5.37.0:5/5.37::gentoo  USE="X nls -debug -doc {-test}" 164 KiB
[ebuild  N     ] kde-frameworks/kdbusaddons-5.37.0:5/5.37::gentoo  USE="X nls -debug -doc {-test}" 35 KiB
[ebuild  N     ] kde-frameworks/kcrash-5.37.0:5/5.37::gentoo  USE="nls -debug -doc {-test}" 22 KiB
[ebuild  N     ] kde-frameworks/karchive-5.37.0:5/5.37::gentoo  USE="bzip2 lzma -debug -doc {-test}" 111 KiB
[ebuild  N     ] kde-frameworks/kconfig-5.37.0:5/5.37::gentoo  USE="nls -debug -doc {-test}" 228 KiB
[ebuild  N     ] kde-frameworks/kitemviews-5.37.0:5/5.37::gentoo  USE="nls -debug -doc {-test}" 74 KiB
[ebuild  N     ] kde-frameworks/kguiaddons-5.37.0:5/5.37::gentoo  USE="-debug -doc {-test}" 40 KiB
[ebuild  N     ] kde-frameworks/kcodecs-5.37.0:5/5.37::gentoo  USE="nls -debug -doc {-test}" 214 KiB
[ebuild  N     ] kde-frameworks/kdoctools-5.37.0:5/5.37::gentoo  USE="-debug -doc {-test}" 408 KiB
[ebuild  NS    ] kde-frameworks/kfilemetadata-5.37.0:5/5.37::gentoo [4.14.3:4/4.14::gentoo] USE="exif pdf taglib -debug -doc -epub -ffmpeg -libav -office {-test}" 214 KiB
[ebuild  N     ] kde-frameworks/kauth-5.37.0:5/5.37::gentoo  USE="nls (policykit) -debug -doc {-test}" 83 KiB
[ebuild  N     ] kde-frameworks/kconfigwidgets-5.37.0:5/5.37::gentoo  USE="man -debug -doc {-test}" 367 KiB
[ebuild  N     ] kde-frameworks/kiconthemes-5.37.0:5/5.37::gentoo  USE="-debug -doc {-test}" 201 KiB
[ebuild  N     ] kde-plasma/polkit-kde-agent-5.10.5:5::gentoo  USE="-debug" 41 KiB
[blocks B      ] <kde-apps/kde4-l10n-15.12.3-r1 ("<kde-apps/kde4-l10n-15.12.3-r1" is blocking kde-frameworks/kdbusaddons-5.37.0, kde-frameworks/kconfig-5.37.0, kde-frameworks/kwindowsystem-5.37.0, kde-frameworks/kitemviews-5.37.0, kde-frameworks/kcodecs-5.37.0, kde-frameworks/kdoctools-5.37.0, kde-frameworks/kfilemetadata-5.37.0, kde-frameworks/kcoreaddons-5.37.0, kde-frameworks/kwidgetsaddons-5.37.0, kde-plasma/polkit-kde-agent-5.10.5, kde-frameworks/karchive-5.37.0, kde-frameworks/kcrash-5.37.0, kde-frameworks/kiconthemes-5.37.0, kde-frameworks/ki18n-5.37.0, kde-frameworks/kguiaddons-5.37.0, kde-frameworks/kauth-5.37.0, kde-frameworks/kconfigwidgets-5.37.0)

Total: 23 packages (1 upgrade, 18 new, 3 in new slots, 1 reinstall, 2 uninstalls), Size of downloads: 234454 KiB
Conflict: 3 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (kde-frameworks/kfilemetadata-5.37.0:5/5.37::gentoo, ebuild scheduled for merge) pulled in by
    kde-frameworks/kfilemetadata

  (kde-apps/kde4-l10n-15.08.3-r2:4/15.08::gentoo, installed) pulled in by
    kde-apps/kde4-l10n required by @selected
    >=kde-apps/kde4-l10n-4.14.3-r1:4[-aqua] required by (kde-apps/kdepim-meta-4.14.10-r1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.14.3-r1:4[-aqua] required by (kde-apps/kde-meta-4.14.3-r1:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_ru(+)] required by (kde-plasma/kscreen-1.0.71_p20150824:4/4::gentoo, installed)
    >=kde-apps/kde4-l10n-4.4:4[-aqua,linguas_ru(+)] required by (kde-plasma/kde-gtk-config-2.2.1:4/4::gentoo, installed)

  (kde-plasma/polkit-kde-agent-5.10.5:5/5::gentoo, ebuild scheduled for merge) pulled in by
    kde-plasma/polkit-kde-agent required by (sys-auth/polkit-0.113:0/0::gentoo, installed)
    kde-plasma/polkit-kde-agent required by (kde-frameworks/kauth-5.37.0:5/5.37::gentoo, ebuild scheduled for merge)
    kde-plasma/polkit-kde-agent required by (kde-frameworks/kdelibs-4.14.16:4/4.14::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


.

So next step is to unmerge kde4-l10n?

Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16898
Location: here

PostPosted: Sat Dec 02, 2017 4:22 pm    Post subject: Reply with quote

Yes you can remove kde-apps/kde4-l10n, in my plasma system is no longer required
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Sat Dec 02, 2017 4:31 pm    Post subject: Reply with quote

Hi,
It looks like this won't help as kdelibs will not be updated:

Code:

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

kde-frameworks/kdelibs:4

  (kde-frameworks/kdelibs-4.14.37:4/4.14::gentoo, ebuild scheduled for merge) conflicts with
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/konqueror-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ktux-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kdebase-cursors-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kdepim-l10n-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kcheckpass-4.11.22-r1:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/killbots-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kwordquiz-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua,handbook] required by (kde-plasma/ksysguard-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/okular-15.08.3-r1:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ktouch-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kmines-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/ksystemlog-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kubrick-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua,handbook] required by (kde-plasma/kdm-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/granatier-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kturtle-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kwrited-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/ksquares-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kanagram-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kwordquiz-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kjumpingcube-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/konqueror-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kapman-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ark-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kteatime-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/phonon-kde-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kcron-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kwrite-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kstartupconfig-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/libtaskmanager-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/filelight-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kalzium-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/ksplash-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/keditbookmarks-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kblackbox-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kfourinline-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/rocs-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/granatier-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/picmi-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/zeroconf-ioslave-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kbreakout-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/dolphin-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/ktimer-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kshisen-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.4:4[-aqua] required by (kde-plasma/libkscreen-1.0.5_p20150822:4/4::gentoo, installed)
                                   ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/bomber-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kollision-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kgeography-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/knetwalk-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/baloo-widgets-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kwrite-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/libkdeedu-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kiriki-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/rocs-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/marble-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/libkcddb-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kruler-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kephal-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/artikulate-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/libkcddb-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kollision-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kcalc-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/krunner-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kolourpaint-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kbounce-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/gwenview-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kig-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/gwenview-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kstars-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kwin-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua,handbook] required by (kde-plasma/klipper-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/ark-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ksystemlog-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/knetwalk-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/freespacenotifier-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kapman-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kqtquickcharts-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-frameworks/kfilemetadata-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kde-wallpapers-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/dragon-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/amor-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-plasma/kgamma-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kcminit-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/liboxygenstyle-4.11.22:4/4.11.22::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kdm-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kblackbox-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/dolphin-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/killbots-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kbounce-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/cantor-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/krdc-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kigo-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/amor-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kfourinline-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kanagram-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kturtle-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kde-base-artwork-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kiriki-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/analitza-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/konquest-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kdepim-l10n-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kate-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kpat-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kblocks-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/konquest-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/konsole-4.14.3-r2:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kblocks-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kgeography-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kdiamond-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kcharselect-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kalzium-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/katomic-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kget-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kiten-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kigo-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua,handbook] required by (kde-plasma/systemsettings-4.11.22-r1:4/4.11::gentoo, installed)
                                       ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/dragon-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kiten-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/blinken-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kfind-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/krdc-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kinfocenter-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kamera-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kamera-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kcolorchooser-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kbreakout-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/solid-actions-kcm-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kcron-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kpat-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/katomic-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/systemsettings-4.11.22-r1:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kteatime-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/step-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/ksmserver-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/klettres-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/powerdevil-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/thumbnailers-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kget-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua,handbook] required by (kde-plasma/kmenuedit-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/bovo-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/klines-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kstars-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kolourpaint-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/khelpcenter-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/khelpcenter-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kalgebra-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ksquares-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/khotkeys-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ktimer-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kdialog-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/marble-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kmix-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kcharselect-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kalgebra-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kdebase-startkde-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/step-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/ktouch-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kdegraphics-mobipocket-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/bovo-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kdiamond-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/libplasmagenericshell-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/klipper-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kshisen-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/klettres-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/blinken-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/khangman-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/khangman-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kmplot-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/filelight-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/ksysguard-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kate-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/konsole-4.14.3-r2:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kfind-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kjumpingcube-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua,opengl] required by (kde-plasma/kwin-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^       
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/klines-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua,handbook] required by (kde-plasma/kinfocenter-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kbruch-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kcalc-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/artikulate-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.4:4[-aqua] required by (kde-plasma/kde-gtk-config-2.2.1:4/4::gentoo, installed)
                                   ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kbruch-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/ksystraycmd-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kscreensaver-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kmenuedit-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/okular-15.08.3-r1:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/svgpart-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/cantor-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kig-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/bomber-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kmines-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ksnakeduel-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kubrick-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.4:4[-aqua] required by (kde-plasma/kscreen-1.0.71_p20150824:4/4::gentoo, installed)
                                   ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/parley-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/kmplot-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/parley-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^         
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/kstyles-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/juk-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-plasma/kgamma-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kmix-4.14.3-r1:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.11.22:4[-aqua] required by (kde-plasma/libkgreeter-4.11.22:4/4.11::gentoo, installed)
                                       ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/kruler-4.14.3:4/4.14::gentoo, installed)
                                      ^^^^^
    >=kde-frameworks/kdelibs-4.14.3:4[-aqua,handbook] required by (kde-apps/juk-15.08.3:4/15.08::gentoo, installed)
                                      ^^^^^         


!!! The following installed packages are masked:
- sys-firmware/b43-firmware-6.30.163.46::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# MichaŠGórny <mgorny@gentoo.org> (22 May 2017)
# for Maciej S. Szmigiero <mail@maciej.szmigiero.name>
# Any version above 5.100.138 breaks b43 driver in various ways.
# Also, b43 wiki page says to use 5.100.138. Bug #541080.

- sys-devel/binutils-2.25.1-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# MichaŠGórny <mgorny@gentoo.org>, Andreas K. Hüttel <dilfridge@gentoo.org>,
# Matthias Maier <tamiko@gentoo.org> (21 May 2017)
# These old versions of toolchain packages (binutils, gcc, glibc) are no
# longer officially supported and are not suitable for general use. Using
# these packages can result in build failures (and possible breakage) for
# many packages, and may leave your system vulnerable to known security
# exploits.
# If you still use one of these old toolchain packages, please upgrade (and
# switch the compiler / the binutils) ASAP. If you need them for a specific
# (isolated) use case, feel free to unmask them on your system.

- sys-libs/glibc-2.21-r2::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Any other idea?

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5569
Location: Austria

PostPosted: Sat Dec 02, 2017 4:42 pm    Post subject: Reply with quote

Because you've never cleaned up your system before.

Code:
>=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/ktux-15.08.3:4/15.08::gentoo, installed)

Code:
$ git log -- kde-apps/ktux

commit 246c8b76303322eaef7c7393888485980a451215
Author: Johannes Huber
Date:   Thu Jun 23 13:26:53 2016 +0200

    kde-apps/ktux: Remove last-rited pkg
   
    Last rited on 2016/05/22.


Code:
>=kde-frameworks/kdelibs-4.14.3:4[-aqua] required by (kde-apps/amor-15.08.3:4/15.08::gentoo, installed)

Code:
$ git log -- kde-apps/amor

6ad9165a5c3022eeebf8fc23baebf317ba6440e6
Author: Johannes Huber
Date:   Thu Jun 23 13:25:51 2016 +0200

    kde-apps/amor: Remove last-rited pkg
   
    Last rited on 2016/05/22.


There are many other dead packages in there, you should definitely remove kde-plasma/kdm as well, others are hopefully covered by blocks and thus would be auto-unmerged by portage.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Sat Dec 02, 2017 4:58 pm    Post subject: Reply with quote

OK,
So remove all of those from the list? Since I will go to KDE5 anyway...
Or just do it selectively after checking the "git log"?

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5569
Location: Austria

PostPosted: Sat Dec 02, 2017 5:03 pm    Post subject: Reply with quote

I've given you three relevant examples I found, read my post, remove them and retry.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 11424

PostPosted: Sat Dec 02, 2017 5:08 pm    Post subject: Reply with quote

Remove all packages that are no longer in tree. As a general rule, Gentoo maintainers do not create/retain blockers for packages that no longer exist, so Portage will offer you substantially less help in resolving conflicts that involve dead packages.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6  Next
Page 5 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum