Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]: qt4 and qt5
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Mon Nov 20, 2017 6:08 am    Post subject: [SOLVED]: qt4 and qt5 Reply with quote

Hi, ALL,
Is it possible to have qt4 and qt5 slotted in one machine?
Or I will have to upgrade my KDE environment as well?

Thank you.


Last edited by ONEEYEMAN on Sun Dec 10, 2017 1:22 am; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5579
Location: Austria

PostPosted: Mon Nov 20, 2017 6:37 am    Post subject: Reply with quote

Erm... Could you tell us your problem exactly? Qt IS slotted.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Mon Nov 20, 2017 12:47 pm    Post subject: Reply with quote

Hi,
I just synced and then got following:

Code:

emerge -pv qt5

/etc/portage/make.profile is not a symlink and will probably prevent most merges.
It should point into a profile within /usr/portage/profiles/
(You can safely ignore this message when syncing. It;s harmless.)

You current profile is invalid. If you have just changed your profile
configuration, you should revert back to the previous configuration.
Allowed action are limited to --help, --info, --search --sync and
--version


Trouble is I didn't change anything. All I did is sync'ed the tree, which shouldn't make profile invalid, right?

Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16932
Location: here

PostPosted: Mon Nov 20, 2017 12:54 pm    Post subject: Reply with quote

You can post eselect profile list and ls -l /etc/portage/?
Yes a sync can make profile invalid if this is removed from protage tree
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Mon Nov 20, 2017 1:18 pm    Post subject: Reply with quote

Hi,
Code:

IgorDellGentoo dbhandler # eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/13.0
  [2]   default/linux/amd64/13.0/selinux
  [3]   default/linux/amd64/13.0/desktop
  [4]   default/linux/amd64/13.0/desktop/gnome
  [5]   default/linux/amd64/13.0/desktop/gnome/systemd
  [6]   default/linux/amd64/13.0/desktop/plasma
  [7]   default/linux/amd64/13.0/desktop/plasma/systemd
  [8]   default/linux/amd64/13.0/developer
  [9]   default/linux/amd64/13.0/no-multilib
  [10]  default/linux/amd64/13.0/systemd
  [11]  default/linux/amd64/13.0/x32
  [12]  hardened/linux/amd64
  [13]  hardened/linux/amd64/selinux
  [14]  hardened/linux/amd64/no-multilib
  [15]  hardened/linux/amd64/no-multilib/selinux
  [16]  hardened/linux/amd64/x32
  [17]  hardened/linux/musl/amd64
  [18]  hardened/linux/musl/amd64/x32
  [19]  default/linux/uclibc/amd64
  [20]  hardened/linux/uclibc/amd64
IgorDellGentoo dbhandler # ls -l /etc/portage/
total 56
drwxr-xr-x 2 root root 4096 Apr 18  2016 bin
-rw-r--r-- 1 root root  816 Apr 18  2016 make.conf
-rw-r--r-- 1 root root  630 May 28  2014 make.conf.catalyst
lrwxrwxrwx 1 root root   63 Jun  3  2014 make.profile -> ../../usr/portage/profiles/default/linux/amd64/13.0/desktop/kde
-rw-r--r-- 1 root root   26 Jul 13  2014 package.accept_keywords
-rw-r--r-- 1 root root  864 Mar 19  2017 package.keywords
-rw-r--r-- 1 root root  150 Feb 13  2017 package.license
-rw-r--r-- 1 root root   21 Apr 17  2016 package.mask
-rw-r--r-- 1 root root  744 Mar 25  2017 package.use
drwxr-xr-x 2 root root 4096 Apr 18  2016 postsync.d
drwxr-xr-x 2 root root 4096 Mar 18  2017 profile
drwxr-xr-x 2 root root 4096 Dec  3  2016 repo.postsync.d
drwxr-xr-x 2 root root 4096 Dec  2  2016 repos.conf
drwxr-xr-x 4 root root 4096 Aug  9  2014 savedconfig

I just wanted the latest qt5 installed for development. I have KDE 4installed and don't want to go KDE 5 as it more resource-unfriendly and I have kind of old and simple laptop.

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5579
Location: Austria

PostPosted: Mon Nov 20, 2017 1:21 pm    Post subject: Reply with quote

When did you last sync before that? Of course removal of a profile is announced in the Portage news well in advance.
Plasma 5 does not need any more resources than 4. In fact it runs better.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Mon Nov 20, 2017 1:31 pm    Post subject: Reply with quote

Hi,
asturm wrote:

When did you last sync before that? Of course removal of a profile is announced in the Portage news well in advance.
Plasma 5 does not need any more resources than 4. In fact it runs better.


Will Plasma run successfully here? Or I will see a lag once in a while? Or even crashes?

Code:

IgorDellGentoo dbhandler # cat /proc/meminfo
MemTotal:        2013144 kB
MemFree:          100572 kB
MemAvailable:    1082380 kB
Buffers:          240716 kB
Cached:           603952 kB
SwapCached:        46240 kB
Active:           939304 kB
Inactive:         572452 kB
Active(anon):     578064 kB
Inactive(anon):   222608 kB
Active(file):     361240 kB
Inactive(file):   349844 kB
Unevictable:           0 kB
Mlocked:               0 kB
SwapTotal:       1913852 kB
SwapFree:        1381024 kB
Dirty:               220 kB
Writeback:             0 kB
AnonPages:        641928 kB
Mapped:           172592 kB
Shmem:            133584 kB
Slab:             342076 kB
SReclaimable:     291592 kB
SUnreclaim:        50484 kB
KernelStack:        6752 kB
PageTables:        30740 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:     2920424 kB
Committed_AS:    3391008 kB
VmallocTotal:   34359738367 kB
VmallocUsed:      342300 kB
VmallocChunk:   34358947836 kB
HardwareCorrupted:     0 kB
AnonHugePages:    206848 kB
HugePages_Total:       0
HugePages_Free:        0
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       2048 kB
DirectMap4k:       17148 kB
DirectMap2M:     2041856 kB
IgorDellGentoo dbhandler #
IgorDellGentoo dbhandler # df -k
Filesystem     1K-blocks     Used Available Use% Mounted on
/dev/sda4      249835380 91994024 145127372  39% /
tmpfs             201316      876    200440   1% /run
dev                10240        0     10240   0% /dev
shm              1006572        4   1006568   1% /dev/shm
cgroup_root        10240        0     10240   0% /sys/fs/cgroup
none             1006572        0   1006572   0% /run/user/1000


Thank you.

P.S.: Also what is the best way to upgrade? Is there a documentation about it somewhere? I was just tried to install qt5 for development, but it looks like I will have to go KDE 5 as well...
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16932
Location: here

PostPosted: Mon Nov 20, 2017 1:37 pm    Post subject: Reply with quote

https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade
https://wiki.gentoo.org/wiki/KDE
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
davidm
Guru
Guru


Joined: 26 Apr 2009
Posts: 552
Location: US

PostPosted: Mon Nov 20, 2017 2:19 pm    Post subject: Reply with quote

Code:

lrwxrwxrwx 1 root root   63 Jun  3  2014 make.profile -> ../../usr/portage/profiles/default/linux/amd64/13.0/desktop/kde


See that profile no longer exists. It has basically been replaced with plasma. So you will have to select a valid profile.

I would second the suggestion to go to plasma. Plasma is a bit more modularized than the old kde 4 workspace so you can be more selective on what you install if you wish. That can help you keep things more minimalistic.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Mon Nov 20, 2017 3:28 pm    Post subject: Reply with quote

Hi,
I put my hardware spec on the reply above. Will I be able to successfully run KDE5/Plasma?

Thank you.

P.S.: This an old DELL laptop.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Mon Nov 20, 2017 4:45 pm    Post subject: Reply with quote

Hi,
fedeliallalinea wrote:

https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade
https://wiki.gentoo.org/wiki/KDE


Is there any reason why the first link says:

Quote:

Only the @world file is going to be changed - while the packages stay installed, they will not block a subsequent installation of Plasma 5.


Shouldn't it be better to remove those packages if they are no longer used by Plasma?

Thank you.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5579
Location: Austria

PostPosted: Mon Nov 20, 2017 5:07 pm    Post subject: Reply with quote

That's the description of one particular step in the whole process. It simply makes you not lose any of the stuff you may be depending on *right now*, until you run emerge --depclean after the upgrade has finished, anyway.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Tue Nov 21, 2017 1:09 am    Post subject: Reply with quote

OK, so I started upgrading process.
I changed the profile and removed the packages from world.

The next step I get following:

Code:

IgorDellGentoo dbhandler # emerge --ask --changed-use --newrepo --deep world
!!! Invalid news item: /usr/portage/metadata/news/2017-10-04-gentoolkit-dev-deprecation/2017-10-04-gentoolkit-dev-deprecation.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-10-10-perl-5_26-update/2017-10-10-perl-5_26-update.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-04-10-split-and-slotted-wine/2017-04-10-split-and-slotted-wine.en.txt
!!!   line 6: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-07-16-systemd-rootprefix/2017-07-16-systemd-rootprefix.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-08-19-hardened-sources-removal/2017-08-19-hardened-sources-removal.en.txt
!!!   line 5: News-Item-Format: 2.0


Is it something that should be fixed right now?

Thank you.

P.S.: 2mods: if needed I can create a new thread for the actual update.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16932
Location: here

PostPosted: Tue Nov 21, 2017 7:01 am    Post subject: Reply with quote

ONEEYEMAN wrote:
Is it something that should be fixed right now?

Your portage is too old, read here
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Tue Nov 21, 2017 1:25 pm    Post subject: Reply with quote

Hi,
I guess I first need to update Portage as it should be the first package to update.

In the meantime running the command to recompile the old packages fails:

Code:

IgorDellGentoo dbhandler # emerge --ask --changed-use --newrepo --deep world
!!! Invalid news item: /usr/portage/metadata/news/2017-10-04-gentoolkit-dev-deprecation/2017-10-04-gentoolkit-dev-deprecation.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-10-10-perl-5_26-update/2017-10-10-perl-5_26-update.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-04-10-split-and-slotted-wine/2017-04-10-split-and-slotted-wine.en.txt
!!!   line 6: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-07-16-systemd-rootprefix/2017-07-16-systemd-rootprefix.en.txt
!!!   line 5: News-Item-Format: 2.0
!!! Invalid news item: /usr/portage/metadata/news/2017-08-19-hardened-sources-removal/2017-08-19-hardened-sources-removal.en.txt
!!!   line 5: News-Item-Format: 2.0

 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


 * IMPORTANT: config file '/etc/portage/package.keywords' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:4

  (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtcore-4.8.6[-aqua,-debug,glib,qt3support,abi_x86_64(-)] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
    ^              ^^^^^
    (and 9 more with the same problem)

  (dev-qt/qtcore-4.8.7-r3:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    >=dev-qt/qtcore-4.8.7-r2:4 required by (media-libs/phonon-vlc-0.9.1-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^^^^
    (and 12 more with the same problems)

dev-qt/qtcore:5

  (dev-qt/qtcore-5.6.2-r1:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtcore-5.6.2 required by (dev-qt/qtopengl-5.6.2:5/5.6::gentoo, installed)
    ^              ^^^^^
    (and 4 more with the same problem)

  (dev-qt/qtcore-5.7.1-r3:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtcore-5.7.1 required by (dev-qt/qttest-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    >=dev-qt/qtcore-5.7.1:5 required by (kde-apps/kcalcore-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^
    (and 143 more with the same problems)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.7.1-r1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-5.7.1[egl] required by (dev-qt/qtwayland-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^             ^^^^^
    >=dev-qt/qtgui-5.7.1:5 required by (kde-frameworks/baloo-5.37.0:5/5.37::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^
    (and 105 more with the same problems)

  (dev-qt/qtgui-5.6.2:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtgui-5.6.2[-gles2,-gtkstyle,png,xcb] required by (dev-qt/qtwidgets-5.6.2:5/5.6::gentoo, installed)
    ^             ^^^^^
    (and 2 more with the same problem)

dev-qt/qtgui:4

  (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtgui-4.8.6[-aqua,-debug,-egl,qt3support,abi_x86_64(-)] required by (dev-qt/qtopengl-4.8.6-r1:4/4::gentoo, installed)
    ^             ^^^^^
    (and 4 more with the same problem)

  (dev-qt/qtgui-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtgui-4.8.7[aqua=,debug=,glib=,qt3support,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtcore-4.8.7-r3:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^
    >=dev-qt/qtgui-4.8.7:4 required by (media-libs/phonon-vlc-0.9.1-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^             ^^^^^^^
    (and 7 more with the same problems)

dev-qt/qtdbus:4

  (dev-qt/qtdbus-4.8.6-r1:4/4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtdbus-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtdbus-4.8.7:4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/phonon-4.9.1-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^
    (and 1 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtdbus-5.7.1:5 required by (kde-frameworks/kjobwidgets-5.37.0:5/5.37::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^
    ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qdbus-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^              ^^^^^
    (and 58 more with the same problems)

  (dev-qt/qtdbus-5.6.2:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtdbus-5.6.2 required by (dev-qt/qtgui-5.6.2:5/5.6::gentoo, installed)
    ^              ^^^^^

dev-libs/libtasn1:0

  (dev-libs/libtasn1-4.5:0/6::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libtasn1-4.12-r1:0/6::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libtasn1-4.9:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (net-libs/gnutls-3.5.15:0/30::gentoo, ebuild scheduled for merge)
    ^^                  ^^^

dev-qt/qtscript:4

  (dev-qt/qtscript-4.8.6-r2:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtscript-4.8.6[-aqua,-debug,abi_x86_64(-)] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
    ^                ^^^^^

  (dev-qt/qtscript-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtscript-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/designer-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                ^^^^^
    (and 2 more with the same problem)

dev-qt/qt3support:4

  (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qt3support-4.8.6[-aqua,-debug,abi_x86_64(-)] required by (dev-qt/qtgui-4.8.6-r4:4/4::gentoo, installed)
    ^                  ^^^^^

  (dev-qt/qt3support-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qt3support-4.8.7[accessibility=,aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,
abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                  ^^^^^
    (and 2 more with the same problem)

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.6.2:5/5.6::gentoo, installed) pulled in by
    ~dev-qt/qtwidgets-5.6.2[-gles2] required by (dev-qt/qtopengl-5.6.2:5/5.6::gentoo, installed)
    ^                 ^^^^^

  (dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtwidgets-5.7.1:5 required by (kde-apps/kdepim-apps-libs-17.04.3:5/5::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^
    ~dev-qt/qtwidgets-5.7.1 required by (dev-qt/qtscript-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                 ^^^^^
    (and 84 more with the same problems)

dev-libs/openssl:0

  (dev-libs/openssl-1.0.2m:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.0.2:0=[-bindist(-)] required by (dev-python/cryptography-2.0.2-r1:0/0::gentoo, ebuild scheduled for merge)


  (dev-libs/openssl-1.0.2g-r2:0/0::gentoo, installed) pulled in by
    dev-libs/openssl:0[bindist=] required by (dev-qt/qtnetwork-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
                       ^^^^^^^^

dev-qt/qtsvg:4

  (dev-qt/qtsvg-4.8.6-r1:4/4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtsvg-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsvg-4.8.7[accessibility=,aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^

dev-qt/qtopengl:4

  (dev-qt/qtopengl-4.8.6-r1:4/4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtopengl-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtopengl-4.8.7[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                ^^^^^

dev-qt/qtopengl:5

  (dev-qt/qtopengl-5.6.2:5/5.6::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtopengl-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtopengl-5.7.1 required by (dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, ebuild scheduled for merge)
    ^                ^^^^^

dev-qt/qtxmlpatterns:4

  (dev-qt/qtxmlpatterns-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtxmlpatterns-4.8.7[aqua=,debug=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^                     ^^^^^

  (dev-qt/qtxmlpatterns-4.8.6-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtxmlpatterns-4.8.6[-aqua,-debug,abi_x86_64(-)] required by (dev-qt/qtwebkit-4.8.6-r1:4/4::gentoo, installed)
    ^                     ^^^^^

dev-qt/qtsql:4

  (dev-qt/qtsql-4.8.7-r1:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qtsql-4.8.7[aqua=,debug=,qt3support=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?] required by (dev-qt/qtdeclarative-4.8.7:4/4::gentoo, ebuild scheduled for merge)
    ^             ^^^^^
    (and 1 more with the same problem)

  (dev-qt/qtsql-4.8.6-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qtsql-4.8.6[-aqua,-debug,qt3support,abi_x86_64(-)] required by (dev-qt/qt3support-4.8.6-r1:4/4::gentoo, installed)
    ^             ^^^^^

dev-qt/qttranslations:4

  (dev-qt/qttranslations-4.8.7:4/4::gentoo, ebuild scheduled for merge) pulled in by
    ~dev-qt/qttranslations-4.8.7 required by (dev-qt/qtcore-4.8.7-r3:4/4::gentoo, ebuild scheduled for merge)
    ^                      ^^^^^

  (dev-qt/qttranslations-4.8.6-r1:4/4::gentoo, installed) pulled in by
    ~dev-qt/qttranslations-4.8.6 required by (dev-qt/qtcore-4.8.6-r2:4/4::gentoo, installed)
    ^                      ^^^^^

x11-misc/xdg-utils:0

  (x11-misc/xdg-utils-1.1.1:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-misc/xdg-utils-1.1.1-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-misc/xdg-utils-1.1.1-r1 required by (kde-frameworks/kf-env-4:5/5::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^

dev-qt/qtx11extras:5

  (dev-qt/qtx11extras-5.6.2:5/5.6::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-qt/qtx11extras-5.7.1:5/5.7::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-qt/qtx11extras-5.7.1:5 required by (kde-frameworks/kidletime-5.37.0:5/5.37::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^
    (and 19 more with the same problem)

dev-db/sqlite:3

  (dev-db/sqlite-3.11.1:3/3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-db/sqlite-3.19.3:3/3::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-db/sqlite-3.17.0:3[secure-delete,debug=] required by (www-client/firefox-52.4.0:0/0::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^^^

dev-libs/glib:2

  (dev-libs/glib-2.46.2-r2:2/2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/glib-2.50.3-r1:2/2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.50:2 required by (dev-libs/gobject-introspection-1.50.0:0/0::gentoo, ebuild scheduled for merge)
    ^^              ^^^^^^

media-libs/libvpx:0

  (media-libs/libvpx-1.3.0:0/0::gentoo, installed) pulled in by
    media-libs/libvpx:0/0= required by (app-emulation/virtualbox-5.1.14:0/0::gentoo, installed)
                     ^^^^^

  (media-libs/libvpx-1.5.0:0/3::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libvpx-1.5:=[svc] required by (dev-qt/qtwebengine-5.7.1-r2:5/5.7::gentoo, ebuild scheduled for merge)
    ^^                  ^^^

net-libs/gnutls:0

  (net-libs/gnutls-3.5.15:0/30::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-libs/gnutls-3.3.17.1:0/0::gentoo, installed) pulled in by
    >=net-libs/gnutls-3:0/0=[abi_x86_64(-)] required by (net-libs/glib-networking-2.46.1:0/0::gentoo, installed)
                       ^^^^^

dev-libs/nettle:0

  (dev-libs/nettle-3.3-r2:0/6.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/nettle-3.1:=[gmp,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (net-libs/gnutls-3.5.15:0/30::gentoo, ebuild scheduled for merge)
    ^^                ^^^

  (dev-libs/nettle-2.7.1-r4:0/4::gentoo, installed) pulled in by
    >=dev-libs/nettle-2.7:0/4=[gmp,abi_x86_64(-)] required by (net-libs/gnutls-3.3.17.1:0/0::gentoo, installed)
                         ^^^^^

dev-python/certifi:0

  (dev-python/certifi-2015.11.20:0/0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-python/certifi-2017.4.17:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-python/certifi-2017.4.17[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,
python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,
-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),
-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by (dev-python/requests-2.18.2-r1:0/0::gentoo, ebuild scheduled for merge)
    ^^                   ^^^^^^^^^

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/cryptography-2.0.2-r1::gentoo[-libressl]
# required by dev-python/urllib3-1.22::gentoo
# required by dev-python/requests-2.18.2-r1::gentoo
# required by dev-python/ssl-fetch-0.4::gentoo
# required by app-portage/layman-2.4.2::gentoo
# required by @selected
# required by @world (argument)
>=dev-libs/openssl-1.0.2m -bindist

Would you like to add these changes to your config files? [Yes/No] n

!!! The following updates are masked by LICENSE changes:
- app-emulation/virtualbox-extpack-oracle-5.1.26.117224::gentoo (masked by: PUEL license(s))
A copy of the 'PUEL' license is located at '/usr/portage/licenses/PUEL'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


emerge: there are no ebuilds to satisfy "sys-libs/ncurses:0/5=".
(dependency required by "dev-lang/ruby-2.1.7::gentoo" [installed])
(dependency required by "dev-qt/qtwebkit-5.7.1::gentoo" [ebuild])
(dependency required by "kde-plasma/libksysguard-5.10.5::gentoo[detailedmemory]" [ebuild])
(dependency required by "kde-plasma/plasma-workspace-5.10.5-r1::gentoo" [ebuild])
(dependency required by "kde-plasma/kdeplasma-addons-5.10.5::gentoo" [ebuild])
(dependency required by "kde-plasma/plasma-meta-5.10.5::gentoo" [ebuild])
(dependency required by "kde-apps/kde-meta-17.04.3::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


I will try to fight with Portage upgrade now. ;-)

Thank you.

[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Tue Nov 21, 2017 2:00 pm    Post subject: Reply with quote

OK, as you can see below Portage is successfully installed. But it is asking to rebuild some packages:

Code:

>>> Installing (2 of 2) sys-apps/portage-2.3.13-r1::gentoo
 *
 * This release of portage NO LONGER contains the repoman code base.
 * Repoman has its own ebuild and release package.
 * For repoman functionality please emerge app-portage/repoman
 * Please report any bugs you may encounter.
 *
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: sys-libs/ncurses-6.0-r1
 *  - /usr/lib64/libmenuw.so.5
 *  - /usr/lib64/libmenuw.so.5.9
 *      used by /usr/bin/alsamixer (media-sound/alsa-utils-1.0.29)
 *  - /usr/lib64/libformw.so.5
 *  - /usr/lib64/libformw.so.5.9
 *      used by /usr/bin/alsamixer (media-sound/alsa-utils-1.0.29)
 *  - /usr/lib64/libpanelw.so.5
 *  - /usr/lib64/libpanelw.so.5.9
 *      used by /usr/bin/alsamixer (media-sound/alsa-utils-1.0.29)
 *      used by /usr/lib64/python2.7/lib-dynload/_curses_panel.so (dev-lang/python-2.7.10-r1)
 *      used by /usr/lib64/python3.4/lib-dynload/_curses_panel.cpython-34.so (dev-lang/python-3.4.3-r1)
 *  - /lib64/libncurses.so.5
 *  - /lib64/libncurses.so.5.9
 *      used by /bin/bash (app-shells/bash-4.3_p42-r1)
 *      used by /lib64/libgpm.so.1.20.0 (sys-libs/gpm-1.20.7-r2)
 *      used by /lib64/libreadline.so.6.3 (sys-libs/readline-6.3_p8-r2)
 *      used by 9 other files
 *  - /lib64/libncursesw.so.5
 *  - /lib64/libncursesw.so.5.9
 *      used by /usr/bin/alsamixer (media-sound/alsa-utils-1.0.29)
 *      used by /usr/bin/hunspell (app-text/hunspell-1.3.3)
 *      used by /usr/lib64/python2.7/lib-dynload/_curses.so (dev-lang/python-2.7.10-r1)
 *      used by 5 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries


However doing so fails:

Code:

IgorDellGentoo dbhandler # emerge @preserved-rebuild

 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


 * IMPORTANT: config file '/etc/portage/package.keywords' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-lang/ruby:2.0".
(dependency required by "@preserved-rebuild" [argument])
IgorDellGentoo dbhandler #


What is the best course of action? Install next version of Ruby?

Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16932
Location: here

PostPosted: Tue Nov 21, 2017 2:07 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
What is the best course of action? Install next version of Ruby?


Code:
 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5579
Location: Austria

PostPosted: Tue Nov 21, 2017 3:54 pm    Post subject: Reply with quote

Code:
 * IMPORTANT: config file '/etc/portage/package.keywords' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Tue Nov 21, 2017 4:54 pm    Post subject: Reply with quote

Hi,
fedeliallalinea wrote:

ONEEYEMAN wrote:

What is the best course of action? Install next version of Ruby?


Code:

 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


Yes, I read them and one says that the lifecycle is ended for Ruby-2.0.
However I fear that I won't be able to upgrade since the ebuild for 2.0 is gone and emerge will simply fail.

Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16932
Location: here

PostPosted: Tue Nov 21, 2017 5:00 pm    Post subject: Reply with quote

Try to see what package depend on old ruby
Code:
$ equery d dev-lang/ruby:2.0

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Tue Nov 21, 2017 5:14 pm    Post subject: Reply with quote

Hi,
OK, will do when I get back home.

Thx.

P.S.: I will fix everything from Portage update and then proceed with KDE update.

In the meantime - could you please check the result of world recompilation I posted earlier. It is confusing since it shouldn't fail with multiple dependencies of KDE 4 packages.

Thank you.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16932
Location: here

PostPosted: Tue Nov 21, 2017 5:30 pm    Post subject: Reply with quote

ONEEYEMAN wrote:
In the meantime - could you please check the result of world recompilation I posted earlier. It is confusing since it shouldn't fail with multiple dependencies of KDE 4 packages.

You can try to add --backtrack=300 as emerge option

EDIT: and as astum say run etc-update
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Tue Nov 21, 2017 5:45 pm    Post subject: Reply with quote

OK, will do.
I will give an update later.

Thx.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5579
Location: Austria

PostPosted: Tue Nov 21, 2017 6:07 pm    Post subject: Reply with quote

No offense, but shouldn't you have learned a thing or two from running that huge old-system-upgrade thread some time ago? Yet we still have to read your own portage output for you.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
ONEEYEMAN
Advocate
Advocate


Joined: 01 Mar 2005
Posts: 2659

PostPosted: Wed Nov 22, 2017 1:51 am    Post subject: Reply with quote

Hi,
fedeliallalinea wrote:

Try to see what package depend on old ruby
Code:

$ equery d dev-lang/ruby:2.0



The result is:

Code:

IgorDellGentoo dbhandler # equery d dev-lang/ruby:2.0
 * These packages depend on dev-lang/ruby:
dev-ruby/rubygems-2.2.5-r1 (dev-lang/ruby:2.0)
net-libs/webkit-gtk-2.10.7 (dev-lang/ruby:2.0)
virtual/rubygems-10 (dev-lang/ruby:2.0)


I don't use Ruby, I am C++ developer. I can probably safely uninstall both rubygems, and probably will need to update webkit-gtk.

Trying it gives:

Code:

IgorDellGentoo dbhandler # emerge -pv webkit-gtk

 * IMPORTANT: config file '/etc/portage/package.keywords' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-portage/elt-patches-20170815::gentoo  28 KiB
[ebuild     U  ] app-eselect/eselect-ruby-20161226::gentoo [20131227::gentoo] 2 KiB
[ebuild     U  ] sys-devel/gettext-0.19.8.1::gentoo [0.19.4::gentoo] USE="acl cxx ncurses nls openmp -cvs -doc -emacs -git -java -static-libs" ABI_X86="(64) -32 (-x32)" 19243 KiB
[ebuild     U  ] dev-libs/libgpg-error-1.27-r1::gentoo [1.19::gentoo] USE="nls -common-lisp -static-libs" ABI_X86="(64) -32 (-x32)" 795 KiB
[ebuild     U  ] dev-libs/libgcrypt-1.8.1:0/20::gentoo [1.6.5:0/20::gentoo] USE="-doc -static-libs (-threads%*)" ABI_X86="(64) -32 (-x32)" 2898 KiB
[ebuild  NS    ] dev-lang/ruby-2.2.8:2.2::gentoo [1.9.3_p551-r1:1.9::gentoo, 2.0.0_p647-r1:2.0::gentoo, 2.1.7:2.1::gentoo] USE="berkdb gdbm ipv6 ncurses rdoc readline ssl -debug -doc -examples -jemalloc -libressl -rubytests -socks5 -tk -xemacs" 10280 KiB
[ebuild     U  ] dev-ruby/rubygems-2.6.14::gentoo [2.2.5-r1::gentoo] USE="-server {-test}" RUBY_TARGETS="ruby22%* (-ruby23) (-ruby24) (-ruby19%) (-ruby20%*) (-ruby21%*)" 752 KiB
[ebuild     U  ] virtual/rubygems-11::gentoo [10::gentoo] RUBY_TARGETS="ruby22%* (-rbx) (-ruby23) (-ruby19%) (-ruby20%*) (-ruby21%*)" 0 KiB
[ebuild     U  ] dev-ruby/rake-10.5.0::gentoo [0.9.6-r1::gentoo] USE="-doc {-test}" RUBY_TARGETS="ruby22%* (-ruby23) (-ruby20%*) (-ruby21%*)" 128 KiB
[ebuild  N     ] dev-ruby/power_assert-0.3.1::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby22 (-ruby23)" 14 KiB
[ebuild  N     ] dev-ruby/test-unit-3.1.9:2::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby22 (-ruby23)" 122 KiB
[ebuild     U  ] dev-ruby/json-1.8.6-r1::gentoo [1.8.2-r1::gentoo] USE="-doc {-test}" RUBY_TARGETS="ruby22%* (-ruby23) (-ruby24) (-ruby19%) (-ruby20%*) (-ruby21%*)" 141 KiB
[ebuild  N     ] dev-ruby/minitest-5.9.1:5::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby22 (-ruby23)" 72 KiB
[ebuild   R    ] dev-ruby/racc-1.4.11::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby22%* (-ruby19%) (-ruby20%*) (-ruby21%*)" 0 KiB
[ebuild   R    ] dev-ruby/rdoc-4.2.0::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby22* (-ruby20%*) (-ruby21%*)" 0 KiB
[ebuild     U  ] dev-util/gdbus-codegen-2.50.3::gentoo [2.46.2::gentoo] PYTHON_TARGETS="python2_7 python3_4 -python3_5 (-python3_3%)" 7412 KiB
[ebuild     U  ] dev-libs/glib-2.50.3-r1:2::gentoo [2.46.2-r2:2::gentoo] USE="dbus (mime) xattr -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild     U  ] media-libs/gstreamer-1.10.5:1.0::gentoo [1.6.3:1.0::gentoo] USE="caps introspection nls orc {-test} (-unwind)" ABI_X86="(64) -32 (-x32)" 3710 KiB
[ebuild     U  ] media-libs/harfbuzz-1.4.6-r2:0/0.9.18::gentoo [1.1.3:0/0.9.18::gentoo] USE="cairo glib graphite icu introspection truetype -debug% -fontconfig -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 1441 KiB
[ebuild     U  ] media-libs/gst-plugins-base-1.10.5:1.0::gentoo [1.6.3:1.0::gentoo] USE="X alsa introspection nls ogg orc pango vorbis -ivorbis -theora" ABI_X86="(64) -32 (-x32)" 2989 KiB
[ebuild     U  ] x11-libs/gtk+-3.22.16:3::gentoo [3.18.7:3::gentoo] USE="X introspection xinerama (-aqua) -broadway -cloudprint -colord -cups -examples {-test} -vim-syntax -wayland (-debug%)" ABI_X86="(64) -32 (-x32)" 18218 KiB
[ebuild     U  ] media-libs/gst-plugins-bad-1.10.5:1.0::gentoo [1.6.3:1.0::gentoo] USE="X bzip2%* egl* gtk introspection nls opengl orc -gles2 {-test} -vcd -vnc -wayland" ABI_X86="(64) -32 (-x32)" 4627 KiB
[ebuild     U  ] net-libs/webkit-gtk-2.18.2:4/37::gentoo [2.10.7:4/37::gentoo] USE="(X) egl geolocation%* gstreamer introspection jit libnotify%* opengl spell webgl (-aqua) -coverage -doc -gles2 -gnome-keyring -nsplugin {-test} -wayland (-geoloc%*)" 14477 KiB

Total: 23 packages (16 upgrades, 4 new, 1 in new slot, 2 reinstalls), Size of downloads: 87341 KiB


Which makes Ruby-2.2 slotted, which means the old Ruby won't be un-installed.

Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3, 4, 5, 6  Next
Page 1 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum