Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mysql refuses to stop/restart after upgrade
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message

Joined: 18 May 2004
Posts: 173

PostPosted: Fri Nov 17, 2017 7:45 pm    Post subject: mysql refuses to stop/restart after upgrade Reply with quote


i just emerge some gentoo updates and now mysql refuses to restart.
But i'm not sure why.
/etc/init.d/mysql restart
 * Caching service dependencies ...                                                                                                                                                                      [ ok ]
 * Checking mysqld configuration for mysql ...
2017-11-17 20:25:51 0 [Note] --secure-file-priv is set to NULL. Operations related to importing and exporting data are disabled
2017-11-17 20:25:51 0 [Note] /usr/sbin/mysqld (mysqld 5.6.38) starting as process 24942 ...
19:25:51 UTC - mysqld got signal 11 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.

It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 412154 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x30000
The manual page at contains
information that should help you find out what is causing the crash.

This crash occured while the server was calling initgroups(). This is
often due to the use of a mysqld that is statically linked against
glibc and configured to use LDAP in /etc/nsswitch.conf.
You will need to either upgrade to a version of glibc that does not
have this problem (2.3.4 or later when used with nscd),
disable LDAP in your nsswitch.conf, or use a mysqld that is not statically linked.
 * mysql config check failed                                                                                                                                                                             [ !! ]
 * ERROR: mysql failed to stop

Mysql is built with these flags for years:
dev-db/mysql-5.6.38:0/18::gentoo  USE="openssl perl server -debug -embedded -extraengine -jemalloc -latin1 -libressl -numa -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test} -yassl"

And this is - also unchanged - my glibc:
sys-libs/glibc-2.25-r9:2.2::gentoo  USE="hardened nscd rpc -audit -caps -debug -gd (-multilib) (-profile) (-selinux) -suid -systemtap (-vanilla)

MySQL is still running just fine and i didn't enable ldap in /etc/nsswitch.conf.

The previous Version was MySQL 5.6.36. GCC and libc where rebuilt so they are the same versions as before
How can i solve this?

Best regards,
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum