Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Checking for workin nanosleep...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
moige
n00b
n00b


Joined: 17 Nov 2017
Posts: 4

PostPosted: Fri Nov 17, 2017 3:01 pm    Post subject: Checking for workin nanosleep... Reply with quote

Hi,

I have a problem when I tried to do emerge @preserved-rebuild. When emerge rebuild
Code:
net-misc/wget-1.19.1-r2
it got stuck in
Code:
checking for working nanosleep...
and nothing more happens.

This is my emerge info:
Code:
Portage 2.3.13 (python 3.4.5-final-0, default/linux/amd64/13.0, gcc-5.4.0, glibc-2.25-r9, 4.12.12-gentoo x86_64)
=================================================================
System uname: Linux-4.12.12-gentoo-x86_64-06-17-with-gentoo-2.4.1
KiB Mem:     1006264 total,    249744 free
KiB Swap:   10485756 total,  10470644 free
Timestamp of repository gentoo: Fri, 17 Nov 2017 12:00:01 +0000
Head commit of repository gentoo: 116c20ee8fa701f8e9277cea22dd114348df351b
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.14::gentoo, 3.4.5::gentoo, 3.6.3::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.34.8::gentoo
sys-apps/sandbox:         2.10-r4::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.15-r2::gentoo
sys-devel/binutils:       2.28.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r9::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.mirrors.easynews.com/linux/gentoo/ rsync://rsync.gtlib.gatech.edu/gentoo http://www.gtlib.gatech.edu/pub/gentoo http://lug.mtu.edu/gentoo/ http://gentoo.osuosl.org/ http://gentoo.mirrors.pair.com/ http://mirrors.rit.edu/gentoo/ rsync://mirrors.rit.edu/gentoo/ http://gentoo.mirrors.tds.net/gentoo http://mirror.lug.udel.edu/pub/gentoo/ http://cosmos.illinois.edu/pub/gentoo/ http://gentoo.cs.uni.edu/ rsync://gentoo.cs.uni.edu/gentoo-distfiles http://gentoo.cs.utah.edu/"
LANG="es_VE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 berkdb bindist bzip2 cli cracklib crypt cxx dri fortran gdbm glamor iconv ipv6 modules multilib ncurses nls nptl openmp pam pcre readline seccomp session ssl tcpd unicode xattr zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="intel i915" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


EDIT: Bug report


Last edited by moige on Mon Nov 20, 2017 12:42 am; edited 1 time in total
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16757

PostPosted: Sat Nov 18, 2017 3:12 am    Post subject: Reply with quote

How long have you waited to see if it completes?

There aren't a lot of results for that error, but I did read one suggesting it eventually finished.

It might be helpful to upload the build.log with wgetpaste and provide a link here. If you're not able to get that working, you could try posting the info here within code tags for readability. Depending on how long the build log is, that might be cumbersome.

Since that is occurring in the configure stage, it might be worthy of opening a bug at bugs.gentoo.org.
_________________
Those who dream by day are cognizant of many things that escape those who dream only at night. --Poe
Back to top
View user's profile Send private message
moige
n00b
n00b


Joined: 17 Nov 2017
Posts: 4

PostPosted: Sat Nov 18, 2017 1:49 pm    Post subject: Reply with quote

pjp wrote:
How long have you waited to see if it completes?

There aren't a lot of results for that error, but I did read one suggesting it eventually finished.

It might be helpful to upload the build.log with wgetpaste and provide a link here. If you're not able to get that working, you could try posting the info here within code tags for readability. Depending on how long the build log is, that might be cumbersome.

Since that is occurring in the configure stage, it might be worthy of opening a bug at bugs.gentoo.org.


I tried again today at 08:25:32 and waited until 9:25:00 and nothing happens. It still stuck. I suppose that one hour is enough to wait... This is the build.log https://paste.pound-python.org/show/E1hpgV1eafYXFpT2JRSP/

"emere -pqv =net-misc/wget-1.19.1-r2" output:
Code:
[ebuild R ] net-misc/­wget-1.19.1-r2 USE="ipv6 nls pcre ssl zlib -debug -gnutls -idn -libressl -ntlm -static {-test} -uuid"


"var/tmp/portage/net-misc/wget-1.19.1-r2/temp/enviroment" output: https://paste.pound-python.org/show/pCBZNmybtN0W5K4PFKN4/
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16757

PostPosted: Sun Nov 19, 2017 4:22 am    Post subject: Reply with quote

The build log has this line:
Quote:
checking for working nanosleep... sandbox:stop caught signal 2 in pid 8243


I have no idea if this is related, but this thread has a similar message, though the thread is from 2006. Maybe the solution which worked then will work again. In that thread, the issue was with coreutils, so I'd try the steps they took but try to reinstall wget since that is what won't install for you.
_________________
Those who dream by day are cognizant of many things that escape those who dream only at night. --Poe
Back to top
View user's profile Send private message
moige
n00b
n00b


Joined: 17 Nov 2017
Posts: 4

PostPosted: Sun Nov 19, 2017 1:17 pm    Post subject: Reply with quote

pjp wrote:
The build log has this line:
Quote:
checking for working nanosleep... sandbox:stop caught signal 2 in pid 8243


I have no idea if this is related, but this thread has a similar message, though the thread is from 2006. Maybe the solution which worked then will work again. In that thread, the issue was with coreutils, so I'd try the steps they took but try to reinstall wget since that is what won't install for you.


Yes, I just Control-C because nothings happens. I followed that solution but didn't work... I do the same: Loggin without X11 and tried to reinstall wget and the problem is the same. I just open a bug report, so, I will wait to a response.

Thanks for you effort.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 11434

PostPosted: Sun Nov 19, 2017 5:00 pm    Post subject: Reply with quote

For the benefit of future readers, I believe moige refers to net-misc/wget-1.19.1-r2: stuck in "checking for working nanosleep..." when rebuilding after OpenSSL update as the newly opened bug report.

moige: please use the [bug] tag to link to Gentoo bug reports, so that readers can easily follow the link between the forum thread and the bug report. If the solution is posted there first (or exclusively), readers who later find this thread would otherwise not benefit from that solution.
Back to top
View user's profile Send private message
moige
n00b
n00b


Joined: 17 Nov 2017
Posts: 4

PostPosted: Mon Nov 20, 2017 12:41 am    Post subject: Reply with quote

Hu wrote:
For the benefit of future readers, I believe moige refers to net-misc/wget-1.19.1-r2: stuck in "checking for working nanosleep..." when rebuilding after OpenSSL update as the newly opened bug report.

moige: please use the [bug] tag to link to Gentoo bug reports, so that readers can easily follow the link between the forum thread and the bug report. If the solution is posted there first (or exclusively), readers who later find this thread would otherwise not benefit from that solution.


Sure. I will edit the post to paste the bug report with [bug] tag.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16927
Location: here

PostPosted: Thu Nov 23, 2017 12:57 pm    Post subject: Reply with quote

I'm not sure if is same problem but see this comment
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum