Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] can not install gdm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
klas
n00b
n00b


Joined: 30 Aug 2017
Posts: 63
Location: Bradford, UK

PostPosted: Wed Nov 15, 2017 10:09 pm    Post subject: [SOLVED] can not install gdm Reply with quote

Hi
Any one helps me how to install gdm
Code:
 
-lcom_err -lk5crypto -lcrypto -ldl -lkrb5support -lkeyutils -lresolv -Wl,-O1 -Wl,--as-needed -Wl,--version-script binutils.versions
pkinit_crypto_openssl.so: In function `pkinit_openssl_init__aux':
pkinit_crypto_openssl.c:(.text+0x21): undefined reference to `ERR_load_crypto_strings'
pkinit_crypto_openssl.c:(.text+0x28): undefined reference to `OpenSSL_add_all_algorithms'
pkinit_crypto_openssl.so: In function `cms_signeddata_create':
pkinit_crypto_openssl.c:(.text+0x3459): undefined reference to `X509_STORE_CTX_trusted_stack'
pkinit_crypto_openssl.so: In function `cms_signeddata_verify':
pkinit_crypto_openssl.c:(.text+0x3eab): undefined reference to `X509_STORE_CTX_trusted_stack'
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:724: pkinit.so] Error 1
make[1]: Leaving directory '/var/tmp/portage/app-crypt/mit-krb5-1.15.2/work/krb5-1.15.2/src-abi_x86_64.amd64/plugins/preauth/pkinit'
make: *** [Makefile:1523: all-recurse] Error 1
 * ERROR: app-crypt/mit-krb5-1.15.2::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=app-crypt/mit-krb5-1.15.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-crypt/mit-krb5-1.15.2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-crypt/mit-krb5-1.15.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-crypt/mit-krb5-1.15.2/temp/environment'.
 * Working directory: '/var/tmp/portage/app-crypt/mit-krb5-1.15.2/work/krb5-1.15.2/src-abi_x86_64.amd64'
 * S: '/var/tmp/portage/app-crypt/mit-krb5-1.15.2/work/krb5-1.15.2/src'

>>> Failed to emerge app-crypt/mit-krb5-1.15.2, Log file:

>>>  '/var/tmp/portage/app-crypt/mit-krb5-1.15.2/temp/build.log'

 * Messages for package media-sound/pulseaudio-10.0:

 * A preallocated buffer-size of 2048 (kB) or higher is recommended for the HD-audio driver!
 * CONFIG_SND_HDA_PREALLOC_SIZE=64

 * Messages for package app-crypt/mit-krb5-1.15.2:

 * ERROR: app-crypt/mit-krb5-1.15.2::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=app-crypt/mit-krb5-1.15.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-crypt/mit-krb5-1.15.2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-crypt/mit-krb5-1.15.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-crypt/mit-krb5-1.15.2/temp/environment'.
 * Working directory: '/var/tmp/portage/app-crypt/mit-krb5-1.15.2/work/krb5-1.15.2/src-abi_x86_64.amd64'
 * S: '/var/tmp/portage/app-crypt/mit-krb5-1.15.2/work/krb5-1.15.2/src'

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-libs/openssl-1.1.0g
 *  - /usr/lib64/libssl.so.1.0.0
 *      used by /usr/bin/w3m (www-client/w3m-0.5.3-r9)
 *      used by /usr/bin/wget (net-misc/wget-1.19.1-r2)
 *      used by /usr/lib64/libldap-2.4.so.2.10.7 (net-nds/openldap-2.4.44)
 *      used by 4 other files
 *  - /usr/lib64/libcrypto.so.1.0.0
 *      used by /usr/bin/ssh (net-misc/openssh-7.5_p1-r1)
 *      used by /usr/bin/ssh-add (net-misc/openssh-7.5_p1-r1)
 *      used by /usr/bin/ssh-agent (net-misc/openssh-7.5_p1-r1)
 *      used by 15 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.



Any help please
_________________
... brute force works in coding ...


Last edited by klas on Sat Nov 18, 2017 12:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 5968

PostPosted: Wed Nov 15, 2017 10:57 pm    Post subject: Reply with quote

portage have a bug with autounmask that remove the hardmask on openssl, and openssl-1.1 should remain mask.
see:
Code:
>>> package: dev-libs/openssl-1.1.0g


so autounmask or your fault, the solve remain the same.
Code:
# Lars Wendler <polynomial-c@gentoo.org> (26 Aug 2016)
# Masked while being tested and reverse deps aren't fully compatible
=dev-libs/openssl-1.1*


ps: i'm not using autounmask myself, so i don't know how the feature unmask a package, maybe /etc/portage/package.unmask
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16911
Location: here

PostPosted: Thu Nov 16, 2017 6:57 am    Post subject: Reply with quote

krinn wrote:
ps: i'm not using autounmask myself, so i don't know how the feature unmask a package, maybe /etc/portage/package.unmask

If in a stable system also in package.accept_keywords
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
klas
n00b
n00b


Joined: 30 Aug 2017
Posts: 63
Location: Bradford, UK

PostPosted: Fri Nov 17, 2017 1:26 am    Post subject: Reply with quote

Thanks that was helpful
but it start giving
Code:

Failed to connect to bus: No such file or directory

_________________
... brute force works in coding ...
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16911
Location: here

PostPosted: Fri Nov 17, 2017 6:29 am    Post subject: Reply with quote

Can help this?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
klas
n00b
n00b


Joined: 30 Aug 2017
Posts: 63
Location: Bradford, UK

PostPosted: Sat Nov 18, 2017 10:04 am    Post subject: Reply with quote

thanks. i got it . just uncomment the grub init for systemd on /etc/default/gru but I have now switched to openrc, so no need for that
_________________
... brute force works in coding ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum