Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ glsa 201711-09 ] lxc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1997

PostPosted: Sat Nov 11, 2017 5:26 pm    Post subject: [ glsa 201711-09 ] lxc Reply with quote

Gentoo Linux Security Advisory

Title: LXC: Remote security bypass (GLSA 201711-09)
Severity: normal
Exploitable: remote
Date: 2017-11-11
Bug(s): #636386
ID: 201711-09

Synopsis

A vulnerability in LXC may lead to an unauthorized security bypass.

Background

LinuX Containers userspace utilities

Affected Packages

Package: app-emulation/lxc
Vulnerable: < 2.0.7
Unaffected: >= 2.0.7
Architectures: All supported architectures


Description

Previous versions of lxc-attach ran a shell or the specified command
without allocating a pseudo terminal making it vulnerable to input faking
via a TIOCSTI ioctl call.


Impact

Remote attackers can escape the container and perform unauthorized
modifications.


Workaround

There is no know workaround at this time.

Resolution

All LXC users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-emulation/lxc-2.0.7"
   


References


CVE-2016-10124
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum