Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201711-03 ] hostapd and wpa_supplicant
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1997

PostPosted: Fri Nov 10, 2017 11:26 pm    Post subject: [ GLSA 201711-03 ] hostapd and wpa_supplicant Reply with quote

Gentoo Linux Security Advisory

Title: hostapd and wpa_supplicant: Key Reinstallation (KRACK) attacks (GLSA 201711-03)
Severity: normal
Exploitable: local, remote
Date: 2017-11-10
Bug(s): #634436, #634438
ID: 201711-03

Synopsis

A flaw was discovered in the 4-way handshake in hostapd and
wpa_supplicant that allows attackers to conduct a Man in the Middle attack.


Background

wpa_supplicant is a WPA Supplicant with support for WPA and WPA2 (IEEE
802.11i / RSN). hostapd is a user space daemon for access point and
authentication servers.


Affected Packages

Package: net-wireless/hostapd
Vulnerable: < 2.6-r1
Unaffected: >= 2.6-r1
Architectures: All supported architectures

Package: net-wireless/wpa_supplicant
Vulnerable: < 2.6-r3
Unaffected: >= 2.6-r3
Architectures: All supported architectures


Description

WiFi Protected Access (WPA and WPA2) and it’s associated technologies
are all vulnerable to the KRACK attacks. Please review the referenced CVE
identifiers for details.


Impact

An attacker can carry out the KRACK attacks on a wireless network in
order to gain access to network clients. Once achieved, the attacker can
potentially harvest confidential information (e.g. HTTP/HTTPS), inject
malware, or perform a myriad of other attacks.


Workaround

There is no known workaround at this time.

Resolution

All hostapd users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-wireless/hostapd-2.6-r1"
   
All wpa_supplicant users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=net-wireless/wpa_supplicant-2.6-r3"
   


References


CVE-2017-13077


CVE-2017-13078


CVE-2017-13079


CVE-2017-13080


CVE-2017-13081


CVE-2017-13082


CVE-2017-13084


CVE-2017-13086


CVE-2017-13087


CVE-2017-13088

KRACK Attacks Website
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum