Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Cannot get rid of GLSA 201705-10
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Spargeltarzan
Apprentice
Apprentice


Joined: 23 Jul 2017
Posts: 288

PostPosted: Fri Nov 10, 2017 5:46 pm    Post subject: [Solved] Cannot get rid of GLSA 201705-10 Reply with quote

Hi,

I cannot get rid of GLSA 201705-10:

Code:

lenovo-yoga /etc/portage/package.use # glsa-check -p $(glsa-check -t all)
This system is affected by the following GLSAs:
Checking GLSA 201705-10
>>> No upgrade path exists for these packages:
     media-libs/gst-plugins-base-0.10.36-r2


Code:

[I] media-libs/gst-plugins-base
     Verfügbare Versionen:   
     (0.10) 0.10.36-r2
     (1.0)  [m]1.10.3 1.10.5 ~1.12.3
       {X alsa +introspection ivorbis nls +ogg +orc +pango theora +vorbis ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installierte Versionen: 0.10.36-r2(0.10)(20:33:27 30.08.2017)(introspection nls orc ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32") 1.10.5(1.0)(18:07:22 29.09.2017)(X alsa introspection nls ogg orc pango theora vorbis -ivorbis ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")
     Startseite:             https://gstreamer.freedesktop.org/
     Beschreibung:           Basepack of plugins for gstreamer


As you see, two versions are installed. (0.10.36-r2 and 1.10.5) How can I find out which package depends on 0.10.36-r2 and how can I resolve this GLSA?
Code:

emerge --ask --oneshot --verbose ">=media-libs/gst-plugins-base-1.10.3:1.0"

didn't help.


Thank you in advance


Last edited by Spargeltarzan on Fri Nov 10, 2017 6:10 pm; edited 3 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21360
Location: here

PostPosted: Fri Nov 10, 2017 5:49 pm    Post subject: Reply with quote

Quote:
How can I find out which package depends on 0.10.36-r2

Code:
equery d media-libs/gstreamer:0.10

Quote:
and how can I resolve this GLSA?

Depend if the package that depend on it is important for you
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Spargeltarzan
Apprentice
Apprentice


Joined: 23 Jul 2017
Posts: 288

PostPosted: Fri Nov 10, 2017 5:54 pm    Post subject: Reply with quote

Hi,

Thank you for very quick reply:

Code:

lenovo-yoga ~ # equery d media-libs/gstreamer:0.10
 * These packages depend on media-libs/gstreamer:
media-libs/gst-plugins-base-0.10.36-r2 (>=media-libs/gstreamer-0.10.36:0.10[introspection?,abi_x86_32(-)?,abi_x86_64(-)?,
abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
                                       (>=media-libs/gstreamer-0.10.36-r2:0.10[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,
abi_s390_32(-)?,abi_s390_64(-)?])
x11-libs/wxGTK-3.0.2.0-r2 (gstreamer ? media-libs/gstreamer:0.10[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])


is x11-libs/wxGTK the problem? I don't know who installed it or for what it's needed. When I trace back it seems that winetricks installed it:

Code:

lenovo-yoga ~ # equery d x11-libs/wxGTK
 * These packages depend on x11-libs/wxGTK:
app-arch/p7zip-16.02-r1 (wxwidgets ? x11-libs/wxGTK:3.0[X])


[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]


Last edited by Spargeltarzan on Fri Nov 10, 2017 6:00 pm; edited 2 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21360
Location: here

PostPosted: Fri Nov 10, 2017 5:57 pm    Post subject: Reply with quote

Spargeltarzan wrote:
is x11-libs/wxGTK the problem? I don't know who installed it or for what it's needed.

Yes and you can see what depend on it in the same way as gstreamer.
You can also remove gstreamer use flag from wxGTK for remove this package.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Spargeltarzan
Apprentice
Apprentice


Joined: 23 Jul 2017
Posts: 288

PostPosted: Fri Nov 10, 2017 6:01 pm    Post subject: Reply with quote

Code:

lenovo-yoga ~ # equery d app-arch/p7zip
 * These packages depend on app-arch/p7zip:
app-emulation/winetricks-20170823 (app-arch/p7zip)


Winetricks I use...

Code:

lenovo-yoga ~ # eix winetricks
[I] app-emulation/winetricks
     Verfügbare Versionen:   20170823^t **99999999^t {gtk kde rar}
     Installierte Versionen: 20170823^t(18:18:54 14.09.2017)(gtk -kde -rar)
     Startseite:             https://github.com/Winetricks/winetricks https://wiki.winehq.org/Winetricks
     Beschreibung:           Easy way to install DLLs needed to work around problems in Wine


and the latest version is installed. So I no have a possibility to fix this issue since winetricks causes it? Since I use a wine software to play music, I believe I cannot simply -gstreamer for wxGTK. But I will try
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21360
Location: here

PostPosted: Fri Nov 10, 2017 6:07 pm    Post subject: Reply with quote

Spargeltarzan wrote:
and the latest version is installed. So I no have a possibility to fix this issue since winetricks causes it? Since I use a wine software to play music, I believe I cannot simply -gstreamer for wxGTK. But I will try

Or also with remove wxwidgets use flag to app-arch/p7zip you can remove all wxGTK.
In your case wxGTK is required by p7zip with use flag wxwidgets for the GUI not required by winetricks (this require p7zip but not force use flag wxwidgets)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Spargeltarzan
Apprentice
Apprentice


Joined: 23 Jul 2017
Posts: 288

PostPosted: Fri Nov 10, 2017 6:10 pm    Post subject: Reply with quote

I applied
Code:
x11-libs/wxGTK -gstreamer
for package.use. I don't know what might be broken, but my software still plays music under wine and the glsa is solved
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum