Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
library (development) for gpgme [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
LIsLinuxIsSogood
Guru
Guru


Joined: 13 Feb 2016
Posts: 458

PostPosted: Tue Nov 07, 2017 10:28 pm    Post subject: library (development) for gpgme [SOLVED] Reply with quote

I'm working to follow instructions for the use of patchset to install Gnome without systemd. I've been able to follow the wiki page that is up to this point,

during compilation of package app-crypt/gpgme
Code:

Could not find gpgme-config.  Please install the libgpgme development package.
 * ERROR: app-crypt/gpgme-1.9.0::dantrell-gnome failed (compile phase):
 *   (no error message)


emerge --info:
https://paste.pound-python.org/show/AGQzeq46JH9qgT6L01WM/

Build log:
https://paste.pound-python.org/show/Po0spLmOtUOR9XHfpANh/

Environment File:
https://paste.pound-python.org/show/7TfMmPA2AnOHLKR9lNJI/


As I mentioned the package I am trying to install...is here

Code:
playby /home/jonr # emerge -pqv '=app-crypt/gpgme-1.9.0::dantrell-gnome'
[ebuild  N    ] app-crypt/gpgme-1.9.0  USE="cxx python qt5 -common-lisp -static-libs" PYTHON_TARGETS="python2_7 python3_4 -python3_5 (-python3_6)"


Please help.


Last edited by LIsLinuxIsSogood on Thu Nov 09, 2017 7:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
dantrell
Apprentice
Apprentice


Joined: 01 Jun 2007
Posts: 293
Location: Earth

PostPosted: Wed Nov 08, 2017 3:51 am    Post subject: Re: library (development) for gpgme Reply with quote

LIsLinuxIsSogood wrote:
I'm working to follow instructions for the use of patchset to install Gnome without systemd.

For future reference, the support thread is here.

LIsLinuxIsSogood wrote:
during compilation of package app-crypt/gpgme

This looks like Gentoo bug #617182. It didn't show up in my tests because the python USE flag is not enabled by default.

This has been corrected as per comment #3.

LIsLinuxIsSogood wrote:
Please help.

Sync up and rebuild.
_________________
Dantrell B.
Back to top
View user's profile Send private message
LIsLinuxIsSogood
Guru
Guru


Joined: 13 Feb 2016
Posts: 458

PostPosted: Wed Nov 08, 2017 6:23 am    Post subject: Reply with quote

Woah you are thee Dantrel B. That's cool, thanks for the tips and for taking care of it on the end of developer files from the sources. The only thing, is now I just tried syncing my overlays within gentoo, and get the following:

Code:
 * Errors:
 * ------
 * Failed to sync overlay "dantrell-gnome".
 * Error was: Syncing overlay "dantrell-gnome" returned status 1!
 * db.sync()
 *

 * CLI: Errors occurred processing action sync_all
 *
 * Errors:
 * ------
 * Failed to sync overlay "dantrell-gnome".
 * Error was: Syncing overlay "dantrell-gnome" returned status 1!
 * db.sync()
 *


Ideas as to why this could be? Or if it is maybe something specific on my end....I will just have a quick double check to see if maybe I need to unsync and resync or something like that.
Back to top
View user's profile Send private message
dantrell
Apprentice
Apprentice


Joined: 01 Jun 2007
Posts: 293
Location: Earth

PostPosted: Wed Nov 08, 2017 7:25 am    Post subject: Reply with quote

LIsLinuxIsSogood wrote:
Ideas as to why this could be? Or if it is maybe something specific on my end....I will just have a quick double check to see if maybe I need to unsync and resync or something like that.

There's this and this but I'm going to say just re-add the overlay:

Code:
layman --delete dantrell-gnome
layman --add dantrell-gnome

_________________
Dantrell B.
Back to top
View user's profile Send private message
LIsLinuxIsSogood
Guru
Guru


Joined: 13 Feb 2016
Posts: 458

PostPosted: Wed Nov 08, 2017 7:39 am    Post subject: Reply with quote

ty
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum