Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pulseaudio not detecting hardware
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1110

PostPosted: Fri Oct 27, 2017 7:38 pm    Post subject: pulseaudio not detecting hardware Reply with quote

I have the following in journalctl (and whenever I run teh pulseaudio command):
Code:
Oct 27 21:26:44 pc pulseaudio[4139]: [pulseaudio] module.c: module-detect is deprecated: Please use module-udev-detect instead of modu
Oct 27 21:26:44 pc pulseaudio[4139]: [pulseaudio] module-detect.c: failed to detect any sound hardware.
Oct 27 21:26:44 pc pulseaudio[4139]: [pulseaudio] module.c: Failed to load module "module-detect" (argument: ""): initialization faile
Oct 27 21:26:44 pc pulseaudio[4139]: [pulseaudio] main.c: Module load failed.
Oct 27 21:26:44 pc pulseaudio[4139]: [pulseaudio] main.c: Failed to initialize daemon.
Oct 27 21:26:44 pc pulseaudio[4136]: [pulseaudio] main.c: Daemon startup failed.


I'm using an ATI radeon 5450 card with HD audio.
Code:
pc ~ # aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


kernel config:
https://pastebin.com/UGafcsJU

The user who logs on to the system:
Code:
pc ~ # id adel
uid=1000(adel) gid=1000(adel) groups=1000(adel),10(wheel),18(audio),27(video),247(systemd-journal),1001(pulse)

I want to be able to use pulseaudio as an audio output.

[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1110

PostPosted: Tue Oct 31, 2017 5:52 am    Post subject: Reply with quote

bump
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 5961
Location: Saint Amant, Acadiana

PostPosted: Tue Oct 31, 2017 1:52 pm    Post subject: Reply with quote

PulseAudio will not detect the hardware, it works on top of ALSA or OSS4. You need one of these set up before PA can work.
_________________
Please learn how to denote units correctly!

Political Correctness is all about replacing imaginary injustice with real injustice.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum