Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No subtitle editor working in Gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
jssilva
n00b
n00b


Joined: 27 Sep 2017
Posts: 64

PostPosted: Thu Oct 26, 2017 11:12 pm    Post subject: No subtitle editor working in Gentoo Reply with quote

Hello,

On my previous distro I used to have three subtitle editors: Gnome-Subtitles, Aegisub and SubtitleEditor, by order of preference. Now, here, I can't get one to work.

Gnome-subtitles: doesn't exist on portage. Zugaina.org states an overlay at gentoo-playground but doesn't exist, it's outdadted, I checked github.

Aegisub compiles but then breaks with error on execution:
Code:
$ aegisub
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8).
Aborted


SubtitleEditor pulls gstreamer and plugins, which gives an error before completing compile.

So, does anyone know a workaround for any of the previous, or another subtitle editor?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16890
Location: here

PostPosted: Fri Oct 27, 2017 6:09 am    Post subject: Re: No subtitle editor working in Gentoo Reply with quote

jssilva wrote:
Gnome-subtitles: doesn't exist on portage. Zugaina.org states an overlay at gentoo-playground but doesn't exist, it's outdadted, I checked github.

You can download all file in your local overlay only for this program. Anyway also this program is outdadted, lastest version is 4 year ago.

jssilva wrote:
Aegisub compiles but then breaks with error on execution:
Code:
$ aegisub
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8).
Aborted

Try to rebuild x11-libs/wxGTK package
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 5957
Location: Saint Amant, Acadiana

PostPosted: Fri Oct 27, 2017 1:17 pm    Post subject: Reply with quote

media-video/gaupol will do text-based subtitles.
_________________
Please learn how to denote units correctly!

Political Correctness is all about replacing imaginary injustice with real injustice.
Back to top
View user's profile Send private message
jssilva
n00b
n00b


Joined: 27 Sep 2017
Posts: 64

PostPosted: Fri Oct 27, 2017 5:19 pm    Post subject: Reply with quote

Thank you again for helping. You're really my rescue team. :)

Jaglover wrote:
media-video/gaupol will do text-based subtitles

I'll give it a try, although gnome-subtitles has been my favorite since a long time. It's very good ajusting and shifting to compensate for different video/subtitle speeds, and editing cuts.

fedeliallalinea wrote:
You can download all file in your local overlay only for this program

After creating the custom repo as you said, it compiled correctly although calling for the heavy gstreamer. At first was not working, which was fixed by pulling Sergio Leone's trio, the good, the bad and the ugly, and I think some more.

I just hope gstreamer security problems have gone away with the new versions I've pulled.

As to aegisub, I reinstalled the version I had of wxGTK but saw no change in behavior.
Then pulled the other two versions as NS, but the error remains the same. Are there any more versions that aegisub could expect?

Code:
# eix wxGTK
[I] x11-libs/wxGTK
     Available versions:
     (2.8)  2.8.12.1-r1 (~)2.8.12.1-r2
     (3.0)  3.0.2.0-r1 3.0.2.0-r2 (~)3.0.2.0-r3
     (3.0-gtk3) (~)3.0.2.0-r300 (~)3.0.2.0-r301
       {+X aqua debug doc gnome gstreamer libnotify odbc opengl pch sdl tiff web
kit ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  2.8.12.1-r2(2.8)(17:30:49 27/10/17)(X opengl sdl tiff
-aqua -debug -doc -gnome -gstreamer -odbc -pch ABI_MIPS="-n32 -n64 -o32" ABI_PPC
="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32") 3.0.2.0-r3(3.0)(23:52:28 19
/09/17)(X libnotify opengl sdl tiff -aqua -debug -doc -gstreamer -webkit ABI_MIP
S="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32") 3
.0.2.0-r301(3.0-gtk3)(10:00:12 27/10/17)(X libnotify opengl sdl tiff -aqua -debu
g -doc -gstreamer -webkit ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="
-32 -64" ABI_X86="64 -32 -x32")
     Homepage:            http://wxwidgets.org/
     Description:         GTK+ version of wxWidgets, a cross-platform C++ GUI to
olkit


Anyway, aegisub is not that important, now that I have gnome-subtitles.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16890
Location: here

PostPosted: Fri Oct 27, 2017 6:45 pm    Post subject: Reply with quote

jssilva wrote:
Then pulled the other two versions as NS, but the error remains the same. Are there any more versions that aegisub could expect?

No correct slot is 3.0
Code:
...
EAPI=6

WX_GTK_VER=3.0
...

What version of gcc you installed?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
jssilva
n00b
n00b


Joined: 27 Sep 2017
Posts: 64

PostPosted: Fri Oct 27, 2017 8:13 pm    Post subject: Reply with quote

fedeliallalinea wrote:

What version of gcc you installed?

It's 6.4.0:
Code:
# eix gcc
...
[I] sys-devel/gcc
...
     Installed versions:  6.4.0(6.4.0)^s(20:39:07 03/10/17)(cxx fortran multilib nls nptl openmp pch sanitize ssp vtv -altivec -awt -cilk -debug -doc -fixed-point -gcj -go -graphite -hardened -jit -libssp -mpx -objc -objc++ -objc-gc -pgo -pie -regression-test -vanilla)


EDIT: @fedeliallalinea: please don't waste your precious time with this. As I said before, I've got gnome-subtitles and now also gaupol which looks quite good, does everything I need and doesn't have heavy dependencies.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum