Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED ]Can't compile KDE4's plasma-runtime [kde-sunset]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
UFeindschiff
n00b
n00b


Joined: 18 Jan 2014
Posts: 23

PostPosted: Wed Oct 25, 2017 4:04 pm    Post subject: [SOLVED ]Can't compile KDE4's plasma-runtime [kde-sunset] Reply with quote

Technically it would've been correct to say that it is unable to link it against the implementation of Plasma::WebView as it cannot find it, but that would've been too long of a title for the Gentoo forums.

Anyhow, let me explain my situation. Fed up with the buggy mess that is KDE5 I decided to remove KDE5 from my system and try my luck at compiling KDE SC 4.14 from the kde-sunset overlay, set I seem to have hit a brick wall here. Before anyone tells me, I know KDE4 is considered legacy by the KDE devs, unsupported by Gentoo and that the kde-sunset repo is currently unmaintained. I know I will put myself at a potential security risk when running KDE4 software that does connect to the internet.

So when compiling plasma-runtime I get the following error output https://pastebin.com/ABGWWzK4 which makes me conclude that while the header files for Plasma::WebView are there, the actual implementation to link against is not. A quick google search prompted me to a post claiming this is a problem with missing qtwebkit:4. So I downgraded my qtwebkit (where the QT5 version was still installed) to the Qt4 version yet still with the same results. I also tried compiling different versions of kdelibs (thinking that that may be a kdelibs issue) and with both the plasma USE flag set and not set all to no help whatsoever.

So my question is: What package contains the implementation of KDE4s Plasma::WebView since I suspect that I have a Qt5 package there left over from my old KDE5 install incompatible with KDE4, which is causing those issues? Alternatively and imo even better: Is there any way to disable all of that web functionality in Plasma4 cause that would propably work and remove an attack vector in the process.

Thanks in advance


Last edited by UFeindschiff on Sat Oct 28, 2017 12:48 am; edited 1 time in total
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 5570
Location: Austria

PostPosted: Wed Oct 25, 2017 4:44 pm    Post subject: Reply with quote

There is no problem related to having Qt4 and Qt5 installed at the same time. Everyone who is installing kde-apps-meta right now has exactly that.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
UFeindschiff
n00b
n00b


Joined: 18 Jan 2014
Posts: 23

PostPosted: Fri Oct 27, 2017 11:35 pm    Post subject: Reply with quote

Thanks, so it's something else that's missing than some Qt4 web-related stuff. That or the old ebuilds don't check in their requirements that the Qt packages are in slot4. If you or anyone else for that matter have any idea on what ebuild contains those files or how to disable Plasma's web-rendering support alltogether, I'd love to know
Back to top
View user's profile Send private message
UFeindschiff
n00b
n00b


Joined: 18 Jan 2014
Posts: 23

PostPosted: Sat Oct 28, 2017 12:47 am    Post subject: Reply with quote

Okay. Figured out that Plasma::WebView is part of kdelibs and while going over changes of the kdelibs I came across the change that the official gentoo repos dropped webkit support for kdelibs, which would explain my problem. Changed the ebuild so it configures kdelibs with webkit support and merged that. Now plasma-runtime merges without problem. Hope this will help anyone having a similar problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum