Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Failed to install kde plasma because media-sound/lame fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
TheMachinesTeacher
n00b
n00b


Joined: 09 Sep 2017
Posts: 48
Location: Somewhere over there

PostPosted: Fri Oct 20, 2017 4:45 pm    Post subject: Failed to install kde plasma because media-sound/lame fails Reply with quote

I'm not sure why I cannot install media-sound/lame. Hopefully you can help.

emerge --info '=media-sound/lame-3.99.5-r1'
Code:

Portage 2.3.8 (python 3.4.5-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-5.4.0, glibc-2.23-r4, 4.12.12-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.12.12-gentoo-x86_64-AMD_Ryzen_5_1600X_Six-Core_Processor-with-gentoo-2.4.1
KiB Mem:    16449768 total,  13447656 free
KiB Swap:     976892 total,    976892 free
Timestamp of repository gentoo: Fri, 20 Oct 2017 00:45:01 +0000
Head commit of repository gentoo: 1b0d23325cf132e9f85ec34ae6bac49f3b5f5ec8
sh bash 4.3_p48-r1
ld GNU ld (Gentoo 2.28.1 p1.0) 2.28.1
app-shells/bash:          4.3_p48-r1::gentoo
dev-lang/perl:            5.24.3::gentoo
dev-lang/python:          2.7.12::gentoo, 3.4.5::gentoo
dev-util/cmake:           3.8.2::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.28::gentoo
sys-apps/sandbox:         2.10-r3::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.15-r2::gentoo
sys-devel/binutils:       2.28.1::gentoo
sys-devel/gcc:            5.4.0-r3::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1::gentoo
sys-kernel/linux-headers: 4.4::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r4::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j12"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg kde kipi kwallet lcms ldap libnotify mad mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qml qt3support qt4 qt5 readline sdl seccomp semantic-desktop session spell ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vdpau vorbis widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2 mmxext" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="libinput synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


emerge -pqv '=media-sound/lame-3.99.5-r1::gentoo'
Code:

[ebuild  N    ] media-sound/lame-3.99.5-r1  USE="frontend -debug -mp3rtp -sndfile -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(-mmx)"


cat /var/tmp/portage/media-sound/lame-3.99.5-r1/temp/build.log
Code:

* Package:    media-sound/lame-3.99.5-r1
 * Repository: gentoo
 * Maintainer: sound@gentoo.org
 * USE:        abi_x86_64 amd64 elibc_glibc frontend kernel_linux userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking lame-3.99.5.tar.gz to /var/tmp/portage/media-sound/lame-3.99.5-r1/work
>>> Unpacking lame-3.99.5-automake-2.12.patch.gz to /var/tmp/portage/media-sound/lame-3.99.5-r1/work
>>> Source unpacked in /var/tmp/portage/media-sound/lame-3.99.5-r1/work
>>> Preparing source in /var/tmp/portage/media-sound/lame-3.99.5-r1/work/lame-3.99.5 ...
 * Applying lame-3.96-ccc.patch ...
 [ ok ]
 * Applying lame-3.98-gtk-path.patch ...
 [ ok ]
 * Applying lame-3.99.5-tinfo.patch ...
 [ ok ]
 * Applying lame-3.99.5-msse.patch ...
 [ ok ]
 * Applying lame-3.99.5-automake-2.12.patch ...
 [ ok ]
 * Running eautoreconf in '/var/tmp/portage/media-sound/lame-3.99.5-r1/work/lame-3.99.5' ...
 * Running libtoolize --install --copy --force --automake ...
 [ ok ]
 * Running aclocal -I . ...
 [ ok ]
 * This package has a configure.in file which has long been deprecated.  Please
 * update it to use configure.ac instead as newer versions of autotools will die
 * when it finds this file.  See https://bugs.gentoo.org/426262 for details.
 * Running autoconf -I . --force ...
 [ !! ]

 * Failed Running autoconf !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/media-sound/lame-3.99.5-r1/temp/autoconf.out

 * ERROR: media-sound/lame-3.99.5-r1::gentoo failed (prepare phase):
 *   Failed Running autoconf !
 *
 * Call stack:
 *     ebuild.sh, line  115:  Called src_prepare
 *   environment, line 2792:  Called eautoreconf
 *   environment, line  824:  Called eautoconf '--force'
 *   environment, line  737:  Called autotools_run_tool '--at-m4flags' 'autoconf' '--force'
 *   environment, line  556:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of `emerge --info '=media-sound/lame-3.99.5-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-sound/lame-3.99.5-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-sound/lame-3.99.5-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/lame-3.99.5-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-sound/lame-3.99.5-r1/work/lame-3.99.5'
 * S: '/var/tmp/portage/media-sound/lame-3.99.5-r1/work/lame-3.99.5'


cat /var/tmp/portage/media-sound/lame-3.99.5-r1/temp/autoconf.out
Code:

***** autoconf *****
***** PWD: /var/tmp/portage/media-sound/lame-3.99.5-r1/work/lame-3.99.5
***** autoconf -I . --force

configure.in:394: error: possibly undefined macro: AM_PATH_GTK
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

So here it seems like the error, but how do I fix it? The internet said reinstall pkg-config, automake, autoconf, m4, and autoconf-wrapper, which I did and that did not solve the problem. My environment does not have AM_PATH_GTK defined, but what should it be defined as? I figured it might be related to x11-libs/gtk+, so I reinstalled that too. That didn't fix it either.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 739
Location: S.O. France

PostPosted: Fri Oct 20, 2017 5:32 pm    Post subject: Reply with quote

See this bug
Back to top
View user's profile Send private message
TheMachinesTeacher
n00b
n00b


Joined: 09 Sep 2017
Posts: 48
Location: Somewhere over there

PostPosted: Fri Oct 20, 2017 5:35 pm    Post subject: Reply with quote

Ah great. Thanks.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum