Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qtnetwork 5.9.2 takes too long to complete
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
younker
Apprentice
Apprentice


Joined: 18 Feb 2004
Posts: 273
Location: China

PostPosted: Sun Oct 15, 2017 11:20 am    Post subject: qtnetwork 5.9.2 takes too long to complete Reply with quote

Solved by removing ABI_X86="64" from make.conf, but I had to rebuild the whole system by emerge -e world as I couldn't figure out which exact package affected by this one. Thanks @DONAHUE
***************************************************************
Not sure if this is a bug for my system. I tried to build qtnetwork 5.9.2 today and no matter what use flags I used I stopped at below tasks.
Code:
Checking for zlib...
Trying source 0 (type inline) of library zlib ...
  => source failed condition 'config.msvc'.
Trying source 1 (type inline) of library zlib ...
+ cd /var/tmp/portage/dev-qt/qtnetwork-5.9.2/work/qtbase-opensource-src-5.9.2/config.tests/zlib && /var/tmp/portage/dev-qt/qtnetwork-5.9.2/work/qtbase-opensource-src-5.9.2/bin/qmake "CONFIG -= qt debug_and_release app_bundle lib_bundle" "CONFIG += shared use_gold_linker warn_off console single_arch" 'LIBS += -lz' /var/tmp/portage/dev-qt/qtnetwork-5.9.2/work/qtbase-opensource-src-5.9.2/config.tests/zlib
+ cd /var/tmp/portage/dev-qt/qtnetwork-5.9.2/work/qtbase-opensource-src-5.9.2/config.tests/zlib && MAKEFLAGS= /usr/bin/gmake
> g++ -c -pipe -O2 -w -fPIC  -I. -I/var/tmp/portage/dev-qt/qtnetwork-5.9.2/work/qtbase-opensource-src-5.9.2/mkspecs/linux-g++ -o main.o main.cpp
> g++ -Wl,-O1 -fuse-ld=gold -o zlib main.o   -lz
 => source accepted.
test config.qtbase.libraries.zlib succeeded
Checking for clock_gettime()...
Trying source 0 (type inline) of library librt ...
+ cd /var/tmp/portage/dev-qt/qtnetwork-5.9.2/work/qtbase-opensource-src-5.9.2/config.tests/librt && /var/tmp/portage/dev-qt/qtnetwork-5.9.2/work/qtbase-opensource-src-5.9.2/bin/qmake "CONFIG -= qt debug_and_release app_bundle lib_bundle" "CONFIG += shared use_gold_linker warn_off console single_arch" /var/tmp/portage/dev-qt/qtnetwork-5.9.2/work/qtbase-opensource-src-5.9.2/config.tests/librt
+ cd /var/tmp/portage/dev-qt/qtnetwork-5.9.2/work/qtbase-opensource-src-5.9.2/config.tests/librt && MAKEFLAGS= /usr/bin/gmake
^C

Exiting on signal 2
sandbox:stop  caught signal 2 in pid 1803
sandbox:stop  Send signal 4 more times to force SIGKILL


It takes more than 80 minutes with one test, I have to kill it.

Anyone encountered this issue? I have no problems with other qt modules, like qtcore, qtgui, qtsvg, etc.

Below is emerge info
Code:
Portage 2.3.11 (python 3.6.3-final-0, default/linux/amd64/13.0/systemd, gcc-6.4.0, glibc-2.25-r7, 4.13.6-gentoo x86_64)
=================================================================
System uname: Linux-4.13.6-gentoo-x86_64-Intel-R-_Core-TM-_i7-6700_CPU_@_3.40GHz-with-gentoo-2.4.1
KiB Mem:    49364812 total,  47342404 free
KiB Swap:   49057788 total,  49057788 free
Timestamp of repository gentoo: Sat, 14 Oct 2017 12:00:01 +0000
Head commit of repository gentoo: 844892b5e74474368a033d33c7bd6a24bd60ee65
sh bash 4.4_p12
ld GNU ld (Gentoo 2.29.1 p1.0) 2.29.1
app-shells/bash:          4.4_p12::gentoo
dev-lang/perl:            5.26.1::gentoo
dev-lang/python:          2.7.14::gentoo, 3.6.3::gentoo
dev-util/cmake:           3.9.4::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.33::gentoo
sys-apps/sandbox:         2.12::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.15.1-r1::gentoo
sys-devel/binutils:       2.29.1::gentoo
sys-devel/gcc:            6.4.0::gentoo
sys-devel/gcc-config:     1.9.0::gentoo
sys-devel/libtool:        2.4.6-r4::gentoo
sys-devel/make:           4.2.1-r1::gentoo
sys-kernel/linux-headers: 4.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.25-r7::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-extra-opts:

ACCEPT_KEYWORDS="amd64 ~amd64 ~x86"
ACCEPT_LICENSE="* -@EULA @BINARY-REDISTRIBUTABLE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/data/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirrors.163.com/gentoo/ http://gentoo.aditsu.net:8000/ rsync://ftp.iij.ad.jp/pub/linux/gentoo/ http://ftp.iij.ad.jp/pub/linux/gentoo/"
LANG="zh_CN.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/data/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl alsa amd64 berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 modules multilib ncurses nls nptl openmp pam pcre qt5 readline seccomp session ssl systemd tcpd udev unicode wayland xattr zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx sse sse2 mmxext" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" L10N="en zh_CN" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en zh_CN" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="nvidia intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


[Moderator edit: added [code] tags to preserve output layout. -Hu]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum