Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X-Server hängt – und ich weiß nicht, warum
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2278
Location: Konradsreuth (Germany)

PostPosted: Thu Oct 12, 2017 5:22 pm    Post subject: X-Server hängt – und ich weiß nicht, warum Reply with quote

Hallo allerseits!

Ich habe zwei kleine Rechner mit jeweils einem Asrock-D1800B-ITX-Mainboard. Das hat eine eingebaute Graphikkarte "VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0c)". Auf beiden passiert es ab und an (ohne, dass ich es tatsächlich reproduzieren könnte), dass der X-Server hängen bleibt. Heißt: Das Bild bleibt stehen. Den Mauszeiger kann ich noch bewegen, aber es passiert nichts, wenn ich irgendwo hinklicke. Wenn z. B. ein Video läuft, dann läuft auch der Ton weiter. Aber das Bild steht. Wenn ich auf eine Konsole wechsle und /etc/init.d/xdm neu starte, dann ist alles wieder gut.

Im Syslog steht nichts. In dmesg steht auch nichts. Genausowenig wie in /sys/kernel/debug/dri/0/i915_error_state oder Xorg.0.log.

Was ist da los? Bzw. wie kann ich rausfinden, was da los ist?!
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1776
Location: Oranienburg/Germany

PostPosted: Fri Oct 13, 2017 6:03 am    Post subject: Reply with quote

Hi,

hast du schon das aktuelle BIOS (2.0) installiert? Vielleicht kannst du auch mal mit den PM Features der "Intel 7th gen graphics" rumspielen. Also Stichwort rc6 und co.

MfG. Stefan

EDIT: Ich sehe gerade, das es sich um bei dem J1800 um ein Intel Bay Trail System handelt. Daher schau doch mal hier im Arch Wiki wegen den PM Optionen https://wiki.archlinux.org/index.php/intel_graphics
_________________
1st: i5-4570, 16GB, 1.75TB
2nd: i5-4570, 8GB, 620GB
3rd: i5-4570, 16GB, 10TB
4th: Asus N61VN, 8GB, 120GB
5th: Cubietruck, 2GB, 160GB + NFS
6th: C2D T7200, 2GB, 16GB USB + NFS
7th: RPi3 1GB, 64GB USB
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2278
Location: Konradsreuth (Germany)

PostPosted: Fri Oct 13, 2017 7:45 am    Post subject: Reply with quote

Hey, danke für den Tip – das ist ja zumindest mal ein Anfang zum Experimentieren ;-)

Das aktuellste BIOS ist drauf. Hab ich vorgestern gecheckt.

Mal ne blöde Frage: Heutzutage hat man ja keine xorg.conf-Datei mehr wie früher, die man erstmal anpassen muss. Geht ja "einfach so". Wenn die von Arch jetzt was schreiben von wegen Option "NoAccel" "True", also das, was man da früher mal reingeschrieben hat – da erstellt man da /etc/X11/xorg.conf.d/20-intel.conf und schreibt das da rein, oder?! Musste ich schon lang nicht mehr machen …
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1776
Location: Oranienburg/Germany

PostPosted: Fri Oct 13, 2017 8:32 am    Post subject: Reply with quote

Hu,

jup, so sollte das gehen. Ich erzwinge so ein deutsches Tastaturlayout für meine Clients.

MfG. Stefan
_________________
1st: i5-4570, 16GB, 1.75TB
2nd: i5-4570, 8GB, 620GB
3rd: i5-4570, 16GB, 10TB
4th: Asus N61VN, 8GB, 120GB
5th: Cubietruck, 2GB, 160GB + NFS
6th: C2D T7200, 2GB, 16GB USB + NFS
7th: RPi3 1GB, 64GB USB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum