Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Not booting Xen DomU
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
karmaking
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2004
Posts: 80
Location: Berlin, Germany

PostPosted: Thu Oct 12, 2017 11:04 am    Post subject: [solved] Not booting Xen DomU Reply with quote

I'm trying to get a Gentoo-DomU (PV) running, Dom0 is Debian 9, Xen 4.8.1.

The Kernel (gentoo-sources) is not booting up; it goes until this and then freezes (see below).

The Gentoo-VM is however booting fine with a stock Debian kernel, but who would want to permanently run a Gentoo with a Debian kernel!? ;)

I have all options set according to https://wiki.gentoo.org/wiki/Xen (and https://wiki.xenproject.org/wiki/Mainline_Linux_Kernel_Configs ). What could I be missing?

Any hints appreciated.

Cheers,
Daniel

Code:
[    0.000000] Linux version 4.13.5-gentoo (root@xxxxxxxx) (gcc version 5.4.0 (Gentoo Hardened 5.4.0-r3 p1.4, pie-0.6.5)) #3 SMP Wed Oct 11 16:33:01 CEST 2017
[    0.000000] Command line: root=/dev/xvda1 ro console=hvc0 xencons=tty
[    0.000000] KERNEL supported cpus:
[    0.000000]   Intel GenuineIntel
[    0.000000] x86/fpu: Supporting XSAVE feature 0x001: 'x87 floating point registers'
[    0.000000] x86/fpu: Supporting XSAVE feature 0x002: 'SSE registers'
[    0.000000] x86/fpu: Supporting XSAVE feature 0x004: 'AVX registers'
[    0.000000] x86/fpu: xstate_offset[2]:  576, xstate_sizes[2]:  256
[    0.000000] x86/fpu: Enabled xstate features 0x7, context size is 832 bytes, using 'standard' format.
[    0.000000] ACPI in unprivileged domain disabled
[    0.000000] Released 0 page(s)
[    0.000000] e820: BIOS-provided physical RAM map:
[    0.000000] Xen: [mem 0x0000000000000000-0x000000000009ffff] usable
[    0.000000] Xen: [mem 0x00000000000a0000-0x00000000000fffff] reserved
[    0.000000] Xen: [mem 0x0000000000100000-0x000000017fffffff] usable
[    0.000000] NX (Execute Disable) protection: active
[    0.000000] DMI not present or invalid.
[    0.000000] Hypervisor detected: Xen PV
[    0.000000] tsc: Fast TSC calibration failed
[    0.000000] tsc: Unable to calibrate against PIT
[    0.000000] tsc: No reference (HPET/PMTIMER) available
[    0.000000] e820: last_pfn = 0x180000 max_arch_pfn = 0x400000000
[    0.000000] MTRR: Disabled
[    0.000000] x86/PAT: MTRRs disabled, skipping PAT initialization too.
[    0.000000] x86/PAT: Configuration [0-7]: WB  WT  UC- UC  WC  WP  UC  UC 
[    0.000000] e820: last_pfn = 0x100000 max_arch_pfn = 0x400000000                                                                     
[    0.000000] Zone ranges:                                                                                                             
[    0.000000]   DMA      [mem 0x0000000000001000-0x0000000000ffffff]                                                                   
[    0.000000]   DMA32    [mem 0x0000000001000000-0x00000000ffffffff]                                                                   
[    0.000000]   Normal   [mem 0x0000000100000000-0x000000017fffffff]                                                                   
[    0.000000] Movable zone start for each node                                                                                         
[    0.000000] Early memory node ranges                                                                                                 
[    0.000000]   node   0: [mem 0x0000000000001000-0x000000000009ffff]                                                                   
[    0.000000]   node   0: [mem 0x0000000000100000-0x000000017fffffff]                                                                   
[    0.000000] Initmem setup node 0 [mem 0x0000000000001000-0x000000017fffffff]                                                         
[    0.000000] p2m virtual area at ffffc90000000000, size is c00000
[    0.000000] Remapped 0 page(s)
[    0.000000] [Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x22 (or later)
[    0.000000] smpboot: Allowing 6 CPUs, 0 hotplug CPUs
[    0.000000] e820: Cannot find an available gap in the 32-bit address range
[    0.000000] e820: PCI devices with unassigned 32-bit BARs may not work!
[    0.000000] e820: [mem 0x180100000-0x1804fffff] available for PCI devices
[    0.000000] Booting paravirtualized kernel on Xen
[    0.000000] Xen version: 4.8.1 (preserve-AD)
[    0.000000] clocksource: refined-jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.000000] setup_percpu: NR_CPUS:8 nr_cpumask_bits:8 nr_cpu_ids:6 nr_node_ids:1
[    0.000000] percpu: Embedded 34 pages/cpu @ffff880178400000 s107928 r0 d31336 u262144
[    0.000000] PV qspinlock hash table entries: 256 (order: 0, 4096 bytes)
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 1548170
[    0.000000] Kernel command line: root=/dev/xvda1 ro console=hvc0 xencons=tty
[    0.000000] PID hash table entries: 4096 (order: 3, 32768 bytes)
[    0.000000] Dentry cache hash table entries: 1048576 (order: 11, 8388608 bytes)
[    0.000000] Inode-cache hash table entries: 524288 (order: 10, 4194304 bytes)
[    0.000000] Memory: 6144164K/6291068K available (4997K kernel code, 672K rwdata, 1600K rodata, 1020K init, 516K bss, 146904K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=6, Nodes=1
[    0.010000] Hierarchical RCU implementation.
[    0.010000]  RCU restricting CPUs from NR_CPUS=8 to nr_cpu_ids=6.
[    0.010000] RCU: Adjusting geometry for rcu_fanout_leaf=16, nr_cpu_ids=6
[    0.010000] Using NULL legacy PIC
[    0.010000] NR_IRQS: 4352, nr_irqs: 112, preallocated irqs: 0
[    0.010000] xen:events: Using FIFO-based ABI
[    0.010000] Console: colour dummy device 80x25
[    0.010000] console [tty0] enabled
[    0.010000] console [hvc0] enabled
[    0.010000] clocksource: xen: mask: 0xffffffffffffffff max_cycles: 0x1cd42e4dffb, max_idle_ns: 881590591483 ns
[    0.010000] installing Xen timer for CPU 0
[    0.010000] tsc: Fast TSC calibration failed
[    0.010009] tsc: Unable to calibrate against PIT
[    0.010011] tsc: No reference (HPET/PMTIMER) available
[    0.010014] tsc: Detected 3400.002 MHz processor
[    0.010017] Calibrating delay loop (skipped), value calculated using timer frequency.. 6800.00 BogoMIPS (lpj=34000020)
[    0.010017] pid_max: default: 32768 minimum: 301
[    0.010026] Security Framework initialized
[    0.010050] Mount-cache hash table entries: 16384 (order: 5, 131072 bytes)
[    0.010067] Mountpoint-cache hash table entries: 16384 (order: 5, 131072 bytes)
[    0.010209] CPU: Physical Processor ID: 0
[    0.010213] CPU: Processor Core ID: 0
[    0.010218] Last level iTLB entries: 4KB 1024, 2MB 1024, 4MB 1024
[    0.010221] Last level dTLB entries: 4KB 1024, 2MB 1024, 4MB 1024, 1GB 4
[    0.024203] cpu 0 spinlock event irq 1
[    0.024209] smpboot: Max logical packages: 1
[    0.024213] VPMU disabled by hypervisor.
[    0.024262] Performance Events: unsupported p6 CPU model 60 no PMU driver, software events only.
[    0.024309] Hierarchical SRCU implementation.
[    0.024400] smp: Bringing up secondary CPUs ...
[    0.024446] installing Xen timer for CPU 1
[    0.024461] SMP alternatives: switching to SMP code
[    0.037722] cpu 1 spinlock event irq 13
[    0.037829] installing Xen timer for CPU 2
[    0.037949] cpu 2 spinlock event irq 20
[    0.038064] installing Xen timer for CPU 3
[    0.038192] cpu 3 spinlock event irq 27
[    0.038271] installing Xen timer for CPU 4
[    0.038389] cpu 4 spinlock event irq 34
[    0.038480] installing Xen timer for CPU 5
[    0.038600] cpu 5 spinlock event irq 41
[    0.038625] smp: Brought up 1 node, 6 CPUs
[    0.038800] devtmpfs: initialized
[    0.038965] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.038974] futex hash table entries: 2048 (order: 5, 131072 bytes)
[    0.039007] kworker/u12:0 (40) used greatest stack depth: 13904 bytes left
[    0.039051] NET: Registered protocol family 16
[    0.039059] xen:grant_table: Grant tables using version 1 layout
[    0.039066] Grant table initialized
[    0.039182] random: fast init done
[    0.039471] PCI: setting up Xen PCI frontend stub
[    0.040791] ACPI: Interpreter disabled.
[    0.040791] xen:balloon: Initialising balloon driver
[    0.041602] vgaarb: loaded
[    0.041607] SCSI subsystem initialized
[    0.041735] dmi: Firmware registration failed.
[    0.041735] PCI: System does not support PCI
[    0.041773] clocksource: Switched to clocksource xen
[    0.044630] pnp: PnP ACPI: disabled
[    0.044709] NET: Registered protocol family 2
[    0.044709] TCP established hash table entries: 65536 (order: 7, 524288 bytes)
[    0.044709] TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
[    0.044709] TCP: Hash tables configured (established 65536 bind 65536)
[    0.044709] UDP hash table entries: 4096 (order: 5, 131072 bytes)
[    0.044709] UDP-Lite hash table entries: 4096 (order: 5, 131072 bytes)
[    0.044709] NET: Registered protocol family 1
[    0.046068] RAPL PMU: API unit is 2^-32 Joules, 4 fixed counters, 655360 ms ovfl timer
[    0.046074] RAPL PMU: hw unit of domain pp0-core 2^-14 Joules
[    0.046077] RAPL PMU: hw unit of domain package 2^-14 Joules
[    0.046080] RAPL PMU: hw unit of domain dram 2^-14 Joules
[    0.046082] RAPL PMU: hw unit of domain pp1-gpu 2^-14 Joules
[    0.046573] audit: initializing netlink subsys (disabled)
[    0.046573] audit: type=2000 audit(1507805930.154:1): state=initialized audit_enabled=0 res=1
[    0.046711] workingset: timestamp_bits=62 max_order=21 bucket_order=0
[    0.048525] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    0.048525] io scheduler noop registered
[    0.048525] io scheduler deadline registered
[    0.048593] io scheduler cfq registered (default)
[    0.048593] io scheduler mq-deadline registered
[    0.175335] io scheduler kyber registered
[    0.175979] Non-volatile memory driver v1.3
[    0.176122] xen:xen_evtchn: Event-channel device installed
[    0.176801] loop: module loaded
[    0.177103] tun: Universal TUN/TAP device driver, 1.6
[    0.177145] xen_netfront: Initialising Xen virtual ethernet driver
[    0.178443] i8042: PNP: No PS/2 controller found.
[    0.178450] i8042: Probing ports directly.
[    0.193786] blkfront: xvda1: flush diskcache: enabled; persistent grants: enabled; indirect descriptors: enabled;
[    1.120028] clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x31025119198, max_idle_ns: 440795368506 ns
[    1.186721] i8042: No controller found
[    1.186785] mousedev: PS/2 mouse device common for all mice
[    1.186875] Netfilter messages via NETLINK v0.30.
[    1.186935] nf_conntrack version 0.5.0 (65536 buckets, 262144 max)
[    1.186984] ctnetlink v0.93: registering with nfnetlink.
[    1.187020] ip_tables: (C) 2000-2006 Netfilter Core Team
[    1.187034] Initializing XFRM netlink socket
[    1.187039] NET: Registered protocol family 17
[    1.187052] Bridge firewalling registered
[    1.187068] sched_clock: Marking stable (1185906897, 0)->(1872004338078392, -1872003152171495)
[    1.187252] registered taskstats version 1
[    1.187278] console [netcon0] enabled
[    1.187278] netconsole: network logging started
[    1.193957] EXT4-fs (xvda1): couldn't mount as ext3 due to feature incompatibilities
[    1.194186] EXT4-fs (xvda1): couldn't mount as ext2 due to feature incompatibilities
[    1.206897] EXT4-fs (xvda1): mounted filesystem with ordered data mode. Opts: (null)
[    1.206907] VFS: Mounted root (ext4 filesystem) readonly on device 202:1.
[    1.207197] Freeing unused kernel memory: 1020K
[    1.207201] Write protecting the kernel read-only data: 8192k
[    1.208805] Freeing unused kernel memory: 1136K
[    1.208937] Freeing unused kernel memory: 448K
[    2.922205] init-early.sh (553) used greatest stack depth: 13216 bytes left
[   14.940046] random: crng init done


Last edited by karmaking on Fri Nov 24, 2017 2:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
karmaking
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2004
Posts: 80
Location: Berlin, Germany

PostPosted: Fri Nov 24, 2017 2:16 pm    Post subject: Reply with quote

OK I got it. For future reference:

CONFIG_DEVTMPFS_MOUNT=y

This solely got it to run.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum