Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] SDDM doesn't start after updating what(?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 772

PostPosted: Wed Oct 11, 2017 12:06 pm    Post subject: [Solved] SDDM doesn't start after updating what(?) Reply with quote

Got the following:
- Plasma 5.11,
- xorg-server 1.19.4 with Fedora's patches for nvidia-drivers,
- nvidia 387.12.

SDDM 0.15 and 0.16 doesn't, i.e. there is no logon window.
LightDM works fine.

Where can be bug?


Last edited by Perfect Gentleman on Wed Oct 11, 2017 12:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21354
Location: here

PostPosted: Wed Oct 11, 2017 12:13 pm    Post subject: Reply with quote

For version 0.15 I don't know, but version 0.16 has problem (see this thread)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1595
Location: Just over the horizon

PostPosted: Wed Oct 11, 2017 12:15 pm    Post subject: Reply with quote

Unless you are using systemd, you'll need to enable the elogind USE flag for sddm. 0.16 requires logind.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 772

PostPosted: Wed Oct 11, 2017 12:16 pm    Post subject: Reply with quote

forget to add that migrating to elogind from consolekit2 didn't resolve the problem
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1595
Location: Just over the horizon

PostPosted: Wed Oct 11, 2017 12:29 pm    Post subject: Reply with quote

I had to work thru this same issue yesterday. One last thing...did you add elogind to the boot run-level with rc-update? Until I did that, sddm would not come up for me.
Back to top
View user's profile Send private message
Perfect Gentleman
l33t
l33t


Joined: 18 May 2014
Posts: 772

PostPosted: Wed Oct 11, 2017 12:44 pm    Post subject: Reply with quote

adding sddm user to video group fixed the issue.
deleted user sddm from video group and it still works.
WTF?
Back to top
View user's profile Send private message
kosgorbunov
n00b
n00b


Joined: 23 Nov 2015
Posts: 2

PostPosted: Sun Aug 05, 2018 12:00 pm    Post subject: Reply with quote

platojones wrote:
I had to work thru this same issue yesterday. One last thing...did you add elogind to the boot run-level with rc-update? Until I did that, sddm would not come up for me.

yup it helps
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum