Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] PulseAudio - Keeps Blasting me with 100% Volume
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Cygon
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2006
Posts: 75
Location: Germany

PostPosted: Sun Oct 08, 2017 1:16 pm    Post subject: [SOLVED] PulseAudio - Keeps Blasting me with 100% Volume Reply with quote

Hi!

I've been running with ALSA only for 2 years but wanted to try PulseAudio for its per-application volume controls. Now I've been thrown off my chair about 5 times when the darn thing decided to set volume at 100% :-/

The behavior, as far as I can tell, seems to be this:


  • If only 1 application is running, application volume == global volume. So when there's been no audio streams and I launch a new application, it will start at 100%, thus PulseAudio will adjust output volume to 100% and give me ringing ears.
  • If a second application starts, the application volume suddenly becomes a sub-volume of the global volume, meaning if I have set global volume to 25%, applications need to be set to 100% to become audible.
  • If PulseAudio feels like it, it will just go to 100% volume anyway


I can not set the maximum volume in the control panel to anything but 100%, either.

I've put the following in ~/.config/pulse/default.pa

Code:
.include /etc/pulse/default.pa

# Set volume to 25% on boot
set-sink-volume 0 16384
set-sink-volume 1 16384


But this is ignored entirely as far as I can tell. If I put it in /etc/pulse/default.pa, PulseAudio claims that I have no output devices.[/code]


Last edited by Cygon on Wed Oct 11, 2017 7:05 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16571
Location: here

PostPosted: Sun Oct 08, 2017 1:44 pm    Post subject: Reply with quote

Possible related with this?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Cygon
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2006
Posts: 75
Location: Germany

PostPosted: Sun Oct 08, 2017 2:21 pm    Post subject: Reply with quote

Very possible.

The "flat-volumes" option was commented out in my daemon.conf, but I couldn't find docs for what the default is.

I explicitly set "flat-volumes = no" and will report back.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 16571
Location: here

PostPosted: Sun Oct 08, 2017 3:10 pm    Post subject: Reply with quote

This problem has caused me the speakers breakup.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Cygon
Tux's lil' helper
Tux's lil' helper


Joined: 05 Feb 2006
Posts: 75
Location: Germany

PostPosted: Wed Oct 11, 2017 7:05 am    Post subject: Reply with quote

That was it! PulseAudio has behaved nicely and exactly how I expect it to in the last 3 days :)

Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum